Il PC si blocca

11 contenuti / 0 new
Ultimo contenuto
Ritratto di luke
Offline
Last seen: 9 anni 6 mesi fa
Iscritto: 24/12/2011 - 10:27
Il PC si blocca

Ciao a tutti,
ogni tanto mi trovo che il PC si blocca è devo spegnere la macchina o togliere corrente. Con Windows non è mai successo, ma a dire la verita l'ho usato poco.

Il mio PC portatile è un Asus k53s Intel I7 Scheda video Nvidia gforce gt540.

Ciao

Ritratto di monsee
Offline
Last seen: 1 mese 4 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Messa così, ci vuol proprio la sfera di cristallo.
Dacci qualche dettaglio in più: che versione di PCLinuxOS usi esattamente, in quali casi si blocca, se capita in occasioni fra loro similari per qualche ragione. se t'è iniziato ad accadere già dal momento in cui hai installato o è iniziato dopo. E -se iniziato dopo che l'usavi già da un po',- quando è iniziato, il fenomeno? Era accaduto qualcosa, prima che iniziasse (un qualche aggiornamento?... hai mica cominciato a usar qualcosa che prima non usavi? [esempio: un nuovo mouse o qualcos'altro che non utilizzavi prima]).
Se dalle info aggiuntive non si riesce a cavar niente, direi che forse è il caso di puntar l'obiettivo delle indagini sui drivers della tua Scheda NVIDIA...

Ritratto di ernstfree
Offline
Last seen: 4 anni 8 mesi fa
Iscritto: 09/08/2011 - 16:02

Come dice Monsee, attendiamo qualche info aggiuntiva ...
... pure io puntere l'attenzione sulla gestione della scheda grafica ... il processore è molto diffuso per dare problemi.
Se windows non si piantava e Linux si ... la situazione è molto grave! Smile
Controlla anche i sensori termici e fai un "top" da console per vedere se c'è qualcosa che macina male ...

Ernst

Ritratto di luke
Offline
Last seen: 9 anni 6 mesi fa
Iscritto: 24/12/2011 - 10:27

In effetti fare una diagnosi è complicato, il PC si è bloccato 3 volte 2 con Firefox, e una volta Gwnewiev, Una volta acceso da pochi minuti,le altre molto di più.

Scusa la mia ignoranza ma vuol dire
"Controlla anche i sensori termici e fai un "top" ?

Grazie per il Vs interessamentoMa ho impressione che trovare un motivo si acomplicato.

Dimenticavo uso KDE FULLMONTY

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Prova a fare una ricerca in synaptic per "nvidia" e a postare la lista di quelli installati.
Io ne avevo due che non ci dovevano essere e mi facevano crashare opera.
Rimuovendoli ho risolto.

Guarda anche quale driver stai usando e la risoluzione.

Ritratto di luke
Offline
Last seen: 9 anni 6 mesi fa
Iscritto: 24/12/2011 - 10:27

Ciao Zafran, in effetti non ci sono drivers Nvidia installati solo:
x11 drivers-video-nouveau
x11 drivers-video-nv
x11 drivers-video-nvidia173
x11 drivers-video-nvidia96xx
x11 drivers-video-nvidia-current

La risoluzione è 1366*768 il monitor è un 15 pollici 16:9.

Ciao

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Per quanto ne so dovrebbe bastarti rimuovere il 96.
E poi naturalmente riconfigurare il server grafico che dovrebbe ripartire con nouveau a 24 bit. può darsi che ora vada a 16 come succedeva a me.

Incrocio le dita.

Ritratto di luke
Offline
Last seen: 9 anni 6 mesi fa
Iscritto: 24/12/2011 - 10:27

zafran wrote:
Per quanto ne so dovrebbe bastarti rimuovere il 96.
E poi naturalmente riconfigurare il server grafico che dovrebbe ripartire con nouveau a 24 bit. può darsi che ora vada a 16 come succedeva a me.

Incrocio le dita.


Scusa ancora 2 domande , la prima mi conviene installare i drivers non liberi trovato nell' elenco di di Synaptic?
Poi come faccio a configurare il server grafico?

Grazie per la pazienza.

Ciao

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Allora: c'è un'utility in pclinuxos che si chiama XFdrake.
Serve a configurare il server grafico e pclos te la scodella tutta in ghingheri nel pannello di controllo (Hardware->ConfigureVideoCard o simile).

Da lì dentro puoi avere un po' di indicazioni sul driver che il sistema ti suggerisce, risoluzione, profondità etc.

Quando esci salvando le modifiche, il file /etc/X11/xorg.conf viene riscritto e riletto al riavvio.
Per questo, prima di modificare alcunché, io una guardatina al file in questione gliela darei.
Perciò, senza dire nulla a monsee, in console:
$ cat /etc/X11/xorg.conf
e magari
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf_oggi (NB: da root)

Questi sono i pacchetti che ho io:
dkms-nvidia173
dkms-nvidia-current
libdri-drivers-experimental
x11-driver-video-nouveau
x11-driver-video-nv
x11-driver-video-nvidia173
x11-driver-video-nvidia-current

Come si vede, non c'è x11 drivers-video-nvidia96xx, e infatti gìà in estate o prima, avevano avvisato di rimuoverlo.
Non so come era successo ma a me aveva seguitato a funzionare anche senza rimuoverlo fino a qualcosa di imponderabile successo qualche settimana fa e risolto con l'eliminazione di quel pacchetto.

Ritratto di luke
Offline
Last seen: 9 anni 6 mesi fa
Iscritto: 24/12/2011 - 10:27

Grazie, Penso di aver risolto, grazie Zafran.

Ciao

Se si blocca di nuovo vi farò sapere

Ritratto di ernstfree
Offline
Last seen: 4 anni 8 mesi fa
Iscritto: 09/08/2011 - 16:02

luke wrote:

Scusa la mia ignoranza ma vuol dire
"Controlla anche i sensori termici e fai un "top" ?

Scusa! Ho visto l'email solo ora!
In ogni caso:
1 - top: digitare da console "top" e vedere i dati consumo RAM e CPU delle varie applicazioni ...
2 - sensori: ci sono dei plasmoidi o comandi a console che permettono di leggere le temperature di lavoro di più parti del computer (purtroppo non sempre funzionano ...).

Ernst