Unity engine 3d

6 contenuti / 0 new
Ultimo contenuto
Ritratto di nemsis85
Offline
Last seen: 7 anni 2 mesi fa
Iscritto: 03/08/2014 - 13:06
Unity engine 3d

Salve amici di PcLinuxOs . Mi presento mi chiamo Luigi, dalla mia postazione di Latina (Però sono un terrone DOC Lol
Arrivo subito al succo del mio post.
Vorrei poter utilizzare unity 3d (il software per la creazione di giochi e non unity di ubuntu). Premetto che negli ultimi anni ho usato saltuariamente sia windows che linux. Ultimamente avevo provato ubuntu 14.04....lasciamo perdere,blocchi rallentamenti ecc, peggio di windows. Così ho voluto provare Pclinux os; e come per magia mi è rinato il PC. Davvero un ottima distribuzione. Ora ritornando al mio problema sto cercando di seguire questo post
http://forum.unity3d.com/threads/unity3d-on-linux-with-wine-support-thread.211059/
ma senza sucesso (non mastico molto l'inglese :-().
Cos volevo chiedere il vostro aiuto per riuscire nell impresa.
Vi ringrazio in anticipo per il vostro aiuto.
Orgoglioso di entrare a far parte del Fansclub Italiano di PcLInuxOs Smile

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Ho dato una veloce occhiata al post in lingua inglese che hai linkato.
Qual'è, se puoi spiegarlo, la parte delle istruzioni che ti resta poco chiara? Un pizzico d'inglese io lo mastico, per cui, se può aiutare...

In snella sintesi, il post che hai linkato suggerisce:

1) scaricare (ma NON cercare di installare) l'eseguibile (un ffile EXE) di Unity3d;
2) installare PlayOnLinux (che puoi tranquillamente installare, in PCLinuxOS, sia a 32-bit che a 64-bit) con un semplice click del mouse, dato che lo si trova tranquillamente fra i pacchetti già disponibili in Synaptic);
3) dopo l'avvenuta installazione, aprire PlayOnLinux e cliccare, nella finestra che si apre, su
Strumenti/gestisci la versione di Wine
4) nella finestra che ti appare, c'è una parte (un intero quadro) relativa a "x86": ivi devi selezionare la versione 1.7.6 (che penso sia un poco obsoleta, comunque, dato che mi par di rammentare che la versione più recente è la 1.7.23, in questo momento). Selezionata la versione in oggetto, clicca sul tasto "freccia" (ossia, quello contrassegnato dal simbolo

>

... questo, al fine di installare la suddetta versione di Wine. E, al termine di questa fase:

5) clicca su:

Strumenti/Esegui uno script

(sempre, nella finestra principale di PlayOnLinux che hai dinnanzi ai tuoi occhi) e seleziona lo script allegato

6) esegui a puntino le istruzioni per l'installazione e rilassati mentre il processo provvede ad installare ogni cosa.

Possibili problemi (e soluzioni):

a) se l'installazione va, ma ti becchi, alla fine dei giochi, un fantastico "schermo vuoto"... prova a cambiare il tuo Fuso Orario di Sistema, impostandone uno più noto (ad esempio, quello di Roma);
b) può essere che non si riesca a creare un nuovo progetto usando la strada normale (ovvero, da dialogo: "Crea nuovo progetto"), ma questo è superabile creando una directory (ossia, una cartella) vuota e poi puntando su di essa.

Ritratto di nemsis85
Offline
Last seen: 7 anni 2 mesi fa
Iscritto: 03/08/2014 - 13:06

Ciao ti ringrazio per la tua risposta. Ho eseguito l'intera procedura, installando anche l'eseguibile di unity 3d da PlayonLInux. Tutto ok. Il problema adesso è che non parte unity 3d Sad Nel log di playonLinux mi visualizza il seguente messaggio:
[08/03/14 19:34:01] - Running wine-1.7.23 Unity.exe (Working directory : /home/condor/.PlayOnLinux/wineprefix/Unity3D/drive_c/Program Files/Unity/Editor)
wine: cannot find L"C:\\windows\\Microsoft.NET\\Framework\\v4.0.30319\\mscorsvw.exe"
fixme:service:scmdatabase_autostart_services Auto-start service L"clr_optimization_v4.0.30319_32" failed to start: 2
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\Unity\\Editor\\Unity.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Unity\\Editor\\Unity.exe" failed, status c0000135
E' stano anche perchè lo script che esegue PlayonLInux installa le Microsoft.Net e quindi il file mscorsw.exe

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Nel messaggio di errore che hai postato, fra le altre cose, vedrai che c'è scritto che tu hai installato e stai usando WINE 1.7.23 (che è la versione più recente che sia oggi disponibile). Invece, sul post che tu hai seguito per effettuar l'installazone, si spiegava chiaramente che era da installare WINE 1.7.6 (una versione precedente, dunque, e non di poco, rispetto a quella attuale). Non so se questo basti a spiegar tutto, nel messaggio di errore che ti appare, ma certo spiega perchè c'è qualcosa che non è andata per il verso giusto (non hai selezionato, insomma, la versione "vecchia" di wine che ti suggerivano, nel post che hai linkato, di installare... e hai preferito installare la versione aggiornata... che sarà di certo un po' migliore, ma non è quella che veniva richiesta per il tuo specifico scopo).

Ritratto di nemsis85
Offline
Last seen: 7 anni 2 mesi fa
Iscritto: 03/08/2014 - 13:06

Ciao. Ho provato prima con la versione di wine della guida, poi con la versione più recente. In entrambi i casi si presenta il medesimo errore Sad

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Verifica "de visu" se i files che ti dichiara son mancanti mancano per davvero. Purtroppo, io non uso Wine, per cui non posso manco fare delle prove. Sicuro di aver seguito in dettaglio quanto previsto dallo script? Perchè mi par sia strano che manchino all'appello anche dei files di Unity3D...