Thunderbird installato non si avvia

88 contenuti / 0 new
Ultimo contenuto
Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15
Thunderbird installato non si avvia

ho installato adesso pclos, ho effettuato gli aggiornamenti ed installato quel che mi serve, tra cui thunderbird in italiano, ma quello non è un problema perchè con addlocale me lo ha aggiornato, infatti avevo installato anche la versione in inglese per vedere se così si avviava dal menu, ma non si avvia unico modo farlo partire da terminale ma se spengo il terminale si spegne anche thunderbird. Come fare a superare questo problema? Ho effettuato anche l'installazione da terminale ma non è cambiato niente, thunderbird non ne vuole dapere di avviarsi da menu. Ogni dritta è bene accetta naturalmente. ciao

Ritratto di dxgiusti
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 22/01/2013 - 17:30

nelle proprietà del comando nel menù, thunderball è scritto con la t iniziale minuscola?

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

No dxgiusti, è con la maiuscola

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Che DE usi?

Ritratto di dxgiusti
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 22/01/2013 - 17:30

se il comando inizia con la T maiuscola come dici, è ovvio che non si avvii.

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

come sarebbe a dire? Come faccio a cambiarlo?

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

L'ho cambiata ma non parte lo stesso

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Cosa usi kde, lxde , mate...?

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

il DE è quello che c'è con l'installazione, non so come è definito...

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

kde credo

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Non ci aiuti molto se non dici cosa usi, mandaci uno screenshot del tuo desktop, ho il sospetto che non hai capito cosa intende dx giusti con la "proprietà del comando", se con il terminale ti parte digitando thunderbird è ovvio che deve avere un problema nel menù, sì ma il menù quale?

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

LXDE ho guardatio adesso

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Ok se è kde clicca con il mouse dx su l'icona in basso sx, quella che ti apre il menù. Qui ti si apre il menù editor di kde, naviga fino a internet/thunderbird e controlla se sotto la voce "comando" thunderbird è scritto con la t piccola

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Oppero, siamo sicuri? Ok passiamo a lxde....naviga fino a /usr/share/applications/thunderbird aprilo con leafpad e copia ed incolla il contenuto

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

Allora, con leafpad si apre un file vuoto. Sono andato a vedere seguendo il percorso e c'è nei permessi l'esecuzione non è permessa a nessuno, forse è per questo che non parte. Ho provato a selezionare i permessi a chiunque e non mi fa fare la modifica, neppure se seleziono "solo il proprietario", non mi fa fare la modifica.

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

Aspetta ora sono riuscito ad aprire con leafpad:

[Desktop Entry]
Version=1.0
Name=Thunderbird
GenericName=Email
Comment=Send and Receive Email
Exec=thunderbird
Icon=thunderbird
Terminal=false
Type=Application
StartupWMClass=Thunderbird-bin
MimeType=message/rfc822;
X-Desktop-File-Install-Version=0.22
Categories=Network;Email;X-MandrivaLinux-Internet-Mail;

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Questo è in ordine, se ci clicchi sopra si avvia?

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

E' curioso, se cambio la T maiuscola in "Name= Thunderbird" in t minuscola non me la cambia...

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Chiaro, per modificarla devi essere "root"

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

si ma se apro il percorso da terminale mi apre un file vuoto non so perchè

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

sono riuscito a fare la modifica da terminale ma non parte lo stesso

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Se clicchi sull'icona di thunderbird che è in usr/share/applications ti dovrebbe partire, il file è in ordine a quanto vedo. Ps che modifica hai fatto da terminale? E come l'hai fatta da root o da utente?

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

adesso il file è così:

[Desktop Entry]
Version=1.0
Name=thunderbird
GenericName=Email
Comment=Send and Receive Email
Exec=thunderbird
Icon=thunderbird
Terminal=false
Type=Application
StartupWMClass=thunderbird-bin
MimeType=message/rfc822;
X-Desktop-File-Install-Version=0.22
Categories=Network;Email;X-MandrivaLinux-Internet-Mail;

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

Da terminale ho modificato tutte le t maiuscole in minuscole come puoi vedere, da root ovviamente. ora provo a cliccare da application

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Allora quello che intendeva dxgiusti era Exec=thunderbird ma il file è corretto, l'unica modifica che hai fatto, se vuoi controllare, è che adesso nel tuo menù è minuscola invece che con la T maiuscola. Prova a cliccare sull'icona di thunderbird, intendo su quella in usr/share/applications

 

Ritratto di dxgiusti
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 22/01/2013 - 17:30

ma perchè divaghi cosi tanto. diviene difficile seguirti. nessuno ti ha detto di modifica re T in t, anzi rimetti tutto in ordine come era prima.

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

credo che dipenda dai permessi di esecuzione, aprendo da proprità del file /usr/share/applications/mozilla-thunderbird.desktop i permessi di esecuzione sono preclusui a tutti, c'è scritto esecuzione "nessuno" e non me lo fa modificare, forse bisogna intervenire con chmod ma non so come fare

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

l'hai detto tu che cion la maiuscola era ovvio che non partiva comunque è per i permessi che non parte, ci giurerei, ho provato a cliccare sull'icona non parte in nessun modo

Ritratto di dxgiusti
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 22/01/2013 - 17:30

rimetti la sua configurazione come era. come utente normale ( l'hai installato da synaptic con la tua sessione vero? ), vai in usr/bin/thunderball, doppio click sull'ingranaggio e nella finestra che si apirà scegli esegui. si avvia?

 

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

Ho dato con chmod il permesso a tutti, è andato a buon fine ora possono eseguire tutti ma non parte lo stesso, non riesco a capire...

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

ho provato da usr/bin/thunderbird sull'ingranaggio esaegui non parte, esegui da terminale non parte lo stesso

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Taglia la testa al toro, rimuovi thunderbird con synaptic compreso i file di configurazione e riscaricalo, credo che oramai hai fatto delle modifiche che per venircene a capo....

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

parte solo da terminale con un messaggio di errore che dice:

nessun demone DBUS in esecuzione

Ritratto di dxgiusti
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 22/01/2013 - 17:30

da synaptic scegli rimuovi completamente.

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

no il file l'ho rimesso pari pari come era

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

rimosso e reinstallato adesso va, grazie comunque di tutto

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Figurati, è che sei partito in quarta con terminale, chmod etcc..quello che diceva dxgiusti era Exec=thunderbird nel file che ti ho fatto aprire (ecco il perchè della t munuscola) e che potevi guardare anche con il mouse dx cliccando sull'icona nel menù e scegliendo proprietà/elemento scrivania/comando

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

Si comunque i permessi andavano cambiati, adesso il file ha i permessi eseguibile per tutti come l'avevo modificato io, e qualcosa d'altro c'era nella configuraziione generale, comunque l'importante è che adesso ve tutto ok, ciao e grazie ancora.

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Ma più facile che avevi un errore nella configurazione, per curiosità in proprietà chi hai come proprietario? Anch'io uso lxde ed ho come proprietario root

Allegati: 
Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

pure io ho root, certo

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

Adriano siamo daccapo, oggi non si avvia proprio come ieri, riapro la discussione perchè risiamo nel caos, di nuovo ho fatto tutte le prove di ieri, l'ho anche rimosso totalmente e reinstallato ma non è servito, non riesco a capire cosa c'è che non funziona, qiualcosa c'è ma cosa???

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Dunque hai detto che è una installazione pulita. Posso solo immaginare che hai un file corrotto, forse relativo al dbus, come avevi detto al #32...faccio una ricerca

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

si il messaggio diceva così, nessun demone DBUS in funzione

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

da terminale se avvio da anche questo messaggio:

(process:16673): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Mi puoi dire come hai installato thunderbird? Da synaptic o in altro modo?

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Sì e normale, così anche per me ma poi dovresti avere:[calBackendLoader] Using libical backend at /home/adriano/.thunderbird/n3obfrj8.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical-manifest
 

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Dunque sembra che sia un problema legato al tentativo di lanciare una applicazione come superuser, cioè da root. Per favore mi vai nella tua home digiti ctrl+h e poi vai in .local/share/applications clicchi con il mouse dx sull'icona di thunderbird e mi mandi uno screenshot di proprietà del file/permessi

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 02/01/2015 - 12:20

Prova a lanciare manualmente il demone dbus e poi prova ad avviare thunderbird dal menù, il comando è /usr/bin/dbus-daemon --system

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

local/ share/ application non esiste....

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

con quel comando mi da questo messaggio(ma non fa niente)

Failed to start message bus: The pid file "/var/run/messagebus.pid" exists, if the message bus is not running, remove this file

 

Ritratto di pabform
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 17/02/2014 - 13:15

https://app.box.com/s/6701g7isuifcw9pqvsaua4vgaxlkskhx

Questo è lo screenshot dei permessi

Pagine