[RISOLTO] W: There are multiple versions of "NomeDelFile" in your system.

12 contenuti / 0 new
Ultimo contenuto
Ritratto di Sargon6
Offline
Last seen: 6 anni 3 settimane fa
Iscritto: 05/08/2011 - 15:53
[RISOLTO] W: There are multiple versions of "NomeDelFile" in your system.

Quando apro synaptic, mi compare il messaggio

W: There are multiple versions of "kbreakout-handbook" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^kbreakout-handbook$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "fal

ripetuto tante volte quanti sono le versioni multiple dei vari files.
Che significa?
Come elimino il problema?

Ritratto di zafran
Offline
Last seen: 8 mesi 2 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Ho avuto codesto problema anni fa e ne trovai la soluzione
Prova (molto) pazientemente a cercare nelle discussioni di quei tempi.
Bisogna cancellare uno a uno i doppioni che si sono creati.
Se non ce la fai, dillo e ti darò una mano anch'io a ricercarlo

Ritratto di Sargon6
Offline
Last seen: 6 anni 3 settimane fa
Iscritto: 05/08/2011 - 15:53

Ho copiato il messaggio di errore in un file di testo che ho salvato col nome di errore1.txt
dopo di che, da terminale aperto nella medesima cartella in cui ho salvato il file suddetto, ho impartito il comando
[pclinuxoskde@localhost Documenti]$ grep "W:" errore1.txt > errore2.txt
[pclinuxoskde@localhost Documenti]$

Il risultato è stata la creazione di un file di testo avente nome errore2.txt contenente 354 righe del tipo
W: There are multiple versions of "kbreakout-handbook" in your system.
W: There are multiple versions of "kde-artwork-styles" in your system.
W: There are multiple versions of "lib64klinkstatuscommon4" in your system.
W: There are multiple versions of "php-openssl" in your system.

(ho ricopiato solo le prime 4, ce ne sono altre 350 che differiscono solo per il nome del file indicato fra apici)
Adesso apro Synaptic e vedo che mi dice a proposito di ciascun file.

Ritratto di Sargon6
Offline
Last seen: 6 anni 3 settimane fa
Iscritto: 05/08/2011 - 15:53

Si tratta di pacchetti per cui esiste una versione sia dell'anno 2013, sia dell'anno 2014.
Per esempio: del pacchetto kde-baseapps kdepasswd, esiste sia la versione
kde-baseapps-kdepasswd#4.11.3-2pclos2013
sia la versione
kde-baseapps-kdepasswd#4.11.5-1pclos2014

Se io elimino la versione kde-baseapps-kdepasswd#4.11.3-2pclos2013 e poi riavvio Synaptic, il pacchetto kde-baseapps-kdepasswd#4.11.3-2pclos2013 NON compare fra i pacchetti installabili, quindi ne deduco che era proprio quella la versione da cancellare.
Però, trattandosi del nome di un pacchetto, mi sembra veramente strano che sia capitato solo a me.

edit: per trovare più velocemente tutti i pacchetti da togliere, utilizzo la stringa di ricerca pclos201, così vengono evidenziati tutti i pacchetti che esistono sia nella versione pclos2014, sia nella versione pclos2013, e posso eliminare questi ultimi selezionandoli uno ad uno, per poi rimuovere in un colpo solo tutti i pacchetti selezionati.

Ritratto di 500paolo
Offline
Last seen: 2 anni 1 settimana fa
Iscritto: 16/12/2011 - 10:52

C'e' una funzione apposta (per lo meno nella versione kde), apri il menu, quindi "gestione software" o "software center" o comunque dove trovi anche synaptic e dovresti trovarci "Dupeclean-gui".
Vedrai che risolvi subito.

Ritratto di Sargon6
Offline
Last seen: 6 anni 3 settimane fa
Iscritto: 05/08/2011 - 15:53

500paolo wrote:
C'e' una funzione apposta (per lo meno nella versione kde), apri il menu, quindi "gestione software" o "software center" o comunque dove trovi anche synaptic e dovresti trovarci "Dupeclean-gui".
Vedrai che risolvi subito.

Confermo che selezionando [Menù principale] >[Software Center] > [Dupeclean-gui], si apre l'applicazione per risolvere in un solo "colpo" il problema della duplicazione dei pacchetti.

Invece da Synaptic non ho trovato nulla che permettesse di risolvere il problema della duplicazione dei pacchetti.

Ritratto di 500paolo
Offline
Last seen: 2 anni 1 settimana fa
Iscritto: 16/12/2011 - 10:52

Non puoi risolverlo da synaptic perche' o per errore o perche' ne avevi bisogno, lo hai costretto ad accettare versioni multiple di un pacchetto e per lui e' una cosa contro natura...te lo fa fare ma poi ti avverte di continuo e si aspetta che tu lo risolva da solo.
Tempo fa io lo feci volontariamente per conservare un applicazione che altrimenti avrei perso con gli aggiornamenti, purtroppo pclinuxos e' così, un giorno potresti non avere piu' un'applicazione che ti piace a favore del sistema sempre aggiornato.

Ritratto di dxgiusti
Offline
Last seen: 10 mesi 1 settimana fa
Iscritto: 22/01/2013 - 17:30

installa:
Dupeclean-gui
farà lui il lavoro per te.

Ritratto di Sargon6
Offline
Last seen: 6 anni 3 settimane fa
Iscritto: 05/08/2011 - 15:53

@ 500paolo: scusa, tu avevi scritto "dove trovi anche synaptic", ed io avevo capito "lo trovi anche in synaptic"; errore mio.

@ dxgiusti: si, Dupeclean-gui è già installato, e da
[Menù principale] >[Software Center] > [Dupeclean-gui]
l'ho ho avviato, risolvendo in un solo "colpo" il problema della duplicazione dei pacchetti.
il problema è [RISOLTO], ma in questo forum non ho idea di come mettere [RISOLTO] nell'oggetto del primo post...
Saluto.

Ritratto di 500paolo
Offline
Last seen: 2 anni 1 settimana fa
Iscritto: 16/12/2011 - 10:52

Grazie @Sargon6, pensavo di essermi spiegato male e infatti Dxgiusti ti ha consigliato di installarlo.

Ritratto di dxgiusti
Offline
Last seen: 10 mesi 1 settimana fa
Iscritto: 22/01/2013 - 17:30

per il [RISOLTO] ci penserà chi di dovere, ciao

Ritratto di zafran
Offline
Last seen: 8 mesi 2 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Ho risoltato.
Però mi spiace che il mio suggerimento (alternativo a dupeclean-gui) non è stato riesumato