[RISOLTO]: problemi di aggiornamento

11 contenuti / 0 new
Ultimo contenuto
Ritratto di monsee
Offline
Last seen: 3 mesi 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34
[RISOLTO]: problemi di aggiornamento

Può capitarvi, aggiornando il vostro PCLinuxOS che salti fuori che per aggiornare si debbano risolvere problemi: nello specifico, la presenza di un pacchetto danneggiato (o più pacchetti danneggiati). C'è un apposito tasto che consente, in Synaptic, di "riparare" un pacchetto danneggiato (o più pacchetti danneggiati).
In questi giorni, tuttavia, a tanti accade che il tentativo di riparazioni in oggetto fallisca invariabilmente. Di norma, in questi casi, si risolve impostando le la "rimozione totale" i pacchetti danneggiati in questione, ma... in questi giorni, specificamente, NON è questa la via da seguire!
I problemi nascono, infatti, da una disposizione erronea che svariati Server hanno attuato nel "posizionamento" dei pacchetti. Ci sarà da aspettare un poco, a quanto sembra, affinché la situazione si risolva.
Tuttavia, taluni Server han già provveduto a risolvere e, dai loro Repository, si può aggiornare senza alcun problema.
Uno di tali Repository è quello di HEADNET (ma sembra che anche il server SWISS abbia messo a posto le cose).
Suggerisco caldamente a tutti, dunque, per adesso, di impostare HEANET come Reposirtory principale. Non appena le cose torneranno alla normalità, si potrà re-impostare il GARR di Napoli, ovviamente.

Ritratto di zafran
Offline
Last seen: 8 mesi 2 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Ottimo a sapersi.
Ero incappato anch'io in qualcosa di strano con garr di napoli.

Avevo dato un dist-upgrade da CLI e in effetti qualcosa anzi parecchio di tetex latex aveva detto di voler eliminare.
Ma non credo che abbia rimosso nulla.
Solo, si è fermato dopo il download dei pacchetti e non voleva andare avanti per dipendenze non soddisfatte.

E' ripartito con --fix-missing e install -f ed è arrivato in fondo con un unico avviso di errore.

Ora aspetto un paio di giorni e riupdato da heanet, tanto non ho fretta: quel sistema funziona e non è neanche che lo usi tanto; oltretutto è un bel po' che ci pasticcio e andrebbe abbattuto come un cavallo.

Ritratto di monsee
Offline
Last seen: 3 mesi 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Purtroppo, la situazione non sembra destinata a risolversi nelle prossime ore: pare potrà volerci qualche giorno... La cosa importante, è sapere che si tratta di una situazione, comunque, temporanea.
Personalmente, avevo perso sia Kile che LyX (due programmi che uso tantissimo, specie Kile... che, in pratica, è il mio strumento di scrittura preferito)... Adesso, in due installazioni li ho recuperati, per fortuna, entrambi (usando solo Synaptic, senza fare ricorso alcuno alla riga di comando), ma per riuscirci ho dovuto fare più di un tentativo, lo confesso...

Ritratto di monsee
Offline
Last seen: 3 mesi 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Ho messo a posto, fino ad ora, quattro mie differenti installazioni. Ora sembra funzionar quasi tutto (in Synaptic, intendo). Ho anche testato se il GARR offre aggiornamenti differenti e -rispetto a come ho sistemato le cose io sui miei PC- non pare ne offra, sicché, se già non hanno messo a posto le cose, dovrebbero comunque esser sulla via...
Sulle mie installazioni, per ora, ho recuperato sia LyX che Kile che Texlive... purtroppo, ci ho rimesso un valido programma per l'analisi numerica (Teoria dei Numeri) che si chiama "Pari"... confido che, aggiustandosi ulteriormente le cose, potrò recuperare pure lui.
Rilevo che mettere a posto le cose nella versione LXDE è stato un po' più semplice che mettere a posto le cose per la versione XFCE (in quest'ultima [mi riferisco a una nuova instalalzione fatta con l'ultima ISO appena uscita], al momento, non sono stato in gradodi installare neanche AbiWord, perchè par manchino un paio di dipendenze). Di fatto, nei miei tentativi di risolvere le cose, mi son ritrovato a più riprese con la proposta di disinstallar seccamente l'intero Desktop Environment (cosa che, ovviamente, NON ho fatto, perchè se avessi eliminato XFCE non avrei più avuto alcun Desktop Environment cui accedere dopo aver fatto Login). Alla fine, comunque, sono riuscito a mettere a posto le cose (a parte la questione già detta di AbiWord e il fatto che non riesco a reinstallare neanche Pari) sempre facendo ricorso solo ed esclusivamente a Synaptic...

Ritratto di zafran
Offline
Last seen: 8 mesi 2 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Come già detto (ma va?) synaptic o non synaptic è la medesima.
L'importante è che la roba trovata sul repository abbia un senso.
E dalle prove che hai fatto sembra che tutto stia andando a posto.

Non ho capito cosa era successo, visto che sia heanet che il garr dovrebbero essere dei semplici mirror.
Se però sono così deformanti, male che vada li vendiamo a qualche luna park..

Ritratto di monsee
Offline
Last seen: 3 mesi 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Sembra che la situazione stia effettivamente tornando a posto (prima, nella mia nuova instalalzione di Phoenix a 32 bit non riuscivo ad installare Abiword... stanotte, invece, ci son riuscito (e proprio dal Repository del GARR di Napoli) senza incontrare problemi. Penso che sia ancora questione di qualche giorno prima che tutte le voci e tutti i pacchetti correlati tornino a funzionar correttamente (per ora, mi risultan esser "problematici" taluni pacchetti relati a "tetex", taluni pacchetti legati a "fontmatrix" e ai fonts collegato a LaTeX... e il pacchetto "pari" [e "pari-data"]).

Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46

monsee wrote:
Sembra che la situazione stia effettivamente tornando a posto (prima, nella mia nuova instalalzione di Phoenix a 32 bit non riuscivo ad installare Abiword... stanotte, invece, ci son riuscito (e proprio dal Repository del GARR di Napoli) senza incontrare problemi. Penso che sia ancora questione di qualche giorno prima che tutte le voci e tutti i pacchetti correlati tornino a funzionar correttamente (per ora, mi risultan esser "problematici" taluni pacchetti relati a "tetex", taluni pacchetti legati a "fontmatrix" e ai fonts collegato a LaTeX... e il pacchetto "pari" [e "pari-data"]).

Invece no !
Sto provando ora ed è il caos.
A parte che mi fa errore il synaptic sulla rilevazione degli aggiornamenti, ma dopo mi dice che tutti i pacchetti installati sono obsoleti Sad
Speriamo nella risoluzione del problema.
Ciao
Francesco bat

Ritratto di zafran
Offline
Last seen: 8 mesi 2 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Uhm.
Io stamani ho aggiornato tutto da heanet perché dal garr mi diceva che era irraggiungibile o qlc del genere.
Tipo server down.

Allora ho girato su heanet e lui ha fatto un bell'aggiornamento facendo qualcosa su tetex latex (rimozione) e su texenlive (sostituzione).
Sinceramente non ho guardato latex ora sia vivo e consapevole ma di tutto il resto sembra che non manchi nulla.

Secondo me, come suggerito da monsee già troppo tempo fa, il casino è del garr.
Chissà che hanno combinato.

Ritratto di monsee
Offline
Last seen: 3 mesi 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

OK, è intervenuto -pochi minuti fa- Texstar in persona, puntando il proprio indice su di una possibile causa alla base di tutti questi problemi (un qualche errore nella gestione delle dipendenze di texlive relativamente a tetex).
Si tratta di aspettare le verifiche che certamente seguiranno, adesso. Se l'idea che è emersa si confermerà, finiremo fra non molto di penare.

Ritratto di monsee
Offline
Last seen: 3 mesi 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Rilasciato e uploadato su tutti i Repository (GARR compreso) il nuovo pacchetto "texlive". L'ho appena installato e par funzioni bene (sembran sparite le bizzarre richieste che ultimamente Synaptic faceva).
Rilevo che rimane ancora il problema relatiovo al fatto che non si riesce ad installare "pari" (dice che manca "xdvi"), che prima che scoppiasse la buriana, invece, avevo e usavo... Per cui presumo che presto altri pacchetti verranno aggiornati.
Sproggy consiglia a chi usa XFCE di reimpostare il "tema" delle Finestre da:
Menu/Xfce 4 Settings Manager/Gestore delle finestre
e poi anche il Tema da
Menu/Xfce 4 Settings Managers/Aspetto
per ottenere il meglio dalle impostazioni.

Ritratto di monsee
Offline
Last seen: 3 mesi 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Posso confermare (perchè l'ho appena constatato io stesso in prima persona [sono con PCLinuxOS Phinx Edition, al momento... e proprio tale versione -XFCE- è quyella che ho usato per la mia verifica]) che i problemi correlati agli aggiornamenti che si son riscontrati negli ultimi giorni sono arrivati, finalmente, a soluzione. Grazie davvero a tutti quelli che si sono tanto prodigati a questo fine. Praticamente, a questo punto, non si riscontran più anomalie di sorta negli aggiornamenti. Un'ottima notizia, credo, per chiunque -come noi- ama davvero PCLinuxOS.