[RISOLTO] Konqueror e Java

15 contenuti / 0 new
Ultimo contenuto
Ritratto di francesco bat
Offline
Last seen: 2 anni 6 mesi fa
Iscritto: 20/11/2011 - 02:46
[RISOLTO] Konqueror e Java

Dopo l'aggiornamento dell'altro giorno, konqueror ha smesso di funzionare sul web (come file manager funziona senza problemi).
Qualunque indirizzo digito, la pagina non è visualizzabile.
Disattivando nelle impostazioni di konqueror il Java esso riprende a funzionare; recentemente è stato infatti fatto un aggiornamento java.
Avete notato anche voi il problema ?
Ciao
Francesco bat

Ritratto di leo82
Offline
Last seen: 8 anni 1 mese fa
Iscritto: 16/07/2011 - 11:03

a me funziona bene ho provato un po di siti e li ha aperti tutti...

Ritratto di francesco bat
Offline
Last seen: 2 anni 6 mesi fa
Iscritto: 20/11/2011 - 02:46

Invece a me esce questa pagina quando apro konqueror:

"Non è stato possibile completare l'operazione richiesta
Errore tempo scaduto

Dettagli della richiesta:
URL: http://www.pclinuxos.com
Protocollo: http
Data e ora: domenica 9 settembre 2012 21:14
Informazioni aggiuntive: www.pclinuxos.com: Operazione sul socket scaduta
Descrizione:
Anche se il server è stato contattato non è stata ricevuta alcuna risposta entro il tempo massimo deciso:
Tempo massimo per stabilire la connessione: 20 secondi
Tempo massimo per ricevere una risposta: 600 secondi
Tempo massimo per accedere ai server proxy: 10 secondi
Nota che è possibile cambiare questi valori nelle Impostazioni di Sistema di KDE selezionando Impostazioni di rete -> Preferenze sulle connessioni.
Cause possibili:
Potrebbero esserci stati dei problemi da qualche parte lungo il percorso di rete tra il server e il tuo computer.
Il server era troppo occupato nel rispondere ad altre richieste per poter rispondere a noi.
Soluzioni possibili:
Prova di nuovo, adesso oppure più tardi.
Contatta l'amministratore del server per maggiore assistenza."

Se disattivo java funziona senza problemi Sad

Ritratto di francesco bat
Offline
Last seen: 2 anni 6 mesi fa
Iscritto: 20/11/2011 - 02:46

Individuato l'inghippo.
Java sembra non c'entri nel problema, ma konqueror sembra essere piantato di suo.
Se avvio konqueror mi fa errore il caricamento della pagina; ma se aggiorno più volte la pagina me la carica a pezzi su più tentativi di aggiornamento.
Google.it, ad esempio, al primo caricamento fallisce ma se aggiorno me lo carica.
Pclinuxos.com al primo caricamento fallisce, aggiornando la prima volta mi carica solo l'html della pagina, al secondo aggiornamento mi carica la pagina completa o con dei pezzi mancanti (risolvendo in un eventuale terzo aggiornamento).
Non riesco a capire perchè mi fa così; Opera, Firefox e Chromium funzionano senza problemi.
Ciao
Francesco bat

Ritratto di leo82
Offline
Last seen: 8 anni 1 mese fa
Iscritto: 16/07/2011 - 11:03

non saprei prova a reinstallarlo è l'unica cosa che mi viene in mente...

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

A me funziona benissimo, hai forse problemi con i plugin? (magari il flash?)

Ritratto di francesco bat
Offline
Last seen: 2 anni 6 mesi fa
Iscritto: 20/11/2011 - 02:46

Non so spiegare altro.
Succede anche su un notebook aggiornato insieme.
Siccome non aggiornavo da una ventina di giorni, non vorrei che si fosse incasinato un pò tutto con gli aggiornamenti.
Magari provo a rinstallare kde4-config e vedo che succede.
Konqueror non lo trovo nel synaptic, forse sarà una dipendenza di un pacchetto.
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Konqueror dovrebbe essere un pacchetto a se, ma su pclinux ci sono pacchetti installati di default che poi non trovi nei repo.
Se lo usi come browser potresti provare rekonq che si integra benissimo con kde, konqueror fa tutto ma niente bene e per un certo periodo era a rischio abbandono.

Comunque vedi se hai installato o prova a installare/reinstallare konq-plugins.

Ritratto di francesco bat
Offline
Last seen: 2 anni 6 mesi fa
Iscritto: 20/11/2011 - 02:46

500paolo wrote:
Konqueror dovrebbe essere un pacchetto a se, ma su pclinux ci sono pacchetti installati di default che poi non trovi nei repo.
Se lo usi come browser potresti provare rekonq che si integra benissimo con kde, konqueror fa tutto ma niente bene e per un certo periodo era a rischio abbandono.

Comunque vedi se hai installato o prova a installare/reinstallare konq-plugins.

No, non fa niente !
Io comunque uso sempre Opera, solo che ogni tanto mi capita anche di aprire konqueror e il fatto che non funziona mi dispiace molto specie il fatto di non comprendere la causa.
Ho anche reinstallato kde4-config ma i problemi non si sono risolti Sad
Ciao
Francesco bat

Ritratto di francesco bat
Offline
Last seen: 2 anni 6 mesi fa
Iscritto: 20/11/2011 - 02:46

Il mistero comincia a prendere forma.
Ho provato da live su virtualizzazione con virtualbox l'ultima iso di pclinuxos e stesso problema con konqueror e non funziona il rintracciamento della città delle previsioni meteo che rimane in ricerca per moltissimo tempo.
Invece la vecchia versione di pclinuxos senza aggiornamento all'ultimo kde funziona egregiamente.
Siccome ho cambiato casa di recente e ora sto usando Infostrada invece di Alice di Telecom, non vorrei che fossero proprio la causa del problema (magari dei loro filtri) che mi incasinano con l'ultimo kde.
Infatti la cosa strana e che funziona tutto senza problemi, Opera, Firefox, Chromium ecc.
A non funzionare bene sembrano proprio tutte le applicazioni di kde che vanno su internet da quando sto usando Infostrada :?
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Può essere?
Io ho una ca..ta di wimax filtratissima,lentissima e che non funziona mai eppure konqueror va.
Il problema potrebbe presentarsi se il protocollo da noi utilizzato fosse del tipo p2p, malvisto da tutti gli internet provider.
Poi ho anche l'ultimissima vers di kde su altra distro e non ho alcun problema.

Ritratto di francesco bat
Offline
Last seen: 2 anni 6 mesi fa
Iscritto: 20/11/2011 - 02:46

Risolto il problema !
Su internet ho trovato vari post di utenti che si lamentavano di problemi di connessione con kde e infostrada.
La soluzione sembra quello di disattivare ipv6 dalla gestione rete.
Aprendo il net applet nella barra e "impostazioni avanzate" si può disattivare l'ipv6.
Io ho provato questo test e ora funziona tutto.
Konqueror apre tutte le pagine e il meteo di yawp funziona correttamente.
Ora mi chiedo: è necessario ipv6 o posso farne a meno di tenerlo attivo ?
Perchè infostrada si incasina con ipv6 di kde ?
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Ipv6 serve ad aumentare gli ip disponibili in rete aumentando la struttura dell'indirizzo.
Mi pare che tuttora l'ipv6 viene "tradotto" in ipv4 perche' ancora poco diffuso, quindi lo si puo' lasciare sospeso.

Comunque: http://it.wikipedia.org/wiki/IPv6

Ritratto di zafran
Offline
Last seen: 10 mesi 1 settimana fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Chiedo scusa perché non me ne sono ricordato.
Il 'trucco' di disabilitare ipv6 è conosciuto da tantissimo tempo, solo che non avendone più sentito parlare, si vede che l'avevo archiviato nella memoria come superato per sempre.

Si vede che invece è più attuale che mai e la domanda sorge spontanea: che famo?
Gli ipv4 disponibili sono finiti ufficialmente un paio di mesi fa e quindi da ora in poi i server che si aggiungeranno avranno ipv6.
Evidentemente questo già succede e c'è questa sorta di 'traduzione' in ipv4 (che se capisco bene è un'operazione di proxi) perché tutti possano accedere ancora a tutto ma prima o poi succederà che si debba usare ipv6 esso medesimo.
E allora che succederà se ancora ci sono tutti 'sti problemi?
Mah boh

Per ora metto risolto perché la cosa è chiarita ma mi sa che ne riparleremo.

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52