[RISOLTO] inkscape

20 contenuti / 0 new
Ultimo contenuto
Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30
[RISOLTO] inkscape

ho installato inkscape da gestore pacchetti. click sull'icona del programma, gira gira, il puntatore ma non fa nulla.
lo lancio dal terminale e mi appare:

[palla@localhost ~]$ inkscape

(inkscape:23924): Gtk-WARNING **: Theme file for ArtNet has no name

Fontconfig error: "/etc/fonts/conf.d/10-chromium.conf", line 40: invalid attribute 'name'
Fontconfig error: "/etc/fonts/conf.d/10-chromium.conf", line 46: invalid attribute 'name'

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Errore di segmentazione
[palla@localhost ~]$

allora sempre dal terminale lo lancio come amministratore ed il programma si apre. si può rimediare?

Ritratto di zafran
Offline
Last seen: 10 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

I permessi di chromium.conf?

Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30

in pratica cosa dovrei fare?
con chromium non ho nessun problema e nemmeno con art-net il tema delle icone.
questo quanto dice il file 10-chromium.conf ( si apre in una pagina di mozilla )
https://www.dropbox.com/s/z1wjfh381hswh96/10-chromium.conf

Ritratto di zafran
Offline
Last seen: 10 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Il file va bene sennò non funzionerebbe neanche per root.
Mi chiedevo se sia eseguibile da utente.

Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30

ce guardo il log error dice:

Estensione "Sketch Input" non caricata perchè una dipendenza non è stata soddisfatta.
Dipendenza:
tipo: executable
posizione: tracciato
stringa: skconvert

a dire il vero ne diceva molti e dava indicazione per installare, cosa che ho fatto ma questo non trovo nulla relativo a quella estensione. ho provato anche come amministratore a dare i permessi all'utente. nulla, parte solo da amministratore.

Ritratto di monsee
Offline
Last seen: 6 mesi 1 giorno fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Avrei trovato questo: http://www.mandrakeitalia.org/forum/programmi/grafica-vettoriale-inkscape
Se il programma non ti si apre quando cerchi di aprire uno specifico file, la ragione potrebbe essere analoga a quella cui si accenna nel thread in questione (che è del 2009, ma il messaggio di errore riportato è quasi identico a quello che esce a te).

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Ho installato inkscape su kde32 (su questo ho installato anche lxde come DE aggiuntivo a kde) e funziona.
Ma seguendo il percorso non trovo: /etc/fonts/conf.d/10-chromium.conf

Mi domando quindi se ti va di provare a spostare momentaneamente questo file per vedere se effettivamente e' necessario o se e' un aggiunta incompleta e non funzionante magari lasciata da qualche altra applicazione.

Nel file da te postato alla linea 40 si parla di "arial" e "liberation sans", puoi verificare che tu li abbia installati?

Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30

500paolo wrote:
Ho installato inkscape su kde32 (su questo ho installato anche lxde come DE aggiuntivo a kde) e funziona.
Ma seguendo il percorso non trovo: /etc/fonts/conf.d/10-chromium.conf

Mi domando quindi se ti va di provare a spostare momentaneamente questo file per vedere se effettivamente e' necessario o se e' un aggiunta incompleta e non funzionante magari lasciata da qualche altra applicazione.

Nel file da te postato alla linea 40 si parla di "arial" e "liberation sans", puoi verificare che tu li abbia installati?

forse a te non compare in quanto non avrai chromium, forse.
i font non li avevo, li ho installati ma non cambia nulla.
il programma funzione, solo che devo aprirlo come amministratore, unico programma tra i molti installati. bho?

Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30

monsee wrote:
Avrei trovato questo: http://www.mandrakeitalia.org/forum/programmi/grafica-vettoriale-inkscape
Se il programma non ti si apre quando cerchi di aprire uno specifico file, la ragione potrebbe essere analoga a quella cui si accenna nel thread in questione (che è del 2009, ma il messaggio di errore riportato è quasi identico a quello che esce a te).

ciao monse, ho provato ma il file zip quando lo scarico mi dice che non c'è più.
come dicevo a paolo, il programma funziona, solo che devo aprirlo come amministratore.
quello che mi fa incavolare è che sulla macchina virtuale VB ho installato zen ( aggiornatissimo ad oggi, vestito con cinnamon ) li ho installato e tutto funziona....... mha!

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Non credo che il file sia collegato a al browser "chromium", io ho FF e chrome, ma non ho di questi file, penso sia piu' qualcosa legato a qualche tema: una volta mi capito' su openbox dove modificai un tema e mi ritrovai con tutte le apps gtk che non si aprivano compreso synaptic, dovevo aprire il terminale, diventare root (su) e lanciare il programma che a questo punto non usava quel tema.
Comunque hai provato a spostare questo file? (poi puoi sempre rimettercelo...) Ricordati pero' di riavviare dopo aver spostato il file.

Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30

grande paolo. mi hai indirizzato nella giusta strada. ho cambiato le icone mettendo quelle standar menta, e tutto funziona. ho imparato una cosa che proprio non ci sarei mai arrivato. con le mie icone art-net scaricate da gnome genera il problema che hai detto.
grazie ancora.

edit: si può mettere il [RISOLTO]

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Eh Eh! Me l'aspettavo! Non perche' sono bravo, ma perche' sono un fervido "personalizzatore" e ne ho visti di temi sfasciare i sistemi piu' stabili!
(intendo per temi sia schemi di colore, icone, bordi finestra o puntatori)

L'esempio che ti portavo prima mi era capitato su Semplice linux, semplice di nome e di fatto, ha di default openbox e il desktop pulito e senza la possibilita' di metterci icone...insomma impossibile che la modifica della spaziatura dei menu delle applicazioni gtk apportata da me sul file gtk.css contenuta in un tema potesse creare qualche problema e invece panico! Non partiva piu' synaptic!

Nel mio prossimo post ti avrei chiesto se tu avessi scaricato qualche tema appunto perche', come sono in grado io di modificarne o crearne uno, qualsiasi imbecille lo puo' fare e uploadare su qualche sito, ma questo non significa che sia ben testato e non crei problemi all'utente che se lo accatta.
La riprova e' che i temi piu' "votati" sono proprio quelli piu' semplici e poco particolari e ti viene da chiedere ma che ha creato di particolare questo tipo? Invece e' proprio la loro semplicita' a non indurre noie nelle applicazioni.

Comunque ti ringrazio a mia volta! A presto!

Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30

grazie per l'imbecille...... sto ridendo mentre posto, tanto per interpretare bene il mio essere. ciao e grazie ancora

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

No, mica l'imbecille sei tu, parlavo di me che faccio modifiche ai temi in modo "casalingo" e rifletto sul fatto che se uploadassi quanto fatto, chi sa quanta gente mi verrebbe a cercare a casa...LOL!

Ritratto di zafran
Offline
Last seen: 10 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Vabbè facciamo che l'imbecille sono io che non personalizzo mai nulla perché non so neanche come fare a cambiare un tema.

Risolvo e ringrazio per i contributi

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Va beh, ho capito, mi auto punisco e mi tengo lontano dal forum per 2 giorni.

Ritratto di dxgiusti
Offline
Last seen: 1 mese 1 settimana fa
Iscritto: 22/01/2013 - 17:30

500paolo wrote:
Va beh, ho capito, mi auto punisco e mi tengo lontano dal forum per 2 giorni.

e no cosi non vale, per punizione, doppio tempo sul forum. ciao paolo

Ritratto di 500paolo
Offline
Last seen: 2 anni 2 mesi fa
Iscritto: 16/12/2011 - 10:52

Davvero scusa @Dxgiusti se ho dato l'impressione di voler dare dell'imbecille a qualcuno all'infuori di me...

Ritratto di zafran
Offline
Last seen: 10 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Volete continuare ancora per molto?

Ritratto di esabatad
Offline
Last seen: 11 mesi 2 settimane fa
Iscritto: 20/06/2012 - 07:37

zafran wrote:
Volete continuare ancora per molto?

Smile
Ok, tagliamo la testa al toro: l'imbecille sono io hahahaha!!!!