[RISOLTO] Eaglemode libxine.so.2

5 contenuti / 0 new
Ultimo contenuto
Ritratto di adrianomorselli
Offline
Last seen: 1 anno 2 settimane fa
Iscritto: 02/01/2015 - 12:20
[RISOLTO] Eaglemode libxine.so.2

Eaglemode mi richiede come unica dipendenza non installata, e non installabile sigh, libxine.so.2. Qualche idea?

Ritratto di monsee
Offline
Last seen: 1 mese 3 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Per 32-bit o per 64-bit? Perché, da quel che scrivi, mi par tu intenda a 32-bit... e forse è proprio per questo che non lo puoi installare (nel senso che PCLinuxOS a 64-bit mi pare NON abbia pacchetti a 32-bit).
Controlla comunque se hai installato un pacchetto denominato xine-lib... o se lo puoi installare (tramite Synaptic, intendo). Magari, prova ad installare il pacchetto gxine (mi par che richieda anche lui il pacchetto che cerchi... magari lo include pure).
Il file in questione, comunque, si trova -ad esempio- fra i pacchetti di Fedora 20 (e non solo per la versione 20, ovviamente), oltre che in RedHat (per cui, immagino anche in CentOS e in Scientific Linux) e OpenSuSE... oltre che per Mageia (a 64-bit soltanto, mi pare, in questo caso).

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 2 settimane fa
Iscritto: 02/01/2015 - 12:20

64 bit @monsee, proverò a vedere fra le dipendenze di gxine, da una rapida ricerca su synaptic mi sembra che sia disponibile solo libxine.so.1, ma magari non ho controllato bene. Eventualmente vedrò se è possibile installare il pacchetto .rpm oppure se non è possibile o rompe troppe dipendenze magari proverò con un symlink, alle volte funziona ugualmente (ad es. su arch richiede appunto libxine.so.1 e non 2). Se risolvo metterò un mino how-to, mi sembra una GUI interessante, se usata propriamente dà molte facilitazioni per tenere sotto controllo il SO "con una visione di aquila" Smile Per chi fosse interessato posto il link di un video di un mio amico https://www.youtube.com/watch?v=cXJFcXJRtNQ&feature=youtu.be

 

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 2 settimane fa
Iscritto: 02/01/2015 - 12:20

Prima di tutto ho scaricato il file rpm da http://eaglemode.sourceforge.net/download.html

Poi ho creato un symlink per il file libxine.so.2 in questo modo: aprire terminale come root e digitare cd /usr/lib64 && ln -s libxine.so.1.30.2 libxine.so.2

Poi ho installato il file da dove l'ho scaricato, sempre come root, in questo modo rpm -ivh --nodeps eaglemode-0.90.0-1.x86_64.rpm

A questo punto ho lanciato l'applicazione da terminale eaglemode (poi l'ho anche aggiunta nel menù dandogli come comando /usr/bin/eaglemode) e si è avviata! Adesso devo solo accomodare alcune configurazioni, che si trovano in /usr/lib/eaglemode/etc/emFileMen/Commands. Per comodità potete copiare la cartella Commands in /home/vostroutente/.eaglemode/emFileMen per affinare le vostre configurazioni.

Ritratto di adrianomorselli
Offline
Last seen: 1 anno 2 settimane fa
Iscritto: 02/01/2015 - 12:20
Oggetto:
Eaglemode libxine.so.2
»
[RISOLTO] Eaglemode libxine.so.2

Ah divertitevi con questo file-manager veramente particolare ma che una volta configurato ed imparato ad usarlo diventa anche molto produttivo