[RISOLTO] dopo aggiornamento sparito amule

10 contenuti / 0 new
Ultimo contenuto
Ritratto di duns
Offline
Last seen: 2 anni 3 mesi fa
Iscritto: 30/10/2008 - 11:43
[RISOLTO] dopo aggiornamento sparito amule

Amule non parte più, o meglio forse parte ma non è visibile (dunque non serve a niente, se non a consumare banda). Facendolo partire da terminale ecco il messaggio:

[duns@localhost ~]$ amule
amule: Symbol `_ZTVN8CryptoPP21SimpleKeyingInterfaceE' has different size in shared object, consider re-linking
2014-09-10 11:49:55: Initialising aMule 2.3.1 compiled with wxGTK2 v2.8.12
2014-09-10 11:49:55: Checking if there is an instance already running...
2014-09-10 11:49:55: No other instances are running.
Segmentation fault

In precedenza avevo avuto qualche raro problema con amule per il fatto che non sempre la chiusura avveniva correttamente e restava il fil mule.lock nella cartella .amule, allora bastava eliminare tale file e il programma partiva regolarmente. Adesso, quando tento di eliminare il file mule.lock a volte viene immediatamente ri-creato, oppure non succede niente.

Qualche idea?

Ritratto di francesco bat
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 20/11/2011 - 02:46

duns wrote:
Amule non parte più, o meglio forse parte ma non è visibile (dunque non serve a niente, se non a consumare banda). Facendolo partire da terminale ecco il messaggio:

[duns@localhost ~]$ amule
amule: Symbol `_ZTVN8CryptoPP21SimpleKeyingInterfaceE' has different size in shared object, consider re-linking
2014-09-10 11:49:55: Initialising aMule 2.3.1 compiled with wxGTK2 v2.8.12
2014-09-10 11:49:55: Checking if there is an instance already running...
2014-09-10 11:49:55: No other instances are running.
Segmentation fault

In precedenza avevo avuto qualche raro problema con amule per il fatto che non sempre la chiusura avveniva correttamente e restava il fil mule.lock nella cartella .amule, allora bastava eliminare tale file e il programma partiva regolarmente. Adesso, quando tento di eliminare il file mule.lock a volte viene immediatamente ri-creato, oppure non succede niente.

Qualche idea?

È vero ! Hai ragione !
Ho provato ora anche io e non parte più e stesso errore da terminale Sad
Per ora non ho idea che cosa è successo.
Indago e faccio sapere.
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 16/12/2011 - 10:52

Avendo una connessione nattata e' da anni che non uso piu' amule, ma emule con wine che stranamente scarica di piu' di amule.
Prima con amule avevo continue chiusure del programma, up e dw a 0 per ore.
Io ti consiglio di usare wine e emule.

Ritratto di footstep11
Offline
Last seen: 1 mese 4 giorni fa
Iscritto: 31/01/2013 - 11:01

500paolo wrote:
Avendo una connessione nattata e' da anni che non uso piu' amule, ma emule con wine che stranamente scarica di piu' di amule.
Prima con amule avevo continue chiusure del programma, up e dw a 0 per ore.
Io ti consiglio di usare wine e emule.

...o ancora meglio, usare torrent Wink

Mauro

Ritratto di 500paolo
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 16/12/2011 - 10:52

Non trovi tutto su torrent e la migliore alternativa sarebbe dc++ ma anche questo con rete nattata non funziona.

Ritratto di francesco bat
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 20/11/2011 - 02:46

duns wrote:
Amule non parte più, o meglio forse parte ma non è visibile (dunque non serve a niente, se non a consumare banda). Facendolo partire da terminale ecco il messaggio:

[duns@localhost ~]$ amule
amule: Symbol `_ZTVN8CryptoPP21SimpleKeyingInterfaceE' has different size in shared object, consider re-linking
2014-09-10 11:49:55: Initialising aMule 2.3.1 compiled with wxGTK2 v2.8.12
2014-09-10 11:49:55: Checking if there is an instance already running...
2014-09-10 11:49:55: No other instances are running.
Segmentation fault

In precedenza avevo avuto qualche raro problema con amule per il fatto che non sempre la chiusura avveniva correttamente e restava il fil mule.lock nella cartella .amule, allora bastava eliminare tale file e il programma partiva regolarmente. Adesso, quando tento di eliminare il file mule.lock a volte viene immediatamente ri-creato, oppure non succede niente.

Qualche idea?

Forse ho individuato la causa del problema Smile
Leggendo questo post:
http://oldforum.adunanza.net/threads/77098-AdunanzA-richiede-libcrypto-7...
sembra esserci lo stesso problema e la causa sembrerebbe la libreria libcrypto.
Infatti nel recente aggiornamento è stato aggiornato libcryptopp6 5.5.2-1 a 5.6.2-1.
Quindi sembra abbastanza evidente l'eventuale responsabile Smile
Ciao
Francesco bat

Ritratto di duns
Offline
Last seen: 2 anni 3 mesi fa
Iscritto: 30/10/2008 - 11:43

1) Che cosa significa rete nattata?
2) Su torrent si trova meno del 20% di quello che si trova con amule/emule
3) Si può fare un downgrade di quella libreria? Dove trovare il file? Ho provato invano su http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/pclinuxos...

Grazie

Ritratto di francesco bat
Offline
Last seen: 1 mese 2 settimane fa
Iscritto: 20/11/2011 - 02:46

duns wrote:
1) Che cosa significa rete nattata?
3) Si può fare un downgrade di quella libreria? Dove trovare il file? Ho provato invano su http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/pclinuxos...

Grazie

Io penso che è meglio aspettare che aggiustano loro il problema.
Nel frattempo si può usare Emule di windows con il wine.
Non è la prima volta che uso programmi di windows quando succedono problemi come questi.
Mi capitò di recente con vlc quando volevo avviare la visualizzazione projectm con pclinuxos e non funzionava per un aggiornamento e allora usavo la versione portatile di vlc di windows con il wine senza problemi.
Poi dopo un pò hanno aggiustato tutto e vlc mi ha ripreso ha funzionare correttamente su pclinuxos Wink
Ciao
Francesco bat

Ritratto di footstep11
Offline
Last seen: 1 mese 4 giorni fa
Iscritto: 31/01/2013 - 11:01

Appena apparso sull'account twitter di pclinuxos:

-----------------------------------------------------------------
pclinuxos @iluvpclinuxos · 1 h
Fixed the amule package before there was a total geek riot.
-----------------------------------------------------------------

Ritratto di duns
Offline
Last seen: 2 anni 3 mesi fa
Iscritto: 30/10/2008 - 11:43

Nuovo aggiornamento di amule, problema risolto! (qualcuno può dirlo nel titolo?) Grazie