Problema vlc

10 contenuti / 0 new
Ultimo contenuto
Ritratto di VEGETUX
Offline
Last seen: 4 anni 4 mesi fa
Iscritto: 15/08/2012 - 23:15
Problema vlc

Salve a tutti, ho un problema con vlc da diversi giorni (credo due settimane abbondanti). Penso sia successo sempre con un aggiornamnto fatto da synaptic; credo che abbia aggiornato ad una nuova versione, ma non ne sono sicuro. Il fatto è che quando apro vlc, non si sente l'audio e per metterlo ho scoperto che devo andare in alto sulla voce del menù audio di vlc e selezionare la seconda voce vale a dire :HDA ATI SB ALC887-VD Analog Default Audio Device, e l'audio si sente. Ora se faccio però quest'operazione con un mkv, si l'audio torna, ma il video si blocca, riparte e poi si riblocca, e così via... con tutti gli altri file, un volta selezionata la voce sopra citata dal menù audio di vlc, non danno problemi. E' capitato anche a qualcuno di voi e sapreste dirmi come risolvere se siete riusciti? Oppure è proprio un problema di aggiornamento di vlc (ammesso anche che questa sia la nuova versione)? Grazie in anticipo Smile

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Invece io ho patito per alcuni giorni con alcuni files wmv e asf.
Sembra un bug su wmv3, ma con un recente aggiornamento i wmv partono ma non so se si è risolto tutto.
Del resto non funziona più neanche projectm e devo ricorrere alla versione di windows di vlc con il wine.
Comunque l'mkv è solo un contenitore, dovresti controllare il codec utilizzato; se non l'ho hai ancora installato, installa mediainfo e controlla quale codec video e audio è utilizzato nell'mkv Wink
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Last seen: 1 anno 2 settimane fa
Iscritto: 16/12/2011 - 10:52

Infatti nemmeno a me funziona piu' projectm su vlc e sono i flv a fare "pause" a intervalli di 3-4 secondi. Comunque uso saltuariamente vlc, preferisco smplayer.

Negli utlimi aggiornamenti e' stato rimosso libprojectmqualcosa ed e' stato sostituito da qualcosa di simile...forse il cambio di nome ha creato problemi nella chiamata alla libreria.

Ritratto di VEGETUX
Offline
Last seen: 4 anni 4 mesi fa
Iscritto: 15/08/2012 - 23:15

francesco bat wrote:
Invece io ho patito per alcuni giorni con alcuni files wmv e asf.
Sembra un bug su wmv3, ma con un recente aggiornamento i wmv partono ma non so se si è risolto tutto.
Del resto non funziona più neanche projectm e devo ricorrere alla versione di windows di vlc con il wine.
Comunque l'mkv è solo un contenitore, dovresti controllare il codec utilizzato; se non l'ho hai ancora installato, installa mediainfo e controlla quale codec video e audio è utilizzato nell'mkv Wink
Ciao
Francesco bat

Il problema dell'audio purtroppo me lo fà con tutti i file (anche se per risolvere mi basta andare a selezionare il dispositivo audio), quello del video che si blocca quando vado a selezionare il tipo di dispositivo audio me lo fa con tutti gli mkv. Con i file wmv e asf non saprei,non ne ho proprio sul pc, posso sempre fare una prova scaricandone uno. Comunque ho installato mediainfo, anche se quando vado nelle informazioni dovrei cercare di capire meglio.In generale, penso che questo problema dovrebbe risolversi con un aggiornamenrto futuro, o con una nuova versione di vlc. Smile

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Vedendo nella cronologia del synaptic, non è stato rimosso projectm ma è stato aggiornato.
La rimozione è stato di un certo libswscaler-extra2 con l'aggiornamento di vlc qualche giorno prima di projectm.
Comunque già dall'aggiornamento di vlc non funzionava più projectm (per ora sto usando vlc di windows con il wine per questo).
La cosa bella è che al primo aggiornamenti di vlc, non solo non funzionava projectm ma alcuni video wmv con codec wmv3 non partivano e altri wmv e asf mi si distorciono ogni tanto durante la riproduzione.
Con il secondo aggiornamento di vlc i video con codec wmv3 ora sono visibili ma continua a distorcere random i wmv e asf.
Il recente aggiornamento di projectm non ha risolto.
Sembra un bug di vlc con i codec wmv, comunque ora sto usando un pò di più anche smplayer che funziona senza problemi.
Speriamo risolvono presto.
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Last seen: 1 anno 2 settimane fa
Iscritto: 16/12/2011 - 10:52

Ecco cosa e' successo:

Commit Log for Fri Nov 1 14:32:13 2013

I seguenti pacchetti sono stati rimossi:
libvisual-projectm

I seguenti pacchetti sono stati aggiornati:
lib64mesaglu1 (9.0.0-2pclos2013) to 9.0.0-3pclos2013
lib64mesaglu1-devel (9.0.0-2pclos2013) to 9.0.0-3pclos2013
lib64projectm2 (2.1.0-2pclos2013) to 2.1.0-4pclos2013
libkvkontakte (3.5.0-1pclos2013) to 3.5.0-2pclos2013
libmediawiki (3.5.0-1pclos2013) to 3.5.0-2pclos2013
libprojectm-data (2.1.0-1pclos2012) to 2.1.0-4pclos2013
lomanager (4.1.2-1pclos2013) to 4.1.3-1pclos2013
x11-proto-devel (7.6-6pclos2013) to 7.7-1pclos2013

I seguenti pacchetti sono stati installati:
lib64glew1.10 (1.10.0-1pclos2013)
lib64projectm2-libvisual (2.1.0-4pclos2013)

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Ho visto nella mia cronologia del synaptic e non mi risulta.
Forse perchè la situazione è diversa su 64 bit, io ho la 32 bit.
Ciao
Francesco bat

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Provato ad installare "projectm-libvisual-alsa" da synaptic (solo se si usa alsa e no pulse).
Avviandolo da terminale con il seguente comando: projectM-libvisual-alsa
appare una finestra X totalmente nera e nel terminale ottengo questo errore a catena: "The given actor does not reference any actor plugin".
Ciao
Francesco bat

Ritratto di VEGETUX
Offline
Last seen: 4 anni 4 mesi fa
Iscritto: 15/08/2012 - 23:15

Credo che il mio pc-los usa pulse, quindi preferisco non installare alsa, comunque credo anch'io che sia un bug, anche perchè la cosa al momento sembra irrisolvibile, speriamo che si risolva presto con qualche aggiornamento, per il momento penso che userò di più smplayer!! Smile

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Infatti !
Anche io sto usando spesso smplayer per questi problemi e vlc di windows sul wine.
L'importante che c'è sempre un'alternativa valida.
Comunque speriamo che quelli di vlc risolvono presto.
Ciao
Francesco bat