Openshot non mi genera il filmato

18 contenuti / 0 new
Ultimo contenuto
Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52
Openshot non mi genera il filmato

Ciao a tutti, come da titolo ho provato Openshot su pclinuxos-xfce dopo averlo utilizzato con successo per molto tempo su Mint. Il problema e' che quando vado a generare il filmato, questo non va avanti e rimane bloccato su 0.0% qualsiasi tipo di codifica scelgo (nvidia, cpu...) mi appare anche un messaggio sulla finestra dell'applicazione che mi avverte di un aggiornamento, ma come sappiamo su pclinuxos niente si pu' fare se non da apt, credo nemmeno installare ppa, cosa mi consigliate?

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

Ci sono anche altri video editor su synaptic solo ora che non me li ricordo (a parte kdenlive).

Prima di installarne altri perchè non provi a vedere meglio qual'è il problema?

Prova ad eseguirlo da terminale e vedi che errore fa.

Se è un problema di vecchia versione si può anche richiedere sul forum internazionale di aggiornarlo.

Ciao

Francesco bat

Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52

Facendo delle prove ho scoperto che fino a 1080p funziona, ma a me diventa inutile. Mi piaceva openshot per la semplicità e la qualita' del video in uscita, ma leggendo in giro pare che abbia molti problemi, eppure l'ho usato per diversi anni su mint e ieri ho fatto la prova anche su mx e andava bene...mah!

Comunque l'errore e' qualcosa del genere e credo sia di python: "double free or corruption".

Ora sto provando shotcut ma e' troppo macchinoso, poco intuitivo e dal risultato variabile.

Comunque ben risentito Francesco.

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

Ho visto che è appena ad una versione indietro.

Quindi è abbastanza aggiornato, magari lo aggiornano a breve.

Se viene richiesto sul forum internazionale potresti vederlo aggiornato subito.

In alternativa potresti vedere anche qualcosa qui:

https://www.pling.com/browse/cat/483/order/latest

È un piacere risentire anche te Paolo. Bye

Ciao

Francesco bat

Ritratto di footstep11
Offline
Last seen: 4 giorni 18 ore fa
Iscritto: 31/01/2013 - 11:01

Prova avidemux.  Nonostante il nome ricordi il formato avi, funziona con qualsiasi formato in ingresso/uscita.

La versione di openshot su pclos e' la 2.5.0 mentre l'ultima e' la 2.5.1.  Dubito fortemente che sia un problema di versione. Il mio sospetto e' che sia un problema di python (openshot usa la 3.4 mentre su pclos c'e' la 3.6)

 

Ciao, Mauro

 

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

Ma non è possibile installare anche altre versioni vecchie di Phython?

Io ad esempio non riesco a far funzionare: https://www.pling.com/p/1012371

Mi funziona tranquillamente su Slackware eppure sembra che ha le stesse versioni di Python installate di PCLinuxOS ma non quelle richieste da "Icon Theme Updater" che sono più vecchie. Shok

Misteri di Python  Scratch one-s head

Ciao

Francesco bat

Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52

Grazie a tutti voi, ciao anche a te Footstep, sentivo la vostra mancanza. Ho abbandonato per un po' pclinuxos sul pc principale ma non sul portatile che uso quando sono in tempo libero e del resto su quello non ho avuto problemi per anni, ma necessitavo di una distro piena di software e compatibilità come mint e sono dovuto scendere a compromessi che pero' alla fine sono svaniti all'ultimo avanzamento di versioe che e' andato male mentre quello precedente ero riuscito a sistemarlo (sulle deb purtroppo bisognerebbe sempre fare una fresh install ma che pa**e rifare tutta la configurazione!).

Purtroppo sul sito di openshot non si forniscono piu' pacchetti rpm o deb, ma appimage che chiaramente su pclinuxos a me ha dato errore per percorsi errati, librerie di versioni e nomi diversi. Anche su mint avevo la stessa verione di openshot ma li riuscivo a esportare il video sopra il full hd.

Ora mi sto abituando a shotcut che comunque fatte delle prove e trovate le giuste impostazioni da buoni risultati.

Altra cosa che mi ha dato fastidio sono le QT5 (ormai credo siano anche su mint), non c'e' verso di uniformare lo stile delle app scritte con quel linguaggio al mio tema di sistema(tutto grigio scuro e colore di selezione rosso acceso), le ho provate tutte (tranne che installare kde, ma se non ricordo male tempo fa provai anche con quello e certe cose non si riuscivano a cambiare) anche il tema Kvantum e qt5ct ma il primo si configura poco e il secondo non ha effetto. In sostanza non riesco a liberarmi del tema chiaro e di quel azzurrino come colore di selezione.

Ritratto di footstep11
Offline
Last seen: 4 giorni 18 ore fa
Iscritto: 31/01/2013 - 11:01

francesco bat wrote:
Ma non è possibile installare anche altre versioni vecchie di Phython?

Si', si puo' fare... le versioni di python risiedono in cartelle con il numero di versione: python2.5, python2.6, python3.0, ecc. Al loro interno c'e' l'eseguibile e le corrispondenti librerie. Il problema si pone se si richiama il programma con un semplice 'python'. In questo caso /usr/bin/python e' un link simbolico all'ultima versione installata.  Se si vuole lanciare una versione definita bisogna dargli il path completo, del tipo /usr/bin/python3.5

Esiste anche un programma che gestisce le varie versioni in maniera trasparente, creando un ambiente in cui al comando python viene associata una particolare versione. Si chiama pyenv  Se ti interessa puoi dargli una occhiata.

Ciao, Mauro

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

footstep11 wrote:

francesco bat wrote:
Ma non è possibile installare anche altre versioni vecchie di Phython?

Si', si puo' fare... le versioni di python risiedono in cartelle con il numero di versione: python2.5, python2.6, python3.0, ecc. Al loro interno c'e' l'eseguibile e le corrispondenti librerie. Il problema si pone se si richiama il programma con un semplice 'python'. In questo caso /usr/bin/python e' un link simbolico all'ultima versione installata.  Se si vuole lanciare una versione definita bisogna dargli il path completo, del tipo /usr/bin/python3.5

Esiste anche un programma che gestisce le varie versioni in maniera trasparente, creando un ambiente in cui al comando python viene associata una particolare versione. Si chiama pyenv  Se ti interessa puoi dargli una occhiata.

Ciao, Mauro

Si, hai ragione.

Tempo fa forse individuai la causa dell'errore, solo che avevo ormai tutto inserito su Slackware e la maggior parte delle operazioni con lo script le avevo fatte su Slackware e non mi rimase quasi più niente da fare.

Ora non riesco neanche a ricordarmi l'ipotetica causa del problema che se confermato era sicuramente risolvibile.

Per 500paolo

Con Qt5 molte applicazioni sono diventate indipendenti e spesso hanno un loro tema grafico per cambiare la skin del programma.

Negli ultimi tempi tutto sembra essersi più distaccato: gtk2, gtk3, qt4, qt5, x11

Se oggi applichi un tema al proprio desktop, devi provvedere a modificare manualmente le altre interfacce.

Io ormai ci sono abituato, cambio tutto di continuo e ho creato anche con un lanciatore, Paunch: http://paunch.sourceforge.net/

a inserire li tutte le impostazioni di varie applicazioni e anche singole applicazioni per cambiare i temi a tutti.

Io che del resto non amo gtk3, l'ho preimpostato con tema dei colori e icone Numix e non lo cambio più.

Numix a mio parere è il miglior tema in alternativa all' arrogante Adwaita.

Il resto, gtk2, programmi x11 e qt5, spesso li cambio manualmente inserendo tutti quelli che cambio periodicamente in Paunch.

Ciao

Francesco bat

 

Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52

@Francesco bat, per scrupolo oggi ho clonato la /home di pclinuxos xfce su altro hd dove poi ho installato la versione kde plasma. Risultato sono riuscito a ottimizzare il tema per tutte le applicazioni, gtk2,gtk3 e qt5 (Synaptic, smplayer, vlc, tutto grigio scuro, testo bianco e colori di hover rosso #ff0000, tutto completamente identico compresi i widget) il problema ora e' che non riesco a far funzionare l'app touplite per acquisire le immagini al microscopio.  In pratica qualcosa non gli piace di /usr/lib64/libgtk3-nocsd.so.0 e di /usr/lib64/libfontconfig.so che sono presenti in entrambe le distro, ho pure copiato i file dall'istallazione di xfce in quella kde ma nulla. Insomma mi devo tenere xfce che non mi piace proprio ma e' il miglior compromesso. Cosa che mi fa accapponare le pelle di xfwm4? La mancanza di hover sui pulsanti finestra inattiva, sta anche su lxde, perche' cavolo non lo mettono anche su xfce? Mi pare un partito preso...

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

Forse perchè tu usi i convertitori, cioè quei programmi a volte preinstallati che trasformano le applicazioni gtk con lo stesso stile di kde e viceversa.

Io li ho usati ai tempi di kde4 e per un pò su Trinity Desktop ma li ho rimossi perchè spesso non erano precisi e alcuni programmi mi crashavano pure.

Preferisco fare tutto io manualmente e con tanti temi differenti che del resto a me piace anche di più così Smile

Ciao

Francesco bat

Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52

No, e' che ho modificato un tema gtk pezzo per pezzo, cartella per cartella, css per css così ho uniformato gtk2.0, 3.0, 3.1,3.18,3.20 mi rimanevano solo le qt5...

Ritratto di dxgiusti
Offline
Last seen: 2 mesi 6 giorni fa
Iscritto: 22/01/2013 - 17:30

ciao, uso spesso openshot sulla mia desktop pclinuxos-mate, devo rilevare che non ho problemi di nessun genere. mi piacerebbe sapere come esportate il video ( se ho inteso bene è questo il vostro problema ).

Ritratto di dxgiusti
Offline
Last seen: 2 mesi 6 giorni fa
Iscritto: 22/01/2013 - 17:30

per curiosità ho scaricato il programma ultima versione appimage, dopo aver dato il permesso, l'ho avviato. mi è comparsa una finestra con molti avvertimenti ma solo un errore l'ultimo in lista dove mi chiedeva >>> libselinux....... , da synaptic ho installato >> libselinux-utils, libselinux-python, libselinux-pyton3, rilanciato photoshop appimage ed ho editato un video. tutto ha funzionato senza problemi.

Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52

Il problema nel mio caso e' che non riesco a esportare (creare il video finale) in mp4 con risoluzione superiore al classico Hd 1080p, ovvero niente 4k, la finestra si blocca  a 0.0% e alla fine devi ucciderla. Posso farti un video e darti il link.

Ritratto di dxgiusti
Offline
Last seen: 2 mesi 6 giorni fa
Iscritto: 22/01/2013 - 17:30

immagino tu abbia installato >>> x264, x265 magari controlla. per esportare in 4k devi avere una scheda video adeguata ed il tuo processore diciamo abbastanza potente. se riesci a dare il link del mp4 posso provare.

Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52

@DxGiusti, leggi il primo post.

Con mint esportavo anche in 6k, dopodiché openshot non va oltre ma io potrei anche. Parliamo di spezzoni di filmati da tagliare, unire e mettere un watermark con trasparenza. Il pc è molto superiore alla media. Sono installate le medesime librerie di mint e tutti gli encoder disponibili su synaptic, ci sono anche le librerie x far fare la codifica alla scheda video nvidia ma niente.

Ritratto di 500paolo
Offline
Last seen: 2 settimane 4 giorni fa
Iscritto: 16/12/2011 - 10:52

Sapete per caso dove si trova il file di configurazione o comunque dove modificare fusion (qt5)?