openoffice 2.4

10 contenuti / 0 new
Ultimo contenuto
Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10
openoffice 2.4

Non riesco a capire: qualche settimana fa openoffice si è aggiornato durante un dist-upgrade venendo fuori in inglese e col numero di 2.3 mentre le altre distruibuzioni lo mettono già a 2.4 (e cosi sembrerebbe anche nei forum di www.pclinuxos.com).
La lingua l'ho sistemata mettendo il ..l10n-it che mancava ma la versione resta quella anche cambiando mirror dei repo (giustamente essendo mirror non cambia nulla).
Qui sotto quanto reso da synaptic per openoffice fra i pacchetti installati, tutti all'ultima versione disponibile:

myspell-thes-it_IT 1.0.2
myspell-it_IT 1.0.2
openoffice.org 2.3.1
openoffice.org-l10n-it 2.3.1
openoffice.org-core 2.4.1
openoffice.org-java 2.4.1
openoffice.org-kde 2.4.1
openoffice.org-mimelnk 2.4.1
openoffice.org-ooqstart 2.4.1

Ritratto di patel
Offline
Last seen: 5 anni 4 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Per avere la 2.4 devi abilitare i repo testing aggiungendo alla voce sezioni "testing". Fai ricarica e lo installi

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Ops, cioè scrivere nel source list:
rpm ..../pclinuxos/2007 main extra nonfree kde testing ?

Però non mi cambia nulla, forse perché:
openoffice.org-2.4.0-2pclos2007.src.rpm
è in
..../pclinuxos/2007/SRPMS.testing/
e non in
..../pclinuxos/2007/RPMS.testing/

Continuo a non capire.
Le sezioni di synaptic non sono editabili

Ritratto di patel
Offline
Last seen: 5 anni 4 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Non in Source list.
Su Synaptic Impostazioni, archivi pacchetti, selezioni il tuo repo (quello spuntato è editabile) ed aggiungi testing. Il mio ha la seguenti voci "main extra nonfree kde testing ".

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Questa è bellina.

Sono daccordo sul fatto che che non sia molto importante, se lo fosse prenderei il .rpm direttamente e lo installerei.
Ma visto che magari da tutta questa discussione qualcun altro ne può avere beneficio, proseguo.

Editato il repo da synaptic l'ho trovato giustamente già fornito del testing che gli avevo messo a mano nel source.list.
... main extra nonfree kde testing, esattamente come il tuo.
Comunque gli ho ridato 'ricarica' (come pure avevo già apt-get updatato da shell) ma openoffice.org 2.3.1 e openoffice.org-l10n-it 2.3.1 restano lì imperturbati.
Ci sarà pure un motivo per cui ci sono due directory (RPMS.testing e SRPMS.testing) sul server.
Ma tu hai il 2.4 funzionante?

Ritratto di patel
Offline
Last seen: 5 anni 4 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Si l'ho funzionate, SRPMS sono i source quindi da compilare. Ma dopo ricarica lo dai il Marca tutti gli aggiornamenti ?

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Azz. No.

Non lo davo perché la versione installata e l'ultima disponibile erano la stessa.
In debian e ubuntu l'ultima disponibile è veramente quella che si installerà e quindi pensavo lo stesso anche per pclinuxos.
Comunque ho dato Marca e Esegui doodiché è partito a lavorarsi credo 350Mb di roba, è crashato ogni cosa e al riavvio ora si blocca al caricamento del mouse.

Quindi domani se nn riesco a sanare la faccenda, reinstallo senza testing e vivo felice aspettando il 2.4 utontproof.
Evidentemente qui la testing è testing per davvero.

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Ma anche quella normale mica scherza.
Ho reinstallato tutto il sistema ma al momento di rimettere:

gedit:
Depends: gnome-python-gtksourceview
Depends: libgtksourceview-1.0.so.0 but it is not installable
gnumeric:
Depends: libgnomedb-3.so.4
Depends: libgnomedb_graph-3.so.4
Depends: libgnomedb_handlers-3.so.4

Lo strano è che di solito queste dipendenze non vengono richieste.
Le gtk dovrebbero essere a posto visto che gimp openoffice e abiword sono perfetti.

Come fare?

Ritratto di patel
Offline
Last seen: 5 anni 4 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Io credo che con pclos bisogna rassegnarsi ad utilizzare la versione con kde. Quella gnome ha dei bugs.

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Si, evidentemente nella reinstallazione qualcosa è andato storto perché prima gedit e gnumeric c'erano senza problemi, ora loro non risolvono le dipendenze e firefox3 crasha appena lanciato dicendo:
$
(crashreporter:4671): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed

E' la prima volta che trovo problemi a farli girare con kde.

Per il resto è tutto ok.
Vediamo se matura.