Installare MMEX

10 contenuti / 0 new
Ultimo contenuto
Ritratto di xdodo49
Offline
Last seen: 1 settimana 5 giorni fa
Iscritto: 09/10/2016 - 22:04
Installare MMEX

Sono un nuovo utente di pclinuxos. Da anni uso su un pc linux mint con soddisfazione, ma recentemente ho scoperto pclinuxos  e devo dire che mi piace per cui l'ho installato sul notebook. Ora però mi nasce un problema dovuto alla mia scarsa conoscenza dei sistemi che usano software rpm. Infatti io uso da tempo un programma di contabilità familiare sia su pc che su cellulare ed ora volevo installarlo anche sul notebook, ma non trovo la versione rpm. Io dispongo del software in versione .deb e in versione tar.gz, ma non so assolutamente come fare per installarlo. Se qualcuno è in grado di aiutarmi..........

Ritratto di esabatad
Offline
Last seen: 3 mesi 1 giorno fa
Iscritto: 20/06/2012 - 07:37
Ritratto di zafran
Offline
Last seen: 6 mesi 4 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Non è detto che mmex.deb non funzioni.

  1. Va convertito in .rpm con il comando
    alien -r mmex.deb (basta essere utente e avere alien installato)
  2. e installato con
    rpm -i mmex.rpm (da root)

Tentar non dovrebbe nuocere

 

Ritratto di xdodo49
Offline
Last seen: 1 settimana 5 giorni fa
Iscritto: 09/10/2016 - 22:04

La trasformazione con alien l'ho già fatta tempo indietro ma ho ottenuto un errore a causa di dipendenze mancanti. Ho provato a farlo nuovamente ma ottengo questi errori: (non so come inserire le righe di codice, in altri forum ho trovati i caratteri per delimitare il codice, qui non li vedo)

[root@localhost Scaricati]# rpm -i mmex-1.2.7~xenial5-2.x86_64.rpm
errore: Dipendenze fallite:
        libstdc++.so.6(GLIBCXX_3.4.21)(64bit) necessario a mmex-1.2.7~xenial5-2.x86_64
        rpmlib(TildeInVersions) <= 4.10.0-1 necessario a mmex-1.2.7~xenial5-2.x86_64

 

a questo punto io non sono in grado ne di trovare  le dipendenze mancanti, ne di installarle.

 

 

Ritratto di xdodo49
Offline
Last seen: 1 settimana 5 giorni fa
Iscritto: 09/10/2016 - 22:04

Ho provato a seguire le tue indicazioni, anche se il software è in versione obsoleta, tanto per vedere, ma ho ottenuto tutta uan serie di dipendenze fallite.

[root@localhost Scaricati]# rpm -i moneymanagerex-0.9.4.2-1pclos2009.i586.rpm                       
errore: Dipendenze fallite:
        libSDL-1.2.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586
        libwx_baseu-2.8.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586
        libwx_baseu_net-2.8.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586
        libwx_baseu_xml-2.8.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586
        libwx_gtk2u_adv-2.8.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586
        libwx_gtk2u_aui-2.8.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586
        libwx_gtk2u_core-2.8.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586
        libwx_gtk2u_html-2.8.so.0 necessario a moneymanagerex-0.9.4.2-1pclos2009.i586

Grazie comunque.

 

Ritratto di monsee
Offline
Last seen: 3 settimane 3 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Vorresti installare MoneyManagerEx sul tuo notebook?
A che ti serve far ricorso ad Alien e crearti a manina il pacchetto? Dovrebbe esistere già, nei Repo di UPLOS (che è il nuovo supporto che eroici combattenti stanno cercando di dare a quello che era prima PCLInuxOS 32-bit), il pacchetto che installa MoneyManagerEx (difatti, io ce l'ho installato nel mio PC). Insomma, se usi il Repo di UPLOS, credo dovresti trovar MoneyManagerEx (il pacchetto datato 2009, intendo) in Synaptic... e dovresti poterlo installar per tale via.
Inoltre, se ciò può giovarti, avrei trovato ben tre pacchetti RPM (due dei quali per Fedora [fc16 e fc17] più un terzo RPM non meglio definito) che, se ti va (e se il tuo PC ha un Processore a 32-bit) potresti magari tentar di utilizzare. Li trovi sulla pagina Web (di Sourceforge) cui ti conduce il sottostante link:
https://sourceforge.net/projects/moneymanagerex/files/moneymanagerex/Ver...
Non esiste -immagino, a causa di difficoltà interne al Programma in oggetto- al momento (tranne che per OpenSuSE e ArchLinux, mi pare... e forse, ma non garantisco, anche per UBUNTU) alcun pacchetto per Linux a 64-bit. In quanto ai due errori che hai avuto al primo tentativo (nel quali hai cercato di installare, invece, un pacchetto a 64-bit... e in questo caso UPLOS -che è solo a 32 bit- non ti può certo aiutare), il primo errore può esser sia risolubile con l'installazione di Google Chrome (il browser), ma temo che la cosa non ti possa poi servire a niente, perché il secondo errore che segnali subito dopo è relativo ad un BUG (irrisolto a tutt'oggi) afferente il pacchetto che hai ottenuto "trasformando" tramite ALIEN.

Ritratto di adrianomorselli
Offline
Last seen: 7 ore 19 min fa
Iscritto: 02/01/2015 - 12:20

Visto che il programma esiste anche per windows puoi usare wine, non credo che richieda tante risorse poichè è del 2009, da non girarti in questo modo. In alternativa puoi virtualizzare mint sotto virtualbox o anche windows xp, o a questo punto pure uplos e scaricare il programma a 32bit.

Ritratto di xdodo49
Offline
Last seen: 1 settimana 5 giorni fa
Iscritto: 09/10/2016 - 22:04

Io il programma lo uso regolarmente su win 10, cellulare e mint 18. In teoria posso farne tranquillamente a meno, ma un per principio e un po per sfida volevo usarlo anche sul notebook dove ho installato pclinusos. Con wine le vecchie versioni funzionavano, le ultime a partire dalla release 1.1 non funzionano ne a 32 ne a 64. Usare virtualbox non mi interessa, so benissimo che così funzionerebbe.

Per rispondere a monsee, tutte le indicazioni che mi hai suggerito mi trovano spiazzato, perchè come ho gia detto, io non sono un esperto, anzi un inesperto e non ho idea di come maneggiare i repos che mi indichi ( ci riesco a malapena su mint dopo anni di utilizzo) e poi di una versione datata no ne faccio nulla, perche essendo un programma che utilizza il dropbox per salvare i dati, le ultima versioni non sono compatibili con i vecchi dati. Su ubuntu o mint si può utilizzare l'ultima versione, la 1.3 che pero ha problemi nello scaricamento per via del fatto che il ppa indicato sul sito non è più attivo. La senzazione è che comunque gli sviluppatori siano sempre meno interessati alla versione linux per priviligiare quella andtroid, windows e forse mac ed è un vero peccato perchè per me rimane uno dei migliori software gratuiti di contabilità famigliare.

Ritratto di adrianomorselli
Offline
Last seen: 7 ore 19 min fa
Iscritto: 02/01/2015 - 12:20

Il sorgente c'è, o ti adatti tu con ./configure make make install ma devi anche scaricarti le varie dipendenze, posto che ci siano, oppure posti sul forum internazionale e chiedi se qualche anima pia ti faccia il pacchetto .rpm. Normalmente sono abbastanza celeri e nel capo di qualche settimana dovresti avere il pacchetto a disposizione nel repositories

Ritratto di xdodo49
Offline
Last seen: 1 settimana 5 giorni fa
Iscritto: 09/10/2016 - 22:04

Vedrò di seguire il tuo consiglio, magari nel frattempo a qualche altro si porrà il mio stesso problema e chissà che si possa risolvere.