Gnome-do non si avvia

3 contenuti / 0 new
Ultimo contenuto
Ritratto di maronno
Offline
Last seen: 9 anni 9 mesi fa
Iscritto: 23/01/2012 - 17:18
Gnome-do non si avvia

Purtroppo, dopo il mintmenu, e xbmc, ho trovato subito un altro software che non si avvia.
Gnome-do, installato sulla versione xfce di pclinuxos, non si avvia. Dopo averlo installato e lanciato da terminale, ecco cosa ottengo:

[code]
gnome-do

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for Mono.Unix.Native.Stdlib ---> System.DllNotFoundException: libMonoPosixHelper.so
at (wrapper managed-to-native) Mono.Unix.Native.Stdlib:GetDefaultSignal ()
at Mono.Unix.Native.Stdlib..cctor () [0x00000] in :0
--- End of inner exception stack trace ---
at Mono.Unix.UnixMarshal.AllocHeap (Int64 size) [0x00000] in :0
at Mono.Unix.UnixMarshal.StringToHeap (System.String s, Int32 index, Int32 count, System.Text.Encoding encoding) [0x00000] in :0
at Mono.Unix.UnixMarshal.StringToHeap (System.String s, System.Text.Encoding encoding) [0x00000] in :0
at Mono.Unix.UnixMarshal.StringToHeap (System.String s) [0x00000] in :0
at Mono.Unix.Catalog.MarshalStrings (System.String s1, System.IntPtr& p1, System.String s2, System.IntPtr& p2, System.String s3, System.IntPtr& p3) [0x00000] in :0
at Mono.Unix.Catalog.Init (System.String package, System.String localedir) [0x00000] in :0
at Do.Do.Main (System.String[] args) [0x00000] in :0

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for Mono.Unix.Native.Stdlib ---> System.DllNotFoundException: libMonoPosixHelper.so
at (wrapper managed-to-native) Mono.Unix.Native.Stdlib:GetDefaultSignal ()
at Mono.Unix.Native.Stdlib..cctor () [0x00000] in :0
--- End of inner exception stack trace ---
at Mono.Unix.UnixMarshal.AllocHeap (Int64 size) [0x00000] in :0
at Mono.Unix.UnixMarshal.StringToHeap (System.String s, Int32 index, Int32 count, System.Text.Encoding encoding) [0x00000] in :0
at Mono.Unix.UnixMarshal.StringToHeap (System.String s, System.Text.Encoding encoding) [0x00000] in :0
at Mono.Unix.UnixMarshal.StringToHeap (System.String s) [0x00000] in :0
at Mono.Unix.Catalog.MarshalStrings (System.String s1, System.IntPtr& p1, System.String s2, System.IntPtr& p2, System.String s3, System.IntPtr& p3) [0x00000] in :0
at Mono.Unix.Catalog.Init (System.String package, System.String localedir) [0x00000] in :0
at Do.Do.Main (System.String[] args) [0x00000] in :0
[/code]

Ritratto di bebolinux
Offline
Last seen: 5 anni 1 mese fa
Iscritto: 10/12/2008 - 22:27

ho installato gnome-do su KDE4 e funziona correttamente.
Io avevo già installato per altri motivi mono, da cui dipende.
In effetti gli errori che ti da dipendono dal pacchetto mono (una sorta di frameword opensource) con cui sembra stato scritto il programma.
E' tra i pacchetti richiesti quindi synaptic dovrebbe già avertelo installato insieme a gnome-do.
In ogni caso controlla da synaptic che hai installato Mono Runtime .
ciao

Ritratto di maronno
Offline
Last seen: 9 anni 9 mesi fa
Iscritto: 23/01/2012 - 17:18

Mono è installato. Ho ovviato al problema installando Kupfer. Davvero un ottimo strumento, anch'esso! Wink