Errore aggiornamento privoxy

6 contenuti / 0 new
Ultimo contenuto
Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46
Errore aggiornamento privoxy

Qualche giorno fa, 29 marzo, ho fatto un aggiornamento e alla fine il synaptic mi ha lasciato un avviso di errore su privoxy:

"Durante l'installazione del pacchetto privoxy-3.0.21-1pclos2013:

Warning: network-up is needed by privoxy in runlevel 2
Warning: network-up is needed by privoxy in runlevel 4
Warning: network-up is needed by privoxy in runlevel 2
Warning: network-up is needed by privoxy in runlevel 4
Warning: network-up is needed by privoxy in runlevel 2
Warning: network-up is needed by privoxy in runlevel 4
Warning: network-up is needed by privoxy in runlevel 2
Warning: network-up is needed by privoxy in runlevel 4
Warning: network-up is needed by privoxy in runlevel 2
Warning: network-up is needed by privoxy in runlevel 4
Warning: network-up is needed by privoxy in runlevel 2
Warning: network-up is needed by privoxy in runlevel 4
/etc/sysconfig/network: riga 4: errore di sintassi vicino al token non atteso "newline"
/etc/sysconfig/network: riga 4: `DHCP_HOSTNAME='
/etc/sysconfig/network: riga 4: attenzione: syntax errors in . or eval will cause future versions of the shell to abort as Posix requires
"

Cosa potrebbe essere ?
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

... Ma l'aggiornamento è riuscito oppure t'è stato proprio abortito?

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

No è andato bene, solo che alla fine dell'aggiornamento è uscita una finestra di synaptic con quanto riportato.
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Se il programma funziona bene, non preoccuparti del messaggio d'errore finale. Lo stesso Texstar, relativamente a un altro caso analogo in PCLinuxoS a 32-bit, più o meno un annetto or sono, scrisse esplicitamente che non c'era da preoccuparsi troppo di tutti i messaggi d'errore che appaiono a conclusione (positiva) di un'installazione o di un aggiornamento effettuati attraverso Syanptic. Il messaggio d'errore, in questi casi, concerne cose secondarie ancora in fase di perfezionamento (e interessa ai pacchettizzatori, insomma, più che ai normali Utenti).

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Infatti non sono errori, sono solo warning.
Il che non fa mai male (essere warned).

Ritratto di footstep11
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 31/01/2013 - 11:01

francesco bat wrote:
Qualche giorno fa, 29 marzo, ho fatto un aggiornamento e alla fine il synaptic mi ha lasciato un avviso di errore su privoxy:

"Durante l'installazione del pacchetto privoxy-3.0.21-1pclos2013:

Warning: network-up is needed by privoxy in runlevel 2
snip-snip

Questi sono dei warning e puoi tranquillamente ignorarli.

francesco bat wrote:
/etc/sysconfig/network: riga 4: errore di sintassi vicino al token non atteso "newline"
/etc/sysconfig/network: riga 4: `DHCP_HOSTNAME=<francesco-pclinuxos>'
/etc/sysconfig/network: riga 4: attenzione: syntax errors in . or eval will cause future versions of the shell to abort as Posix requires

Questo invece significa che c'e' qualche cosa che non gli e' piaciuto nel file /etc/sysconfig/network Secondo me non gli piacciono i '<' e '>' nel nome del server dhcp (che immagino abbia impostato tu). Infatti i segni di maggiore e minore sono caratteri di shell per il re-indirizzamento dell'input, quindi andrebbero evitati (o almeno 'escapati' - mi si perdoni il termine).

Il sistema dovrebbe funzionare, ma se fossi in te io li toglierei.

Ciao, Mauro