Boot sempre più lento, anzi: lentissimo !

16 contenuti / 0 new
Ultimo contenuto
Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46
Boot sempre più lento, anzi: lentissimo !

Ciao a tutti.
Apro questo post per capire e consultarci un pò tutti dopo il recente kernel 3.18.
Con questo aggiornamento diciamo che ho risolto i problemi gravi di funzionamento del sistema che erano presenti con il precedente kernel 3.17, ma ora si presenta un'altra odissea: lentissimo all'avvio.
Calcolando i tempi ecco i risultati:
1. Boot dal grub per arrivare al login: 1 minuto e 45 secondi
2. accesso al desktop kde: 2 minuti (meno di 5 secondi per accedere ad icewm ma netapplet non è subito funzionante).
La lentezza di accesso al desktop kde è notevolmente aumentata ma il vero problema sembra proprio il boot da grub che con il kernel 3.16 (e forse anche 3.17), mi ci metteva una 30ina di secondi.
Eppure ho un dual core 2,60 ghz e 2 gb di ram (un sistema operativo a 32 bit non accetta ram maggiori di 2 gb quindi il sistema non può pretendere di più).
A voi invece che aria tira ?
Ciao
Francesco bat

Ritratto di Hertz
Offline
Last seen: 1 anno 9 mesi fa
Iscritto: 02/08/2014 - 10:59

Buongiorno francesco bat e Buon Anno,

tutti i vari problemi che tu hai riscontrato e descritto riguardanti il kernel 3.18.1 (nel mio caso), non li ho avuti e non li ho neppure tutt'ora, forse perchè il sistema su cui gira PCLOS è a 64bit e non a 32bit, di conseguenza la RAM disponibile me la vede interamente.
Per accedere alla schermata di KDE ci impiego pochi secondi (una ventina o poco più), ma senza nessun tipo di latenza del sistema (compreso l'avvio della connessione di rete e riconoscimento della scheda di rete stessa).
Come ho indicato in un post precedente a questo, l'ultima versione del kernel mi ha portato dei giovamenti generali, come la velocizzazione del bootloader e dell'apertura delle applicazioni ed un minor consumo di memoria fisica.
Ferma restando che utilizzando soltanto il repository test, sul mio sistema compaiono quotidianamente (o quasi), nuovi aggiornamenti e per conseguenza apparentemente meno stabile, ma ciò nonostante tutto (per ora), non mi ha recato nessun problema.
Come mia considerazione prettamente personale, se hai un processore dual-core hai a disposizione i 64bit ed avendo un paio di GiB di RAM io penso che comunque girerebbe il tuo sistema senza grossi problemi, ma comprendo che in un certo senso dovresti rifare un'installazione ex-novo di tutto, quindi questa resta prettamente una scelta personale.
Per concludere, in alternativa potresti testare (sempre che ce ne sia la possibilità), la versione a 64bit su una differente macchina o "muletto" (se disponibile) e vedere come si comporta, secondo me ti troveresti molto meglio di adesso, e con un margine più ridotto di problematiche legate alla velocità di esecuzione del sistema in generale.
Nell'ipotesi di poter o voler passare ad un kernel PAE, non servirebbe, perchè il sistema riconosce soltanto la RAM se superiore a 3 GiB e non inferiore a tale misura.

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

Grazie delle info Wink
Ora però ho voluto fare un test e forse ho capito il motivo del rallentamento del caricamento del kernel.
Ho provato ad avviare il sistemma dal grub selezionando la voce: linux-nonfb
Da qui mi esce una schermata nera di attesa con una scritta sopra in alto: cannot open file delete
Pensavo a qualcosa andato storto perchè ho avuto la pazienza di apettare 1 minuto circa; poi d'improvviso è partito il caricamento del kernel.
Quindi se il kernel è partito dopo 1 minuto circa, è evidente che ci sia un problema proprio con quel riferimento.
Traducendo in inglese sembra che voglia dire di non riuscire ad aprire un file cancellato (anche se dice "delete" invece di "deleted").
Magari bisognerebbe capire cosa non può aprire e magari risolvere e così si velocizzerebbe il boot; ma non so dove vedere una cosa del genere. Sad
ciao
Francesco bat

Ritratto di Hertz
Offline
Last seen: 1 anno 9 mesi fa
Iscritto: 02/08/2014 - 10:59

Ciao Francesco bat,

francesco bat wrote:
Grazie delle info Wink
Ora però ho voluto fare un test e forse ho capito il motivo del rallentamento del caricamento del kernel.
Ho provato ad avviare il sistemma dal grub selezionando la voce: linux-nonfb
Da qui mi esce una schermata nera di attesa con una scritta sopra in alto: cannot open file delete
Pensavo a qualcosa andato storto perchè ho avuto la pazienza di apettare 1 minuto circa; poi d'improvviso è partito il caricamento del kernel.
Quindi se il kernel è partito dopo 1 minuto circa, è evidente che ci sia un problema proprio con quel riferimento.
Traducendo in inglese sembra che voglia dire di non riuscire ad aprire un file cancellato (anche se dice "delete" invece di "deleted").
Magari bisognerebbe capire cosa non può aprire e magari risolvere e così si velocizzerebbe il boot; ma non so dove vedere una cosa del genere. Sad
ciao
Francesco bat

potrebbe e sottolineo che potrebbe riguardare una qualche applicazione che forse è stata installata e poi in seguito rimossa, lasciando qualche file dell'applicazione che nonostante sia stata disinstallata, per certi aspetti non lo sia stata completamente. (Questa è soltanto una mia ipotesi).

Altra cosa di cui sono curioso sapere è che tipo di grub hai adottato, cioè quello di default oppure il grub2?
Dico questo perchè con il Grub classico ho riscontrato delle performance non proprio buone, ma passando al Grub2 ho notato diversi miglioramenti, tra cui l'avvio e lo spegnimento più veloci (tanto per citare una differenza tra i due tipi di Grub).

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

Io sto usando la versione di grub 0.97.
Poi cercando online ho trovato questo articolo:
http://www.paolodistefano.name/joomla/software-e-applicazioni/pclinuxos-...
Non è che per caso potrebbe quindi esserci un problema con il gfxboot ?
Infatti recentemente è stato aggiornato proprio quell ma non ho trovato alcuna differenza Sad
Ciao
Francesco bat

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

Provando a fare una ricerca sul synaptic ho trovato:

gfxboot-theme-pclinuxos : Installato
pclinuxos-gfxboot-theme : non installato

Provando ad installare: pclinuxos-gfxboot-theme
mi dice che è impossibile installare il programma perchè ha delle dipendenze non risolte.
La cosa bella è che l'interno dell'avviso dove dovrebbero stare queste fantomatiche dipendenze viene riportato solo:

pclinuxos-gfxboot-theme:

Effettivamente non esistono dipendenze riportate, quindi non si spiega che problema ci sia.
Essendo un applicazione di boot e se non erro è proprio del tema di boot, potrebbe essere forse proprio lui a mancare, ma non capisco perchè fa questo errore nell'installazione e perchè lo fa solo a me il "cannot open file delete".
Ciao
Francesco bat

Ritratto di footstep11
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 31/01/2013 - 11:01

Io ho installato l'ultimo kernel a 32bit su tutte le mie macchine e non ho avuto nessun problema (sono pero' macchine che hanno tutte almeno 4GB di RAM e quindi ho installato la versione PAE).

Riguardo la scritta 'cannot open file delete', questo non e' sintomo di problemi (vedi il mio commento http://www.pclinuxos.com/forum/index.php/topic,124520.msg1041080.html#ms...)

Hai provato a vedere in quale punto della sequenza di boot si ferma? Per vederlo, basta premere il tasto ESC alla schermata di boot... potrebbe essere che hai un modulo del kernel che non si compila (io non avevo aggiornato virtualbox, e con il nuovo kernel non me lo compilava), e quindi cerca di ricompilarlo ad ogni boot.

Facci sapere...

Ciao, Mauro

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

footstep11 wrote:
Io ho installato l'ultimo kernel a 32bit su tutte le mie macchine e non ho avuto nessun problema (sono pero' macchine che hanno tutte almeno 4GB di RAM e quindi ho installato la versione PAE).

Riguardo la scritta 'cannot open file delete', questo non e' sintomo di problemi (vedi il mio commento http://www.pclinuxos.com/forum/index.php/topic,124520.msg1041080.html#ms...)

Hai provato a vedere in quale punto della sequenza di boot si ferma? Per vederlo, basta premere il tasto ESC alla schermata di boot... potrebbe essere che hai un modulo del kernel che non si compila (io non avevo aggiornato virtualbox, e con il nuovo kernel non me lo compilava), e quindi cerca di ricompilarlo ad ogni boot.

Facci sapere...

Ciao, Mauro

Grazie mille della risposta !
Allora, dopo aver premuto il tasto ESC esce la seguente scritta:
Cannot open file delete
e dopo 1 minuto:

Could not find resume device (UUID=f34b337d-de72-441c-a86e-18b4e551bdc8)
Could not resolve resume device (UUID=f34b337d-de72-441c-a86e-18b4e551bdc8)
Starting udev

Sono riuscito a trascriverlo grazie ad una foto effettuata con il mio galaxy ace durante il boot Smile
successivamente c'è altro ma penso che sia il boot regolare.
Il momento del blocco è proprio dopo il cannot open file delete con la stringa che ho riportato Sad
Ciao
Francesco bat

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

Digitando da terminale:
ls -al /dev/disk/by-uuid/*
ottengo:

lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/662a0815-6644-458b-8ad0-d35039a3be8e -> ../../sdb3
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/6817a41c-2c21-47ec-817a-b75829493d6a -> ../../sdb4
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/7683caab-bd86-4b05-96c3-57304a5d1aea -> ../../sdb6
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/8db46538-c688-44aa-854b-18746516ccf6 -> ../../sdb7
lrwxrwxrwx 1 root root 10 gen 3 13:32 /dev/disk/by-uuid/8ebd6d6a-f9a5-4907-858a-4a01d5cf09c4 -> ../../sda3
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/99cb0ff2-3699-4732-a778-eff13e968d36 -> ../../sda4
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/a0c17035-098a-4ecb-8155-039faf049cec -> ../../sda2
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/CC645BB7645BA34E -> ../../sdb1
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/dde97df0-6ff6-4ea6-9c6a-7750c595118c -> ../../sda1
lrwxrwxrwx 1 root root 10 gen 3 13:31 /dev/disk/by-uuid/eb8f3b24-5212-454c-a7c9-c7d9bc231157 -> ../../sdb5

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

Riporto anche questo:

cat /etc/fstab

# Entry for /dev/sda3 :
UUID=8ebd6d6a-f9a5-4907-858a-4a01d5cf09c4 / ext4 defaults 1 1
none /proc proc defaults 0 0
# Entry for /dev/sda4 :
UUID=f34b337d-de72-441c-a86e-18b4e551bdc8 swap swap defaults 0 0
none /dev/pts devpts defaults 0 0

Sembra che non coincide UUID di sda4
Infatti aprendo il pclinuxos control center, e da grub vedendo in /boot/vmlinuz
ci sono i seguenti parametri:
quiet vmalloc=256M acpi=on resume=UUID=f34b337d-de72-441c-a86e-18b4e551bdc8 splash=silent

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

Risolto come da questa guida:
http://www.pclinuxos.com/forum/index.php?topic=124455.0
Ora si avvia tutto come prima in una 30ina di secondi.
Mi rimane solo un dubbio.
Digitando cat /etc/fstab
ottengo ancora:

# Entry for /dev/sda3 :
UUID=8ebd6d6a-f9a5-4907-858a-4a01d5cf09c4 / ext4 defaults 1 1
none /proc proc defaults 0 0
# Entry for /dev/sda4 :
UUID=f34b337d-de72-441c-a86e-18b4e551bdc8 swap swap defaults 0 0
none /dev/pts devpts defaults 0 0

sda4 continua a riportare su fstab quell' UUID.
C'è un modo per aggiornarlo ?
Del resto mi domando: c'è ancora qualcos'altro che riporta il precedente UUID ?
Perchè è cambiato UUID dal precedente al nuovo ?
Ciao
Francesco bat

Ritratto di francofait
Offline
Last seen: 3 anni 5 mesi fa
Iscritto: 31/03/2012 - 02:01

IIl metodo più semplice possa esistere , togliere l' indirizzamento
UUID
e riattivare l' indirizzo real device.
Lo hai a tua disposizione commentato sezione per sezione , nel file fstab stesso

# Entry for /dev/sda3 :
UUID=8ebd6d6a-f9a5-4907-858a-4a01d5cf09c4 / ext4 defaults 1 1

/dev/sda3 / ext4 defaults 1 1
Per risolverlo così bastano pochi minuti , e sei sicuro che non sbaglierà mai.

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

francofait wrote:
IIl metodo più semplice possa esistere , togliere l' indirizzamento
UUID
e riattivare l' indirizzo real device.
Lo hai a tua disposizione commentato sezione per sezione , nel file fstab stesso

# Entry for /dev/sda3 :
UUID=8ebd6d6a-f9a5-4907-858a-4a01d5cf09c4 / ext4 defaults 1 1

/dev/sda3 / ext4 defaults 1 1
Per risolverlo così bastano pochi minuti , e sei sicuro che non sbaglierà mai.

Il fatto è che pensavo che l'fstab fosse stato realizzato da qualche altro programma di sistema, e che correggendolo non risoveva il tutto realmente.
Ora l'ho editato a mano ma gli ho ho inserito l' UUID giusto.
Naturalmente tutta questa vicenda me la sono salvata come documento html per un eventuale problema futuro Smile
Ciao
Francesco bat

Ritratto di footstep11
Offline
Last seen: 1 anno 1 mese fa
Iscritto: 31/01/2013 - 11:01

Bene, sono contento che hai risolto. Anche io tendo a non usare la UUID in fstab, come ti ha consigliato francofait. Io non uso l'indirizzamento con il device perche' una volta mi e' successo che avendo spostato i dischi (per un cambio fisico di uno di essi), udev me li ha rinumerati in maniera diversa, e per rientrare ho dovuto usare una live per modificare a mano fstab.

Ora uso LABEL, cosi' posso identificare meglio cosa c'e' nelle partizioni... questione di gusti (guardati questo messaggio per dettagli: http://www.pclinuxos.com/forum/index.php/topic,129649.msg1093956.html#ms... )

Ciao, Mauro

Ritratto di francesco bat
Offline
Last seen: 1 anno 3 mesi fa
Iscritto: 20/11/2011 - 02:46

Ciao a tutti.
Riesumo questo post non ancora del tutto vecchio Smile
Oggi con il kernel 3.18.2 si è velocizzato tutto, compreso kde che ci mette ora poco più di 1 minuto all'accesso nel desktop.
Quindi tutto si è risolto Wink
Ciao
Francesco bat

Ritratto di Hertz
Offline
Last seen: 1 anno 9 mesi fa
Iscritto: 02/08/2014 - 10:59

Ciao francesco bat,

francesco bat wrote:
Ciao a tutti.
Riesumo questo post non ancora del tutto vecchio Smile
Oggi con il kernel 3.18.2 si è velocizzato tutto, compreso kde che ci mette ora poco più di 1 minuto all'accesso nel desktop.
Quindi tutto si è risolto Wink
Ciao
Francesco bat

posso confermare pienamente che con l'aggiornamento al kernel 3.18.2 molti bug relativi al sistema sono stati risolti, portando un notevole miglioramento su arxhitetture 32bit e 64bit.
Dai test condotti, sembra che questi miglioramenti siano stati riscontrati in linea generale da buona parte dei Testers, portando il kernel stesso dai repository testing a quelli stabili e quindi ad oggi siano stati fatti ottimi passi in avanti per migliorare ulteriormente la situazione. Smile