Aprire porte Transmission

15 contenuti / 0 new
Ultimo contenuto
Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57
Aprire porte Transmission

Buon giorno a tutti. Volevo configurare la porta di Transmission in modo che fosse la stessa del router per avere una buona velocità di download. Ho fatto il test sulla porta attuale e infatti risulta chiusa. Ricordo che per fare questa operazione con Utorrent avevo avuto a che fare con gaeway, IP statico eccetera solo che davvero non ricordo il procedimento.
Grazie

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Non so se ti possa servire (non è, purtroppo, un argomento che io conosca): http://vinyil.altervista.org/blog/transmission-e-la-porta-chiusa/
Un'altra cosa: Zafran ha messo a disposizione un suo indirizzo temporaneo. Torna, per cortesia, a dare un'occhiata alla prima discussione da te aperta su questo Forum. Grazie, Pupet.

Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57

Buonasera caro Monsee. Ho dato un'occhiata al link e dovrebbe essere proprio quello di cui avevo bisogno,il problema è che non so che comando digitare in Esegui per poter accedere a quelle informazioni perchè penso che siano diverse per ogni sistema operativo. Riguardo a Zafran, ho ricevuto una sua mail che mi ha inviato tramite il forum, non ho ancora avuto tempo di rispondergli ma penso che lo farò stasera. Grazie a te amico mio per la solita prontezza nel rispondere.
Buona serata

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Il comando da dare sul Terminale (il Terminale è uno dei programmi che trovi nel tuo PCLinuxOS LXDE) dovrebbe essere universale ed è proprio:

ifconfig

... serve a configurare le interfacce di rete in Linux.
Qui trovi il significato di questo comando: http://it.wikipedia.org/wiki/Ifconfig
Sfortunatamente, in questo genere di cose sono una vera schiappa.
Sicuramente, Zafran e Patel potrebbero aiutarti assai meglio di me.

Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57

Ho seguito tutte le indicazioni ma mi dà comunque "Porta chiusa"...magari è perchè sbaglio a configurare il router visto che non è lo stesso modello di quello del link. Ho trovato altre guide specifiche sul mio router, ho seguito le indicazioni ma niente...io ricordo che quando l'avevo configurato per Utorrent avevo dovuto inserire anche l'IP statico mentre in tutte le guide che ho trovato non lo nomina ma fa solo settare la porta. Cavoli avevo trovato un bel link con spiegazioni dettagliate ai tempi di Utorrent ma non riesco più a recuperarlo...magari qualcuno mi può dare una mano: il mio modem è un Thomson tg 585 v 7, quello che dava in dotazione Tiscali un po' di tempo fa (non so se ora è cambiato)
Grazie

PS:Ma perchè ho fatto il log in e segna 3 pupet come users online?Se faccio log out spariscono tutte e tre e se mi riloggo ricompaiono tutti...sdoppiamento della personalità?!?
EDIT:risolto il problema di sdoppiamento, anzi sTRIplamento...è bastato cambiare passord!Però ora mi ha accusato 3 volte di spam!!Sarà colpa delle finte pupet...

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Che l'ip sia statico o no non ha molta importanza, l'importante è che sia giusto.
Spesso i router danno in dhcp lo stesso ip se la macchina è la stessa.

Con ifconfig o direttamente nel router vedi l'ip attuale (statico o dhcp che sia) e lo segni insieme alla porta nelle impostazioni del router.

Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57

Ciao Zafran, ho controllato nelle impostazioni del router e l'ip è lo stesso che mi esce da ifconfig, ho impostato la porta come descritto in tutte le guide che ho trovato per il mio router ma niente, Transmission mi dà sempre porta chiusa. L'IP in ifconfig è indicato nella riga "Indirizzo inet" giusto?

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Certo.
Hai guardato il link di sopra? L'idea del firewall?

Cmq un router o un altro non cambia, l'ho fatto anche ieri sera perché mia figlia era a un pc dove volevo trasferire dei dati dal portatile.
Cosi ho aperto una porta e ce li ho messi via ssh senza neanche che lei se ne accorgesse.

Prima di ragionare di iptables:
Che porta apri?
E' uguale privata e pubblica?
Trasmission è impostato bene? (la porta è giusta?)
L'accesso è wireless o cablato?

Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57

Per quanto riguarda il firewall del router è disabilitato, quello di Linux sinceramente non mi sono azzardata a toccarlo, non essendo esperta non volevo ficcarmi in qualche guaio. La porta che ho provato ad aprire è la 51413 che era di default in Transmission e l'ho impostata nel router associandola al programma. Il modem è collegato al pc con cavo ethernet. Scusa ma non so cosa intendi quando mi chiedi "E' uguale privata e pubblica?"...
Grazie

Ritratto di zafran
Offline
Last seen: 1 anno 6 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Di solito nei router è richiesto di indicare il numero di porta come viene visto dall'esterno e il numero di porta reale.
http://support.smarttelecom.ie/forums/showthread.php?t=3473

Dopo aver salvato la configurazione è stato riavviato il router?

Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57

Intendi dire TCP e UDP? Ho settato la porta come indicato nella figura postata nel link e dopo ho riavviato il router...mah, non capisco proprio, quando l'avevo fatto per Utorrent era filato tutto liscio e la procedura è la stessa

Ritratto di Genchi
Offline
Last seen: 10 anni 1 settimana fa
Iscritto: 26/06/2010 - 01:28

@ Pupet
Premetto che sono poco pratico di Linux, quindi quello che dico
va preso con le molle.
Io le porte del router per “uTorrent” su Windows le avevo aperte
con il comodissimo programma “Port Forward”, dove nell'elenco
dei router suportati c'è anche il tuo: Thomson TG585 V7.
Vedi qui nella Router List:
http://portforward.com/english/routers/port_forwarding/routerindex.htm
Quando poco tempo fa ho installato PCLinuxOS Gnome, dove
non c'è “uTorrent”, sono andato su Windows e tramite il programma
Port Forward ho selezionato dall'elenco dei programmi “Bit Torrent”,
poi ho messo in PCP e UDP gli stessi numeri di porta di uTorrent, in fine
ho salvato sul router.
Poi tramite cassetto sono saltato su PCLinuxOS Gnome e ho settato in
“Bit Torrent” le preferenze come mi ha gentilmente indicato l'amico
Monsee.
Poi siccome in “Bit Torrent” non compare come in “uTorrent” il bollino
rosso se non va, o il bollino verde se funziona correttamente, ho selezionato
il file Torrent di Mandriva su “uTorrent”, costatando che servivano per
scaricarlo tre ore e mezza.
Poi con lo stesso file Torrent ho fatto la medesima prova su “Bit Torrent” di
PCLinuxOS Gnome, dove o costatato che servivano per scaricarlo tre ore e
venti minuti, quindi ho dedotto che funzionava correttamente pure “Bit Torrent”.

P.S. Tengo a precisare che il mio abbonamento ADSL è di quelli a basso costo, dove
poi i collegamenti non risultano super veloci.

Ritratto di monsee
Offline
Last seen: 1 mese 3 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Ottima pensata, Genchi! Bravo!

Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57

Anche io quando ho aperto la porta di Utorrent mi sono affidata a Port Forward e infatti è andato tutto bene...avevo pensato che applicando lo stesso procedimento per Transmission sarebbe filata liscia comunque. Proverò magari a reinstallare Utorrent e a settare la stessa porta per lui e per Transmission...sperando che funzioni!
Grazie Genchi!

@ Monsee: ho ricevuto la tua mail, sei riuscito a schivare la condanna di spam!Grazie mille

Ritratto di pupet
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 26/09/2010 - 21:57

Niente da fare...ho impostato la stessa porta di Utorrent (che risulta aperta) su Transmission ma il test mi dice comunque "Porta chiusa"...ho provato a scaricare lo stesso torrent con i due programmi e in effetti con Utorrent ci avrebbe impiegato circa un'ora e mezza mente con Transmission quasi DUE GIORNI alla velocità imbarazzante di 15 Kb/s di media...consigli?