Aggiornamento wbar e ora è in avvio automatico con kde

16 contenuti / 0 new
Ultimo contenuto
Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46
Aggiornamento wbar e ora è in avvio automatico con kde

Io ho installato da tempo wbar che uso con interfaccia icewm, ma oggi con un aggiornamento del gestore pacchetti di wbar, mi parte in automatico anche con kde ma il programma non risulta nei servizi di kde di avvio.
Siccome non mi serve su kde ma solo su icewm, come faccio ad escluderlo dall'avvio con kde ?
Ciao
Francesco bat

Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Trovato wbar nella cartella "/etc/xdg/autostart" .
Non vorrei eliminarlo manualmente da li.
C'è qualche tool grafico che gestisce un pò tutti i programmi di avvio siccome quello di kde non li gestisce tutti ?
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 4 mesi 1 giorno fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Prova, magari, a guardare se puoi fare qualcosa da:
Configure Your Computer/Sistema/Attiva o disattiva i servizi del sistema

Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46

monsee wrote:
Prova, magari, a guardare se puoi fare qualcosa da:
Configure Your Computer/Sistema/Attiva o disattiva i servizi del sistema

No, non c'è !
Ho risolto creando una cartella provvisoria li e spostando wbar li dentro disattivando il boot.
Solo che magari sarebbe più comodo un metodo pratico tramite un interfaccia simile ai servizi di avvio di kde.
Ciao
Francesco bat

Ritratto di zafran
Offline
Last seen: 8 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Mi sembra che l'arcano sia spiegato qui
http://ubuntufast.blogspot.it/2012/03/guida-allinstallazione-e-configura...
nel senso che arrivano alla tua conclusione e le difficoltà di usare lxautostart evidentemente sono comuni ubuntu e a pclos.

Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46

zafran wrote:
Mi sembra che l'arcano sia spiegato qui
http://ubuntufast.blogspot.it/2012/03/guida-allinstallazione-e-configura...
nel senso che arrivano alla tua conclusione e le difficoltà di usare lxautostart evidentemente sono comuni ubuntu e a pclos.

Infatti !
Come immaginavo.
Ad esempio nel menu di kde, wbar non è proprio presente e bisogna avviarlo da terminale oppure inserirlo manualmente nel menu.
Forse ecco perchè l'esecuzione su /etc/xdg/autostart.
Ciao
Francesco bat

Ritratto di zafran
Offline
Last seen: 8 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Provato a installarlo, molto carino.
Facile da configurare.
Trovato in autostart sia da kde che da lxde.
Chiesto a cosa serve visto che lxpanel permette un pannello laterale a scomparsa con dentro tutte le applicazioni che voglio.
Disinstallato.
Però bellino, davvero.
Non lo conoscevo.

PS - Kde l'aveva messo in AltriProgrammi->Configurazione->Monitoraggio

Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46

zafran wrote:
Provato a installarlo, molto carino.
Facile da configurare.
Trovato in autostart sia da kde che da lxde.
Chiesto a cosa serve visto che lxpanel permette un pannello laterale a scomparsa con dentro tutte le applicazioni che voglio.
Disinstallato.
Però bellino, davvero.
Non lo conoscevo.

PS - Kde l'aveva messo in AltriProgrammi->Configurazione->Monitoraggio

È vero !
Lo avevo visto anche tempo fa.
Il fatto è che preferisco usarlo su icewm che insieme a idesk realizzano un ambiente grafico completo Smile
Ciao
Francesco bat

Ritratto di erdebeer
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 16/05/2012 - 11:42

per me ' emolto comoda,pero' ho un problema all'avvio mi esce sempre un rettangolo nero dietro a wbar,mi aiutereste a risolvere?ho provato con una guida che dovrebbe avviare prima il desktop e poi wbar ma non funziona...:-(

Ritratto di zafran
Offline
Last seen: 8 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

DE?

Ritratto di erdebeer
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 16/05/2012 - 11:42

scusa ma non ho capito

Ritratto di zafran
Offline
Last seen: 8 mesi 3 settimane fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Quale DesktopEnvironment usi?
Io l'ho provato con lxde e kde.

Con lxde ha sostituito ai miei sfondi uno sfondo nero con la barra pure su sfondo nero che si confondeva con lo sfondo del desktop.

Con kde invece la barra era su sfondo trasparente e aveva rispettato le mie impostazioni dello sfondo.
Senonché a un certo punto la barra è apparsa all'interno di una finestra con tanto di barra del titolo e bottoni.

Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46

erdebeer wrote:
per me ' emolto comoda,pero' ho un problema all'avvio mi esce sempre un rettangolo nero dietro a wbar,mi aiutereste a risolvere?ho provato con una guida che dovrebbe avviare prima il desktop e poi wbar ma non funziona...:-(

Me lo fa anche a me su icewm.
In genere risolvo con un click con il tasto destro del mouse sul bordo inferiore di wbar e mi si aggiusta subito.
Con kde, quando l'ho provato, dovevo cliccare molte più volte ma funzionava.
Ciao
Francesco bat

Ritratto di erdebeer
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 16/05/2012 - 11:42

zafran wrote:
Quale DesktopEnvironment usi?
Io l'ho provato con lxde e kde.

Con lxde ha sostituito ai miei sfondi uno sfondo nero con la barra pure su sfondo nero che si confondeva con lo sfondo del desktop.

Con kde invece la barra era su sfondo trasparente e aveva rispettato le mie impostazioni dello sfondo.
Senonché a un certo punto la barra è apparsa all'interno di una finestra con tanto di barra del titolo e bottoni.


uso lxde

Ritratto di erdebeer
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 16/05/2012 - 11:42

francesco bat wrote:
erdebeer wrote:
per me ' emolto comoda,pero' ho un problema all'avvio mi esce sempre un rettangolo nero dietro a wbar,mi aiutereste a risolvere?ho provato con una guida che dovrebbe avviare prima il desktop e poi wbar ma non funziona...:-(

Me lo fa anche a me su icewm.
In genere risolvo con un click con il tasto destro del mouse sul bordo inferiore di wbar e mi si aggiusta subito.
Con kde, quando l'ho provato, dovevo cliccare molte più volte ma funzionava.
Ciao
Francesco bat


Prova questa guida sembra funzionare
1- Creare un file Wbar.sh nella cartella /opt/
Wbar.sh

#!/bin/bash

sleep 4 && wbar -bpress -above-desk -pos top -isize 40.0 -idist 2.0 -zoomf 1.5

exit 0

Cliccare col tasto destro su Wbar.sh e andare su Proprietà , nella scheda permessi mettere tutti i permessi , anche quelli di esecuzione e dare Ok

2- Nella cartella etc/xdg/autostart/ creare il file wbar.desktop
wbar.desktop

[Desktop Entry]
Encoding=UTF-8
Name=Wbar
Comment=Barra in stile Mac
Exec=/opt/Wbar.sh
Terminal=false
Type=Application

Salvare e riavviare.

Ritratto di francesco bat
Offline
Last seen: 2 anni 4 mesi fa
Iscritto: 20/11/2011 - 02:46

erdebeer wrote:
francesco bat wrote:
erdebeer wrote:
per me ' emolto comoda,pero' ho un problema all'avvio mi esce sempre un rettangolo nero dietro a wbar,mi aiutereste a risolvere?ho provato con una guida che dovrebbe avviare prima il desktop e poi wbar ma non funziona...:-(

Me lo fa anche a me su icewm.
In genere risolvo con un click con il tasto destro del mouse sul bordo inferiore di wbar e mi si aggiusta subito.
Con kde, quando l'ho provato, dovevo cliccare molte più volte ma funzionava.
Ciao
Francesco bat


Prova questa guida sembra funzionare
1- Creare un file Wbar.sh nella cartella /opt/
Wbar.sh

#!/bin/bash

sleep 4 && wbar -bpress -above-desk -pos top -isize 40.0 -idist 2.0 -zoomf 1.5

exit 0

Cliccare col tasto destro su Wbar.sh e andare su Proprietà , nella scheda permessi mettere tutti i permessi , anche quelli di esecuzione e dare Ok

2- Nella cartella etc/xdg/autostart/ creare il file wbar.desktop
wbar.desktop

[Desktop Entry]
Encoding=UTF-8
Name=Wbar
Comment=Barra in stile Mac
Exec=/opt/Wbar.sh
Terminal=false
Type=Application

Salvare e riavviare.

Per l'avvio, come ho scritto prima, non lo voglio perchè lo uso solo su ambiente icewm e non kde.
Quindi l'ho rimosso da etc/xdg/autostart/.
Invece quando avvio ambiente icewm mi parte senza problemi grazie ad uno script di boot di applicazioni che ho creato ed inserito nella cartella di configurazione di icewm.
Ciao
Francesco bat