Aggiornamento kernel (e forse anche kde) si o no ?

52 contenuti / 0 new
Ultimo contenuto
Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46
Aggiornamento kernel (e forse anche kde) si o no ?

Ho visto oggi un mega aggiornamento del kernel con dipendenze a 3.2 più il synaptic aggiornato al kernel 3.2.
Installando gli aggiornamenti risulta ancora il kernel 2.6 e il synaptic riporta nuovo kernel 3.2.
Cosa bisogna fare ?
In più ho visto un mega aggiornamento delle librerie qt ma non vedo cambiamenti a kde.
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Ho aggiornato il Kernel su due miei PC (con PCLinuxOS LXDE£ a 32-bit). E ho avuto la sorpresa di ritrovarmi il computer "muto".
Non dubito, comunque, che a questo problema si troverà (se già non c'0è) una rapida soluzione.
In quanto al come comportarsi per cambiare il Kernel, eccoti come si fa:

1) installi (da Synaptic) il nuovo Kernel;
2) disinstalli (da Synaptic) il vecchio Kernel;
3) chiudi Synaptic e apri "Configure Your Computer"; poi clicci sul pulsante "Avvio" (sta in basso alla tua sinistra nella finestra appena aperta);
4) apri "Configura l'avvio del sistema"; dopo9 di che, vai (senza nulla cambiare) alla schermata in cui ti vengon presentati tutti i Kernel d'avvio; lascia le prime TRE voci (la prima delle quali avrà un asterisco accanto), nessuna della quali reca la parola "kernel". E rimuovi la voce specifica dove si legge il nome del nuovo kernel da te installato. Questo perchè tale voce è "ridondante", dato che le prime TRE voci rappresentago già tale nuovo Kernel.
5) chiudi tutto quanto e poi riavvia il PC. Il riavvio sarà un po' più lento del normale (la prima volta), ma non preoccupartene. La "lentezza" è frutto del fatto che vengono installati nel nuovo Kernel i vari plugins...

Quando sarai di nuovo sul tuo desktop, gioisci... se ti ritrovi un PC che non sia completamente muto (il mio, in questo momento, lo è)... ma non disperarti se te lo ritrovi muto. Una qualche soluzione, o prima o dopo, la troviamo...

PS: aggiorna, ovviamente, anche le librerie QT...

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Si, ma io ho aggiornato tutto quello che mi è stato proposto, solo che mi risulta ancora tutto 2.6.
Il nuovo kernel lo vedo solo nelle novità del synaptic Sad
Ciao
Francesco bat

Ritratto di bebolinux
Offline
Last seen: 5 anni 1 mese fa
Iscritto: 10/12/2008 - 22:27

ciao monsee,
Una puntualizzazione,
consiglio di non eseguire i punti 2-3-4 ma di lasciare installato il vecchio kernel.
Riavviando partirà il nuovo kernel, ed il vecchio sarà nell'elenco delle opzioni di boot.
Nel caso come il tuo in cui il pc è muto, basta all'avvio, selezionare il vecchio kernel per
tornare come prima.
Una volta verificato che tutto funzioni bene... allora è possibile eseguire i punti 2-3-4 e liberare spazio su disco eliminando il kernel vecchio. fff
ciao

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Cioè in pratica volete dire che il kernel non si aggiornerà mai da solo ma lo devo fare io manualmente ?
Spero lumi sulle tenebre che sto vedendo Smile
Ciao
Francesco bat

Ritratto di bebolinux
Offline
Last seen: 5 anni 1 mese fa
Iscritto: 10/12/2008 - 22:27

si esatto,
Il kernel non si aggiorna da solo, ma devi selezionarlo da synaptic.
Puoi installare più versioni di kernel, e all'avvio, nel manu di boot , puoi scegliere con quale avviare il sistema.
Il kernel è un il software che gestisce l'hardware del pc a basso livello, e se non hai problemi con il tuo hardware l'aggiornamento non è così rilevante.
Anzi, potresti al riavvio avere qualche problema con i driver della scheda video e altri che vengono ricompilati per la compatibilità con il nuovo kernel.
Solitamente si ha qualche problema con virtualbox, a cui bisogna aggiornare i driver manualmente, lanciando un comando shell che solitamente viene consigliato nella finestra d'errore di virtualbox.

Quindi a te la scelta, puoi aggiornare correndo qualche rischio, o laciare così com'e dormendo sonni tranquilli.
ciao

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Certo che è così. Come è la stessa cosa nel caso di LibreOffice.
Se lo vuoi aggiornare (LibreOffice, intendo) devi semplicemente avviare il LibreOffice Manager (lui, sì, che si aggiorna automaticamente con Synaptic, ma LivreOffice no: si trova in altri Repositories, accessibili tramite iol LibreOffice Manager). E se non vuoi aggiornare LibreOffice perchè ti piace la versione che già hai... allora basta non avviare il LibreOffice Manager... senza che per questo synaptic si metta a fare il diavolo a quattro per spingerti, ogni santa volta che lo usi, ad aggiornare il tuo LibreOffice.
Simile è la faccenda nel caso del Kernel (salvo che il Kernel sta sui normali Repositories ed è, dunque, accessibile tramite Synaptic): se quello che già hai ti piace e lo vuoi mantenere, puoi farlo... Senza che Synaptic cominci a sbracciarsi ad ogni avvio per segtnalarti che devi aggiornare uil Kernel.
Se invece vuoi aggiornare il Kernel, la cosa è semplicissima: apri Synaptic e selezioni per l'installazione il Kernel nuovo che vuoi installare.
Bebolinux, ovviamente, ha ragione da vendere, quando afferma che è bene controllar che tutto funzioni e solamente DOPO tale verifica, disinstallare il vecchio Kernel... Solo che io ho preso 8facendo il tester per le versioni a 64-bit) la pessima abitudione, in PCLinuxOS, di agir sempre e comunque come un tester, senza nemmeno accorgermente più di tanto, magari... e di pensare sempre che il sorgere di un problema, in fondo, può anche essere visto come un'ottima occasione per cercarne la soluzione (mentalità "da tester" che devo cercar di togliermi dalla testa quanto prima, mi sa...)

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Ah, ora mi è chiaro tutto !
Mi farebbe piacere passare al kernel 3 ma non ho x ora problemi hardware a meno che il pc non ha miglioramenti prestazionali.
Nel caso come faccio a capire quale versione di kernel installare ? Ho visto varie voci su synaptic.
In più abbiamo parlato anche di altri programmi che devo aggiornare io (tipo libreoffice); mi dite quali altri pacchetti che sono disponibili di base e che devo aggiornare io manualmente (sempre se ce ne sono) ?
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Personalmente, debbo informare che ho recuperato per intero la funzionalità sonora di entrambi i PC (sia il desktopPC che il netbook) sui quali avevo aggiornato il Kernel, semplicemente "ritornando" al Kernel precedente e poi disinstallando il Kernel rilasciato ultimamente. Ambedue i PC funzionan bene e non danno alcun segno di portar conseguenze.

Per quel che attiene "quale Kernel installare": alcuni Kernel son fatti per specifici Processori (si tratta di Processori "particolari", ovviamente; ad esempio certi Processori AMD a 32-bit). Ergo, vanno impiegati soltanto se si possiede quello specifico Processore.
Altri, van bene per qualsiasi normale Processore (tipici Intel, ad esempio) e sono stati elaborati per rispondere ad altri (ben specifici) criteri. Si tratta di 2 categorie: BFS e PAE.
BFS indica un Kernel in cui son state implementate talune modifiche ideate da Kolivas.
Si tratta di un valido Kernel, un po' più "prestazionale", adattissimo ai desktopPC, ma un poco meno ai netbooks e ai notebooks, in quanto tende a dar, come effetto collaterale, maggior calore (insomma, il Processore "scalda" lievemente di più). Ergo: se hai un desktopPC, il BFS può benissimo fare al caso tuo. Se usi un notebook, il BFS è un filino meno indicato e se usi un netbook (che, già di suo, ha il suo bel daffare a dissipar bene il calore) è francamente poco indicato.
PAE è una sigla che identifica un Kernel capace di gestire $ Gb di RAM o anche di più. Ergo, se hai 4 Gb di RAM o più, ti conviene utilizzare un Kernel PAE. Se hai, com'è in mio caso in questo momento, solo 2 Gb di RAM, non ti conviene affatto, invece, usare un Kernel PAE.
Codeste due categorie, naturamente, posson "sovrapoporsi". Così, torvi il Kernel PAE.BFS (che è adatto a chi ha da gestire 4 Gb di RAM o più e tende ad essere un poco più "prestazionele", però scalda un filino di più), etc...
Infine, c'è un altra caratteristica di cui tenere conto: il numero che identifica la "relase in PCLinuxOS".
Ad esempio, se guardo il Kernel "2.6.38-pclos1..." sono dinnanzi alla prima relase (in ambito PCLinuxOS" del Kernel numerato 2.6.38... cosa che è indicata dal successivo numero "1". Se guardo il kernel denominato, invece, "2.6.38-pclos3..." sono dinnanzi alla terza relase (in ambito PCLinuxOS) del medesimo Kernel (com'è testimoniato dal numero 3). Va da sé che quando vien rilasciata una "relase successiva" del medesimo Kernel, ciò avviene perché son stati apportati -nell'ambito della distro- miglioramenti ulteriori al Kernel originario. È buona norma, dunque, scegliere di installare -salvo ben precise controindicazioni che, al momento, non saprei proprio immaginare... e che non mi risulta ci siano mai state- la relase più recente di un dato Kernel.
Facciamo allora un esempio: ho un notebook del cui possibile surriscaldamento mi preoccupo abbastanza; tale notebook ha 4 Gb di RAM e un normalissimo Processore Intel... Che Kernel scegliere?
Un Kernel che non sia BFS (perchè non voglio incrementare il potenziale carico di calore) se scelgo di tenermi un Kernel un filo meno "prestazionale" di quel che potrebbe essere altrimenti. E, ovviamente, anche un Kernel PAE (perchè dovrà gestire 4 Gb di RAM). Stabilito quato, io sceglierei il Kernel più recente e più aggiornato, dunque: il kernel "3.2.18-pclos1.pae"... Tuttavia, se preferissi (per qualche ragione: ad esempio, perchè con tale Kernel non si riesce più a sentire i suoni) la versione stabile precedente del Kernel, instalalrei il Kernel denominato 2.6.38-pclos3.pae... perchè si tratta della relase ultima di tale versione del Kernel che si è avuta in PCLinuxOS.
Spero di essere riuscito esporre in modo chiaro: se ci sono domande, comunque, sono qui.

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Avendo un pc desktop ho cercato "kernel" da synaptic e ho visto quello che ho installato:
kernel-2.6.38.8-pclos3.bfs
e
kernel-devel-2.6.38.8-pclos3.bfs
Quindi presuppongo che l'aggiornamento debba essere:
kernel-3.2.18-pclos1.bfs
e
kernel-devel-3.2.18-pclos1.bfs
Non ho trovato appunto il pclos3 negli aggiornamenti.
Quindi se procedo non dovrei sbagliare nulla ?
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Se hai un desktopPC e hai meno di 4 Gb di RAM, devi installare il Kernel denominato:
kernel-3.2.18-pclos1.bfs

Ma, se hai 4 Gb di RAM o più, devi installare il Kernel denominato:
kernel-3.2.18-pclos1.pae.bfs

Il correlato "devel" ti verrà propostio automaticament di istallarlo dallo stesso Synaptic. Accetta, naturalmente.

In quanto all'aggiornamento di KDE, ho letto che il rilascio dei pacchetti correlati dovrebbe essere questione di poco.

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

monsee wrote:
Se hai un desktopPC e hai meno di 4 Gb di RAM, devi installare il Kernel denominato:
kernel-3.2.18-pclos1.bfs

Ma, se hai 4 Gb di RAM o più, devi installare il Kernel denominato:
kernel-3.2.18-pclos1.pae.bfs

Il correlato "devel" ti verrà propostio automaticament di istallarlo dallo stesso Synaptic. Accetta, naturalmente.

In quanto all'aggiornamento di KDE, ho letto che il rilascio dei pacchetti correlati dovrebbe essere questione di poco.

Si, infatti.
È un pc a 32 bit con 2gb di ram.
Quindi andrà bene la versione kernel-3.2.18-pclos1.bfs
Ma se lascio il vecchio kernel nel sistema per un eventuale caso di emergenza, non ci sarebbero problemi ?
Ad esempio con Ubuntu ero abituato a tenere tutti quelli precedenti di quella versione.
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

No, puoi lasciare tranquillamente il vecchio Kernel (son io che -anche un po' azzardatamente- li faccio secchi tutti dopo aver installato quello successivo). Per avviare dal nuovo Kernel puoi impostare come predefinito il nuovo Kernel (col che, avrai comunque, all'avvio, la scelta di avviar col vecchio Kernel, qualora lo volessi). Non stare dietro a me, che disinstallo il vecchio kernel PRIMA ancora di aver verificato se funziona: è un atto poco furbo, il mio; non prenderlo ad esempio.

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Fatto tutto e funziona !
Unico problema (x ora): non funziona più l'audio.
Cosa devo fare ?
devo installare pulse o devo correggere qualcosa ?
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Questa è una cosa che, sinceramente, ancora non ho ben chiarito. Ho anche chiesto lumi sul Forum in lingua inglese di PCLinuxOS, ma non me ne hanno dati (nemmeno m'han risposto). Peraltro, sino a questo momento., non avendo trovato nessun altro, in Rete, a cui fosse capitata la stessa cosa che è successa a me, credevo d'esser l'unico al quale fosse capitato...
Su due miei PC (con installato PClinuxOS LXDE a 32-bit), un netbook e un desktopPC (entrambi con Scheda Audio Realtek, ma di modello alquanto differente), mi sono ritrovato ad aggiornare il Kernel.
In entrambi i casi, mi è subito "sparito" l'audio e non c'è stata maniera di farlo più tornare.
Fatto curioso: i vari programmi che usano l'audio non segnalavano affatto di non riuscire a connettersi alla fonte dell'audio (cosa che VLC, in casi di questo tipo, solitamente fa: appena si apre un file, se il segnale audio non gli arriva, VLC mostra un messaggio in cui avverte di non riuscire a connettersi alla fonte del segnale). Indi, il segnale audio (e l'audio) c'era, eccome... solo che non veniva "espresso" in nessunissimo modo.
Ieri, allora, mi son deciso a tornare al Kernel precedente e, appena cambiato Kernel (prima sul desktopPC), l'audio, come per incanto, è subito tornato...
Per cui, sono andato sul netbook e ho ripetuto l'operazione pure lì. Con identico risultato, peraltro. Tant'è che son venuto a postare qui sul forum riguardo alla vicenda.
Poi, ho spento il netbook e, al riavvio... l'audio era scomparso un'altra volta!
E non c'è stato proprio verso di farlo ritornare.
Al che, mi sono arrabbiato e sono andato a vedere, riaccendendolo, se la medesima cosa fosse capitata pure sul desktopPC... ebbene, era successo! Anche il desktopPC, a nuovo avvio, si mostrava rigorosamente muto. Dal che ho ipotizzato che il problema NOn fosse addebitabile al nuovo Kernel (essendo che anche col vecchio, dopo il primo riavvio funzionava, però dopo un secondo riavvio non funzionava un'altra volta).
Conseguentemente, ho proceduto a reinstallare il nuovo Kernel (sul desktopPC): e, con mia viva sorpresa, dopo l'installazione del nuovo Kernel, al riavvio, l'audio era tornato come per incanto. Per controllare, ho riavviato 5 volte, ma l'audio non se n'è più andato.
Allora, ho ripreso il netbook e ho re-installato il nuovo Kernel pure lì, ma senza ottenere il risultato sperato. il netbook resta muto sia col Kernel vecchio che col Kernel nuovo...
Ma ho scelto di tenere il nuovo Kernel perchè mi sono accorto che le temperature mi son scese, in media, su netbook, di circa 6 gradi (adesso, col nuovo Kernel, viaggio attorno ai 46 gradi; prima, col vecchio Kernel, viaggiavo su una media di 52 gradi, sul netbook), per cui la cosa mi fa gola... e -in ogni caso- spero che si possa venire, o prima o dopo, a capo della faccenda del mutismo che ha preso il mio netbook (il desktopPC, invece, per fortuna, è tornato ad essere loquace)...
Non ti so dar nessuna spiegazione, onestamente. Potrei provare a ipotizzare che orde di gnomi, ilari e baffuti, si stian divertendo a farmi 'sti scherzi da prete, ma temo si tratterebbe di un'ipotesi di ben scarso peso scientifico...

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Notizia aggiuntiva. Pare che taluni Utenti abbian incontrato problemi con Kernel 3.2.18-1 (essenzialmente: alcuni hanno avuto blocchi al riavvio e X che si avviava un po' a singhiozzo, altri han repentinamente perso la connessione Wi-Fi; non sembra sia diffusa, invece, la "perdita della voce" che abbiam registrato noi qui), sicché si sta procedendo al rilascio (già ora si è in piena fase di testing) del Kernel 3.2.18-2 (insomma, una seconda "relase", migliorata, del medesimo Kernel). Dovrebbe arrivare a breve. Speriamo che risolva anche il nostro piccolo problema di mutismo.

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Ciao Monsee.
Ho risolto il problema e individuata la causa Wink
Ti dico come fare e puoi risolvere anche tu facilmente.
È stata un impostazione anomala di kmixer sul volume dell'audio.
In kmixer bisogna rimpostare il volume CD ed riabilitarlo perchè disattivato e nel caso dai uno sguardo anche a Master.
Se non riesci a gestire l'audio da interfaccia grafica (kmixer è su kde), prova da terminale:
alsamixer -Dhw
ti appare l'interfaccia grafica di alsamixer e puoi gestire l'audio (dovrebbe essere master, pcm e cd.
Ciao
Francesco bat

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

L'unica cosa strana è che ora kmixer non è più gestibile dal pannello perchè mi appare un microfono che mi dice volume 0% e non è possibile modificarlo se non cliccando nel microfono e successivamente in kmixer.
Una cosa molto strana.
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Verifico fra un po' questa questione del Mixer (in PClinuxOS, volendo, si può installare un pacchetto che si chiama "aumix" [che poi si lancia da: Main Menu/Audio/Aumix] tramite il quale settare -e, dunque, modificare- i volumi audio). In questo momento non posso, perchè mi trovo con il nottebook a 64-bit, il quale non ha problemi. Debbo riaccendere il netbook (a 32-bit) per controllare dove porta la tua idea.

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Da Kmix dovevo riselezionare il canale principale.
Ho selezionato CD e ora è riapparsa la levetta del volume e mi riporta 70% (la potenza che ho impostato).
Poi non so se è più corretto mettere qualche altro canale al posto di CD; non mi ricordo che c'era prima.
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

A me, invece, non ha funzionato (sul netbook, intendo).
Ho tutto impostato, l'icona mi appare, il Master è il 100%, ma il netbook resta muto comunque... Son certo che la cosa si risolverà, naturalmente. È solo un po' seccante, però comprendo che, ora che si stan preparando a rilasciare, nei giorni e nelle settimane a venire, una bella quantità di aggiornamenti, ci sia -dato l'impegno richiesto e lo sforzo- pure un po' di "maretta"...

ADDENDA: situazione leggermente migliorata. Nel senso che, sul netbook, ora si sente almeno la voce di alcuni programmi (VLC, ad esempio, se apro un file, emette anche i correlati suoni... e uguale cosa vale per i vari browser quando vedo dei filmati (files in flash o in mp4, etc...)
Quello che ancora manca -completamente- sono i cosiddetto "suoni di sistema" (che prima facevan riccamente sentir la propria presenza con tutta una serie di segnali sonori per le diverse situazioni).
Cosa bizzarrissima: son riuscito a far "parlare" i mediavideo soltanto abilitando "pulseaudio"... Ed io, da quando ho cominciato ad utilizzare PCLinuxOS, non avevo mai avuto il benché minimo bisogno di abilitarlo!
Ergo, dato che sino ad oggi il mio audio ha funzionato benissimo SENZA pulseaudio, deduco che il problema mio NON sia da considerarsi affatto risolto... come testimonia anche la completa mancanza dei "suoni di sistema"... Comunque, adesso, almeno, sono in grado di sentire sia i files audio (sto ascoltando ora una bellissima canzone di Lucio Battisti: "I ritorni") che i files video, sia da YouTube che altrove. Meglio di niente, direi. Per ora, se non altro, mi posso accontentare.

ADDENDA all'ADDENDA: ora sono col desktopPC e posso confermare che i suopni si sentono senza problemi (anche se il Kernel che uso è quello più aggiornato), non solo i files audio o video, ma anche tutti i "suoni di sistema". Anche questa installazione è PCLinuxOS LXDE a 32-bit (uguale al netbook, dunque), ma qui l'audio funziona (e alla grande) senza aver minimamente abilitato pulseaudio. E la stessa cosa valeva, prima dell'aggiornamento all'ultima versione del Kernel, anche per il mio netbook, l'audio del quale funzionava alla grande (inclusi tutti i "suoni di sistema") senza ch'io mai avessi abilitato pulseaudio. Ora, abilitando pulseaudio, sono riuscito a sentire di nuovo i files audio e quelli video... Purtroppo, invece, i "suoni di sistema" restano tutti sempre muti (sul netbook, intendo).

twa
Ritratto di twa
Offline
Last seen: 8 anni 8 mesi fa
Iscritto: 17/04/2012 - 20:42

Hi,
per i suoni di sistema, vedi se questo aiuta:
http://pclinuxos.it/node/1424
ciao

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Grazie, TWA!
Purtroppo, nel mio caso, i suoni di avvio erano già impostati... e non sentivo nulla lo stesso.
Ora, però, il problema si è risolto (o meglio, si è "trasferito" -apparentemente- ad altro campo).
Ecco cos'ho combinato e cosa ne ho ottenuto.
Dato che usando pulseaudio riuscivo a sentire i suoni dei video e degli audio, ma non quelli "di sistema", ho provveduto a disabilitare pulseaudio (così com'eran -peraltro- sempre state impostate le cose sul mio netbook). Dopo di che, ho riavviato.
Conseguenza: al riavvio, ho avuto l'immenso piacere di sentir risuonare di nuovo tutti i "suoni di sistema". Rientrato sul desktop, ho subito verificato se si riuscivano a sentire anche i files audio e quelli video: tutto a posto, tutto perfettamente funzionante...
... e, solo allora, mi sono accorto che la mia Wi-Fi non era per nulla connessa. Non si era avviata la connessione ad internet, insomma.
Sono andato a cliccare per avviarla... e ho avuto la sorpresa di vedere che la mia connessione wlan0 (da sempre, wireless) veniva vista come una connessiona "cablata"... e non veniva rilevata alcuna wireless...
Ho, allora, proceduto a re-impostar correttamente le cose tramite "Configura la rete". E la mia wireless è stata immediatamente individuata e s'è regolarmente avviata. Ho anche controllato che fosse impostato tutto correttamente, incluso l'avvio automatico della Wi-Fi al boot del sitema: tutto quanto è a posto. Peraltro, una volta avviata la Wi-Fi, il sistema riconosceva di nuovo wlan0 come connessione wireless.
Per prudenza, a quel punto, ho riavviato. Giusto per controllare.
E, al riavvio, son rimasto estasiato sentendo che i suoni di sistema c'eran sempre, belli vispi... Ma, giunto sul desktop, mi sono ritrovato un'altra volta senza connessione Wireless! (in compenso, tutti i suoni, inclusi quelli dei video e i files audio, funzionavano assai bene).
Ho riprovato ad avviare la connessione (sempre con immediato successo) ben 5 altre volte... Ma, sempre, al riavvio... mi sono ritrovato costretto ad attivare la connessione io (OK che bastano un paio di click, ma prima la medesima connessione si avviava sempre in automatico!)...
Per cui, ne deduco che potrebbe forse esserci una connessione -il diavolo sa quale- fra i problemi correlati al suono (e ai suoni di sistema in particolare) che ho riscontrato prima e il fatto che, all'avvio, le connessioni wireless vengan scambiate per connessioni cablate (problema che sto avendo ora... e che -come testimonian vari post sul Forum in lingua inglese- hanno avuto anche altri, e talmente in tanti che si sta approntando una nuova relase dell'ultimo Kernel).
Per ora, sto bene così: mi basta qualche click, comunque, per connettermi... e i suoni mi funzionan nuovamente... e alla grande... Mi auguro che la nuova relase del Kernel risolva il problema del mancato "avvio automatico" della connessione Wi-Fi (anche se, a legger sul forum in lingua inglese, almeno per ora, non pare ci siano riusciti gran che).
In compenso, rilevo che, col nuovo Kernel le temperature del processore sono, in media, più basse (rispetto a prima) di 6-8 gradi, il che è un'ottima cosa (specie quan do si usa un netbook!)...
Niente di nuovo (per fortuna!), invece, riguardo al mio desktopPC (che, però, si è sempre connesso soltanto in Ethernet "cablata"). Lì, tutto funziona bene, sia i suoni (inclusi quelli di sistema) che la connessione...

twa
Ritratto di twa
Offline
Last seen: 8 anni 8 mesi fa
Iscritto: 17/04/2012 - 20:42

monsee,
beh, mi spiace per i tuoi problemi di Wi-fi e Kernel.
avendo solo un PC desktop e kernel ufficiale, sia la wireles che la LAN funzionano alla grande, anche con i suoni nessun problema.
buon week-end

Ritratto di aleupuat
Offline
Last seen: 9 anni 4 mesi fa
Iscritto: 16/06/2012 - 12:05

Ho appena installato il nuovo kernel sul netbook di mia figlia con (PCLinuxOS LXDE£ a 32-bit) e adesso la famigerata intel gma500 ha una risoluzione perfetta,la stessa di windows xp.
Finalmente adesso è tutto perfetto!
Alessandro

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Evviva! Grazie dell'info, Aleu!

Ritratto di bebolinux
Offline
Last seen: 5 anni 1 mese fa
Iscritto: 10/12/2008 - 22:27

Sull'onda del vostro entusiasmo ho installato anch'io il kernel 3.2.18-pclos1.pae.bfs.
Tutto Ok tranne che per l'audio MUTO.
Dopo svariati tentativi di recuperare il volume con i vari mixer ecc.. ho trovato il comando
alsaunmute
Dopo aver lanciato alsaunmute l'audio è tornato perfetto.
Ovviamente come da prassi ho dovuto ricaricare i driver di virtualbox per il nuovo kernel con

su
/etc/init.d/vboxdrv setup

Come consigliato da monsee sono passato dalla semplice versione pae alla pae.bfs (avendo 4GB di ram installata+memoria dedicata scheda video) ed effettivamente l'opzione bfs mi sembra piu reattiva nell'aprire i programmi e le finestre.

ciao a tutti

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Perfetto, Bebo! lieto che tutto ti funzioni bene.

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Forse ho finalmente capito da dove nasce il problema della mancata connessione "in automatico" via Wi-Fi.
Se non mi sto sbagliando, alla base del problema c'è un "conflitto" ingenerato da tre pacchetti (tre drivers di connessione), e peraltro inultili (non servono alla connessione... per tutti quelli che hanno il medesimo problema che ho incontrato io) col nuovo driver di connessione Wi-Fi da poso instalalto in PCLinuxOS.
Non dico di più, per ora (perchè può esser che mi sbaglio... e non ho nancora avuto modo di fare i necessari esperimenti e controllare com'è che stanno le cose), ma -questa sera- farò le debite prove e, dopo, verrò a riferire.

Ritratto di Benzocaino
Offline
Last seen: 7 anni 11 mesi fa
Iscritto: 11/12/2011 - 04:32

Dopo gli aggiornamenti mi trovo un PCLOS KDE privo delle personalizzazioni che avevo in uso: desktop, font, tema, ecc...
Normale?

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Rammento che la medesima cosa (per ben sei volte) è capitata pure a me (sempre e soltanto con la versione KDE). Ragion per cui, a inzizio promavera del 2009, abbandonai la versione KDE (e non intendo più tornarci in avvenire).
Mi par di rammentare che -all'epoca- trovai anche traccia di una procedura che avrebbe forse potuto condurmi a "rinvenire" le mie impostazioni di base per KDE, ma non mi sembra fosse semplicissima (e c'era da usar -se non rammento male- il Terminale), per cui ho semplicemente "chiuso" con KDE4 (che, dopo, ha dimostrato di non valer gran che nemmeno in altre "distro", tant'è che -alla fine- l'ho abbandonato in toto).
Per tua informazione, quel che ti è accaduto è verosimilmente portato dal fatto che è "in corso d'opera" l'aggiornamento da KDE 4.6.5 a KDE 4.8.3... Per questo, penso, tu hai perduto le tue impostazioni 8eran per KDE 4.6.5 e non son state trasferite a KDE 4.8.3 [che, peraltro, mi par non sia ancora stato aggiornato neanche per metà: nei prossimi giorni, comqunque, l'aggiornamento verrà sicuramente completato]).

Ritratto di Benzocaino
Offline
Last seen: 7 anni 11 mesi fa
Iscritto: 11/12/2011 - 04:32

Grazie della rapida risposta Monsee, poco male perchè in pochi minuti ho ripristinato il tutto; non proprio tutto perchè ho perso gli appunti segnati sul plasmoide ad essi dedicato, in effetti sono un po' contrariato.
Mah, vedremo con il nuovo KDE se sarà ora di migrare verso altri lidi un po' più "premurosi" dell'utente.

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Purtroppo il problemino che ho con la connessione Wi-Fi del netbook (che non si attiva automaticamente al boot) non è risolto ancora. L'idea che avevo avuto, dunque, non è da considerarsi valida.
Poco male, comunque, dato che mi bastano un paio di click per attivar la connessione Wi-Fi "manualmente"... Si tratta, insomma, di un piccolissimo "distrurblo", niente di che: solo, mi piacerebbe che tutto quanto tornasse a funzionar bene come accadeva prima.

Per quel che attiene KDE4, Benzocaino, ti debbo confessare che mi ci son trovato sempre assai male in tutte le "distro" in cui l'ho utilizzato (e anche in PC-BSD). In tutti quanti i casi, ho riscontrato una certa tendenza all'instabiliotà e una più che discreta "pesantezza". In vari casi, mi son trovato innanzi alla repentina perdita delle mie inpostazioni personalizzate subito dopo un qualche aggiornamento. Con KDE3, rammento bene, nulla di simile accadeva...

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

@monsee hai provato a vedere dalla GUI di alsamixer ?
Oggi ho aggiornato il kernel di un mio notebook acer con pclinuxos lxde a 32 bit e l'audio era partito.
Da terminale, digitando: alsamixer -Dhw
ho regolato da GUI il volume e ho dovuto alzare, oltre che master, anche speaker e pcm che erano bassi.
Mentre regoli il volume puoi anche testare l'audio contemporaneamente per vedere se va bene.
Ciao
Francesco bat

Ritratto di Benzocaino
Offline
Last seen: 7 anni 11 mesi fa
Iscritto: 11/12/2011 - 04:32

monsee wrote:
Per quel che attiene KDE4, Benzocaino, ti debbo confessare che mi ci son trovato sempre assai male in tutte le "distro" in cui l'ho utilizzato (e anche in PC-BSD). In tutti quanti i casi, ho riscontrato una certa tendenza all'instabiliotà e una più che discreta "pesantezza". In vari casi, mi son trovato innanzi alla repentina perdita delle mie inpostazioni personalizzate subito dopo un qualche aggiornamento. Con KDE3, rammento bene, nulla di simile accadeva...

Ho sempre usato gnome2 e solo grazie a PLOS sono passato a KDE4.
È l'unica distro con Chakra (abbandonata per altri motivi) che ha reso KDE4 fruibile sul mio pc.
Intendo che lo trovo molto stabile e performante come in nessuna altra distro, l'episodio post-aggiornamento, per ora, resta un piccolo pegno da pagare per avere una distro così piacevole.

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Due buone nuove:

1) ho risolto tutti i problemi sul mio netbook non appena ho proceduto ad installare il nuovo Kernel 3.2.18-2 e ho rimosso il Kernel precedente (il 3.2.18-1). Ora la connessione si avvia di nuovo automaticamente al boot e tutti i suoni sio sentono assai bene;
2) per chi usa KDE4: è stato reso disponibile (lo si può installar da Synaptic con un semplice click) un pacchetto che serve proprio, nel caso che un upgrade di KDE spazzi via le personalizzazioni apportate al proprio desktop- a ritrovar, sul novello KDE appena aggiornato, tutte le proprie personalizzazioni (le quali, come per incanto, ricompariranno con un semplice click del mouse).

axa
Ritratto di axa
Offline
Last seen: 5 mesi 6 giorni fa
Iscritto: 09/12/2011 - 12:50

ciao a tutti ho eseguito l'aggiornamento su una macchina con pclinux kde 32bit chiaramente son passato al kernel nuovo per il momento mi funziona tutto ,devo testare altre periferiche usb wifi ma da subito non ho avuto problemi con l'alfetta chip rtl8187 continuerò a testarlo per bene prima di eliminare il vecchio kernel ,i problemi di impostazioni personalizzate su kde li ho avuti idem a altri utenti comunque roba di poco risettarli ma sicuramente fastidiosi - per quanto riguarda kde a me si presenta ancora il 4.6.5 sicuramente non pronto l'intero pacchetto solo piccole modifiche al vassoio di sistema -puntatore etc ma nulla di piu concordo con Monsee la non finita portatilità delaa relese kde 4.8.3, il vecchio problema con una web cam logitech 3500 persiste il microfono non viene riconosciuto ,continuo i test a risentirci.
Saluti

Ritratto di Benzocaino
Offline
Last seen: 7 anni 11 mesi fa
Iscritto: 11/12/2011 - 04:32

monsee wrote:
Due buone nuove:
2) per chi usa KDE4: è stato reso disponibile (lo si può installar da Synaptic con un semplice click) un pacchetto che serve proprio, nel caso che un upgrade di KDE spazzi via le personalizzazioni apportate al proprio desktop- a ritrovar, sul novello KDE appena aggiornato, tutte le proprie personalizzazioni (le quali, come per incanto, ricompariranno con un semplice click del mouse).

Come si chiama il pacchetto?

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Il pacchetto si chiama (indovina un po'?):

restore-kde-desktop

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

monsee wrote:
Il pacchetto si chiama (indovina un po'?):

restore-kde-desktop

Ah, ecco !
Era proprio quello che volevo sapere.
Ieri sera aggiornando i pacchetti ho visto questo nelle novità, ma la descrizione è molto scarsa e non ho capito realmente come funziona e cosa fa di preciso.
Cercando in rete non ci sono guide.
Quindi, di preciso, come funzionerebbe ?
Ciao
Francesco bat

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Penso dovrebbe apparirti un'icona apposita, cliccando sulla quale, si aprirà una finestra che dovrebbe consentirti di riottenere il tuo desktop personalizzato.
Trovi una descrizione -in lingua inglese- della cosa (ma anche alcune immagini del desktop), qui: http://www.pclinuxos.com/forum/index.php/topic,106268.75.html (in particolare, mi riferisco ad alcuni post di Old-Polack).

Ritratto di Benzocaino
Offline
Last seen: 7 anni 11 mesi fa
Iscritto: 11/12/2011 - 04:32

nel rep italiano non c'è Sad

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

Benzocaino wrote:
nel rep italiano non c'è :(

Hai cercato con precisione:
restore-kde-desktop ?
Se non lo trovi, prova a ricaricare il synaptic prima perchè è una novità.
Ciao
Francesco bat

Ritratto di Benzocaino
Offline
Last seen: 7 anni 11 mesi fa
Iscritto: 11/12/2011 - 04:32

Trovato, provato e ha funzionato alla perfezione!
Grazie 1000 Smile

axa
Ritratto di axa
Offline
Last seen: 5 mesi 6 giorni fa
Iscritto: 09/12/2011 - 12:50

Scusatemi non ho capito una cosa ,ma siete già in kde 4.8.3????
Perchè io ho ancora il 4.6.5 ho cercato nel gestore ma non vi è traccia ,non vorrei che stessi sbagliando io .....
Saluti

Ritratto di francesco bat
Offline
Last seen: 1 anno 4 mesi fa
Iscritto: 20/11/2011 - 02:46

axa wrote:
Scusatemi non ho capito una cosa ,ma siete già in kde 4.8.3????
Perchè io ho ancora il 4.6.5 ho cercato nel gestore ma non vi è traccia ,non vorrei che stessi sbagliando io .....
Saluti

No, non ancora.
Il titolo del post su kde è perchè qualche giorno fa c'è stato un mega aggiornamento delle librerie qt in cui pensavo che cambiasse qualcosa di kde ma non ancora alla 4.8.
Quindi siamo ancora alla 4.6, in più questi aggiornamenti qt hanno compromesso il funzionamento di ProjectM (gli effetti grafici di Clementine) che all'avvio fanno crashare e immediatamente chiudere Clementine.
Infatti ho postato anche un messaggio a riguardo sul forum inglese e hanno confermato il problema e sembrerebbe essere la causa di questo problema proprio quell'aggiornamento delle librerie qt.
Speriamo che risolvino presto.
Ciao
Francesco bat

axa
Ritratto di axa
Offline
Last seen: 5 mesi 6 giorni fa
Iscritto: 09/12/2011 - 12:50

cero arrivato ma la sicurezza non è mai troppa grazie ciao

axa
Ritratto di axa
Offline
Last seen: 5 mesi 6 giorni fa
Iscritto: 09/12/2011 - 12:50

Riassumo la mia situazione post aggiornamento kernel:
ho provato Linux localhost.localdomain 3.2.18-pclos1.bfs #1 SMP PREEMPT Tue May 22 04:05:24 CEST 2012 i686 i686 i386 GNU/Linux che quello successivo il 3.2.18-pclos 2 bfs di regola ritoccato per ovviare alle classiche problematiche audio - aquisizione e uscite audio etc etc ... Io sia nel primo che nel secondo kernel non ho piu l'audio in uscita cuffie e ingresso microfono i diffusori esterni funzionano inutile dire che ho già controllato e ricontrollato su tutte le possibili settaggi audio come già da tempo non riesco a far andare una web cam logitech 3500 sempre riguardo la parte audio cioè da multimedia in configura il tuo desktop i driver 0x46dx:0x9a4 usb sembrano non essere caricati al boot già dal 2.6.38 ,
il resto periferiche usb wifi usb vanno bene solo questi due problemi che mi stanno facendo rotolare i cosidetti ,utilizzati il 2.6.38 e l'audio uscita frontale cuffia ritorna senza problemi resta il driver della web non avviato non so piu che fare uso tanto skype è questo diventa un serio problema per mè ,consigli sul da farsi?????

scheda audio Marca: ‎NVIDIA Corporation Descrizione: ‎MCP61 High Definition Audio
webcam : Marca: ‎Logitech, Inc.

Descrizione: ‎QuickCam E 3500

Classe dei supporti: ‎Video|Video Control
Bus: ‎USB
Bus PCI n°: ‎1
Dispositivo PCI n°: ‎20
ID della marca: ‎0x046d
ID del dispositivo: ‎0x09a4
Altri
Modulo: ‎uvcvideo

Saluti ..

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Mi par di rammentare che sia da poco stata rillasciata una nuova versione -per PCLinuxOS- dei driver NVIDIA odierni (la puoi aggiornare normalmente tramite Synaptic).
L'ultima versione del Kernel (la 3.2.18-2) a me ha subito risolto i problemi di audio sul netbook (sugli altri PC ero riuscito, smanettandpo un pochino, a risolver le cose già io prima). Peccato che non abbia avuto uguale effetto anche sull'hardware tuo.

axa
Ritratto di axa
Offline
Last seen: 5 mesi 6 giorni fa
Iscritto: 09/12/2011 - 12:50

@Monsee : Eh si peccato ,ho provato tutti i kernel possibili ma niente da fare per ora ritorno al vecchio 2.6.38 su questo non và solamente la web logitecht e3500 ,cioè il video funziona ma niente microfono suggerimenti su come posso risolvere????

Ritratto di monsee
Offline
Last seen: 3 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Se hai installato il pacchetto "aumix" e/o il pacchetto "gmixer" verifica che sia abilitato anche il microfono. Non so in KDE, ma penso dovrebb esistere un correlat pacchetto specifico anche per KDE. Non usando ormai da molti anni KDE, non lo rammento proprio...

Pagine