[RISOLTO] pclos in italiano

14 contenuti / 0 new
Ultimo contenuto
Ritratto di olgraz
Offline
Last seen: 2 anni 7 mesi fa
Iscritto: 31/01/2016 - 07:31
[RISOLTO] pclos in italiano

Salve a tutti,

ho appena scaricato ed installato l'ultima versione di pclos mate, trovandolo in inglese ho cercato di settarlo in italiano tramite Regional setting ma l'italiano non compare sulla lista, Leggendo sul vostro forum ho prima fatto gli aggiornamenti tramite synaptic, ho poi cercato il repository  na.garr.... ma non c'era. Allora l'ho aggiunto alla lista lasciandolo come unico repository ed ho ricaricato, ma il risultato è questo;

http://na.mirror.garr.it/mirrors/pclinuxos/apt/pclinuxos/base/pkglist.main: 404 Not Found
http://na.mirror.garr.it/mirrors/pclinuxos/apt/pclinuxos/base/pkglist.up... 404 Not Found
 

Qualcuno sa come aiutarmi?

Grazie e buona domenica a tutti

Ritratto di monsee
Offline
Last seen: 3 settimane 4 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Non ti so dire riguardo al Repo del GARR, ma può anche essere che sia in fase di manutenzione... o, per altre ragioni, che la sua specifica Sezione dedicata a PCLinuxOS sia al momento offline. Infine, è anche possibile che tu abbia inserito male il correlato indirizzo. Non lo so.
Ma puoi risolvere il problema semplicemente impostando il NLUUG (che sta in Olanda, la quale è comunque in Europa) quale unico Repo in Synaptic. Dopo di che, sempre in Synaptic, "ricarica le firme dei pacchetti" e poi procedi -se c'è da aggionare- all'aggiornamento. Fatto questo (e farlo è indispensabile!), puoi "italianizzare" la tua PCLinuxOS utilizzando allo scopo il "Localization Manager" (ovverosia, il cosiddetto "addlocale", che non funziona se il Sistema non viene PRIMA completamente aggiornato).

Ritratto di olgraz
Offline
Last seen: 2 anni 7 mesi fa
Iscritto: 31/01/2016 - 07:31

L'indirizzo che ho immesso nella lista dei repositories è questo:

http://na.mirror.garr.it/mirrors/pclinuxos/apt/

il NLUUg era già impostato di default quindi gli aggiornamenti li ho scaricati da lì, la cosa strana è che nel Localization Manager a parte l'irlandese non c'è neanche una lingua europea.

Ritratto di monsee
Offline
Last seen: 3 settimane 4 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Se parli dell'Add-Locale di PCLinuxOS (il "Localization Manager" che serve a "localizzare" il Sistema, insomma), la cosa è sorprendente e per davvero buffa (solo l'Irlandese?... Robe da matti!)...
In questo caso, la sola cosa che mi viene in mente è che il tuo pacchetto "addlocale" sia difettoso. Infatti, se apro il mio Localization Manager, trovo una valanga di lingue (inclusa la lingua italiana) fra quelle a disposizione. Per cui ti suggerisco di eliminarlo (usando Synaptic: cerchi il pacchetto "addlocale" e lo selezioni per la rimozione), per poi, successivamente, chiuder tutto quanto, riavviare il PC e, dopo il riavvio, reinstallare il pacchetto in questione (la versione attuale è la "4.3.9") sempre usando Synaptic.

In quanto all'indirizzo che hai immesso in Synaptic per il Repo del GARR, rammenta che, nella Scheda, devi anche aggiungere i "campi" relativi a:

Distribuzione
e a
Sezione/i

Sennò è assai probabile che la connessione, poi, non ti funzioni.

Ritratto di zafran
Offline
Last seen: 6 mesi 5 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10
Ritratto di Hertz
Offline
Last seen: 1 anno 9 mesi fa
Iscritto: 02/08/2014 - 10:59

Buongiorno olgraz,

olgraz wrote:

Salve a tutti,

ho appena scaricato ed installato l'ultima versione di pclos mate, trovandolo in inglese ho cercato di settarlo in italiano tramite Regional setting ma l'italiano non compare sulla lista, Leggendo sul vostro forum ho prima fatto gli aggiornamenti tramite synaptic, ho poi cercato il repository  na.garr.... ma non c'era. Allora l'ho aggiunto alla lista lasciandolo come unico repository ed ho ricaricato, ma il risultato è questo;

http://na.mirror.garr.it/mirrors/pclinuxos/apt/pclinuxos/base/pkglist.main: 404 Not Found
http://na.mirror.garr.it/mirrors/pclinuxos/apt/pclinuxos/base/pkglist.up... 404 Not Found
 

Qualcuno sa come aiutarmi?

Grazie e buona domenica a tutti

come ti è stato già indicato da zafran, ho creato una variante del repositorio na.garr (non più disponibile), con quello linkato.

Quest'ultimo funziona perfettamente, inoltre ha un minimo scarto di tempo in sincronizzazione per quello che riguardano i vari aggiornamenti rispetto che al repositorio nluug, quindi affidabile come quello ufficiale.

Mi sembra comunque anomalo che in Mate non ci sia la possibilità di configurare la lingua italiana, ma potrebbe anche essere come tu affermi, personalmente non adottando Mate e non usando i miei sistemi in lingua italiana, ma nativi non posso esserti qui di grande aiuto. Sad

Ritratto di olgraz
Offline
Last seen: 2 anni 7 mesi fa
Iscritto: 31/01/2016 - 07:31

@Monsee   Ho eseguito alla lettera le tue indicazioni  ma nel localization Manager manca sempre l'italiano.

@Zafran @Hertz   Ho anche provato con quel repository che mi avete linkato ma dopo qualche secondo di caricamento mi rimanda un messaggio di errore come se il repo non fosse più attivo.

Non so più cosa fare.

Ritratto di monsee
Offline
Last seen: 3 settimane 4 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Da Synaptic, prova ad installare i seguenti pacchetti (te li do in ordine alfabetico; alcuni sono relativi a programmi specifici -a Firefox, per esempio- ed è necessario installarli solo se installi anche il Programma cui sono riferiti [accanto ai nomi ti ho posto anche un asterisco, per evitare di sbagliarci]):

aspell-it
firefox-it (*)
locales-it
man-pages-it
myspell-it_IT
thunderbird-it (*)

Quando li selezioni per l'installazione, vedrai che ti verrà richiesto di installare qualche altro pacchetto, assieme: accetta. Per impostare, poi, la lingua italiana, riavvia il PC e, nella schermata di Login (senza ancora essere entrato sul desktop, insomma), seleziona la lingua italiana. Quando poi ti loggherai ti verrà chiesto se vuoi che la lingua italiana sia "di default": rispondi che lo vuoi. Non usando io Mate (io uso solo LXDE e XFCE) non so se c'è qualcosa d'altro che si debba fare, ma se c'è vedrai che qualcun altro (che invece usa Mate) te lo saprà indicare.

Ritratto di olgraz
Offline
Last seen: 2 anni 7 mesi fa
Iscritto: 31/01/2016 - 07:31

Scusatemi ragazzi ma avevo sbagliato il localization manager, mi spiego:

io partivo dal centro di amministrzione e da quel punto mi dava i problemi che vi avevo descritto,

ma poi ho visto il Localization Manager sul menu delle applicazioni alla voce Software Center l'ho lanciato e da lì ho potuto installare la lingua italiana.

Vi ringrazio per il vostro prontissimo aiuto, alla prossima.

Ritratto di olgraz
Offline
Last seen: 2 anni 7 mesi fa
Iscritto: 31/01/2016 - 07:31

Come si inserisce Risolto alla discussione?

Ritratto di dxgiusti
Offline
Last seen: 3 settimane 4 giorni fa
Iscritto: 22/01/2013 - 17:30

partiamo dall'inizio. abilita il repo di nluug, solamente lui. ( poi se vorrai impostarne altri al suo posto vedrai... ). 

verifica di aver installato > addlocal <, nel caso reinstallalo. ( prima di questa operazione aggiorna il sistema )

adesso avvia > localizzazion manager <. guarda che durante il processo ti scomparirà la finestra, lascialo lavorare. ti avviserà lui al termine.

 

 

Ritratto di monsee
Offline
Last seen: 3 settimane 4 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34
Oggetto:
pclos in italiano
»
[RISOLTO] pclos in italiano

Mi sembra che gli Utenti non abbiano, al momento, la possibilità di mettere "risolto". O, quantomeno, ancora non abbiam compreso bene come si può fare a farlo.
Ci penso io a metterti il "risolto", se non ti dispiace.

Ritratto di olgraz
Offline
Last seen: 2 anni 7 mesi fa
Iscritto: 31/01/2016 - 07:31

Asolutamente no, grazie.

 

Ritratto di monsee
Offline
Last seen: 3 settimane 4 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Non c'è di che, figurati! I-m so happy