[RISOLTO] PCLinuxOS 32 bit LXDE su Lenovo ThinkPad T61 - Non si italianizza.

9 contenuti / 0 new
Ultimo contenuto
Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53
[RISOLTO] PCLinuxOS 32 bit LXDE su Lenovo ThinkPad T61 - Non si italianizza.

Per l'ennesima volta apro una discussione in merito all'italianizzazione di PCLinuxOS.
Il fatto è che, a causa del "decesso" del precedente PC di mia figlia (un anziano IBM ThinkPad R50e) mi sono visto costretto a sostituirlo con un tecente (si fs per dire) Lenovo ThinkPad T61.
Come Sistema Operativo, considerato il fatto che nemmeno il nuovo PC è poi tanto nuovo, ho pensato di installare PCLinuxOS 32 BIT con LXDE.
L'installazione è andata bene. Il disco fisso, un SSD da 128GB, è stato codì partizionato:
$ df -T -h
Filesystem Type Size Used Avail Use% Mounted on
/dev/sda1 ext2 15G 2.8G 12G 20% /
/dev/sda5 ext2 25G 83M 24G 1% /home
/dev/sda6 ext2 25G 44M 24G 1% /mnt/dati1
/dev/sda7 ext2 25G 44M 24G 1% /mnt/dati2
/dev/sda8 ext2 27G 44M 26G 1% /mnt/dati3
$ su
# fdisk -l

Disk /dev/sda: 126.0 GB, 126035288064 bytes, 246162672 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001e72c

Device Boot Start End Blocks Id System
/dev/sda1 63 31455269 15727603+ 83 Linux
/dev/sda2 31457280 246161407 107352064 5 Extended
/dev/sda5 31459328 83888127 26214400 83 Linux
/dev/sda6 83890176 136318975 26214400 83 Linux
/dev/sda7 136321024 188749823 26214400 83 Linux
/dev/sda8 188751872 246161407 28704768 83 Linux
#

Dopo l'installazione, ho eseguito l'aggiornamento, che si è concluso positivamente.
Ripeto la localizzazione finchè Synaptic mi dice che non c'è nulla da aggiornare.
Spengo e riaccendo il PC. Ovviamente l'icona della localizzazione, sullo aschemo NON c'era.
Da menù seleziono:
[Menù] > [More applications] > [Configuration] > [Localization Manager]
e mi compare il messaggio:
More than one repositories are configured in Synaptic.

Please start Synaptic and follow these steps:
1. Go to 'Settings -> Repositories' and ensure to have only
one (1) repository enabled.
2. Click the button 'Reload' at the top left,
3. Click the button 'Mark All Upgrades',
4. Click the button 'Apply' to fully update your system,
5. After Synaptic has finished, close Synaptic and run
addlocale again.

Exiting...
Come italianizzo?

Ritratto di dxgiusti
Offline
Last seen: 5 mesi 3 giorni fa
Iscritto: 22/01/2013 - 17:30

ciao, apri synaptic e rifai l'aggiornamento. quando hai terminato, ( se hai installato qualche cosa ) rilancialo. ora puoi avviare il manager per la lingua.
mi dimenticavo, prima dell'operazione relativa al linguaggio, controlla di aver attivato un solo server ( normalmente il primo, quello olandese, selezionalo )

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

dxgiusti wrote:
ciao, apri synaptic e rifai l'aggiornamento. quando hai terminato, ( se hai installato qualche cosa ) rilancialo. ora puoi avviare il manager per la lingua.
mi dimenticavo, prima dell'operazione relativa al linguaggio, controlla di aver attivato un solo server ( normalmente il primo, quello olandese, selezionalo )

Apro Synaptic verifico che sia attivo il solo server olandese, clicco su Reload, attendo che faccia effetto, clicco su Mark All Upgraes, attendo che faccia effetto, NON clicco su Apply perchè non trova nulla.
Pensando di avere sbagliato qualcosa in fase di installazione, riformatto tutto, cogliendo l'occasione per fare una piccola modifica al partizionamento.
A reinstallazione avvenuta, apro Synaptic verifico che sia attivo il solo server olandese, clicco su Reload, attendo che faccia effetto, clicco su Mark All Upgraes, attendo che faccia effetto, clicco su Apply, attendo che faccia effetto, spengo il Portatile, lo riaccendo, apro Synaptic verifico che sia attivo il solo server olandese, clicco su Reload, attendo che faccia effetto, clicco su Mark All Upgraes, attendo che faccia effetto, NON clicco su Apply perchè non trova nulla.
Da menù seleziono:
[Menù] > [More applications] > [Configuration] > [Localization Manager]
e mi compare il messaggio:
More than one repositories are configured in Synaptic.

Please start Synaptic and follow these steps:
1. Go to 'Settings -> Repositories' and ensure to have only
one (1) repository enabled.
2. Click the button 'Reload' at the top left,
3. Click the button 'Mark All Upgrades',
4. Click the button 'Apply' to fully update your system,
5. After Synaptic has finished, close Synaptic and run
addlocale again.

Exiting...
Detesto quando fa così!
Che faccio?
Installo PCLinuxOS a 64 BIT?
Installo PCLinuxOS con MATE?
Installo PCLinuxOS con KDE?

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Puoi installare un Sistema a 64-bit soltanto e unicamente se il tuo Processore è un Processore a 64-bit.
Se il tuo Processore è a 32-bit, NON ti è proprio possibile farci funzionar sopra un Sistema a 64-bit (è invece possibile l'opposto: far funzionare un Sistema a 32-bit su di un Processore a 64-bit,. ma è un po' uno spreco a parer mio).

Da quel che riporti, il tuo problema è che NON hai affatto UN SOLO Repository, selezionato in Synaptic: ne hai più di uno.
E questo ti blocca tutto il procedimento di italianizzazione, inevitabilmente.
Oltretutto, adesso il cosiddetto "Repo dei Megagames" nemmeno esiste più: per cui, devi lasciar la spunta soltanto e unicamente sul Repo del NLUUG. Su quello, punto e basta: non lasciare alcuna altra "spunta". Se lasci un solo Repo, vedrai che l'Add-Locale, ti si avvia.

PS: il Sistema che stai cercando di installare e italianizzare si chiama PCLinuxOS, non OpenSuSE come hai inavvertitamente scritto nel titolo del thread...

Ritratto di dxgiusti
Offline
Last seen: 5 mesi 3 giorni fa
Iscritto: 22/01/2013 - 17:30

non so dove hai scaricato la iso, comunque dato per scontato che il computer è collegato ad internet, apri il terminale:
su
per essere amministratore seguito da invio. nella nuova riga scrivi:
leafpad etc/apt/sources.list
si aprirà un foglio di testo, cancella tutto il contenuto ed al suo posto copia/incolla il contenuto di questo:
https://www.dropbox.com/s/7bjdg3dqzd43lq0/sources.list.doc
salva prima di uscire.
ho dato per scontato che il tuo sistema sia a 32bit.
ora apri synaptic, aggiorna ed al termine :
https://www.dropbox.com/s/8uysjkpvn5qris0/Selezione_002.jpg

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

monsee wrote:
Puoi installare un Sistema a 64-bit soltanto e unicamente se il tuo Processore è un Processore a 64-bit.
Se il tuo Processore è a 32-bit, NON ti è proprio possibile farci funzionar sopra un Sistema a 64-bit (è invece possibile l'opposto: far funzionare un Sistema a 32-bit su di un Processore a 64-bit,. ma è un po' uno spreco a parer mio).
Premetto che la CPU del laptop in questione è una
Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz
In generale, anche io la penso come te; in nessun PC con CPU a 64 bit destinato a restare in mio possesso installerei un S.O. a 32 bit, ma questo PC non è destinato a restare nelle mie mani, quindi preferisco installare un Sistema operativo (PCLinuxOS) leggero (LXDE) e collaudato (a 32 bit).

monsee wrote:
Da quel che riporti, il tuo problema è che NON hai affatto UN SOLO Repository, selezionato in Synaptic: ne hai più di uno.
E questo ti blocca tutto il procedimento di italianizzazione, inevitabilmente.
Oltretutto, adesso il cosiddetto "Repo dei Megagames" nemmeno esiste più: per cui, devi lasciar la spunta soltanto e unicamente sul Repo del NLUUG. Su quello, punto e basta: non lasciare alcuna altra "spunta". Se lasci un solo Repo, vedrai che l'Add-Locale, ti si avvia.

Il contenuto del file etc/apt/sources.list è il seguente:

# 32bit Package repository URL's, working as of 04/02/2014
#==================================================================
# Please enable only ONE (1) entry !!!
#==================================================================
rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://spout.ussg.indiana.edu/linux/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://pclinuxos.c3sl.ufpr.br/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://ftp.heanet.ie/pub/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://pclinuxos.fi/pub/linux/ 32bit main updates nonfree kde games xfce4
# rpm http://ftp.belnet.be/pclinuxonline.com/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://ftp.cc.uoc.gr/mirrors/linux/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://ftp-srv2.kddilabs.jp/Linux/packages/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://distrib-coffee.ipsl.jussieu.fr/pub/linux/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://ftp2.ie.freesbie.org/pub/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://mirror.internode.on.net/pub/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://mirror.aarnet.edu.au/pub/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://mirrors.xservers.ro/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://ftp.jaist.ac.jp/pub/Linux/PCLinuxOS/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
# rpm http://mirrors.ispros.com.bd/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4
Come vedi, è selezionato solo il repository
rpm http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/ pclinuxos/32bit main updates nonfree kde games xfce4

monsee wrote:
PS: il Sistema che stai cercando di installare e italianizzare si chiama PCLinuxOS, non OpenSuSE come hai inavvertitamente scritto nel titolo del thread...
Non me n'ero accorto! Lapsus froudiano! E adesso come lo correggo?

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

dxgiusti wrote:
non so dove hai scaricato la iso, comunque dato per scontato che il computer è collegato ad internet, apri il terminale:
su
per essere amministratore seguito da invio. nella nuova riga scrivi:
leafpad etc/apt/sources.list
si aprirà un foglio di testo, cancella tutto il contenuto ed al suo posto copia/incolla il contenuto di questo:
https://www.dropbox.com/s/7bjdg3dqzd43lq0/sources.list.doc
salva prima di uscire.
ho dato per scontato che il tuo sistema sia a 32bit.
ora apri synaptic, aggiorna ed al termine :
https://www.dropbox.com/s/8uysjkpvn5qris0/Selezione_002.jpg[/quote]
Fatto.
Nulla da fare. l'errore persiste.

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

[RISOLTO] Italianizzazione di PCLinuxOS.
Ho aperto Synaptic, ho selezionato l'archivio dei pacchetti, ho deselezionato l'unico archivio selezionato, ho ricaricato l'elenco dei pacchetti, ho avviato il Manager di Localizzazione. A quel punto, il Manager di Localizzazione si è accorto che non era selezionato alcun repository, e me lo ha segnalato.
Io allora, sempre da Synaptic, ho selezionato l'archivio dei pacchetti, ho selezionato l'archivio che avevo deselezionato prima, ho ricaricato l'elenco dei pacchetti, ho avviato il Manager di Localizzazione, e mi ha localizzato quasi tutto... Ovviamente firefox l'ho dovuto litalianizzare a parte abilitando il pacchetto che, nel frattempo, era già stato scaricato, ma non è stato nulla di complicato.
Quando accadono fatti come questo, il problema non è applicare la soluzione, ma indovinare la soluzione da applicare.

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Sargon6 wrote:
monsee wrote:
PS: il Sistema che stai cercando di installare e italianizzare si chiama PCLinuxOS, non OpenSuSE come hai inavvertitamente scritto nel titolo del thread...
Non me n'ero accorto! Lapsus froudiano! E adesso come lo correggo?

Ci ho pensato io (i normali Utenti non possono intervenire, in questi casi; ci vogliono "permessi speciali"). Ho anche -già che c'ero- provveduto ad inserire la scritta "risolto".