Installazione PCLinuxOS 64 bit LXDE con probliemi di GRUB e di lingua.

19 contenuti / 0 new
Ultimo contenuto
Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53
Installazione PCLinuxOS 64 bit LXDE con probliemi di GRUB e di lingua.

Avendo a disposizione un Sony Vaio VGN-FE41M con CPU a 64 bit sul quale avevo già installato Windows® Seven™, OpenSUSE 12.1 a 64 bit con KDE e PCLinuxOS a 32 bit con KDE, ho deciso di installare, in una ulteriore partizione, PCLinuxOS a 64 bit con LXDE.
Non ho usato Virtualbox; ogni S.O. è stato installato in una partizione.
A installazione ulktimata, ho riscontrato questi problemi:

1) Il menù del boot è completamente saltato, e parte direttamente PCLinuxOS 64 bit con LXDE
2) PCLinuxOS 64 bit con LXDE è completamente in inglese, e non c'è verso di italianizzarla.

Per il salto del menù di boot, non so proprio da dove iniziare per sistemare il tutto.
Il problema della lingua pensav o fosse semplice...
Ho aperto Synaptic
Ho impostato, come unico repository, http://na.mirror.garr.it/mirrors/pclinuxos/apt/
Ho cliccato su Localization Manager che, stranamente, ha finito in pochi secondi.
Ho ricaricato ila lista dei pacchetti di Synaptic
Ho cliccato sull'cona per selezionare tutti gli aggiornamenti.
Ho cliccato sull'icona per applicare le modifiche.
Ho atteso oltre mezz'ora l'installazione degli aggiornamenti.
Ho spento e riacceso il portatile.
PCLinuxOS ERA IN INGLESE.
Allora clicco nuovamente su Localization Manager, ed ecco che compare questo messaggio:

The repository in Synaptic is not configured properly.

Please start Synaptic and follow these steps:
1. Go to 'Settings -> Repositories' and ensure to have only
one (1) repository enabled having the sections:
x86_64 kde
2. Click the button 'Reload' at the top left,
3. Click the button 'Mark All Upgrades',
4. Click the button 'Apply' to fully update your system,
5. After Synaptic has finished, close Synaptic and run
addlocale again.

Exiting...

Sbalordito, riapro Synaptic e controllo i repository: l'unico repository selezionato è
http://na.mirror.garr.it/mirrors/pclinuxos/apt/
Come risolvo i due problemi?

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

Ridimensioniamo la cosa...
Il boot non viene saltato, mi è permesso di scegliere fra PCLinuxOS e PCLinuxOS. Il primo è con LXDE, ed il secondo è con KDE, ma, essendo indistinguibili, sembra che la stessa voce compaia due volte nel menù.
Rimane il problema della localizzazione.

Ritratto di zafran
Offline
Last seen: 3 mesi 6 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Per il menu di boot puoi editare /boot/grub/menu.lst e modificare i title come preferisci.

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Per PCLinuxOS LXDE 64-bit e la sua traslazione in lingua italiana (ti sto scrivendo proprio da PCLinuxOS LXDE-mini 64-bit... ed è in lingua italiana [perchè il mio Add-Locale ha fatto il proprio dovere]), posso soltanto ipotizzare che il problema tuo consista nel fatto che NON hai il Sistema perfettamente aggiornato.
Si tratta di un problema che può essere descritto in questo modo: Synaptic rileva che ci son dei pacchetti de tu dovresti aggiornare. Sicché, Add-Locale, quando viene avviato, verificando la cosa (e rilevando il mancato aggiuornamento di almeno UN pacchetto) si chiude senza "localizzare" un bel niente.
Talora, per risolvere, basta effettuare un completo aggiornamento tramite Synaptic (nella quasi totalità dei casi, è proprio questa la via da seguire). Tuttavia (dato che siam parlando di un 64-bit, ossia di una versione "da test", dunque -per sua stessa definizione- instabile e presumibilmente colma di acciacchi [se fosse un Sistema "stabile" e davvero "affidabile" non servirebbe certo fare i test!]), c'è da tener nel debito conto il fatto che può ben capitare che le normali procedure, in un Sistema "da testing", non servano a nulla e -anzi- possano addirittura peggiorar la situazione.
Quindi, la prima mossa da fare (quella che ti suggerisco io, per intenderci) è di provar la strada dell'aggiornamento completo del sistema tramite Synaptic (da interfaccia grafica: niente "riga di comando" e niente Terminale, per favore).
Se ciò risolverà le cose, bene.
Se non risolverà, ci sarà da capire quali pacchetti non si riesce proprio ad aggiornare (personalmente, ho una mezza idea di saper già di quali pacchetti si tratta [uno risulta "difettoso" e gli altri due son direttamente collegati ad esso]); se i pacchetti che verranno fuori sono quelli che immagino io, si tratta di tre pacchetti che, su di un PCLinuxOS LXDE non dovrebbero affattpo venir installati (e non lo sono, infatti), mentre vanno benissimo se si parla di un PCLinuxOS KDE (KDE4 io non lo uso da anni, ma so che i tre pacchetti in questione afferiscono proprio a KDE]).
Restando, comunque, a LXDE: una volta capito QUALI pacchetti ti danno il problema (quelli che immagino io sono "kate", una libreria di Kate e un plugin di Kate; il pacchetto veramente difettoso è la libreria di Kate, ma nessuno dei tre dovrebbe essere installato in LXDE (io, infatti, non ho nessuno dei tre.... e non ne hai nemmeno uno manco tu). Bizzarrissimo il fatto che vengan segnalati tre pacchetti "di aggiornamento" che afferiscono, invece, a pacchetti -sul Sistema- inesistenti.
Apparentemente, sembra una situazione parecchio intricata, ma ti posso indicar come risolverla con semplicità (indicandoti la medesima via che ho seguito io per poter installare LibreOffice 3.5.5). Tuttavia, per non rischiar di darti istruzioni errate, preferisco che tu prima provi semplicemente ad aggiornar da Syanptic, nel modo normale... e mi dica i nomi esatti dei pacchetti che non si riescono ad "aggiornare". Grazie.

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

L'aggiornamento lo avevo già fatto; per sicurezza l'ho ripetuto. Ovviamente non si è aggiornato nulla, stranamente nessun poacchetto è stato individuato come "da agiornare".
Che faccio?

Altra cosa: tu descrivi la 64 bit TEST come una dsistro testing. Sinceramente losospettavo. Dunque consiglieresti di preferire PCLinuOS a 32 bit? Non parlo soilo di LXDE, ma anche di KDE.

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Stranissimo che nessun pacchetto sia marcabile per l'aggiornamento...
La cosa non sembra avere il minimo senso, a dirla tutta.
In quanto alle versioni "da test": si tratta di versioni "da test" e NON vanno considerate in alcun modo come "versioni stabili". personalmente, mi piaccion molto le versioni "da test" a 64-bit di PCLinuxOS con desktop LXDE, XFCE_Phoenix e (sia pure un po' meno) ZEN-mini. Non ho neanche provato la versione con desktop KDE perchè non apprezzo minimamente KDE4 (il quale -com'è ben noto- NON è minimamente "l'evoluzione di KDE3", ma è un desktop-environment del tutto differente, completamente riscritto daccapo e senza punti in comune di sorta con KDE3 [il quale, invece, come desktop, era alquanto valido]... un po' come Gnome3 non è affatto l'evoluzione di Gnome2, ma un desktop del tutto diverso e scritto "da zero"). Fermo restando che sconsiglio caldamente l'utilizzo di Sistemi a 32-bit se si usa un processore a 64-bit, ritengo che le versioni di PCLinuxOS a 32-bit che NON sian "in fase di testing" sian da considerarsi decisamente più sicure e stabili delle versioni a 64-bit (essendo queste ultime "da test").
Avendo io un notebook che usa un processore a 64-bit, ho preferito comunque installare sempre e soltanto Sistemi a 64-bit (incluso PCLinuxOS a 64-bit) perchè son sicuro che è solo questione di tempo prima che sia rilasciata la versione stabile e definitiva (non più "da test", dunque) di PCLinuxOS a 64-bit. Spero soltanto che non stian prendendo in considerazione l'ipotesi di realizzare solo la versione "stabile" a 64-bit di PCLinuxOS KDE, perchè questo mi costringerebbe a privarmi per sempre di PCLinuxOS, dato che non son disposto di certo -e a qualsivoglia prezzo- ad installare e utilizzare mai più alcun KDE4.

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

Concordo pienamente. Anche secondo me il fatto che l'applicazione per italianizzare il sistema segnali l'assenza di qualcosa, e, contemporaneamente, l'applicazione per aggiornare il sistema segnali che non manchi nulla, non ha senso.
Potrebbe dipendere da qualche click dato involontariamente in fase di installazione? Se fosse solo quello, potrei rifare l'installazione da ZERO utilizzando un mouse esterno...

Capisco la tua avversione al KDE4 (che anche secondo me non è un'evoluzione del KDE3, ma qualcosa di completamente diverso [talmente diverso che, volendo, avrebbero potuto farlo passare per GNOME3 {non sono l'unico a pensare che, vista la differenza fra KDE4 dal suo predecessore, nonchè la differenza fra GNOME3 ed il suo predecessore, ciò che noi oggi chiamiamo KDE4 si sarebbe anche potuto chiamare GNOME3 e viceversa}³]²), ma ti posso assicurare che oggi è molto meglio di com'era agli inizi (ci vuole poco!)³. Forse OpenSUSE con KDE ricomparirà nel mio PC a 64 bit.

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

[Risolto]. Ora PCLinuxOS è quasi tutto in in Italiano. Ho parzialmente risolto installando da Synaptic il pacchetto locales-it, in modo da avere la lingua italiana fra quelle selezionabili al log-in. Successivamente ho spento e riacceso il portatile, e, con mio sommo piacere, era quasi tutto in italiano.
Però se clicco sul Manager di Localizzazione, continua a darmi l'errore descritto nei post precedenti. Evidentemente è un bug.
Qualcosina è rimasto in inglese... forse il manager di localizzazione faceva qualcosa di più che installare il pacchetto locales-it, e la traduzione del S.O., ne risente, anche se in misura minima.

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Sì, Sargon: il solo e unico modo esistente per avere il sistema localizzato quanto più possibile è di usare Add-Locale (il Localizzation Manager).
Dovresti cercare di comprendere qual'è il pacchetto il cui mancato aggiornamento ti provoca il malfunzionamento di Add-locale. Probabilmente, avrai lo stesso problema (se non lo vai a risolver prima, ovviamente) quando dovrai usare il LibreOffice Manager per andare ad aggiornare LibreOffice 8che non si aggiorna tramite Synaptic, ma -proprio come il Localizzation Manager- usa il "LibreOffice Manager" per effettuare l'aggiornamento... e anche il LibreOffice Manager si blocca e si rifiuta di andare avanti se c'è (sul Sistema) anche un solo pacchetto che gli risulta esser "da aggiornare".

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

Mi hai incuriosito, così ho installato Libre Office Manager, e poi, con quello ho installato Libre Office.
L'installazione è andata a buon fine, ora ho Libre Office completamente in italiano, mentre altre applicazioni (es. Synaptic) sono totalmente in inglese, ed altre ancora sono tradotte a metà.

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

Ho fatto un altro passo in avanti installando da Synaptic tutti i pacchetti il cui nome finiva con -i10n (9 pacchetti più alcune dipendenze). Ora il menù che si apre cliccando col tasto destro del mouse su una parte vuota del desktop, PCManFM ed LXTerminal sono in italiano, mentre altre applicazioni tipo Synaptic e Leafpad restano in inglese.

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Veramente bizzarro. Ti sto scrivendo dal mio PCLinuxoS LXDE a 64-bit e posso assicurarti che la localizzazione italiana è pressoché perfetta. Peraltro, ti posso confermare che quando avevo il problema dei pacchetti "non-aggiornati" (pacchetti che non avrebbero nemmeno potuto venire aggiuornati, giacché sul mio Sistema nemmeno c'erano), nemmeno l'installazione di libreOffice funzionava.
A questo punto, posso soltanto ipotizzare un malfunzionamento dell'Add-Locale.
Derivato -presumibilmente, dato che sul mio PC funziona senza problemi- da qualche intoppo in fase di download del pacchetto o di installazione (nel caso tuo, intendo).
Sicché, posso solamente suggerirti di disinstallare COMPLETAMENTE (scegli "rimozione completa") il pacchetto "addlocale", poi di riavviare il PC e, dopo l'avvenuto riavvio, procedere a reinstallare il pacchetto "addlocale".
Fatto questo, prova nuovamente a localizzare il tuo sistema in lingua italiana... e speriamo in bene.

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

Nulla da fare.
La rimozione completa e successiva reinstallazione non ha risolto il problema.
per fortuna le applicazioni che uso più spesso sono quasi tutte italianizzate...
Mi infastidisce soprattutto la mancata italianizzazione delle cartelle di utente.

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Mi spiace non riuscire proprio ad esserti di alcun aiuto: il mio PCLinuxOS LXDE-mini a 64-bit non ha mostrato nessunissimo problema concernente la localizzazione. Mi viene in mente che forse tu hai installato PCLinuxOS LXDE 64-bit test2, mentre io ho installato PCLinuxOS LXDE-mini 64-bit test. Potrebbe essere che ci sia quna qualche minuscola differenza, fra le due ISO, tale da generar questo tuo problema? Mi pare strano, ma non lo posso escludere.

ADDENDA: mi è venuto in mente proprio ora che potresti aver usato la ISO di PCLOS LXDE 64-bit denominata RC1 (il che spiegherebbe perchè non rilevi le questioni relative a Synaptic che mi aspettavo io e perchè Add-Locale non ti funzioni correttamente [essendo una ISO appena uscita è possibile che il difetto, anche se rilevato, non sia ancora stato compiutamente risolto] mentre nel mio caso tutto funziona).

ADDENDA2: confermo che trattasi di un problema di Add-Locale, come risulta anche da un post che ho appena letto. Immagino stiano lavorando a dar giusta soluzione a detto problema (vedrai che aggiorneranno Add-Locale a breve).

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

Ho usato la pclinuxos64-lxde-test2.iso scaricata da qui:
http://na.mirror.garr.it/mirrors/pclinuxos/live-cd/

Attenderò l'aggiornamento di Add-Locale

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Ciao, Sargon!
Ti informo che è appena uscito l'aggiornamento di Add-Locale a 64-bit che risolve il problema di localizzazione che ti ha assillato (e che ha assillato un pochettino pure me, te lo confesso).
La versione funzionante è addlocale 4.2-3.
E, se non ho inteso male io, la dobbiamo al buon Pinoc.

Ritratto di Sargon6
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 05/08/2011 - 15:53

Ho aggiornato PCLinuxOS 64 bit con LXDE ed ho avviato il manager di localizzazione.
Ora sembra tutto a posto, a parte il fatto che alcune cartelle di sistema, anzichè venire rinominate in Italiano, sono state aggiunte in italiano, così ora ho sia la cartella Desktop, sia la cartella Scrivania, sia la cartella Movies, sia la cartella Video.

[pclinuxosl@localhost ~]$ ls
Desktop/ Immagini/ Musica/ tmp/
Documenti/ Modelli/ Scaricati/ Video/
getLOdictionary.txt Movies/ Scrivania/ VirtualBox VMs/
[pclinuxosl@localhost ~]$

Ritratto di zafran
Offline
Last seen: 3 mesi 6 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Questa storia delle cartelle di sistema localizzate è una iattura.
È stata abborracciata malissimo per scimmiottare windows, neanche il quale, peraltro, l'ha saputa risolvere perfettamente, anche se sicuramente in modo più dignitoso ma non meno offensivo per l'intelligenza degli utenti (cosa vorrà dire desktop? mah, boh).

Il mio consiglio è sempre e comunque di farsi dei bei link in italiano puntati alle cartelle originali.
Es:
ln -s ~/Desktop ~/Scrivania
In questo modo siamo sicuri:
- di quello che abita la nostra Home
- che qualsiasi programma troverà il posto giusto dove andare a parare
- non avremo più il patema di non sapere cosa aveva in mente quel giorno l'imitatore di turno.

Ritratto di monsee
Offline
Last seen: 2 mesi 1 settimana fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Di norma, io elimino seccamente le cartelle in inglese (dopo l'avvenuta localizzazione, ovvio!)... Mi è capitato di ritrovare la cartella Movies e la cartella Pictures (quest'ultima, più di rado), qualche volta. E le ho sempre immediatamente eliminate (conservando lla cartella Video e la cartella Immagini). Mai m'è accaduto che rimanesse anche l'iconetta "desktop" in lingua inglese, per fortuna. Immagino, però, che la soluzione proposta qui da Zafran possa ben funzionare.
Di fatto, ho avuto modo di vedere che quando resta la "versione inglese" di una cartella di Sistema, la correlata versioone italiana è sempre completamente vuota (se avevamo inserito qualcosa dentro la cartella PRIMA di localizzare, il contenuto lo ritroveremo certamente nella cartella restata in inglese, NON in quella "tradotta" in italiano. Sicché, prima di eliminare il contenuto, è bene spostarlo in un'altra cartella (non quella "tradotta" in italiano, però, perchè non si sa mai, dato che, al momento, è ancora un po' un "doppione").
Poniamo che io (prima di "localizzare") abbia inserito un file video nella cartella Movies. In questo caso, se -dopo l'avvenuta italianizzazione- mi trovo ancora la cartella Movies (e anche la cartella Video), provvedo a spostare il file mio dalla cartella Movies alla carteòlla Documenti. Poi, elimino la cartella Movies, svuoto il Cestino e, solo a quel punto, provvedo a spostare il file-video dalla cartella Documenti alla cartella Video.
Naturalmente, è sempre meglio non metter nulla dentro le cartelle se prima non si è provveduto a "localizzare" a puntino il Sistema.

A me, stranamente, capita, nella mia installazione di PCLinuxOS64 LXDE RC1, di avere due files di testo dai nomi bizzarri dentro alla cartella mia personale... e non riesco manco ad immaginare a che servano o cosa siano: so solo che li ho eliminati, ma me li sono ritrovati uguali identici al successivo riavvio... Beh, si tratta di una Relase Candidate, per cui è anche normale che mostri ancora dei problemi...