Installazione file rpm

11 contenuti / 0 new
Ultimo contenuto
Ritratto di samiam1000
Offline
Last seen: 11 anni 2 mesi fa
Iscritto: 07/04/2008 - 19:37
Installazione file rpm

Vorrei installare un file .rpm. Come procedo???
E' giusto dare: rpm -ivh nome.rpm ???

Perché quando provo ad installare plotmtv mi dice:

error: Failed dependencies:
/bin/csh is needed by plotmtv-1.4.1-1051.i586

O meglio: ho capito il motivo. Ma non trovo una soluzione.
Mi sapete aiutare? Grazie mille,
Samuele

PS: scarico plotmtv da http://fr2.rpmfind.net/linux/rpm2html/

Avete altri siti?

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Cercalo tra i repository mandriva:
ftp://gd.tuwien.ac.at/pub/linux/Mandrakelinux/official/

Così con l'rpm sorgente ci si può capire qualcosa di più.

Ritratto di samiam1000
Offline
Last seen: 11 anni 2 mesi fa
Iscritto: 07/04/2008 - 19:37

Mi puoi dare tutti i parametri da mettere in Synaptic, per favore...

Thanks,
Samuele

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Non lo puoi mettere in synaptic. Devi scaricarti l'rpm dal loro ftp e poi installarlo col classico

rpm -Uvh nome.rpm

La cosa migliore, però, è crearsi un repository locale dove mettere gli rpm di altre distro. In questo modo, se ci sono dipendenze e i pacchetti sono già presenti nel repo ufficiale di PCLOS, synaptic te li scarica in automatico.
Segui quanto scritto qui:
http://pclinuxos.it/node/528

Ritratto di samiam1000
Offline
Last seen: 11 anni 2 mesi fa
Iscritto: 07/04/2008 - 19:37

Ho seguito la discussione che mi hai suggerito.
In effetti, ora tra i pacchetti trovo Paraview (uno di quelli che avevo installato)...
Clicco sopra e mi dice che deve scaricare anche altri pacchetti.
Allora accetto, ma poi esce un messaggio d'errore in cui mi dice che non può soddisfare alcune dipendenze.
Purtroppo non so come catturare la schermata, altrimenti ti manderei la finestra che mi esce.

Tu hai altre idee?
Grazie,
Samuele.

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Questo significa che c'è qualche pacchetto (presente in mandriva e non in pclos) che è necessario per paraview e non è nei tuoi repo.
Sappi che ciò che ti dico di fare protrebbe rendere il tuo sistema instabile, quindi non farlo se non puoi permettertelo. Se esegui

rpm -Uvh nome_pacchetto_paraview.rpm

dovrebbe dirti quali sono i pacchetti mancanti. Devi cercare anche quelli nel repo mandriva e metterli nel repo personale. Ricordati poi di aggiornare il tuo repo col comando descritto nell'altro thread.

Ritratto di samiam1000
Offline
Last seen: 11 anni 2 mesi fa
Iscritto: 07/04/2008 - 19:37

Ma a me, onestamente, da dei nomi... Ma sono .so e non .rpm.

Dici che se do quel comando mi dici i .rpm mancanti???

Ma perché dici che il mio sistema diventa instabile?

Proverò domattina. Grazie,
Samuele.

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Quelli sono nomi di librerie, tu prova a elencarmeli.

Ritratto di samiam1000
Offline
Last seen: 11 anni 2 mesi fa
Iscritto: 07/04/2008 - 19:37

ok.
Ma come faccio a fare una foto del desktop???
C'è un "cattura schermata"?

Ritratto di zafran
Offline
Last seen: 4 giorni 8 ore fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Con 'Stamp' ti si dovrebbe aprire ksnapshot.
Oppure con 'Alt+Stamp' avere già la schermata negli appunti (clicdestro in una cartella o nel desktop e 'Incolla il contenuto degli appunti').

Io faccio così:
- ho ImageMagick installato
- Alt+F2 e il Launcher nella Barra tengono in memoria il comando:
'import /dove/mi/pare/nome.jpg' (o altra estensione)
- selezionato ll comando il mouse può descrivere una regione che viene salvata automaticamente in quel percorso.
C'è lo scomodo di doverlo rinominare per non sovrascriverlo ma almeno lo ritrovi a botta sicura.

Ritratto di samiam1000
Offline
Last seen: 11 anni 2 mesi fa
Iscritto: 07/04/2008 - 19:37

Ciao, scusate il ritardo con cui torno a questo post (spero non ve ne siate dimenticati, ormai) ma ho avuto problemi di connessione...
Comunque, copio qui di seguito le librerie che non trova...

Grazie per l'aiuto,
Samuele.
Eccoli qui (copio tutto perché non ho capito come inserire l'immagine):

"Could not mark all packages for installation or upgrade"

The following packages have unresolvable dependencies. Make sure that all required are added and enabled in the preferences

paraview:
Depends: libKWCommon.so
Depends: libOSMesa.so.6 but it is not installable
Depends: libQVTK.so.pv3.4
Depends: libQtChart.so
Depends: libQtPython.so
Depends: libQtTesting.so
Depends: libXdmf.so
Depends: libhdf5.so.5 but it is not installable
Depends: libpqComponents.so
Depends: libpqCore.so
Depends: libpqWidgets.so
Depends: libpython2.5.so.1.0 but it is not installable
Depends: libssl.so.7 but it is not installable
Depends: libstdc++.so.6(GLIBCXX_3.4.9) but it is not installable
Depends: libvtkClientServer.so
Depends: libvtkCommon.so.pv3.4
Depends: libvtkCommonCS.so
Depends: libvtkCommonPythonD.so.pv3.4
Depends: libvtkDICOMParser.so.pv3.4
Depends: libvtkFiltering.so.pv3.4
Depends: libvtkFilteringCS.so
Depends: libvtkFilteringPythonD.so.pv3.4
Depends: libvtkGenericFiltering.so.pv3.4
Depends: libvtkGenericFilteringCS.so
Depends: libvtkGenericFilteringPythonD.so.pv3.4
Depends: libvtkGeovis.so.pv3.4
Depends: libvtkGeovisPythonD.so.pv3.4
Depends: libvtkGraphics.so.pv3.4
Depends: libvtkGraphicsCS.so
Depends: libvtkGraphicsPythonD.so.pv3.4
Depends: libvtkHybrid.so.pv3.4
Depends: libvtkHybridCS.so
Depends: libvtkHybridPythonD.so.pv3.4
Depends: libvtkIO.so.pv3.4
Depends: libvtkIOCS.so
Depends: libvtkIOPythonD.so.pv3.4
Depends: libvtkImaging.so.pv3.4
Depends: libvtkImagingCS.so
Depends: libvtkImagingPythonD.so.pv3.4
Depends: libvtkInfovis.so.pv3.4
Depends: libvtkInfovisCS.so
Depends: libvtkInfovisPythonD.so.pv3.4
Depends: libvtkNetCDF.so.pv3.4
Depends: libvtkPVCommandOptions.so
Depends: libvtkPVFilters.so
Depends: libvtkPVFiltersCS.so
Depends: libvtkPVPythonInterpretor.so
Depends: libvtkPVServerCommon.so
Depends: libvtkPVServerCommonCS.so
Depends: libvtkPVServerCommonPythonD.so
Depends: libvtkPVServerManager.so
Depends: libvtkPVServerManagerPythonD.so
Depends: libvtkParallel.so.pv3.4
Depends: libvtkParallelCS.so
Depends: libvtkParallelPythonD.so.pv3.4
Depends: libvtkQtChart.so.pv3.4
Depends: libvtkRendering.so.pv3.4
Depends: libvtkRenderingCS.so
Depends: libvtkRenderingPythonD.so.pv3.4
Depends: libvtkViews.so.pv3.4
Depends: libvtkViewsPythonD.so.pv3.4
Depends: libvtkVolumeRendering.so.pv3.4
Depends: libvtkVolumeRenderingCS.so
Depends: libvtkVolumeRenderingPythonD.so.pv3.4
Depends: libvtkWidgets.so.pv3.4
Depends: libvtkWidgetsCS.so
Depends: libvtkWidgetsPythonD.so.pv3.4
Depends: libvtkXdmf.so
Depends: libvtkXdmfCS.so
Depends: libvtkexoIIc.so.pv3.4
Depends: libvtkftgl.so.pv3.4
Depends: libvtklibxml2.so.pv3.4
Depends: libvtkmetaio.so.pv3.4
Depends: libvtksqlite.so.pv3.4
Depends: libvtksys.so.pv3.4
Depends: libvtkverdict.so.vtk5.3.0
Depends: paraview-data (=3.4.0-1.fc10) but it is not installable
Depends: rtld(GNU_HASH) but it is not installable