Stampante non rilevata durante installazione driver originale.

10 contenuti / 0 new
Ultimo contenuto
Ritratto di Rebumax
Offline
Last seen: 3 anni 9 mesi fa
Iscritto: 08/09/2014 - 16:00
Stampante non rilevata durante installazione driver originale.

Salve a tutti,
premetto che uso questa distro da 1 settimana con de KDE e, da utilizzatore di Kubuntu da tempo, mi sono trovato davvero bene e KDE sembra girare più veloce.

La mia stampante è una CANON PIXMA MG5250 e su Kubuntu (come tutte le distro derivate da Ubuntu) utilizzo il driver originale Canon perchè i colori che stampo con i driver linux sono scuri, il rosso è più marrone che rosso, e potendo utilizzare quelli originali non ho mai voluto capire se si possono modificare.
Ho scaricato i driver .rpm (qui non ci sono i .deb), faccio partire lo script che va regolarmente ma al momento di rilevare la stampante non la trova (con le stesse operazioni sotto Ubuntu e derivate andava a buon fine), la stampante è accesa e collegata via usb.
Il paradosso è che come accendo la stampante PCLOS la rileva e istalla i driver linux, quindi non viene rilevata solo dallo script.

Che può essere??

Nel caso non ci riesca ho una soluzione alternativa e cioè stampare con windows virtualizzato, problemi quindi non ne avrei, ma se riesco a stampare con Ubuntu tramite i driver canon perchè non dovrei riuscirci con pclos??

Ecco il log dello script:
"[max@localhost cnijfilter-mg5200series-3.40-1-rpm]$ su
Password:
[root@localhost cnijfilter-mg5200series-3.40-1-rpm]# ./install.sh
==================================================

Canon Inkjet Printer Driver Ver.3.40-1 for Linux
Copyright CANON INC. 2001-2010
All Rights Reserved.

==================================================
Command executed = rpm --test -U ./packages/cnijfilter-common-3.40-1.x86_64.rpm
il pacchetto cnijfilter-common-3.40-1.x86_64 è già installato
Command executed = rpm --test -U ./packages/cnijfilter-mg5200series-3.40-1.x86_64.rpm
il pacchetto cnijfilter-mg5200series-3.40-1.x86_64 è già installato

#=========================================================#
# Register Printer
#=========================================================#
Next, register the printer to the computer.
Connect the printer, and then turn on the power.
To use the printer on the network, connect the printer to the network.
When the printer is ready, press the Enter key.
>

#=========================================================#
# Connection Method
#=========================================================#
1) USB
2) Network
Select the connection method.[1]

Searching for printers...

#=========================================================#
# Select Printer
#=========================================================#
Select the printer.
If the printer you want to use is not listed, select Update [0] to search again.
To cancel the process, enter [Q].
-----------------------------------------------------------
0) Update
-----------------------------------------------------------
Could not detect the target printer.
-----------------------------------------------------------
Currently selected:[0] Update
Enter the value. [0]"

Se do INVIO riparte la ricerca ma ritorna al punto finale, la stampante è regolarmente accesa e collegata via USB e riconosciuta da PCLOS (per scrupolo ho stampato una pagina di prova e questo ha fatto...

GRAZIE!!

Ritratto di Rebumax
Offline
Last seen: 3 anni 9 mesi fa
Iscritto: 08/09/2014 - 16:00

Mi sa che ho un problema con CUPS, difatti ho fatto una prova con DRAW e non mi ha stampato nulla..

Ritratto di footstep11
Offline
Last seen: 1 settimana 3 ore fa
Iscritto: 31/01/2013 - 11:01

Prova ad aprire la pagina di CUPS: apri un browser (ad esempio firefox) e metti l'indirizzo http://localhost:631
Vai poi in stampanti e configurala (o eventualmente cancellala e re-installala).

Anche io ho a casa una Canon (PIXMA 160) ed i driver si sono installati senza problema.

Mauro

Ritratto di esabatad
Offline
Last seen: 2 mesi 4 giorni fa
Iscritto: 20/06/2012 - 07:37

aggiungo, come ha detto bene footstep11, che quando la pagina web ti chiederà la password, devi dare il tuo nome utente e la password di root (correggetemi eventualmente).
Ciao

Ritratto di footstep11
Offline
Last seen: 1 settimana 3 ore fa
Iscritto: 31/01/2013 - 11:01

esabatad wrote:
aggiungo, come ha detto bene footstep11, che quando la pagina web ti chiederà la password, devi dare il tuo nome utente e la password di root (correggetemi eventualmente).
Ciao

Ti correggo... Wink La password di root la dai per l'utente root (che e' quello che devi dare se fai operazioni di amministrazione, quali cancellare e/o creare una stampante)!

Mauro

Ritratto di Rebumax
Offline
Last seen: 3 anni 9 mesi fa
Iscritto: 08/09/2014 - 16:00

Ho eseguito i vostri consigli e la stampante viene rilevata correttamente, sono riuscito a stampare, ma con lo script non è cambiato nulla, non rileva nessuna stampante...

Io credo che manchi qualche impostazione che renda visibile la stampante allo script, cmq per ora uso windows sotto virtualbox o il pc di mia moglie perchè tramite il driver linux non solo le stampe rimangono scure ma anche più piccole come dimensioni insomma non va proprio bene.

Misteri di Linux...

Ritratto di Rebumax
Offline
Last seen: 3 anni 9 mesi fa
Iscritto: 08/09/2014 - 16:00

Ho notato una cosa dal browser, che quando agisco sulla stampante la connessione cade e devo sempre ricaricare la pagina, come se ci fosse il server cups intasato, anche a voi capita questo?
Non è che è proprio il server cups ha dei problemi con PClinuxOS?

Volevo cancellare la stampante e reinstallarla ma non me lo fa fare perchè quando ricarico la pagina perde le impostazioni di DELETE e devo ricominciare.

Esiste un modo per reinstallare CUPS o tutta la parte relativa alle stampanti di PClinuxOS?

Ritratto di footstep11
Offline
Last seen: 1 settimana 3 ore fa
Iscritto: 31/01/2013 - 11:01

Questo non e' assolutamente normale. Quando sei sulla pagina di impostazione di CUPS, questo e' quello che vedo nella pagina di amministrazione: http://i58.tinypic.com/29c2xxs.jpg

Per quanto riguarda la re-installazione di CUPS, potresti provare a rimuoverlo e re-installarlo direttamente da synaptic, ma credo che ci siano tante di quelle dipendenze che ti farebbe disinstallare mezzo sistema. Comunque questo e' quello che io ho installato facendo una ricerca per "cups" in synaptic: http://i57.tinypic.com/o6mt5v.jpg

Io sono su una FullMonty a 32bit.

Ciao, Mauro

Ritratto di adrianomorselli
Offline
Last seen: 14 ore 17 min fa
Iscritto: 02/01/2015 - 12:20

Anch'io uso una Canon, la mia è una pixma mp280 che uso in modo ibrido, cioè per stampare uso i driver di gutenprint che mi funzionano egregiamente, mentre per lo scanner ho scaricato i driver per linux dal sito Canon. Se posso dire la mia le bestemmie che ho lanciato su questa stampante che mi ha sempre dato più problemi che soddisfazioni, ma questo anche su windows, da parte mia diventerò un afficionados delle stampanti HP, ho una vecchissima laserjet che non mi ha dato mai problemi di sorta, riconosciuta ed installata al volo con qualsiasi sistema operativo

Ritratto di Rebumax
Offline
Last seen: 3 anni 9 mesi fa
Iscritto: 08/09/2014 - 16:00

Mi sa che la prossima sarà anche per me una HP...
...raga come detto ho risolto stampando con windows in virtualbox, ci metto in più il tempo che ci vuole per far avviare windows 7 ma almeno le stampe vanno senza problemi (creo un pdf del documento che intendo stampare in una cartella condivisa).
Ho capito che devo sbattermi troppo quando poi ho la soluzione a portata di click, questo però è uno dei problemi che linux si porta dietro da sempre e cioè quella dei driver che vengono creati in primis per windows, poi mac e infine se il produttore vuole anche per linux, sempre e cmq una terza scelta facoltativa...
...quando si vede che temono la diffusione del pinguino!!