[RISOLTO] usare lo scanner 1200 UB Plus con PCLinuxOS con KDE

11 contenuti / 0 new
Ultimo contenuto
Ritratto di Sargon6
Offline
Last seen: 2 anni 11 mesi fa
Iscritto: 05/08/2011 - 15:53
[RISOLTO] usare lo scanner 1200 UB Plus con PCLinuxOS con KDE

Vorrei usare lo scanner 1200 UB Plus con PCLinuxOS con KDE.
Il S.O. lo riconosce correttamente, infatti
[pclinuxos-kde64bit@localhost ~]$ lsusb | grep Scan
Bus 004 Device 005: ID 05d8:4002 Ultima Electronics Corp. Artec Ultima 2000 (GT6801 based)/Lifetec LT9385/ScanMagic 1200 UB Plus Scanner
[pclinuxos-kde64bit@localhost ~]$

ma non ho trovato una valida guida per PCLinuxOS.
Al contrario, per Ubuntu ho trovato questa guida
http://wiki.ubuntu-it.org/Hardware/StampantiScanner/ScannerMustek
che funziona per Ubuntu e mint, ma non per PCLinuxOS.
Qualcuno sa dirmi come utilizzare lo scanner 1200 UB Plus con PCLinuxOS con KDE?

Ritratto di Sargon6
Offline
Last seen: 2 anni 11 mesi fa
Iscritto: 05/08/2011 - 15:53

Altro output:
[pclinuxos-kde64bit@localhost ~]$ ls /usr/share/sane/gt68xx/
sbfw.usb
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/gt68xx.conf | grep -A 2 "1200 UB Plus:"
# Mustek ScanExpress 1200 UB Plus:
override "mustek-scanexpress-1200-ub-plus"

[pclinuxos-kde64bit@localhost ~]$

Ritratto di Leman
Offline
Last seen: 1 mese 3 settimane fa
Iscritto: 25/03/2013 - 10:18

Ciao Sargon

Questo scanner mi risulta fuori produzione da parecchio tempo, insomma una specie di
residuato bellico come il mio della Canon.
Comunque... se non ricordo male Pclinuxos è derivata da Linux Mandriva.
Vedi se ti può essere utile questa guida di Mandriva specifica per il tuo scanner.

http://www.mandrakeitalia.org/guide/guide/configurare-lo-scanner-mustek-...

Ritratto di Sargon6
Offline
Last seen: 2 anni 11 mesi fa
Iscritto: 05/08/2011 - 15:53

[pclinuxos-kde64bit@localhost ~]$ scanimage --list-devices
No log handling enabled - using stderr logging
MIB search path: /home/pclinuxos-kde64bit/.snmp/mibs:/usr/share/snmp/mibs
Cannot find module (HOST-RESOURCES-MIB): At line 0 in (none)
Cannot find module (HOST-RESOURCES-TYPES): At line 0 in (none)
Cannot find module (UCD-DISKIO-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (MTA-MIB): At line 0 in (none)
Cannot find module (NETWORK-SERVICES-MIB): At line 0 in (none)
Cannot find module (SCTP-MIB): At line 0 in (none)
Cannot find module (RMON-MIB): At line 0 in (none)
Cannot find module (EtherLike-MIB): At line 0 in (none)
Cannot find module (LM-SENSORS-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (NOTIFICATION-LOG-MIB): At line 0 in (none)
Cannot find module (DISMAN-EVENT-MIB): At line 0 in (none)
Cannot find module (DISMAN-SCHEDULE-MIB): At line 0 in (none)
Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-AGENT-MIB): At line 0 in (none)
Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
Cannot find module (IPV6-ICMP-MIB): At line 0 in (none)
Cannot find module (IPV6-MIB): At line 0 in (none)
Cannot find module (IPV6-TCP-MIB): At line 0 in (none)
Cannot find module (IPV6-UDP-MIB): At line 0 in (none)
Cannot find module (IP-FORWARD-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-PASS-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-EXTEND-MIB): At line 0 in (none)
Cannot find module (UCD-DLMOD-MIB): At line 0 in (none)
Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
Cannot find module (SNMPv2-TM): At line 0 in (none)
Cannot find module (NET-SNMP-VACM-MIB): At line 0 in (none)
device `gt68xx:libusb:004:006' is a Mustek ScanExpress 1200 UB Plus flatbed scanner
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/dll.conf | egrep "mustek_usb|gt68xx"
gt68xx
mustek_usb
mustek_usb2
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/mustek_usb.conf | grep "option 1200ub"
#option 1200ub
#option 1200ub
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/mustek_usb.conf | grep "option 1200ub"
option 1200ub
option 1200ub
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/gt68xx.conf | grep -A 2 "1200 UB Plus:"
# Mustek ScanExpress 1200 UB Plus:
override "mustek-scanexpress-1200-ub-plus"

[pclinuxos-kde64bit@localhost ~]$
Vedo se funziona...

Ritratto di Sargon6
Offline
Last seen: 2 anni 11 mesi fa
Iscritto: 05/08/2011 - 15:53

Residuato o non residuato, visto che l'alternativa è metter mano al portafogli, vorrei farlo funzionare.

[pclinuxos-kde64bit@localhost ~]$ scanimage --list-devices
No log handling enabled - using stderr logging
MIB search path: /home/pclinuxos-kde64bit/.snmp/mibs:/usr/share/snmp/mibs
Cannot find module (HOST-RESOURCES-MIB): At line 0 in (none)
Cannot find module (HOST-RESOURCES-TYPES): At line 0 in (none)
Cannot find module (UCD-DISKIO-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (MTA-MIB): At line 0 in (none)
Cannot find module (NETWORK-SERVICES-MIB): At line 0 in (none)
Cannot find module (SCTP-MIB): At line 0 in (none)
Cannot find module (RMON-MIB): At line 0 in (none)
Cannot find module (EtherLike-MIB): At line 0 in (none)
Cannot find module (LM-SENSORS-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (NOTIFICATION-LOG-MIB): At line 0 in (none)
Cannot find module (DISMAN-EVENT-MIB): At line 0 in (none)
Cannot find module (DISMAN-SCHEDULE-MIB): At line 0 in (none)
Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-AGENT-MIB): At line 0 in (none)
Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
Cannot find module (IPV6-ICMP-MIB): At line 0 in (none)
Cannot find module (IPV6-MIB): At line 0 in (none)
Cannot find module (IPV6-TCP-MIB): At line 0 in (none)
Cannot find module (IPV6-UDP-MIB): At line 0 in (none)
Cannot find module (IP-FORWARD-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-PASS-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-EXTEND-MIB): At line 0 in (none)
Cannot find module (UCD-DLMOD-MIB): At line 0 in (none)
Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
Cannot find module (SNMPv2-TM): At line 0 in (none)
Cannot find module (NET-SNMP-VACM-MIB): At line 0 in (none)
device `gt68xx:libusb:004:006' is a Mustek ScanExpress 1200 UB Plus flatbed scanner
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/dll.conf | egrep "mustek_usb|gt68xx"
gt68xx
mustek_usb
mustek_usb2
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/mustek_usb.conf | grep "option 1200ub"
#option 1200ub
#option 1200ub
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/mustek_usb.conf | grep "option 1200ub"
option 1200ub
option 1200ub
[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/gt68xx.conf | grep -A 2 "1200 UB Plus:"
# Mustek ScanExpress 1200 UB Plus:
override "mustek-scanexpress-1200-ub-plus"

[pclinuxos-kde64bit@localhost ~]$ cat /etc/sane.d/gt68xx.conf | grep -A 2 "1200 UB Plus:"
# Mustek ScanExpress 1200 UB Plus:
override "mustek-scanexpress-1200-ub-plus"
firmware "/usr/share/sane/gt68xx/sbfw.usb"
[pclinuxos-kde64bit@localhost ~]$
Ora per funzionare funziona.
Però l'interfaccia grafica di Xsane mi pare più complicata di quanto sia necessario...
Come faccio ad usarlo con Simple scan?

Ritratto di joanlui
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 30/10/2008 - 11:49

lo avevo anche io, pagato una cavolata all'epoca. Addirittura non era più supportato da Windows Xp mi pare, ma con un escamotage riuscivo a farlo andare...Ti parlo di più di 10 anni fa!
Nel mondo Linux mai provato o forse ai tempi di Mandriva con Xsane andava ma chi si ricorda...Comunque dati i costi dei multifunzione oggi buttato in discarica e comprato un multifunzione Panasonic che va anche in Ubuntu e altre distribuzioni note che gestiscono gli RPM po i DEB (pclinuxos non lo uso più da un paio di anni)

Ritratto di adrianomorselli
Offline
Last seen: 3 ore 28 min fa
Iscritto: 02/01/2015 - 12:20

Mai buttare via! Io ho una stampante multifunzioni canon mp280 che su archlinux funziona come stampante ma come scanner no (ma non desisto, prima o poi troverò il modo) ed ho risolto rispolverando un vecchio scanner hp. Se il tuo scanner funziona con Xsane funziona anche con simple-scan o magari con scanlite, prova a scaricarlo da synaptic e a provarlo

Ritratto di Sargon6
Offline
Last seen: 2 anni 11 mesi fa
Iscritto: 05/08/2011 - 15:53

Sono riuscito a farlo funzionare con Xsane.
Qui spiego come.
http://sargonsei.altervista.org/492/
Peccato che non riesca ad installare Simple Scan...

Ritratto di adrianomorselli
Offline
Last seen: 3 ore 28 min fa
Iscritto: 02/01/2015 - 12:20
Ritratto di Sargon6
Offline
Last seen: 2 anni 11 mesi fa
Iscritto: 05/08/2011 - 15:53

Scoperto l'arcano!
Per installare Simple Scan su Ubuntu e derivate, io avevo installato sane, e pensavo di dover fare la stessa cosa anche su PCLinuxOS, ma su PCLinuxOS, il pacchetto sane non c'è.
Per installare Simple Scan su PCLinuxOS, bisogna installare da Synaptic il pacchetto simple-scan.
(Come ho fatto a non capirlo prima?)

Ritratto di adrianomorselli
Offline
Last seen: 3 ore 28 min fa
Iscritto: 02/01/2015 - 12:20

Mi fa piacere che il link che ti ho mandato ti ha aiutato, con distro diverse nomi diversi ma risultati uguali, una buona norma sarebbe quella di fare prima una ricerca all'interno del forum, in alto a sx c'è "trova nel sito", io ho digitato simple-scan ed è uscito subito il post, molte volte i tuoi problemi sono già stati sviscerati più volte, altrimenti siamo tutti qui ad aiutare o a chiedere aiuto Wink