[RISOLTO] Problemi con driver ATI dopo recenti aggiornamenti

10 contenuti / 0 new
Ultimo contenuto
Ritratto di lucarello79
Offline
Last seen: 5 anni 6 mesi fa
Iscritto: 23/04/2013 - 15:31
[RISOLTO] Problemi con driver ATI dopo recenti aggiornamenti

Vi segnalo l'esperienza di oggi...
Come spesso faccio, avvio Synaptic e mi dice, diversamente dal solito, che sono disponibili più di 200 aggiornamenti.
Senza indugio procedo e mi rendo conto che probabilmente è stato aggiornato KDE.
Alla fine mi viene fuori un messaggio che dice che non è stato possibile aggiornare il pacchetto "fglrx".
Cerco info su questo pacchetto, insospettito provo ad avviare ATI Catalyst Control Center ma mi dice che
il driver non è corretto!
Allora provo ad aggiornare tramite Synaptic, trovo due versioni "current" e "legacy", le provo tutte e due
ma nessuna funziona.
Intanto dopo un paio di reboot mi viene fuori il messaggio che verrà utilizzato il driver generico.
Tra l'altro, noto che sono state resettate le impostazioni dei caratteri e non c'è verso di salvarle.
Stremato, mi gioco l'ultima carta: disinstallo tutto, anche x11 e installo il driver dal sito AMD: funziona!
O almeno così pare...
L'unica stranezza: sul sito la dava come versione 13.4 e invece è 12.1, però sembra andare.
Volevo condividere con voi questa disavventura, per tutti quelli che hanno schede ATI

Ritratto di monsee
Offline
Last seen: 3 settimane 3 giorni fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Personalmente, ho installato il driver "legacy" (è quello che vale per il mio modello di notebook) su PCLinuxOS a 64-bit (LXDE, per l'esattezza), installando anche il Catalyst Control Center correlato e il driver X correlato (in pracica, serve installare 4 pacchetti complessivamente, sia che si abbia una Scheda di tipo "legacy", sia che si abbia una Scheda di tipo "normale"; installando anche solo un pacchetto di meno di quelli necessari, le cose non funzionano).
Dopo l'installazione, se si prova ad usare il Catalyst Control Center, appare un messaggio d'errore che informa che il driver non è installato o che la versione non è quella esatta. Invece (se si è installata secondo la giusta scelta) il driver c'è, ma NON è ancora stato inizializiato.
A questo punto, si apre un terminale e ci si logga come root.
Dopo di che si lancia il comando:

aticonfig --initial

Questo comando, eseguito, serve ad inizializzare il driver.
Fatto ciò, si può chiudere il Terminale e poi riavviare il PC.

È possibile (probabile) che all'avvio successivo venga richiesto di configurare il driver video (appare una finestrella nella quale ci si può muovere agendo da tastiera). Bisogna configurare il driver video, in questo caso, così come conviene. A questo punto, il Sistema effettua un controllo. Non è improbabile che venga individuato un driver migliore di quello configurato. E, in tal caso, appare una richiesta che domanda se si preferisce o no usare il driver che risulta più adeguato. Se avviene questo, rispondere che si desidera usare il driver che il Sistema reputa più adeguato (dare ragione al Sistema è spesso una giusta scelta). Fatto anche questo, l'avvio del sistema prosegue e si può entrare nella Schermata di Login.
Poi, rientrati sul desktop, si può, volendo, configurar la Scheda Video sia dal PCLinuxOS Control Center (ossia, Configure Your Computer) che dal Catalyst Control Center (che, a quel punto, risulta adeguato e perfettamente funzionante).

Una mia amica -che, reputando il suo PC molto recente, aveva scelto la versione "normale"- ha scoperto che la versione giusta per lei era comunque la "legacy" (che vale anche per molte schede uscite in mesi assai recenti). Le è bastato disinstallare il pacchetti sbagliati e sostituirli coi correlati pacchetti "legacy", dopo di che ha seguito il percorso che ho descritto sopra... e ora le funziona tutto quanto.

Ritratto di 500paolo
Offline
Last seen: 9 mesi 3 giorni fa
Iscritto: 16/12/2011 - 10:52

Anche io ho provato sul pc della mia consorte e non sono riuscito:

[xxx@localhost ~]$ su
Password:
[root@localhost xxx]# aticonfig --initial
aticonfig: No supported adapters detected
[root@localhost xxx]#

Questo con i legacy, adesso provo con i current.

Scheda: sapphire x1550 pci-e

Aggiornamento:
Anche con i current stesso messaggio.

Terrei il drv xorg ma e' un disastro, quando clicco col tasto dx del mouse il menu' appare un millesimo di secondo e si chiude subito, devo premerlo piu' volte, inoltre gli effetti della composizione vanno così così e il sincronismo verticale e' assente.
Va beh, era l'unica ati in casa, domani la consegno all'ecocentro per lo smaltimento e' ci infilo una bella nvidia.

Ritratto di zafran
Offline
Last seen: 6 mesi 4 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Nvidia che ha dei driver meglio di ati?
Ma dove siamo, a cinecittà?

Ritratto di 500paolo
Offline
Last seen: 9 mesi 3 giorni fa
Iscritto: 16/12/2011 - 10:52

I driver proprietari nvidia funzionano sempre e si installano semplicemente con synaptic.
Per i drv ati/amd e' quasi sempre complicato a spesso non vanno.
Se tu hai una soluzione per la mia x1550 sono prontissimo a diventare un fan della ati e a osannarti, ma fin ora con tutte le ati che mi sono capitate (si perche' solo una volta feci lo sbaglio di acquistarne una) ho avuto solo problemi con linux (bada bene sto parlando di linux non di pclinuxos).

Ritratto di zafran
Offline
Last seen: 6 mesi 4 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Certo, i driver sono uguali per tutte le distro e lo strano è proprio questo: il mondo si divide in linuxiani che aborrono nvidia e linuxiani pronti a giurare che niente ci può essere di peggio che una scheda ati con un kernel linux.

Non lo so.
Qui ho una 'nvidia che ha funzionato bene con nouveau fino mi pare al kernel 3.0 dopodiché vedo delle belle porcherie con fbdev, i driver proprietari non la servono e nouveau non so perché non funziona bene come prima.

Ritratto di 500paolo
Offline
Last seen: 9 mesi 3 giorni fa
Iscritto: 16/12/2011 - 10:52

Ho provato anche a scaricare i drv dal sito amd (ora sono legacy) ma al momento dell'installazione ci sono problemi con files/librerie non presenti nel sistema o in cartelle errate e il kernel pae non gli va a genio.
Dovrei avere da qualche parte una fx5600 che ha sempre funzionato con tutte le distro, domani ce la infilo, tanto per win7 la sostituzione ati-nvidia non da problemi.

Come i drv proprietari non la servono? Deve essere proprio antica (slot isa o eisa? LOL!)

Ritratto di zafran
Offline
Last seen: 6 mesi 4 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Non è databile con le solite procedure.
So solo che la strappai dalle manine di un velociraptor che ci rimase malissimo.

Ritratto di 500paolo
Offline
Last seen: 9 mesi 3 giorni fa
Iscritto: 16/12/2011 - 10:52

Risolto, sostituita la x1550 con una vecchia e rappezzata fx5600 (ho dovuto adattarci un'altra ventolina e un altro dissipatore perche' la sua non girava piu').
Cancellato da terminale l' xorg.conf, dato che nemmeno con do-vesa funzionava, dato startx ecco riapparire il mio desktop a cui poi ho potuto installare i drv nvidia col mio bel vsync attivo.

Che dire, con l'ati avevo anche "strisce virtuali" sul desktop dove i caratteri sembravano non a fuoco...W nvidia!

Ritratto di zafran
Offline
Last seen: 6 mesi 4 giorni fa
Moderatore
Iscritto: 16/06/2008 - 16:10

wow!
messo risolto