Riconoscimento lettore integrato SD-card e tasti funzione

1 contenuto / 0 new
Ritratto di ermariano
Offline
Last seen: 5 anni 7 mesi fa
Iscritto: 17/12/2007 - 17:15
Riconoscimento lettore integrato SD-card e tasti funzione

Salve.
Dopo parecchia assenza avrei alcuni nuovi quesiti da sottoporvi.
Il mio vecchio (10 anni) Acer TM 4051 è passato a miglior vita (non senza espianto di alcuni "organi" che ho conservato anche se obsoleti) Smile
Intimorito dai nuovi Bios UEFI, Secure boot e diavolerie del genere ho acquistato un Asus X551CA Free Dos, Intel dual Core, 4 G Ram e 500 G Hard Disk (che ho partizionato per farci convivere Windows7 e Linux).
Il primo disappunto l'ho avuto quando ho scoperto che il Bios non è in grado di fare il boot dal lettore integrato di schede SD (solo da USB e CD/DVD); l'ho anche aggiornato ma nulla da fare. Suggerimenti?
La cosa mi ha stupito perché in un netbook eeePC 1001HA (che ho da 4 anni) scrivo le live su SD card e le avvio normalmente dal lettore integrato che viene riconosciuto al boot.

Installato per primo W7 da DVD ho dovuto anche qui "tribolare" un po' per reperire in rete i vari driver per farlo funzionare a dovere (col vecchio Acer era tutto stranamente molto più semplice); ho avuto bisogno di installare anche un driver per il lettore integrato di SD card.
Ovviamente, non essendo un esperto, ho fatto tutto servendomi di un sito web (http://www.ma-config.com/en) che mi ha rilevato e fatto scaricare ciò di cui avevo bisogno.
Ora però sembra tutto a posto.

Con Linux, invece, sto avendo alcuni problemi - ho provato Ubuntu 13.10, Mint 16, Mint Debian 2014, PCLinuxOS (KDE e Mate), MaJoNix (Ubuntu 12.04 Mate remixata dal Majorana) e open Suse 13.1 (Gnome e KDE)-:

1. Nessuna riesce a "vedere" le SD card dal lettore integrato (vengono lette invece se inserite in un lettore esterno USB).

2. Su nessuna si riesce a disattivare (con Fn+F9) il touchpad; le altre combinazioni funzionano.

3. Solo PCLinuxOS e MaJoNix rilevano e si collegano (anche da live) alla rete WiFi; le altre non la vedono proprio (alcune segnalano che è disattivata da hardware).

Poco male: ho installato PCLinuxOs (2013.12-64-KDE), che però non mi mantiene le impostazioni dello schermo: ogni volta che lo riavvio mi va sul 4:3 (1024x768) nonostante io lo abbia impostato e salvato come predefinito su 16:9 (1366x768).
Mi piacerebbe sapere se esiste qualche pacchetto che devo scaricare per risolvere questi tre inconvenienti.
Mi rendo conto che sto scrivendo un romanzo, non ho il dono della sintesi. Se può essere utile vi posto anche qualche dato più preciso sul sistema:

[emilio@localhost ~]$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 7 Series Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5286 (rev 01)
03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 06)
[emilio@localhost ~]$ clear

[emilio@localhost ~]$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b404 Chicony Electronics Co., Ltd
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 003 Device 002: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[emilio@localhost ~]$

Non so se possano servire a qualche cosa (relativamente ai problemi in questione).
Un cordiale saluto a tutti.