Problema rete wi-fi e...

24 contenuti / 0 new
Ultimo contenuto
Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37
Problema rete wi-fi e...

Ciao a tutti...
Mi sono da poco buttato nel mondo di Linux e devo dire che mi trovo benissimo...
Tuttavia, sul mio portatile (che è un po' vecchiotto - novembre 2004) non riesco ad installare PCLinuxOS. O meglio, riesco ad installare la versione "povera di grafica".
Questo è normale? O meglio, c'è una soluzione a ciò?
Ho un PackardBell Easynote H3... Il processore è un AMD AthlonXP 3000+...
Avete suggerimenti?
Inoltre, non riconosce la mia scheda wi-fi. Ho una 3com "OfficeConnect Wireless 54Mbps PC card"...
Idee?

Grazie mille,
Samuele - lelelele85@libero.it

Ritratto di supertrack
Offline
Last seen: 6 anni 3 mesi fa
Iscritto: 27/12/2007 - 14:48

Allora una cosa alla volta! cosa vuol dire "povera di grafica"? cosa succede? e soprattutto che scheda grafica hai?
Per il wireless dovresti leggere bene sulla scheda anche il codice prodotto e la versione. La tua scheda è sicuramente compatibile, se provi a impostarla dal centro di controllo cosa ti dice? sicuramente ci vogliono i driver ndiswrapper..vedi qui nella lista http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,co...
Ciao!

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Dunque, per la scheda, adesso cerco.
Per "povero di grafica" intendo che ho dovuto lanciare l'installazione "in safe graphical mode" (o qualcosa del genere). Cioè, non la prima ma la seconda.
La scheda grafica che ho è quella che c'era nel PC... E' una "VIA KN400"...

Grazie ancora per l'aiuto,
Samuele.

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Sono di nuovo io...
La mia scheda è, dalla tua lista, la 6...
Se ho capito bene, mi dice che dovrebbe trovare i driver quando installo PCLinuxOS, giusto?
Ma, a quanto pare, non mi ha installato una mazza... Perché mi dice che non trova alcun hardware, quando provo a lanciare l'installazione... Boh... I will try again...
Oppure, domandone del secolo, posso installare i pacchetti che mi dice all'ultima riga della descrizione della 6???
Già che ci sono, altre 2 domande:
1. come faccio ad installare i pacchetti rpm che scarico?
2. come faccio a far funzionare googleearth, dato che mi dice che non posso, non avendo una risoluzione di almeno 1024x768 pixel?

Grazie infinite,
Samuele.

Ritratto di supertrack
Offline
Last seen: 6 anni 3 mesi fa
Iscritto: 27/12/2007 - 14:48

Allora per la tua scheda allora è una openchrome. esegui queste operazioni. apri synaptic e aggiorna il sistema all'ultima versione come spiegato in questa guida http://linux.p2pforum.it/wiki/Guida_all%27installazione_di_Pclinuxos_200...
così gia che ci sei metti tutto in italiano se non l'hai già fatto....una volta fatto questo con il tasto cerca in synaptic cerca "openchrome". il pacchetto si chiama "x11-driver-video-openchrome". Una volta installato vai nel centro di controllo, hardware, set uo graphical system e in cards seleziona openchrome with 3d effects. Dai ok, imposta la risoluzione e il gioco è fatto. I pacchetti rpm non li devi installare a mano, quando hai bisogno di un programma apri synaptic e cercalo. c'è anche googleearh!
Se hai una connessione ethernet fai così e poi installiamo la scheda wireless..se no devi andare nel centro di controllo (quella con cacciavite e chiave) poi networking, "set up a network interface" e poi selezioni wireless.il firmware della tua scheda è già installato! ciao!

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Comunque gli rpm che scarichi dalla rete si installano con kpackage (da installare con synaptic)

Ritratto di supertrack
Offline
Last seen: 6 anni 3 mesi fa
Iscritto: 27/12/2007 - 14:48

oppure da konsole "rpm -ivh nomepacchetto.rpm". Però ricordati che se un pacchetto lo trovi già in synaptic è sempre meglio..

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Grazie a tutti per l'aiuto.
Ma avrei un'altra domanda: la mia scheda wi-fi non c'è... Mi spiego: quando apro l'"Administration Center" e poi vado su "Network and Internet" e poi "Wireless connection" mi dice "No device found"...
Alternative?

Grazie ancora,
Samuele.

Ritratto di supertrack
Offline
Last seen: 6 anni 3 mesi fa
Iscritto: 27/12/2007 - 14:48

Si, aggiorna il kernel...apri synaptic, cerca kernel, e poi installa l'ultimo kernel-2.6.22-tex2 mi sembra...però devi avere una connessione ethernet...

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Tornando al problema della scheda video, ho fatto come mi avete consigliato, ma adesso non riparte più PXLinuxOS nel senso che fa per avviarsi regolarmente, ma poi diventa tutto nero.
Soluzioni a questo problema?

Grazie ancora,
SZ

Ritratto di supertrack
Offline
Last seen: 6 anni 3 mesi fa
Iscritto: 27/12/2007 - 14:48

Avvia la live come root, entra nell''hard disk dove hai installato pclinuxos, entra nella cartella etc, poi in X11, rinomina il file xorg.conf con un nome a caso, per esempio xorg.conf.1, mentre rinomina il file xorg.conf.old in xorg.conf. Poi se hai ancora voglia rinomina il primo file modificato xorg.conf.1 in xorg.conf.old. In questo modo hai ripristinato i vecchi driver. Tieni conto che i driver openchrome funzionano, ma solo se li ha aggiornati...hai già fatto gli aggiornamenti anche se non hai il wireless? ciao!

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Sì, ho già aggiornato tutto.
Posso chiederti un'altra cosa: mi dai il comando per rinominare un file, visto che non lo conosco?

Grazie mille,
Samuele.

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

clicchi col destro e scegli rinomina. Non c'è bisogno di comandi da console.

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

ma se avvio la live non è che mi parte in terminale???
Proverò anche questo. Comunque ho trovato anche il comando. E' mv, giusto?
Bye.

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

No, la live non parte in terminale. Come hai fatto a installare ? da terminale ? mv è giusto.

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Ah ok, adesso ho capito tutto.
Grazie mille.
Spero di riuscire a sistemare tutto.
Ma un'altra cosa: quando ho installato il Sistema Operativo, non ho potuto scegliere la prima opzione (che ad un certo punto si bloccava) bensì la terza (quella cosa VESA...)...
Vuoi dire che può dipendere da quello?
Comunque, adesso provo ad installare anche la scheda wi-fi. Ma come devo fare? E' giusto - come mi hanno suggerito qui sopra - scaricare "kernel-2.6.22-tex2" e poi cercare i dirver?
Che quando vado nel centro controllo, mi dice che non trova la scheda di rete... Boh.
Grazie ancora,
Samuele

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Per la scheda wi-fi non ti posso aiutare perché non la ho. Non devi scaricare, ma installare l'ultimo kernel che trovi su Synaptic. Non so se l'ultimo è il 22, mi sembra che è già uscito il 24. Ora sono su Vista.

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Allora, buone notizie.
Questa volta mi ha installato Openoffice, senza problemi.
Inoltre, per il kernel che mi dici, non basta che faccio un upgrade generale e mi mette lui l'ultimo disponibile?
Perché quando ho provato a cambiarlo - come mi suggeriva qualche intervento più in su un ragazzo - mi ha dato problemi del tipo che all'avvio diventava tutto nero...

Grazie ancora. ciao

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

No, il kernel non viene cambiato automaticamente, quando lo installi ti mette una nuova voce nel menu di grub per permetterti di provarlo ed eventualmente di tornare indietro..

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Ma riesci a dirmi con precisione che kernel devo installare?
Perché ho provato l'ultimo (o meglio, quello che credevo fosse l'ultimo) ma non andava una mazza...
Boh!!!

Grazie,
Samuele.

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

L'ultimo ufficiale è il 2.6.22.15.tex3, se non ti risolvesse il problema devi andare su synaptic, impostazioni, archivi pacchetti, selezionare quello già spuntato ed aggiungere nel campo sezioni la voce testing, poi OK, Ricarica e cerchi il 2.6.24.3.tex2 e lo installi. Questo è l'ultimo, ma non è ancora ufficiale.

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Fatto... Grazie mille patel per il prezioso help.
Adesso ti devo chiedere una cosa: installato il nuovo kernel (che funziona molto bene) mi rimane da capire come fare per "eliminare" il vecchio...
Cioè, basta che modifichi il grub e metta quella che adesso è l'ultima voce, per prima?

Grazie,
Samuele.

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Edita come superutente il file /boot/grub/menu.lst e aggiungi davanti alle voci del vecchio kernel il cancelletto #, così facendo non lo vedi più, ma se necessario lo puoi riattivare.

Ritratto di Gianvacca
Offline
Last seen: 10 anni 6 mesi fa
Iscritto: 27/11/2007 - 14:45

Se lo vuoi eliminare del tutto, basta che cerchi il pacchetto kernelXXXXX (dove le X stanno per il numero di versione) e lo marchi per la disinstallazione.