Non trovo il modo di abilitare l'accelerazione hardware.

23 contenuti / 0 new
Ultimo contenuto
Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07
Non trovo il modo di abilitare l'accelerazione hardware.
AllegatoDimensione
Image icon graphic-card.png37.58 KB

Vi scrivo dal mio PCLOS portatitle..sta tutto nella pennetta usb da 8 giga e funziona meravigliosamente. Poco fa ho modificato la risoluzione dello schermo. Quando il sistema mi ha chiesto di confermare il setting, ho visto che l'accelerazione grafica era disabilitata. La scheda video e' una semplice intel 810+, ma l'accelerazione dovrebbe esserci.

Ho provato a vedere nelle opzioni della scheda grafica, ma mi presenta solo le opzioni nell'immagine allegata.

Consigli?

Ciao,

Manuel

Ritratto di monsee
Offline
Last seen: 1 mese 2 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Vai a spulciare partendo dal Menu principale:
Menu/Altri programmi/Configurazione/Configure Your Computer
dovrai dare la password di ROOT
... poi si aprirà il Centro di Controllo di PClinuxOS.
Ivi, clicca su Hardware.
Nella finestra che appare, vedrai (fra le varie altre) due icone. Una è quella che afferisce al configurare gli effetti 3D al desktop. L'altra afferisce alla configurazione della Card Video: mi par che sia in quest'ultima che potrai spuntare l'opzione relativa all'accelerazione hardware che desideri (dovrai cliccar su "Opzioni", quando apparirà, naturalmente).

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

E' quello che avevo fatto. Ma le "Opzioni" sono solo quelle mostrate nell'immagine allegata al primo post. Quindi non so come procedere. Non vorrei mettere le mani sul file di configurazione di x.

Ciao e grazie,

Manuel

Ritratto di ernstfree
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 09/08/2011 - 16:02

Ma da centro di controllo, che driver stai usando?

Ernst

Ritratto di monsee
Offline
Last seen: 1 mese 2 settimane fa
Moderatore
Iscritto: 16/09/2009 - 12:34

Il Centro di Controllo di PClinuxOS, naturalmente. Lo trovi denominato: "Configure Your Computer". Cercalo, c'è di sicuro. In quanto alla domanda che m'hai fatto riguardo al Driver, non mi è chiaro cosa tu voglia sapere. Se me lo dici, risponderò di certo. Grazie.

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

ernstfree wrote:
Ma da centro di controllo, che driver stai usando?

Ernst

Da Control center-> hardware-> Configure graphics -> configure video card

mi dice

Graphic card: intel 810 or later

Che credo sia giusto (controllero' poi da Windows).

Ciao,

Manuel

Ritratto di ernstfree
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 09/08/2011 - 16:02

Infatti, mi sembra corretto .... molto molto strano ...
potresti:
- verificare se quella risoluzione è gestita correttamente ... (forse sei oltre la max ...) ..
- se tutto OK, avviare un "liveCD" corrispondente e vedere se funziona. Se si, guardare i driver presenti e le impostazioni (e copiare) ...
- eventualmente (ma non mi assumo responsabilità!), io farei un tentativo stupido ma che a volte può funzionare ...
Prova a mettere driver xorg 2d generici di base, es. xorg intel, mesa, ecc...... (controlla che vadano!), poi riavvii, ... rimetti i driver giusti intel e riavvii di nuovo ... in casi estremi hai sempre il comando da console "XFdrake" e rimetti tutto a posto.
Qualche volta funziona ... La mia paura è che tu stia lavorando con più pacchetti non coordinati per i driver che ti servono (io uso gli stessi driver ed è tutto OK ... però ho una intel hd ...).

PS: se qualcuno ha la stessa scheda grafica di Manuel, ci dica come gli funziona!

Ernst

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

Non credo di essere oltre la risoluzione massima. E' una risoluzione comune per uno schemo da 17 pollici ed e' la stessa che uso, sullo stesso PC, in windows. Ad ogni modo..come faccio a verificare che la risoluzione e' gestita correttamente...?

Ho invece notato che ci sono altri che hanno avuto problemi simili:

http://www.pclinuxos.com/forum/index.php?topic=87324.0

Ma ho un dubbio...mi trovo in questo momento su un altro PC, ma sempre con PCLOS (ma qui installato su HD, non su pennetta). Ho modificato un dettaglio della scheda video, ed anche qui mi ha detto, nel messaggio di conferma del setting, che non ho accelerazione video.
Ma mi e' parso molto strano, perche' uso parecchio la grafica 3d e non ho notato rallentamenti.
Per fare la prova ho lanciato gfxinfo, che mi ha confermato di avere installati i driver giusti con direct acceleration enabled. Quindi, almeno su questo PC, NON E' VERO che non ho accelerazione hardware.

Vuoi vedere che e' un problema di detect della finestra del control center?

Credo che sia da escludere che glxinfo mi dia dei dati sbagliati. Domani provo glxinfo anche sul PC incriminato e vediamo i risultati.

Ciao,

Manuel

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

Eh si..verificato anche su questo secondo PC. Il messaggio della conferma del setting dal Control Center dice che non c'e' accelerazione grafica, ma glxinfo dice il contrario. Quindi probabilmente il messaggio del control center e' sbagliato.

Vi incollo le prime righe di glxinfo output:

-------------------------------
name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_INTEL_swap_event
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, etc... etc....
etc....
--------------------

Tutto l'output sta qui:
http://pastebin.com/QU32rd9T

Ci sono altre controprove che vi vengono in mente per verificare l'accelerazione?

Ritratto di ernstfree
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 09/08/2011 - 16:02

Io, dopo i classici comandi, sperimento sempre qualche applicativo del quale ho dei parametri di confronto, es.
- funzioni 3d di kde (non so se usi kde)
- salvaschermo (faccio misurare gli fps)
- supertuxkart (metto il massimo di veicoli possibile (n.19) e vedo che tutto sia fluido).
Per il 2d: due o tre filmati in contemporanea in fullHD ....
So che sono banalità, ma possono dare un'idea di coordinamento delle varie funzioni del desktop.

Ernst

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

Per un benchmark piu' appropriato ho scoperto che esiste il comando specifico: glxgears.
Fa partire un demo opengl. Se lanciato con l'opzione -info di tice anche tutte le estensioni opengl abilitate, e poi lasciandolo girare per qualche secondo ti fornisce un elenco dei framerate. Con la vecchia scheda grafica intel G41 che ho qui, ottengo questi risultati:

301 frames in 5.0 seconds = 60.108 FPS
301 frames in 5.0 seconds = 60.019 FPS
301 frames in 5.0 seconds = 60.018 FPS
301 frames in 5.0 seconds = 60.021 FPS
301 frames in 5.0 seconds = 60.019 FPS
301 frames in 5.0 seconds = 60.021 FPS
301 frames in 5.0 seconds = 60.020 FPS

Giusto per avere un idea, tu che risultati hai?

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

Questi invece i valori che ottengo con il PC di casa, quello che ha installato PCLOS come sistema stabile su HD, e che ha una nvidia. Anche in questo caso glxinfo dice che il DRI e' attivo, ma lo strumento di control center dice di no:

17765 frames in 5.0 seconds = 3552.993 FPS
18982 frames in 5.0 seconds = 3796.335 FPS
19145 frames in 5.0 seconds = 3828.940 FPS
19122 frames in 5.0 seconds = 3824.276 FPS
19142 frames in 5.0 seconds = 3828.340 FPS
19143 frames in 5.0 seconds = 3828.437 FPS

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

Manuel . wrote:
Per un benchmark piu' appropriato ho scoperto che esiste il comando specifico: glxgears.
Fa partire un demo opengl. Se lanciato con l'opzione -info di tice anche tutte le estensioni opengl abilitate, e poi lasciandolo girare per qualche secondo ti fornisce un elenco dei framerate. Con la vecchia scheda grafica intel G41 che ho qui, ottengo questi risultati:

301 frames in 5.0 seconds = 60.108 FPS
301 frames in 5.0 seconds = 60.019 FPS
301 frames in 5.0 seconds = 60.018 FPS
301 frames in 5.0 seconds = 60.021 FPS
301 frames in 5.0 seconds = 60.019 FPS
301 frames in 5.0 seconds = 60.021 FPS
301 frames in 5.0 seconds = 60.020 FPS

Giusto per avere un idea, tu che risultati hai?

Mhhh..pero' asp..gfxgears -info mi avverte che a causa di vsync gli fps saranno simili al refresh del monitor...quindi forse puo' andare piu' veloce...

Ritratto di ernstfree
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 09/08/2011 - 16:02

Certo, pensavo tu conoscessi già il comando glxgears ...
Io comunque non ho mai ben campito la cosa ... perchè, questo è il mio risulato con attivato il desktop3D e con gli ingranaggi a pieno schermo ...

291 frames in 5.0 seconds = 58.118 FPS
299 frames in 5.0 seconds = 59.779 FPS
288 frames in 5.0 seconds = 57.318 FPS
291 frames in 5.0 seconds = 58.068 FPS
299 frames in 5.0 seconds = 59.777 FPS
299 frames in 5.0 seconds = 59.791 FPS
299 frames in 5.0 seconds = 59.772 FPS

e questo con il 3d disattivato:

284 frames in 5.0 seconds = 56.689 FPS
265 frames in 5.0 seconds = 52.964 FPS
296 frames in 5.0 seconds = 59.014 FPS
298 frames in 5.0 seconds = 59.586 FPS
299 frames in 5.0 seconds = 59.786 FPS
299 frames in 5.0 seconds = 59.786 FPS
299 frames in 5.0 seconds = 59.785 FPS

Ti assicuro che l'openGL e applicazioni 3D in generale vanno benissimo!
mah .... per questo uso banali applicativi 3D per verificare la potenza della scheda ...

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

Ciao.
Non ho letto tutti i messaggi, ma forse ho capito il problema.
Da quel che ho letto nel tuo primo post, tu hai scheda Intel.
In effetti dovrebbe esserci un gravissimo bug nell' opengl sulle schede intel nel kernel linux da 2 anni o più a questa parte.
Io ti posso dire che da quando ho preso questo nuovo pc con grafica Intel, non riesco a far funzionare uno screensaver 3d in maniera decente ed effetti 3d a tutto schermo.
Il problema me lo sto portando dalla Lince Lucida di Ubuntu fino ad oggi che ho installato anche pclinuxos.
Infatti ho scritto anche qui un mio problema su scheda intel:
http://www.pclinuxos.it/node/1243
oppure su launchpad il bug dell'intel:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/...
Questa è una delle segnalazioni più importanti fatte, ma c'è ne sono a miriade fatte sull'argomento e penso che questo potrebbe essee anche il tuo problema.
Ciao
Francesco bat

Ritratto di Manuel .
Offline
Last seen: 7 anni 1 mese fa
Iscritto: 20/11/2011 - 16:07

@Ernst:

Si in effetti glxgear permette solo di testare se le opengl vanno, ma non e' un vero e proprio benchmark:
http://wiki.cchtml.com/index.php/Glxgears_is_not_a_Benchmark

Non conoscevo questo comando perche' con le mie Nvidia non ho avuto mai problemi Blum 3
Questa e' la prima volta che mi tocca smanettare, per via del fatto che ho a che fare con una intel...
Quindi hai ragione, bisognerebbe testare con qualche gioco..ma supertuxkart richiede 100 e rotti mega..e stiamo parlando di un PClos portatile su pennetta USB...
Come fai a fargli stampare i framerate?

@Francesco

Non si tratta di problemi cosi' evidenti..ma solo del fatto che il control center mi dice che non ho l'accelerazione hardware, mentre al contrario, glxinfo dice di si.

Il problema del control center che contraddice gfxinfo mi succedeva anche sul PC con la nvidia, ma ho risolto inserendo:

load "gfx"

in xorg.conf

Per intel pero' la cosa non ha funzionato...

Ciao e grazie!!

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

Infatti, è un mezzo caos !
Ora gli screensaver mi funzionano (disattivando kscreensaver e attivando xscreensaver), ma non sono sicuro ancora al 100% per quelli opengl.
Pixelcity.scr continua a farmi il difetto citato.
Invece ho provato a installare supertux2, al primo avvio, come ho messo a tutto schermo, sono finito alla schermata login.
Dopo l'ho rieseguito a tutto schermo ed è andato benissimo.
A questo punto non ci capisco più niente e non so se il bug delle schede intel alcune distro reagiscono diversamente, oppure in questo caso non si tratta di bug ma di un altro problema.
Ciao
Francesco bat

Ritratto di ernstfree
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 09/08/2011 - 16:02

Manuel . wrote:
@Ernst:

Quindi hai ragione, bisognerebbe testare con qualche gioco..ma supertuxkart richiede 100 e rotti mega..e stiamo parlando di un PClos portatile su pennetta USB...
Come fai a fargli stampare i framerate?

Banale "glxgears" e dovresti più o meno avere questo output:

Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
292 frames in 5.0 seconds = 58.336 FPS
299 frames in 5.0 seconds = 59.788 FPS
299 frames in 5.0 seconds = 59.782 FPS
299 frames in 5.0 seconds = 59.789 FPS

Altre soluzioni per testare il 3D: "extreme tux racer", lo stesso "google earth", ecc....
Facci sapere!

hellraiser (non verificato)
Ritratto di hellraiser

da quel che so le schede viodeo intel danno problemi con linux, ad ogni modo sul forum di archlinux.it suggeriscono di usare questa configurazione nel file xorg.conf


Section "Device"
Identifier "Intel Corporation 82852/855GM Integrated Graphics"
Driver "i810"
# Option "AddARGBGLXVisuals" "On"
Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"
Option "UseFBDev" "true"
EndSection

ad ogni modo pare sia un problema di driver, infatti parlano di un pacchetto relativo al suddetto chiamato xf86-video-i810

tratto da: http://www.archlinux.it/forum/viewtopic.php?id=1387

potresti provare a vedere se ci sia il driver che ti interessa dal sito della intel:
http://www.intel.com/support/graphics/sb/cs-010512.htm

opppure da qua:
http://intellinuxgraphics.org/index.html
che come dice la stessa intel è un sito di terze parti, non riconducibile a loro. Spero che per qunato poco, ti sia stato utile Wink

p.s. un ultima cosa, e mi rivolgo a me stesso e a tutti gli utenti del forum: sarebbe meglio creare topic più specifici e "che vadano al sodo" credo, cosicchè noi si abbia maggior comodità nell'usare il forum, es. creare un topic chiamato, ad es:

"non trovo il modo di abilitare accelerazione hardware scheda video intel 810"

ma è solo il mio modestissimissimo parere personale Smile vi prego non ne abbiate a male Smile

Ritratto di 500paolo
Offline
Last seen: 9 mesi 4 settimane fa
Iscritto: 16/12/2011 - 10:52

Ancora non c'e' soluzione, le schede intel hanno accelerazione 3d ma il minimo indispensabile e disponibile solo per Win (e anche lì...certe delusioni!)

Il solo portatile equipaggiato con tale abominio l'ho sostituito immediatamente e mi sono convinto di aver fatto una c...ta per risparmiare qualcosina.
Mentre per le schede madri dei fissi con questo tipo di grafica ho disabilitato questa da bios e ho aggiunto anche la peggior nvidia a disposizione e ho scoperto come avere la felicita' su sistemi open:

Niente di diverso da Nvidia, nemmeno Ati.

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

500paolo wrote:
Ancora non c'e' soluzione, le schede intel hanno accelerazione 3d ma il minimo indispensabile e disponibile solo per Win (e anche lì...certe delusioni!)

Il solo portatile equipaggiato con tale abominio l'ho sostituito immediatamente e mi sono convinto di aver fatto una c...ta per risparmiare qualcosina.
Mentre per le schede madri dei fissi con questo tipo di grafica ho disabilitato questa da bios e ho aggiunto anche la peggior nvidia a disposizione e ho scoperto come avere la felicita' su sistemi open:

Niente di diverso da Nvidia, nemmeno Ati.

Guarda, io ti dico che sono sottoscritto su launchpad da 2 anni sul bug dell'intel e dopo tutta questa attesa continua a non funzionare.
Ogni versione di Ubuntu faceva un comportamento diverso con il 3d a tutto schermo, vengo su pclinuxos e stessa storia.
Tenendo conto della durata di questo problema non ancora risolto qualcuno ha addirittura fatto richiesta di far specificare che Linux non supporta più l'intel Sad
Io per ora ho risolto parzialmente il problema.
A me piaceva vedere gli effetti grafici di Clementine a tutto schermo (quelli di ProjectM), ma se vedi c'è un opzione che lo si può massimizzare quasi a tutto schermo; questo fortunatamente non incide sul funzionamento del sistema perchè si blocca solo a schermo intero (la finestra massimizzata occupa quasi tutto lo schermo, quindi la differenza è irrisoria).
Lo stesso con degli screensavers che volevo far partire io (Pixelcity, skyrockets) con il wine.
Ho semplicemente creato uno scriptino di esecuzione di quei screensaver e con il wine gli ho impostato l'esecuzione di questi a modalità schermo grande ma non intero; così non mi si bloccano.
Certo un idea di una mitica Nvidia non mi dispiacerebbe più in avanti.
Io ho la possibilità di inserirla insieme a quella dell'intel e far stabilire al bios quale rendere la predefinita.
Magari tra un pò ci farei un pensierino.
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Last seen: 9 mesi 4 settimane fa
Iscritto: 16/12/2011 - 10:52

Io invece non ho mai cercato gli effetti speciali, mi bastava e mi basta tutt'ora poter utilizzare compiz su gnome per non avere quel fastidiosissimo scaling (non so se chiamarlo così o aliasing) nei video che ho nel pc e nei video di youtube a tutto schermo.

L'unico modo che ho trovato per eliminarlo e' abilitare il v-sync su compiz, ma questo deve funzionre sulla scheda video e per le intel non mi ha mai funzionato...per le Ati quasi sempre freezing improvvisi e immotivati.

Per kde la storia e' piu' semplice dato che e' piu' flessibile, non necessita di compiz, e' dotato di suo compositor, ha la possibilita' di attivare il sincronismo e di non escludere la composizione delle finestre a schermo intero così da vedere fluidamente anche i video di youtube.

Ritratto di francesco bat
Offline
Last seen: 2 mesi 1 settimana fa
Iscritto: 20/11/2011 - 02:46

500paolo wrote:
Io invece non ho mai cercato gli effetti speciali, mi bastava e mi basta tutt'ora poter utilizzare compiz su gnome per non avere quel fastidiosissimo scaling (non so se chiamarlo così o aliasing) nei video che ho nel pc e nei video di youtube a tutto schermo.

L'unico modo che ho trovato per eliminarlo e' abilitare il v-sync su compiz, ma questo deve funzionre sulla scheda video e per le intel non mi ha mai funzionato...per le Ati quasi sempre freezing improvvisi e immotivati.

Per kde la storia e' piu' semplice dato che e' piu' flessibile, non necessita di compiz, e' dotato di suo compositor, ha la possibilita' di attivare il sincronismo e di non escludere la composizione delle finestre a schermo intero così da vedere fluidamente anche i video di youtube.

Con i video di Youtube e filmati multimediali a tutto schermo non ci sono problemi.
Il problema è solo per il 3d.
Infatti i screensaver classici di xscreensaver (non 3d), si avviano senza problemi e blocchi di sistema compreso film o eventuali giochi a tutto schermo che non sfruttano il 3D.
Ciao
Francesco bat