installazione usb-stick wireless US MaxG

10 contenuti / 0 new
Ultimo contenuto
Ritratto di sacarde
Offline
Last seen: 11 anni 8 mesi fa
Iscritto: 29/01/2008 - 11:48
installazione usb-stick wireless US MaxG

ciao,
stavo cercando di installare mla penna wireless USrobotics MaxG su pxlinuxos...

su altre distribuzioni gia' mi funziona... quindi ho cercato di installarla come funziona..

-scaricato i driver di windows
-installato ndiswrapper
-caricato il driver

ma l'ultimo passo: echo 1 > /sys/.......
non mi attiva la periferica

in genere si accende il led di xomunicazione sopra la chiavetta, e quirimane spento, quindi non si crea il dispositivo wlan0

avete qualche suggerimento ?

grazie

Ritratto di Gianvacca
Offline
Last seen: 10 anni 4 mesi fa
Iscritto: 27/11/2007 - 14:45

Oggi, pochi minuti fa, per la prima volta sono riuscito a far funzionare la mia Wireless USB N1 della Belkin. Spero che il mio successo diventi anche tuo.

Vai sul sito di ndiswrapper e scarica il file tar
ndiswrapper-1.51.tar.gz

Scompattalo dove vuoi. Io l'ho fatto in /root/

Disinstalla l'ndiswrapper di PCLOS e poi andando nella cartella dove hai scompattato i file per precauzione lancia

make uninstall

dopo lancia

make install

A questo punto controlla se in /etc/ndiswrapper sono rimasti ancora i driver caricati in precedenza con

ndiswrapper -l

se ci sono, rimuovili con

ndiswrapper -r nome

poi li reinstalli con

ndiswrapper -i nome.inf

se è necessario anche il firmware (.bin .cat) e in etc/ndiswrapper/ non li ha messi automaticamente, copiaceli tu.

a questo punto lancia

modprobe ndiswrapper

e poi controlla che la nuova interfaccia di rete sia presente con

iwconfig

se è presente, è andato tutto bene e poi puoi configurarla meglio attraverso il pannello di controllo.

In bocca al lupo.

Ritratto di sacarde
Offline
Last seen: 11 anni 8 mesi fa
Iscritto: 29/01/2008 - 11:48

ho disinstallato il vecchio ndiswrapper e installato quello nuovo

caricari i driver ---> tutto OK
modprobe ndiswrapper --> OK

echo 1 > /sys/....bus dell'usb

ma la luce sulla penna non si accende

ho anche aggiunto la regola udev (come da istruzioni sito ndiswrapper) ma niente da fare

Ritratto di Gianvacca
Offline
Last seen: 10 anni 4 mesi fa
Iscritto: 27/11/2007 - 14:45

Io una volta fatto

modprobe ndiswrapper

potevo vedere già l'interfaccia wlan0 attraverso iwconfig

Tu?

Ritratto di sacarde
Offline
Last seen: 11 anni 8 mesi fa
Iscritto: 29/01/2008 - 11:48

no, anche sulle altre distribuzione che funziona...

vedo il dispositivo wlan0 solo quando faccio

echo 1 > /sys.... sul bus dell'usb

o a mano o tramite udev

Ritratto di Gianvacca
Offline
Last seen: 10 anni 4 mesi fa
Iscritto: 27/11/2007 - 14:45

Allora non so aiutarti, mi dispiace. Prova a chiedere sul forum internazionale.

Ritratto di supertrack
Offline
Last seen: 6 anni 1 mese fa
Iscritto: 27/12/2007 - 14:48

scusate..ma perchè non fate tutto dal centro di controllo??

Ritratto di sacarde
Offline
Last seen: 11 anni 8 mesi fa
Iscritto: 29/01/2008 - 11:48

ho provato anche da li...

e chiaramente da: unable to find ndiswrapper interface

finche non funziona l'istruzione "echo 1 > /sys......"

sara' difficile che vada

Ritratto di sacarde
Offline
Last seen: 11 anni 8 mesi fa
Iscritto: 29/01/2008 - 11:48

ho aggiornato il sistema installando pclinuxos MiniMe
kernel 2.6.22

e la stessa procedura con gli stessi driver adesso funziona

OK!!!

Ritratto di Gianvacca
Offline
Last seen: 10 anni 4 mesi fa
Iscritto: 27/11/2007 - 14:45

Ciò fa ben sperare per il riconoscimento e la gestione hardware di PCLOS 2008. Bene!