installazione Driver Touch screen (touchkit) sono esasperato

18 contenuti / 0 new
Ultimo contenuto
Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05
installazione Driver Touch screen (touchkit) sono esasperato

salve sto cercando di costruire un minuscolo PC per il mio camper con un monitor touchsreeen, ma non riesco ad installarne i driver.
Ovviamente i drivers specifici per pclos non ci sono per cui sto provando con varie release per mandriva.
Sul cd originale dello schermo con touchscreen ci sono i sorgenti del driver ma non ci ho capito niente su come installarli, poi nella guida fa riferimento ad uno script di installazione automatica che si chiama touchkit.setup.sh da lanciare con il comando sh touchkit.setup.sh che pero' da una serie infinita di errori durante l'installazione.
Avendo qualche esperienza nella programmazione in C so che dopo un ; mancante seguono 2000 errori che sono tutti dovuti appunto al puntoevirgola mancante, quindi mi sono soffermato sui primi 3 o 4 files errori di files mancanti:
gcc -m32 -Wall -ggdb2 -I ../include -c -o 4pcal.o 4pcal.c
4pcal.c:10:22: error: X11/Xlib.h: No such file or directory
4pcal.c:11:23: error: X11/Xutil.h: No such file or directory
4pcal.c:12:21: error: X11/Xos.h: No such file or directory
4pcal.c:13:23: error: X11/Xatom.h: No such file or directory
4pcal.c:14:24: error: X11/keysym.h: No such file or directory

provando ad installare vari pacchetti a casaccio della serie x11 con synaptic ero riuscito a ad evitare gli errori ed a compilare tutto il pacchetto correttamente, ma al riavvio non partiva piu' il server grafico quindi dopo una notte insonne ho reinstallato Pclos.

Mi scuso per la pappardella che vi ho postato, ma sono oramai 3 notti che passo insonni davanti a questa cosa che e' sicuramente semplicissima per ognuno di voi ma che farebbe arrabbiare chiunque alle prime armi abituato a fare un semplice doppio click in windows per ottenere (come ho gia' fatto) il perfetto funzionamento di tutto.

VI PREGO aiuto, sono esasperato!!!!!

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Puoi postare un link ai driver?

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

si ecco il link del produttore http://www.touchkit.com/Drivers.htm
e qui ci sono anche quelli per mandriva 2005 e 2006 http://www.cartft.com/support/drivers/TFT

grazie

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Lascia stare l'rpm, io con la tarball non ho avuto alcun problema. Fai in modo di avere aggiornato totalmente la tua pclos. Se non ce li hai, poi, installa questi pacchetti:
gcc-c++
elfutils
libstdc++6-devel
libtool-base
Spacchetti il file nella tua home e da terminale dai
entri nella cartella TouchKit_x14 e dai il comando
su
[password di root]
e poi
./setup.sh
Una volta che hai installato riavviato X, in Esegui comando...
scrivi TouchKit (le maiuscole sono importanti).
Se hai problemi o ottieni errori, posta tutti i messaggi e vedrò di aiutarti. Purtroppo non ho modo di testare l'hardware

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

ti ringrazio molto, oggi provo e poi ti so dire

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

che bello, ho fatto un bell'aggiornamento della durata di 2 ore e adesso non si avvia piu'...come sono contentooo!!!
Fortuna che sono abituato ad usare ghost altrimenti c'e' da spararsi...comincio a credere che il signor gklos avesse ragione a considerare synaptic un pericolo pubblico...=)
Vabbe' ricominciamo da zero...

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

eccomi qua, ore 00:51, ho riaggiornato tutto, ora parte ma non esiste piu' firefox, e non me lo lascia reinstsallare perche' prima dovrei fissare i pacchetti rotti...li avessi rotti io poi, ma ha fatto tutto da solo...ma c'e' un modo per farglielo fare bene o va a fortuna?...per ora ci rinuncio...grazie della pazienza, io l'ho finita.

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

ah dimenticavo l'errore che mi da e' lo stesso anche dopo gli aggiornamenti e l'istallazione dei vari pacchetti
gcc-c++
elfutils
libstdc++6-devel
libtool-base

Grazie lo stesso

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Mi dispiace per la tua disavventura, ma non vorrei che tu abbia fatto qualcosa di sbagliato. Come hai fatto ad aggiornare tutto?

Ritratto di zafran
Offline
Last seen: 4 giorni 8 ore fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Lo diciamo che queso update era meglio perderlo che trovarlo?

Sul sito inglese c'è una pioggia di report di insuccessi, e infatti stanno cercando di fare uscire la iso del 2009 il prima possibile.

Forse potremmo mettere un commento (e il consiglio di copiarsi il sistema) nella documentazione. O sarà troppo tardi?

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

Be' dai, la mia pazienza segue la luna Smile
qua siete molto pazienti e gentili ed io vorrei comunque arrivarci in fondo.
Per aggiornare ho seguito alla lettera le istruzioni trovate in questo sito
http://linux.p2pforum.it/wiki/Guida_all%27installazione_di_Pclinuxos_2007
l'unica differenza sta nel fatto che sono entrato direttamente come root per cui synaptic non mi ha chiesto la password all'avvio.

Ora sto seguendo alla lettera le istruzioni di un pdf scritto in parole molto povere per installare i drivers manualmente (sulla Plos 2007 non aggiornata) e se funzionera' provvedero' a fare un salvataggio della partizione con il driver installato in modo da non doverlo rifare piu'.

Se avro' problemi Vi disturbero' nuovamente Smile

Grazie di tutto

Ritratto di zafran
Offline
Last seen: 4 giorni 8 ore fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Mi raccomando, posta i risultati.
Anche se ci spero poco: a me con synaptic morto e una serie di dipendenze irrisolvibili non si lasciano molte speranze....

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

Salve, sono alla fine riuscito ad installare il driver installando pacchetti a caso della serie x11 stando bene attento a non rimuoverne dei vecchi e creando manualmente quelle directory che non ne volevano sapere di crearsi automaticamente.
Comunque anche con il driver installato il touchscreen non viene riconosciuto cosi' ho pensato di abbandonare il progetto e di passare ad xp.

Grazie nuovamente a tutti

Arrivederci

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

Ci sono riuscitoooooo!!!

Davo per scontato che Gianvacca avesse creato una directory TouchKit_x14 scegliendo il nome lui, non avevo capito che quello derivava dal fatto che la versione di X di Plos e' la 1.4 anche perche' pur avendo usato linux anni fa non sapevo nemmeno cosa fosse una tarball e il comando SU.

Quindi ho prima dovuto imparare le basi (che faticaaaaaa!!!) nel frattempo ho cambiato almeno 10 linux.

Purtroppo nel mondo linux si da spesso per scontato che chi lo usa sia un esperto e io, essendo abituato a chiedere informazioni sentendomi rispondere da gente che si credeva un Dio in terra ho avuto il timore di chiedere cosa fosse una tarball Smile mea culpa!!

Comunque ho installato il tutto su Ubuntu e funziona perfettamente (nonostante su ubuntu l'utente root sia bloccato e le istruzioni per sbloccarlo vengano presentate solo dopo averlo sbloccato grrrrrrrrrr)

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

Ora ho bisogno ancora della vostra santa pazienza perche' dopo aver installato su pclinuxos il driver,
X non parte piu'!!!!
o meglio parte ma lo schermo rimane completamente nero e non posso fare nulla.

Potreste dirmi cominciando dall'inizio cosa devo fare per capire cosa sta succedendo prima di cercare un rimedio cercando di dare per scontato il meno possibile?

Grazie.

Premetto che non ho potuto aggiornare Pclos 2007 per i motivi sopra esposti;

se installo l'ultima 2009 uscita e' come averlo aggiornato?

Grazie di nuovo.

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

ecco svelato il mistero, con il 2009 non funziona proprio...torno alla 2007

Ritratto di Gianvacca
Offline
Last seen: 10 anni 9 mesi fa
Iscritto: 27/11/2007 - 14:45

Scusa non ho capito. Prima non hai scritto che con la 2007 non partiva il server grafico?

Ritratto di cuoredighiaccio
Offline
Last seen: 9 anni 7 mesi fa
Iscritto: 01/02/2009 - 15:05

mmm...si, hai ragione.... ma non ho avuto pazienza e l'ho sovrascritta con la 2009...mi sa che sto scrivendo troppo su questo forum rischiando di creare della confusione.

mi fermo qui, magari potete cancellare tutto, tanto non credo sia di molta utilita' cio' che ho scritto Wink

ciao a tutti
grazie