Disattivare il touchpad

13 contenuti / 0 new
Ultimo contenuto
Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37
Disattivare il touchpad

Ciao ragazzi,
avete mica idea di come possa disattivare il touchpad?
Che ogni tanto impazzisce e inizia a muoversi a mille all'ora in giro per lo schermo...

Grazie

Ritratto di supertrack
Offline
Last seen: 6 anni 3 mesi fa
Iscritto: 27/12/2007 - 14:48

Prova sistema,configurazione,kde....!

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Ma io ho installato GNOME.
Quindi, vado su Sistema/Preferenze/Mouse...
Ma non posso disabilitare il touchpad...

Ergo?

francofait (non verificato)
Ritratto di francofait

editi /etc/X11/xorg.conf e commenti tutte le parti relative alla gestione del tucopado

nella sezione loadmodule dovresti trovarci
Load "synaptix'

la commenti

senza driver sarà alquanto improbabile che continui a funzionare

poi editi /etc/modprobe.d/blacklist

ed aggiungi:

blacklist synaptix

Ma se disaattivi il toucio devi per forza usare un mouse - non che sia gran sforzo , anzi fra i due spazio permettendo rimane sempre più pratico

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Si si, ovvio... Vado di mouse.
Anche se mi par di capire che con Linux si possa fare tutto senza mouse, o no?
O meglio, anche con Winzoz si può, ma con Linux è più semplice.

Grazie, proverò il tuo consiglio!

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

# File generated by XFdrake (rev 57713)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# font server independent of the X server to render fonts.
FontPath "unix/:-1"

# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Extensions"
Option "Composite"
EndSection

Section "ServerFlags"
#DontZap # disable (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable / (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 60 Hz"
HorizSync 31.5-48.5
VertRefresh 50-70

# Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "vesa"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "SynapticsMouse1" "AlwaysCore"
Screen "screen1"
EndSection

Questo è il mio Xorg...
Ma ho provato a commentare la parte

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "SHMConfig" "on"
EndSection

ma non va una mazza...
Come faccio a disattivare il touchpad con questo xorg.conf???

Grazie,
Samuele.

Ritratto di supertrack
Offline
Last seen: 6 anni 3 mesi fa
Iscritto: 27/12/2007 - 14:48

Hai messo il # a tutte le righe??

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Section "InputDevice"
Identifier "SynapticsMouse1"
Driver "synaptics"
Option "SHMConfig" "on"
EndSection

Sì, a queste 5 righe sì... E il risultato che ho ottenuto è stato quello di non poter più utilizzare l'ambiente grafico!

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

Prova a commentare soltanto
Option "SHMConfig" "on"

hai provato dal centro di controllo del kde (kcontrol) sez. periferiche ?

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Io ho installato l'ambiente GNOME...
Comunque, quando provo nei vari "pannelli di controllo" non trovo da nessuna parte il touch pad...
Ma riproverò!
Intanto provo a commentare la riga che mi hai suggerito.
Poi ti dico!

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

prova anche con i tasti Fn F7

Ritratto di samiam1000
Offline
Last seen: 10 anni 10 mesi fa
Iscritto: 07/04/2008 - 19:37

Per disattivare il touchpad?
Da ambiente grafico vado di Fn+F7???

Provo.
Ciao grazie

Ritratto di patel
Offline
Last seen: 3 anni 6 mesi fa
Moderatore
Iscritto: 03/11/2007 - 07:31

La combinazione di tasti dipende dal tipo di notebook, guarda anche sul manuale di istruzioni.