Vmware [RISOLTO]

5 contenuti / 0 new
Ultimo contenuto
Ritratto di adrianomorselli
Offline
Last seen: 7 ore 58 min fa
Iscritto: 02/01/2015 - 12:20
Vmware [RISOLTO]

Ho installato l'ultimo vmware, avviando il programma esce un popup che mi informa che occorre installare diversi moduli (per il kernel) ma che il programma non trova gcc 7.3, peccato che io ho installato gcc 8.1 ed non e' possibile fare il downgrade perche' non esiste piu' la versione precedente sul repo. Ho provato a linkare a gcc8.1 ma non ha funzionato. Come risolvere? 

Ritratto di footstep11
Offline
Last seen: 3 settimane 6 ore fa
Iscritto: 31/01/2013 - 11:01

Potrebbe essere un problema di kernel.  Prova ad usarne uno recente e vedi cosa succede.

 

Ciao, Mauro

Ritratto di adrianomorselli
Offline
Last seen: 7 ore 58 min fa
Iscritto: 02/01/2015 - 12:20

Stesso suggerimento anche sul forum internazionale, ma purtroppo anche installando il kernel 4.9.180 l'errore rimane. Io continuo ad insistere che si' i developers di pclinuxos hanno ricostruito il kernel con gcc8.1, ma che chi ha fatto il pacchetto di vmware abbia invece utilizzato gcc 7.3 e da qui l'errore, il programma di installazione di vmware cerca un gcc che non e' piu' presente per installare i moduli necessari da inserire nel kernel. Ergo o loro ricostruiscono vmware con il nuovo gcc8.1 oppure io ricostruisco da sorgente il vecchio gcc7.3, metterlo in /opt e dare questa path per la installazione dei moduli. Non so se funzionera' visto che il kernel e' stato ricostruito con gcc8.1. Tutti questi upgrade di paxchetti, non mantenendo le vecchie versioni a diaposizione, ma cancellandole subito dai repo mi sfiniscono e non ne comprendo neppure il perche'.

Ritratto di adrianomorselli
Offline
Last seen: 7 ore 58 min fa
Iscritto: 02/01/2015 - 12:20

Ok alla fine il problema era grub2, chiaramente solo dopo un sudo update-grub dal mio SO primario ha rilevato il nuovo kernel, ed ora non mi viene più richiesto gcc7.3 ma solamente esce un pop up per installare i moduli. Per il momento non fà na mazza, ma non dispero visto che metà del problema è sparito. Smile

Ritratto di adrianomorselli
Offline
Last seen: 7 ore 58 min fa
Iscritto: 02/01/2015 - 12:20

Ho scoperto che le versioni 5.2.30 di virtualbox e superiori, compreso anche vmware 15, non supportano piu' alcune cpu. Per chi si trovasse nella mia stessa situazione occorre downgradare la versione, oppure scaricare vmware 12 da qui