[RISOLTO] oooqs2 su PCLinuxOS 2007 non funziona, ma c'è un rimedio: KDocker

15 contenuti / 0 new
Ultimo contenuto
Ritratto di yves
Offline
Last seen: 13 anni 2 giorni fa
Iscritto: 25/08/2008 - 04:52
[RISOLTO] oooqs2 su PCLinuxOS 2007 non funziona, ma c'è un rimedio: KDocker

Era l'unica cosa che mi faceva maledire il portatile con pclos installato, aspettare 5 a 7" l'apertura di un documento con OOo, oooqs2 non sono riuscito a farlo funzionare nemmeno piangendo, ho provato in tutti i modi, anche indicandogli il percorso (/usr/lib/ooo-2.3/program/soffice), ma niente, mi metto a googlare preso dalla disperazione e cado su un applicativo KDE che non conoscevo, "KDocker", installo prontamente e provo, 'na meraviglia, si apre al volo qualsiasi documento OOo :-D..

Come usarlo:

Aprite un documento vuoto Write, una volta aperto aprite KDocker (Menu K -> Sistema -> Monitoraggio -> KDocker), notate che il puntatore del mouse ha cambiato aspetto (diventa una specie di "mirino"), ora fate un semplice "click" sul bordo superiore della finestra del documento vuoto, primo passo eseguito, ora è nella taskbar, facciamo in modo che si carichi all'avvio, click DX sull'icona -> Options -> Launch on startup, vi dirà che non trova OOo, dategli il percorso:
/usr/lib/ooo-2.3/program/soffice
ed ora godetevi in pace pure OOo, finite le crisi di nervi.

Spero torni utile ad altri.

Ritratto di yves
Offline
Last seen: 13 anni 2 giorni fa
Iscritto: 25/08/2008 - 04:52

Bon, apparentemente non si salva ed al riavvio non viene caricato, quindi risolto solo a metà, ho trovato questo in rete, uno è il "man" ed il secondo su una guida Gentoo per far partire Thunderbird, s qualcuno riesce a decifrare come la si può portare su pclos sarebbe benvenuto..
http://www.linuxcertif.com/man/1/kdocker/
http://blog.mroot.net/categories/3-Gentoo-Linux
la versione installata da pclos è:
kdocker -v
Sorry, your locale is not supported. If you are interested in providing translations for your locale, contact gramakri@uiuc.edu

Qt: 3.3.8
KDocker: 1.3
non so perchè mi mostra i denti con i locale, devo per forza lasciare "utf8" e smadonnare tutte le volte che scambio file con mia moglie che usa Windows..
[yves@localhost ~]$ locale
LANG=it_IT
LC_CTYPE=it_IT
LC_NUMERIC=it_IT
LC_TIME=it_IT
LC_COLLATE=it_IT
LC_MONETARY=it_IT
LC_MESSAGES=it_IT
LC_PAPER=it_IT
LC_NAME=it_IT
LC_ADDRESS=it_IT
LC_TELEPHONE=it_IT
LC_MEASUREMENT=it_IT
LC_IDENTIFICATION=it_IT
LC_ALL=

***
Riscopri il PC, installa ed usa Linux Wink
Errare è umano, ma per fare veramente casino ci vuole la password di root..

Ritratto di zafran
Offline
Last seen: 1 anno 7 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Tanto per documentazione:
- a me oooqs2 funziona perfettamente.
- il percorso che gli ho dato è /usr/lib/ooffice2.3.
- in /usr/lib non ho subdirectory (openoffice e oooqs2 installati via apt).

------------------

Questo è il tuo locale senza utf8?
E' uguale al mio senza avere spuntato l'opzione "Codifica per vecchia compatibilità (utf8)" e anch'io mi incasino con quelli di windows.
Spunto l'opzione? Modifico a mano?

Ritratto di yves
Offline
Last seen: 13 anni 2 giorni fa
Iscritto: 25/08/2008 - 04:52

Ciao Zafran e bensentito, io le prove le ho fatte 100 volte usando pure la stringa che citi, con quella proprio non mi trova l'eseguibile, infatti se faccio click DX sull'icona e scelgo una qualsiasi delle voci del programma (Write, Math, ecc.) non si apre una cippa, aprendo il task manager vedo il processo oooqs2 che usa 32.840 in DimensioneVm, quindi è carico, ma lo stesso non va, sia OpenOffice.org che oooqs2 vengono pure i miei dai repository classici, non sono compilati, comunque mi ai incuriosito ed ho rifatto un controllo su oooqs2, e più precisamente sul file di configurazione che si trova in:
/home/yves/.kde/share/config/oooqs2rc
questi aveva un errore, appunto, nella sessione che puntava alla cartella di OOo, e più precisamente:
[Advanced]
Binary=/usr/lib/ooffice2.3
EnablePreload=true
OverrideAutodetection=true

modificando la linea dei binari (Binary=/usr/lib/ooo-2.3) ora sembra comportarsi meglio, ma non contento sono andato a vedere un pò più in la, e son capitato nella cartella:
/usr/lib/menu
dove c'è un file chiamato "oooqs2" che sembra ok, più un secondo chiamato "openoffice.org-2.3" mi da tanto l'aria di essere lui il problema del menu contestuale tasto DX sull'icona, infatti vedo questo:
?package(openoffice.org): needs=x11 section="Office/Spreadsheets" icon="ooo-calc2.3.png" title="OpenOffice.org Calc" longtitle="OpenOffice.org Spreadsheet" command="oocalc2.3" mimetypes="application/vnd.sun.xml.calc,application/vnd.sun.xml.calc.template,application/vnd.ms-excel,application/vnd.stardivision.calc,application/vnd.stardivision.chart,application/vnd.lotus-1-2-3,text/x-comma-separated-values,application/vnd.oasis.opendocument.spreadsheet,application/vnd.oasis.opendocument.spreadsheet-template" kde_opt="InitialPreference=110" xdg="true" startup_notify="true"
copio solo la prima parte relativa a Calc, l'eseguibile è quello giusto, ma sembra non andare lo stesso..
Idee?
***
Riscopri il PC, installa ed usa Linux Wink
Errare è umano, ma per fare veramente casino ci vuole la password di root..

Ritratto di zafran
Offline
Last seen: 1 anno 7 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Allora:

Non vedo differenze fra i tuoi file citati e i miei

C'è un fatto da notare:
1 - avvio kde
2 - dico a oooqs (col destro o con doppioclick) di avviare da modello
3 - mi risponde che "usr/lib/ooo-2.3/program/slot:5500 non esiste"
4 - gli dico ok
5 - torno al punto 2 e openoffice parte tranquillo e seguita a partire fino al prossimo riavvio di kde.

Lo spiritoso che cerca il mitico slot:5500 è
/usr/bin/oofromtemplate2.3
----------------------
#!/bin/sh
if [ -x /usr/lib/ooo-2.3/program/ooqstart ]; then
/usr/lib/ooo-2.3/program/ooqstart "$@"
else
exec /usr/lib/ooo-2.3/program/soffice slot:5500 "$@"
-------------------------------
che dopo essere stato eseguito la prima volta smette di dare errore le volte successive.
Boh di ooqstart non ce n'è né puzzo né bruciaticcio.

Ritratto di yves
Offline
Last seen: 13 anni 2 giorni fa
Iscritto: 25/08/2008 - 04:52

Sul mio continua a non funzionare, che sia attivo il oooqs2 o no il tempo di apertura resta sostanzialmente identico, in oltre ho provato a modificare il file:
/usr/lib/ooo-2.3/program/sofficerc
inserendo "0" a Logo per almeno disabilitare lo splash screen, be, nemmeno lui si disabilita, è dotato di vita propria questa versione di OOo..
[Bootstrap]
Logo=0
ProgressBarColor=0,0,128
ProgressSize=-1,6
ProgressPosition=-1,-1

Sono tentato di aggiornare con i repositori Testing, ho visto che è presente la versione 2.4, magari con lei ho più fortuna Sad
***
Riscopri il PC, installa ed usa Linux Wink
Errare è umano, ma per fare veramente casino ci vuole la password di root..

Ritratto di zafran
Offline
Last seen: 1 anno 7 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

NOOOOOOO !!!!!
Non lo fare !!!

Ci avevo provato anch'io perché su kubuntu e debian il passaggio da 2.3 a 2.4 aveva portato a un avvio davvero molto più rapido.
Quindi provai a passare a testing (http://www.pclinuxos.it/node/485) ma s'incasinò ogni cosa e dovetti reinstallare.
Magari tu sei più fortunato ma a me resta il dubbio cha la testing di pclos sia più testing di quella di debian.

Ritratto di yves
Offline
Last seen: 13 anni 2 giorni fa
Iscritto: 25/08/2008 - 04:52

Accipicchia, ai postato a tempo Smile
Comunque, da cosa ho capito, tu avevi modificato un repo, io direttamente ho aggiunto il secondo (identico al primo selezionato di default) ed avevo inserito solo la voce "testing": Synaptic.jpg, se marco tutti gli aggiornamenti mi indica un macello di robe ed ho il timore, visto anche cosa è successo a te, che mi si inchiodi con una qualche dipendenza non ancora aggiornata, ma la mia idea era di aggiornare solo i pacchetti openoffice.org (click DX -> aggiorna), ho comunque il timore ne manchi uno essenziale e mi vada in malora l'aggiornamento, già su Kubuntu Synaptic a volte faceva scherzi da prete..

Vedo questo weekend, sto scaricando Mandriva MIB Live (2.6 Gb) per una prova, poi decido, comunque vi terrò informati.

Ciao.
***
Riscopri il PC, installa ed usa Linux Wink
Errare è umano, ma per fare veramente casino ci vuole la password di root..

Ritratto di zafran
Offline
Last seen: 1 anno 7 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Ovviamente ognuno ha i suoi gusti e preferenze ma io mi trovo tanto bene con abiword+gnumeric visto che alla fine non gli manca nulla di quello che mi serve e sono tanto più leggeri.

Cmq credo che al pclos2008 non dovrebbe mancare tantissimo e lì il 2.4 ci dovrebbe essere di natura.
Forse qualche installazione si può evitare,

Ritratto di supertrack
Offline
Last seen: 8 anni 1 mese fa
Iscritto: 27/12/2007 - 14:48

Fai così: aggiungi testing al repository che stai usando e solo a quello. Aggiorna solo openoffice e naturalmente le sue dipendenze. A questo punto togli di nuovo testing al repository e vedi se ti trovi bene con oo aggiornato. Nel caso in cui non sia così, disinstalla oo da synaptic, fai ricarica e lo reinstalli, tornando alla versione precedente!
Ciao!

Ritratto di Gianvacca
Offline
Last seen: 12 anni 4 mesi fa
Iscritto: 27/11/2007 - 14:45

Io sconsiglio di aggiornare solo una parte dei pacchetti in testing. Aggiorna sempre tutto, o puoi avere casini colossali. Devo dire, poi, che i pacchetti in testing non mi hanno mai dato grossi problemi di instabilità.

Ritratto di yves
Offline
Last seen: 13 anni 2 giorni fa
Iscritto: 25/08/2008 - 04:52

Provato ad aggiornare (solo OOo, non sono troppo temerario Biggrin ), ma purtroppo mi son reso conto che manca una dipendenza per il pacchetto della lingua, cioè il software resta in inglese (mi son dimenticato di segnarmela Sad ) e proprio non ci penso nemmeno ad usarlo cosi.

Ho disinstallato quindi (--purge) tutto OOo 2.4.x ed ho reinstallato quello dei repo normali, nella lista ho notato che c'è un pacchetto con il nome di openoffice.org-ooqstart, non so se serve ma l'ho installato ugualmente, ho scelto di installare questi dopo aver dato un bel "locate" e levato dai piedi i pochi file di config che restavano, in particolare quelli di oooqs2:
Installed the following packages:
clipart-openclipart (0.18-4pclos2007)
oooqs2 (1.0.1-2pclos2007)
openoffice.org (2.3.1-1pclos2007)
openoffice.org-galleries (2.3.1-1pclos2007)
openoffice.org-kde (2.3.1-1pclos2007)
openoffice.org-l10n-it (2.3.1-1pclos2007)
openoffice.org-ooqstart (2.3.1-1pclos2007)

avvio quindi oooqs2 e gli dico di avviarsi all'avvio del PC, miracolo, nessun errore (non mi ha detto che non trova OOo O_O), non contento ho riavviato il portatile e si è caricato normalmente, sembra si sia messo a funzionare, forse il "colpetto" con OOo 2.4 lo ha spaventato? :P.

@Zafran: Scusami, avevo perso un pezzo, per i locale a me funzionavano, comunque poi mi son ricordato che su Kubuntu c'erano diversi file da modificare ed ho ritrovato la discussione:
http://forum.ubuntu-it.org/index.php/topic,86270.msg539882.html#msg539882
punta sul post che da la soluzione, io ho provato a modificare i due file ("/etc/environment" e "/etc/profile") come avevo fatto sulla Kubuntu ed ora il locale risulta questo:
[yves@localhost ~]$ locale
LANG=it_IT@euro
LC_CTYPE=it_IT
LC_NUMERIC=it_IT
LC_TIME=it_IT
LC_COLLATE=it_IT
LC_MONETARY=it_IT
LC_MESSAGES=it_IT
LC_PAPER=it_IT
LC_NAME=it_IT
LC_ADDRESS=it_IT
LC_TELEPHONE=it_IT
LC_MEASUREMENT=it_IT
LC_IDENTIFICATION=it_IT
LC_ALL=

(nota la prima linea dopo il comando), già prima mi funzionavano, non sto parlando di font ma di accenti e caratteri strambi, ora non mi fanno più disperare, comunque mia moglie li apre con OOo per Windows, con M$ Office la formattazione il più delle volte se ne và allegramente a merenda Smile
***
Riscopri il PC, installa ed usa Linux Wink
Errare è umano, ma per fare veramente casino ci vuole la password di root..

Ritratto di zafran
Offline
Last seen: 1 anno 7 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

@ OOo
Evidentemente non solo windows gode di eventi incomprensibili.
La prendiamo come un'opzione che il pinguino offre ai trasmigratori per sentirsi a casa.

@ Questo è il locale
-------------
[effe@localhost ~]$ locale
LANG=it_IT
LC_CTYPE=it_IT
LC_NUMERIC=it_IT
LC_TIME=it_IT
LC_COLLATE=it_IT
LC_MONETARY=it_IT
LC_MESSAGES=it_IT
LC_PAPER=it_IT
LC_NAME=it_IT
LC_ADDRESS=it_IT
LC_TELEPHONE=it_IT
LC_MEASUREMENT=it_IT
LC_IDENTIFICATION=it_IT
LC_ALL=
--------------------------------
Ben nascosta nel PCLOS ControlCenter si trova la "Codifica per vecchia compatibilità (utf8)" che ora ho spuntato.
Avendo i browser e thunderbird impostati per iso8815 devo dire che funziona 'quasi' sempre tutto ma qualche volta per una mail ricevuta devo girare a utf8.
Perché?
Non potrebbero mettersi daccordo? ... Si, si mi sa che la risposta la so già ....

Ritratto di yves
Offline
Last seen: 13 anni 2 giorni fa
Iscritto: 25/08/2008 - 04:52

Si, e per fortuna che OOo crea direttamente documenti PDF senza fatica (e in quel formato li possono aprire su qualsiasi architettura e/o Sistema Operativo), quando devo inviare qualcosa e voglio essere sicuro lo invio direttamente in quel formato, meno grattacapi, comunque mi è già successo di ricevere in visione (per approvazione) immagini in formato Corel Draw ("*.cdr") o Photoshop ("*.psd"), per fargli capire che le devono prima convertire in un formato più "cristiano" e poi inviarmele non è sempre evidente, a loro avviso son software che hanno "tutti o quasi", dovrò installarne uno per correggere gli occhi rossi delle foto (magari su Wine Smile ), blerk! nemmeno morto...

Ciao.
***
Riscopri il PC, installa ed usa Linux Wink
Errare è umano, ma per fare veramente casino ci vuole la password di root..

Ritratto di zafran
Offline
Last seen: 1 anno 7 mesi fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Non vorrei dire stronzerie ma visto che gimp salva e riapre anche in .psd immagino che li sappia aprire con una buona approssimazione all'originale anche se fatti da photoshop.

Comunque IrfanView sotto wine non perde un colpo (e ha un batch grafico a differenza di ImageMagick).

E quando ti mandano una foto embeddata in un .doc vuoto? E' successo a me.