Audio HDMI disattivo dopo aver spento la TV

4 contenuti / 0 new
Ultimo contenuto
Ritratto di terabyte
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 06/06/2013 - 21:00
Audio HDMI disattivo dopo aver spento la TV

Ciao a tutti,

Sono un nuovo arrivato in questa distro. Vengo da OpenSUSE che ho abbandonato perchè non riuscivo a far funzionare l'audio HDMI.
Utilizzo questo notebook unicamente con la TV, quindi è essenziale per me utilizzare l'audio HDMI.
Dopo aver provato diverse distro ho subito installato questa perchè l'audio HDMI ha subioto funzionato senza problemi. Il giorno dopo però l'audio non funzionava più e dopo diverse prove ho capito che se accendo il notebook con la tv accesa l'audio funziona, se la spengo e la riaccendo l'audio non funziona più.
Questo è un grosso problema poichè ho intenzione di non spegnere mai questo computer se non per eventi eccezionali, e doverlo riavviare ogni volta che ho bisogno dell'audio mi sembre oltremodo fastidioso.

Quindi mi rivolgo a voi che senza dubbio siete più esperti di me, qualche suggerimento per evitare la disattivazione dell'audio HDMI? Anche un metodo veloce (magari da terminale) per riattivarlo va bene, mi accontenterei Smile

Qualche info aggiuntiva, sheda video è un ATI Radeon e ho installato pulseaudio seguendo questo thread:
http://www.pclinuxos.com/forum/index.php?topic=83740.0

$ lspci | grep ATI
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series]
02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Redwood HDMI Audio [Radeon HD 5000 Series]

$ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.

Ritratto di zafran
Offline
Last seen: 6 mesi 1 settimana fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Boh.
Ipotesi di lavoro: se il dialogo fra tv e pc riprende riaccendendo il pc a tv accesa, potrebbe essere lo stesso se invece del pc accendi solo pulseaudio.
Quindi disabilitare pulseaudio a fine utilizzo in modo da poterlo riabilitare con tv già accesa la volta dopo.
Se ho ben capito è un demone e comunque so che lo puoi controllare da riga di comando; quindi, se la strada fosse giusta, basterebbe studiarsi due stringhe da lanciare con un semplice alias o farne due script da lanciare con due bottoni dal desktop.

Ritratto di terabyte
Offline
Last seen: 2 anni 10 mesi fa
Iscritto: 06/06/2013 - 21:00

Grazie per l'idea ma purtroppo pulseaudio non è fatto per essere disabilitato a piacimento:

# pulse-enable
Pulse Audio has been enabled. Please reboot your system now.

Probabilmente è anche il motivo per cui devo riavviare per riavere l'audio HDMI.

Ritratto di zafran
Offline
Last seen: 6 mesi 1 settimana fa
Moderatore
Iscritto: 16/06/2008 - 16:10

Hum
Cercare su quale dev viene indirizzato il servizio e vedere se si riesce a modificare l'indirizzo con un /dev/null?
Potrebbe essere una rule per udev.

MI spiace ma... solo ipotesi di lavoro, spero possano essere utili.