Un altro problema di aggiornamento

10 posts / 0 new
Ultimo messaggio
Ritratto di Manuel .
Offline
Joined: 20/11/2011
Un altro problema di aggiornamento

Stamattina PCLOS lxde non e' riusciuto a fare l'aggiornamento in automatico.
Quindi ho aperto Synaptic per farlo a mano. Procedo al reload, segno tutti i pacchetti da aggiornare...ma poi mi esce questo messaggio:

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

se provo a premere "apply" mi dice:

Could not apply changes!
Fix broken packages first.

Ho googlato un po', ed ho trovato su un forum uno che suiggeriva i due comandi:

apt-get update
apt-get upgrade

Fatto, ma non si risolve nulla...

Mi date una mano?

Ritratto di Manuel .
Offline
Joined: 20/11/2011

Provando un altro comando:

apt-get dist-upgrade

ottengo:

Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Failed
The following packages have unmet dependencies:
libgegl0.2_0: Obsoletes: libgegl0.1_0 (= 0.1.6)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

devo togliere libgegl0?

Ritratto di Manuel .
Offline
Joined: 20/11/2011
Manuel . ha scritto:

Stamattina PCLOS lxde non e' riusciuto a fare l'aggiornamento in automatico.
Quindi ho aperto Synaptic per farlo a mano. Procedo al reload, segno tutti i pacchetti da aggiornare...ma poi mi esce questo messaggio:

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

se provo a premere "apply" mi dice:

Could not apply changes!
Fix broken packages first.

Ho googlato un po', ed ho trovato su un forum uno che suiggeriva i due comandi:

apt-get update
apt-get upgrade

Fatto, ma non si risolve nulla...

Mi date una mano?

Ho dimenticato di dire che dopo l'upgrade ottengo questo messaggio:

Failed to fetch http://ftp.heanet.ie/pub/pclinuxos/apt/pclinuxos/2010/RPMS.updates/libpi... 404 Not Found [IP: 193.1.193.64 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Ritratto di Rayman
Offline
Joined: 18/08/2012

Buongiorno a tutti,
sono nuovo del forum. Confermo che anche a me succede quanto scritto da Manuel. Ho provato a cambiare repository ma il risultato è identico. Ho cancellato con apt-get clean libgegl0 ma non cambia nulla.
Grazie in anticipo per i consigli!

Ritratto di Rayman
Offline
Joined: 18/08/2012

Ho smarcato da Synaptic nella sezione Personalizzato il pacchetto libgegl0.2_0 ed il resto dell'installazione è andato a buon fine. Ho poi cercato di reinstallare i due pacchetti rimanenti ma dipendono sempre dal difettoso libgegl0.2_0.
Sono profano ma a questo punto credo che il problema stia proprio in quel singolo pacchetto e non nei server

Ritratto di Lord Spectre
Offline
Joined: 15/08/2012

Cerca libgegl0.1_0 (nota 1 al posto di 2) e se c'è rimuovilo, poi installa il 2. Così ho risolto molti problemi dell'aggiornamento di KDE, spero che funzioni anche su LXDE.

Ritratto di Manuel .
Offline
Joined: 20/11/2011

Ho risolto in questo modo:

1) Cambiato repository
2) In synaptic ho rimosso completamente il pacchetto difettoso e i software che dipendevano da lui (incluso Gimp!)
3) L'aggiornamento e' andato a buon fine
4) Ho reinstallato i software...e mi sono ritrovato con Gimp 2.8!! Magnifica sorpresa che attendevo da molto tempo!

Ritratto di monsee
Offline
Joined: 16/09/2009

Un consiglio per tutti: in PCLinuxOS EVITARE come la peste il comando:

apt-get upgrade

... tale comando rischia di creare serissimi problemi nelle dipendenze fra i pacchetti sul vostro Sistema.

Ritratto di zafran
Offline
Joined: 16/06/2008

Infatti il comando da dare dopo il canonico
apt-get update
è
apt-get dist-upgrade.

Questo perché con il solo upgrade si aggiornano esclusivamente i pacchetti già installati mentre una distro complessa e ben congegnata come pclinuxos può avere bisogno di nuovi pacchetti per mantenere i servizi già in essere e ben integrati con un panorama modificato.

Il dist-upgrade quindi si riferisce al disegno generale della distribuzione tenendola aggiornata nel suo complesso senza creare disparità di aggiornamento (e inevitabilmente di compatibilità) fra le sue parti.

Ritratto di monsee
Offline
Joined: 16/09/2009

Precisamente.