[RISOLTO] Caos aggiornamento

25 posts / 0 new
Ultimo messaggio
Ritratto di francesco bat
Offline
Joined: 20/11/2011
[RISOLTO] Caos aggiornamento

Oggi nell'aggiornamento di pclinuxos mi sono trovato questo:
libdvbpsi5
Se seleziono dal synaptic "marca tutti gli aggiornamenti", esso non viene selezionato.
Se lo seleziono io manualmente mi dice di rimuovere Vlc e una marea di libreria connesse a vlc.
Che aggiornamento è questo ?
Come vi siete comportati ?
Ciao
Francesco bat

Ritratto di francesco bat
Offline
Joined: 20/11/2011

Sto leggendo questo articolo in inglese dal forum americano di pclinuxos.
http://www.pclinuxos.com/forum/index.php/topic,105713.msg903950.html
Sembra che la libreria da aggiornare permetterebbe in futuro, dopo la rimozione del vecchio vlc, di installare dopo il nuovo vlc 2.
Il problema che sul synaptic vlc 2 non c'è ancora e rinstallare la vecchia versione dopo ti avvisa di dipendenza non soddisfatta.
A questo punto, nel caos dell'attesa e di capirci meglio cosa sta succedendo, io penso che sia meglio non aggiornare niente.
Magari qualcuno qui che capisce meglio la situazione ci illumini un pò.
Io mi sto comunque documentando meglio sulla faccenda Eye-wink
Ciao
Francesco bat

Ritratto di Benzocaino
Offline
Joined: 11/12/2011

Aggiornando da terminale ricevo:

I seguenti pacchetti sono stati mantenuti
libdvbpsi5 (0.1.6-1pclos2007 => 0.1.7-1pclos2012)

Se non erro si dovrebbe trattare semplicemente di dipendenze non soddisfatte.
Immagino che sia solo questione di tempo e tutto si metterà a posto con i prossimi aggiornamenti.

Ritratto di monsee
Offline
Joined: 16/09/2009

Quoto Benzocaino: c'è semplicemente da aspettare un po'...

Ritratto di zafran
Online
Joined: 16/06/2008

Anche secondo me, speriamo poco.

Ritratto di monsee
Offline
Joined: 16/09/2009

Comincia un po' a chiarirsi, la vicenda. Si tratta di questione afferente alla versione 2 di VLC: http://www.pclinuxos.com/forum/index.php/topic,105713.0.html
Neal ha uploadato un nuovo pacchetto di aggiornamento e par che la cosa sia risolta o -quantomeno- già in via di soluzione.

Aggiungo che in almeno una delle versioni "non-ufficiali" s'è appena venuta a creare una situazione leggermente diversa.
Proprio oggi, aggiornando da Synaptic, i pacchetti relativi alla mia ZEN-mini 2012 a 32-bit, mi son visto seccamente disinstallare VLC113... che ora non è più reinstallabile (si tratta, insomma, di aspettare la VLC2 sia resa disponibile). In compenso NON risulta alcun "pacchetto" che non sia aggiornato...

Ritratto di francesco bat
Offline
Joined: 20/11/2011

Infatti.
Io non ho aggiornato ancora per questo motivo.
Preferisco aspettare che rendono disponibile VLC2 perche vlc lo uso spesso.
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Joined: 16/12/2011

Scusate, ma sulla versione kde non succede?
Ormai sono tre giorni consecutivi che mi trovo nuovi aggiornamenti ma fin ora nessun problema se non i soliti messaggini d'errore che a volte appaiono a fine installazione ma senza apparenti problemi.

Ritratto di francesco bat
Offline
Joined: 20/11/2011
500paolo ha scritto:

Scusate, ma sulla versione kde non succede?
Ormai sono tre giorni consecutivi che mi trovo nuovi aggiornamenti ma fin ora nessun problema se non i soliti messaggini d'errore che a volte appaiono a fine installazione ma senza apparenti problemi.

Io uso kde !
Nell'ultimo aggiornamento, dovrebbe rimuoversi VLC senza poter installare la versione 2.
Io sto aspettando che inseriscono la versione 2 di VLC in modo da non doverci rimanere senza perciò non sto ancora aggiornando.
Ciao
Francesco bat

Ritratto di 500paolo
Offline
Joined: 16/12/2011

Boh, a me non e' ancora successo.
Forse tu hai la vers 64bit?

Ho solo il problema dei plasmoidi che non vanno perche' come al solito le librerie per kde4-4.6.5-1 sono incomplete.

Ritratto di monsee
Offline
Joined: 16/09/2009
500paolo ha scritto:

Forse tu hai la vers 64bit?

Nelle versioni a 64-bit, Paolo, accade che VLC è già da vari giorni alla versione 2.0.1... Per cui, tali versioni non dovrebbero risultare affette dai ritardi segnalati in questa Discussione. Il solo pacchetto che appare in lieve ritardo è il "task-pulseaudio" (che è, in realtà, un meta-pacchetto).

Ritratto di 500paolo
Offline
Joined: 16/12/2011

@Monsee,
non so che dirti, anche pochi secondi fa mi e' arrivato l'ennesimo aggiornamento riguardante alsa, ieri qualcosa di simile con la rimozione di "libzero-oss", ma vlc e' sempre li vers. 1.1.1.3.

Voglio dire che ultimamente gli aggiornamenti sono insistenti, ma vlc e' ancora li, sebbene a me importi poco dato che uso da sempre smplayer.

Ritratto di monsee
Offline
Joined: 16/09/2009

Riassunto della situazione così come mi appare al momento attuale.

PCLinuxOS a 32-bit: nella versione ZEN-mini, VLC è stato disinstallato (in corso di aggiornamenti) automaticamente. La versione 2 di VLC, in questo caso, non risulta ancora disponibile.

PCLinuxOS a 32-bit: nella versione LXDE, VLC non viene automaticamente disinstallato (in corso di aggiornsmenti) e resta, dunque, VLC 1.1.3. Inoltre, non risulta ancora aggiornaboile (per mancanza di alcune dipendenze necessarie) il pacchetto "libdvbpsi5"). Se si va a disinstallare tale pacchetto, così da poter avere una situazione che non abbia più "aggiornamenti in sospeso", si ottiene che anche VLC 1.1.3 viene automaticamente disinstallato. Il non poter avere una situazione priva di "aggiornamenti in sospeso" inmpedisce l'aggiornamento di libreOffice alla versione 3.5.4 (disponibile fin da ieri), anche se il pacchetto LibreOffice Manager viene aggiornato ugualmente e senza il minimo problema.

PCLinuxOS a 64-bit: nella versione ZEN-mini, VLC è già alla versione 2.0.1. Non è comunque possibile effettuar l'aggiornamento di LibreOffice in quanto il LibreOffice Manager si rifiuta di farla, rilevando che il meta-pacchetto "task-pulseaudio" sia da aggiornare, prima. Ma tale pacchetto NON si riesce ad aggiornare perchè -al momento- mancano ancora alcune indispensabili dipendenze. Disinstallando tale pacchetto, viene disinstallata completamente la Gnome-Shell (rammento che la versione ZEN-mini a 64-bit usa Gnome3 e non Gnome2 come accade, invece, per la versione ZEN-mini a 32-bit).

Ora vado a verificare cosa succede per le altre versioni a 64-bit che io uso (XFCE Phoenix e LXDE).

ADDENDA: ho appena trovato il modo (recependo un suggerimento assai "pratico e concreto" di djohnston, suggerimento postato sul Forum in lingua inglese) di porre rimedio alla faccenda (al momento, nella mia LXDE a 32-bit, tutti i pacchetti aggiornabili son stati aggiornati e non ci sono più "aggiornamenti in sospeso"), per cui dovrei essere ora in grado di aggiornare anche LibreOffice. Ora verifico se tutto funziona bene e, nel caso, provo ad applicar la medesima soluzione anche negli altri casi a 32-bit (ZEN-mini inclusa) e vedere se funziona bene anche lì. Dopo di che, se tutto va come dovrebbe, torno quei a postar la procedura da farsi per risolvere (che è molto semplice, ma va rimossa -pena un grave rischio d'incasinamento completo del proprio Sistema- immediatamente dopo aver risolto). Anticipo sin d'ora, dunque, che -risolto lo specifico problema afferente VLC e installato VLC 2.0.1- è indispensabile cancellar l'opzione attuata per risolvere il nostro attuale problema.

Ritratto di francesco bat
Offline
Joined: 20/11/2011

Allora, spuntando l'opzione "marca tutti gli aggiornamenti" mi marca tutto e installo tutto tranne il famigerato file che tenta di rimuovere vlc.
Così ho aggiornato tutto senza problemi tranne "libdvbpsi5" e quindi non si è disinstallato vlc.
Aspettiamo sempre la versione vlc2 sia disponibile per fare questo mitico aggiornamento.
So che vlc2 ha stravolto totalmente Smiling
Ciao
Francesco bat

Ritratto di monsee
Offline
Joined: 16/09/2009

Sì. gli Sviluppatori di VLC hanno deciso di "costruire dentro" al programma tutti quei plug-ins che prima l'Utente poteva scegliere se installare oppure co e che erano da installare (eventualmente) "a parte" (indipendentemente dal programma principale).
Comunque, in questo momento io ho (in ZEN-mini a 32-bit, col quale sono al momento) installato VLC 2.0.1 e non ci sono pacchetti che presentino "aggiornamenti in sospeso", tant'è che sono riuscito a installare anche LibreOffice 3.5.4...
Problemi risolti anche per la versione LXDE a 32-bit.
Prima di presentare la via che ho usato per sbrogliare l'inghippo, vorrei, comunque, vedere se tutto funziona a dovere anche nel caso di una PCLinuxOS XFCE Edition a 32-bit.
Penso, però, che per quel che concerne le versioni a 64-bit, il procedimento in oggetto potrebbe facilmente rivelarsi inefficace. Ma, questo, è un altro discorso...

Per cui, ora lascio le cose "in sospeso" (semplicemente, perchè debbo andare a cucinare il pranzo) e ci si ritrova dopo mangiato. Meglio far attendere un poco, ma controllare bene le procedure in modo da non rischiar di fare casini che sbolognare lì una soluzione che, magari, per chi una questa o quella specifica versione, può dar -magari- grattacapi...

Ritratto di 500paolo
Offline
Joined: 16/12/2011

Ho spulciato su synaptic e libdvbpsi5 e' marcato come aggiornabile ma non me lo propone.
Comunque non me ne faccio niente per ora, serve per il transporter stream delle schede dvb-t e dvb-s.

Ritratto di monsee
Offline
Joined: 16/09/2009

Come ho già scritto (e posso confermare, avendo fatto le prove in tutte le versioni di PCLinuxOS in mio possesso). la cosa è immediatamente risolvibile.
Purtroppo, c'è stato oggi un guasto sulla linea telefonica (una centralina è andata e ci hanno messo un sacco per ripararla), per cui sono stato bloccato sin quasi a mezzanotte. Dopo di che, di nuovo in grado di connettermi, ho fatto le varie prove che servivano.

La potenziale soluzione è di due tipi ben distinti.

1) aspettare che gli Sviluppatori terminino di testare e mettano a disposizione di tutti gli utenti i pacchetti che mancano all'appello; seguendo questa via, si avrà il solo "disagio" di non essere in grado (per ora) di aggiornare o installare ex-novo LibreOffice e di non poter -nel caso- manco "localizzare"; il vantaggio, ovvio, è che chi segue questa via non fa correre al proprio sistema rischi di sorta. Fra qualche giorno, potrà risolvere comunque semplicemente aggiornando tramite Synaptic.

2) non aspettare e correre il rischio (davvero minimo, in questo specifico caso, ma che comunque esiste) di aver problemi sul sistema andando ad installare uno o due pacchetti che -ufficialmente- si trovano ancora in fase di test. E proprio questa è la strada che ho seguito io.
Se a qualcuno interessa, la può seguire facendo (per i Sistemi a 32 bit), punto per punto, quanto segue:

a) aprire Synaptic, ricaricar l'elenco dei pacchetti e andarli ad aggiornare tutti (chi ha PCLinuxOS ZEN-mini oppure PCLinuxOS XFCE si vedrà chiedere di disinstallare anche VLC 1.1.13: date tranquillamente il necessario assenso; chi usa PCLinuxOS LXDE non si dovrebbe veder fatta tale richiesta, invece, ma gli resterà il pacchetto denominato "libdvbpsi5" "in attesa di aggiornamento" e non aggiornabile: lasciate che le cose stian così). Terminate l'aggiornamento così come di norma. Al termine, NON chiudete Synaptic, ma lasciatelo aperto;
b) avendo lasciato aperto il vostro Synaptic, adesso che tutti gli aggiornamenti son stati effettuati (e chi usa ZEN-mini o XFCE s'è visto disinstallare VLC; mentre chi usa LXDE è rimasto con un "aggiuornamento pendente"), cliccate su:
Impostazioni/Archivi dei pacchetti
... e poi selezionate il vostro repository di riferimento (io uso il GARR, per cui metterò lui, nel mio esempio).
Nella finestrella che starete guardando, leggerete, a questo punto, una riga che recita:
main updates nonfree games kde4 xfce4
... dovete correggerla, in modo che diventi uguale a quella subito qui sotto:
main updates nonfree games kde4 xfce4 testing
e dopo la parola "testing" dovete lasciare anche uno spazio vuoto (è importante, per cui non dimenticate di farlo)
Fatto ciò, cliccate su OK e poi ricaricate l'elenco del pacchetti in Synaptic.
c) ricaricando l'elenco, avrete -oltre ai pacchetti stabili- anche i pacchetti ancora in fase di test. NON dovete assolutamente "marcare tutti gli aggiornamenti", nè dovete marcare per l'aggiornamento o l'installazione alcunché se non i paccetti che vi indico qui. Sappiate che andando a installare altre cose, il rischio di incasinarvi il Sistema è davvero grande. Ma, se farete esattamente come vi indico, tale rischio -a mio parere- è veramente minimale.
Se avete disinstallato VLC 1.1.13 (cosa che dovrebbe essere accaduta a chi usa ZEN-mini o XFCE), dovete semplicemente scorrere l'elenco dei pacchetti, a questo punto, e andare a marcare per l'installazione il pacchetto: che installa VLC 2.0.1; fatto questo, procedete pure con l'installazione (che, vedrete, andrà a buon fine); se invece non avete disinstallato VLC 1.1.13 (e, dunque, avete un "aggiornamento pendente" sul vostro pacchetto "libdvbpsi5"), dovete semplicemente andarvi a cercare il pacchetto "libdvbpsi5" e "marcarlo per l'aggiornamento". Vi verrà richiesto di aggiornare anche VLC: date il vostro assenso. in questo modo, il pacchetto "libdvbpsi5" verrà regolarmente aggiornato e vi ritroverete ad avere VLC 2.0.1.
Ecco, avreste finito, ma è ora indispensabile rimuovere l'opzione dei "pacchetti da test" per il futuro, giacché tenerla vi condurrebbe di certo a incasinarvi il Sistema. Ed ecco come dovete fare:
d) terminato l'aggiornamento di "libdvbpsi5" e VLC (per chi usa LXDE) o installato VLC 2.0.1 (per chi usa XFCE o ZEN-mini), sempre sul vostro Synaptic, cliccate su:
Impostazioni/Archivi dei pacchetti
Poi, selezionate il vostro Repository preferito (quello che avete modificato prima, per capirci) e togliete la modifica che avete prima apportato, facendo sì che la riga riappaia com'era all'inizio, ovvero:
main updates nonfree games kde4 xfce4
Dopo di che, cliccate su OK e, fatto ciò, provcedete a "ricaricare" l'elenco dei pacchetti in Synaptic.
fatto anchq questo, chiudete pure Synaptic e aprite il LibreOffice Manager, per aggiornare il vostro libreOffice alla versione 3.5.4. Vedrete che tutto andrà a buon fine.

twa
Ritratto di twa
Offline
Joined: 17/04/2012

monsee,
ancora una volta grazie alle tue istruzioni, ho aggiornato VLC alla v2.0.1 ed il sistema è aggiornato.
un chiarimento però ti chiedo gentilmente: il mio repo di GARR era : main updates nonfree games kde4
manca quindi : xfce4
che ho aggiunto unitamente a testing per installare VLC v2.
ora ho rimosso la parola testing, ma devo lasciare xfce4 anche se uso PCLOS LXDE..32 bit ??
grazie

Ritratto di monsee
Offline
Joined: 16/09/2009

Sì, devi lasciare anche la parola xfce4.
Dunque, l'espressione che ti deve apparire è precisamente:

main updates nonfree kde4 games xfce4

... che è quella che io stesso ho nel mio Synaptic relativamente a LXDE a 32-bit (ho appena verificato, dunque son sicurissimo).

twa
Ritratto di twa
Offline
Joined: 17/04/2012

monsee,
scusa, ma nel tuo post precedente avevi scritto:
main updates nonfree games kde4 xfce4
mentre adesso dici:
main updates nonfree kde4 games xfce4
le parole sono le stesse, ma messse in modo diverso
quale è quello giusto ?
grazie

Ritratto di zafran
Online
Joined: 16/06/2008

Non c'è un ordine preciso.
Basta che ricorrano i termini giusti.

Infatti:

monsee ha scritto:

Sì, devi lasciare anche la parola xfce4.

Ritratto di Benzocaino
Offline
Joined: 11/12/2011

c.v.d. libdvbpsi5 si è aggiornato.

twa
Ritratto di twa
Offline
Joined: 17/04/2012

zafran,
grazie..fatto
sistema aggiornato

Ritratto di francesco bat
Offline
Joined: 20/11/2011

Anche io tutt'ok !
Speriamo che non troviamo problemi di conflitti codecs.
Ciao
Francesco bat

Ritratto di zafran
Online
Joined: 16/06/2008

Bene.
Ho messo risolto