[RISOLTO] Lingua italiana...

70 posts / 0 new
Ultimo messaggio
Ritratto di monsee
Offline
Joined: 16/09/2009

Ma certo che è vero: lo posso veder bene, proprio qui e di persona.

Ritratto di zafran
Offline
Joined: 16/06/2008

Anch'io!!!
Hai visto che siamo d'accordo?
Sticking out tongue

Ritratto di zafran
Offline
Joined: 16/06/2008

@ sandro TT
Avevi abilitato la sezione xfce4 nel repository?

Ritratto di monsee
Offline
Joined: 16/09/2009

Beh, non penso possa esser questo, il problema, Zafran.
È vero che -prima- non tutti i repository fornivano XFCE4, ma la situazione, adesso, è mutata (e da almeno tre mesi): ora, tutti i repository (escluso il Megagames, naturalmente), han pure XFCE4.
Per la questione della disinstallazione forzata di XFCE, etc (incluso il localizzar tutto in lingua italiana e riavere XFCE... senza più problemi di alcun di dipendenze fra i pacchetti), si può risolver tutto tramite Synaptic e in una mezz'oretta al più...
Lo dico perchè ci son passato e so come si può risolver la questione.

Una curiosità (non c'entra niente con quel di cui stiamo parlando qui e afferisce alle versioni a 64 bit): non so se proprio oggi è stato inghippato qualcosa, ma mi è arrivato un aggiornamento (solo per i PCLinuxOS a 64 bit) che ha cambiato l'impostazione dei Repository e sembra voler indurre Synaptic a suggerir la disinstallazione di svariati "pacchetti" (a 64 bit), inclusi alcuni di XFCE4... per sostituirli, perlopiù, con una versione a 32 bit... Inoltre, sembra che vada a ripresentarsi (per i 64 bit), a seguito di ciò, una situazione non troppo dissimile (all'apparenza e per quel poco che ne so fino a questo momento io) a quella che ha incasinato un po' tutti -poche settimane or sono- in relazione al pacchetto texlive "malriuscito" e successive conseguenze. Problemi, quelli, oramai pienamente risolti (resta solo un pacchetto che non sembra si possa installare: Pari) grazie all'ottimo lavoro degli Sviluppatori di PCLinuxOS.
Per ora, ho preso tempo e NON ho aderittoalla richiesta di disinstallare o aggiornare i pacchetti che mi son stati proposti dopo l'ultimo aggiornamento... debbo capirci meglio, prima di arrischiarmi... Pensa che adesso, l'elenco dei pacchetti risulta di quasi 15.000 pacchetti... e ciò perchè include (mescolati) sia quelli a 32 bit che quelli a 64 bit (prima, c'erano solo quelli a 64 bit)...

Ritratto di zafran
Offline
Joined: 16/06/2008

Non avendo processori a 64 bit di tutto questo purtroppo capisco ben poco.
Certo l'entrata del 64 ha scombinato un bel po' di cose, speriamo si riordinino e alla svelta perché il passaggio massiccio alle architetture a 64 bit non è certo prossimo.

Il discorso sulla xfce4 non l'ho inventato io ma neal lui medesimo al quale ho segnalato la faccenda della sua home improvvidamente comparsa nella disinstallazione di SandroTT.
Gli ho anche detto che poteva farsi vedere lui stesso da queste parti ma ci credo poco.

Penso comunque che quegli errori siano stati superati come dici tu da diversi mesi e che quei messaggi venissero da file installati quando la sezione non era attiva.
Questo, quello che ho capito.

Ritratto di monsee
Offline
Joined: 16/09/2009

Ti confermo che le versioni a 32 bit NON presentano problemi di sorta (c'è lo stesso aggiornamento dell'apt-souce-list cui accennavo anche per le versioni a 64 bit, soltanto che, per quel che concerne le versioni a 32 bit, NON crea il benché minimo problema [nè cambia il numero dei pacchetti a disposizione nell'elenco, dato che sono presenti i soli pacchetti a 32 bit]). Dunque, NESSUN PROBLEMA per tutte le versioni a 32 bit (incluse le versioni con XFCE, ovvero la Phoenix e la Phinx a 32 bit).
La questione cui accennavo in coda al mio post precedente afferisce soltanto e unicamente tutte le versioni a 64 bit (ti sto scrivendo da ZEN-mini a 64 bit e ho appena verificato che il problema è anche qui). Possono star tranquillissimi, invece, quelli che usano PClinuxOS a 32 bit.
E c'è comunque da specificare che TUTTE le versioni a 64 bit son da considerarsi "versioni da test" (per il momento: quando saran rilasciate le versioni stabili e definitive,. naturalmente verremo informati) e NON sono supportate, com'è anche ovvio, dalla Community (né da alcun Forum ufficiale: c'è una pagina Web apposita, per le questioni relative ai test). Non deve, di conseguenza, affatto stupire che possano capitare (dato che si sta facendo semplicemente testing!) tutta una serie di naturali problemi.
In quanto al fatto che Neal (Sviluppatore ch'io stimo tantissimo, specie per il lavoro davvero GENIALE -impareggiabile!- da lui svolto implementando LXDE in PCLinuxOS 2011 LXDE [e LXDE-mini] a 32 bit [ma anche PCLinuxOS 2012.1 LXDE-mini a 64 bit è straordinaria!]) possa -speriamo!- approdare anche su questo Forum, posso dir semplicemente che, se mai ci facesse un simile onore, ne sarei più che lieto (come puoi ben immaginare).

Ritratto di monsee
Offline
Joined: 16/09/2009

Questione risolta (mi riferisco alla questione recentissima attinente i 64-bit): si tratta di un BUG.
Bisogna reimpostare (in Synaptic), manualmente, l'impostazione per avere solo i pacchetti x86_64 (ovvero, quelli a 64-bit) nell'elenco di Synaptic.
Questa info proviene direttamente da Leiche (che è lo Sviluppatore che si occupa di PCLinuxOS LXDE), in risposta ad un mio post, ed è -di conseguenza- da considerarsi più che attendibile.
Codesto BUG non afferisce (ripeto: NON afferisce) in alcun modo PCLinuxOS a 32 bit, nel quale -oggi come oggi- non ci sono problemi di sorta.

Ritratto di zafran
Offline
Joined: 16/06/2008

Ottimo, bravissimo (come sempre).

Ora vediamo: se neal volesse venire a chiedere, tanto meglio.
In ogni caso, credo che il problema sia davvero superato.

Ritratto di zafran
Offline
Joined: 16/06/2008

Neal verificherà lo stato delle cose.
Al momento però ipotizza che l'installazione sia stata fatta con un srpm invece che rpm.
Il che mi sembra un po' strano, però.

Ritratto di monsee
Offline
Joined: 16/09/2009

Ho visto che è anche possibile risolvere scaricando un pacchetto da Repository e poi installandolo (io, per installarlo, ho usato rpm-installer [è un pacchetto disponibile in PClinuxOS] e tutto ha funzionato benissimo). Sia andare ad aggiungere "a mano" alla riga che indica il Repository usato quel che serve per indicare i soli pacchetti a 64-bit che installare il pacchetto cui accennavo all'inizio di questo mio post, risolve il problema. Penso (anche se non l'ho testato ancora) che anche il re-installare tramite Synaptic il pacchetto apt-sources-list (senza installare, però, null'altro, nè disinstallare niente!) possa -almeno, è ragionevole- esser risolutivo. Se così fosse, ci sono tre vie per rimettere a posto le cose.
Tutto questo discorso (è meglio ripeterlo, perchè non vorrei che qualcuno leggesse e capisse male) vale solo e unicamente per chi sta facendo testing con PCLinuxoS a 64 bit. La versione a 32 bit di PClinuxOS (TUTTE le versioni a 32 bit) NON ha, invece, nessunissimo problema (non c'è affatto, il BUG di cui stiam qui parlando) e non c'è bisogno di fare alcunché.

Per chi volesse "editare a manina" il file /etc/apt/sources-list (anziché reinstalalre il pacchetto "apt-sources-list"),, ecco come bisogna mettere -specificamente- la riga relativa al GARR di Napoli:

rpm http://na.mirror.garr.it/mirrors/pclinuxos/apt/ pclinuxos/2011 x86_64

(rammentarsi che lo spazio vuoto fra la slash che segue "atp" e la parola "pclinuxos" deve ESSERCI)
Le altre righe vanno -ovviamente- corrette in modo del tutto analogo.

Ritratto di SandroTT
Offline
Joined: 28/03/2012
monsee ha scritto:

PS: la questione riportata e relativa ai pacchetti texlive, etc (a proposito: meglio installarli, i pacchetti suggeriti: non son stati suggeriti affatto a caso)... è ben nota (così come la conseguente "disinstallazione completa -e praticamente "forzata"- di XFCE ad essa collegata). Il problema ormai è completamente risolto, comunque, e si può riottenere senza difficoltà alcuna anche XFCE (da interfaccia GRAFICA [ossia, da Synaptic] ed evitando sempre -questa la mia raccomandazione, qui e ora e sempre anche per l'avvenire,- di usare il Terminale oppure la "riga di comando" per la gestione dei pacchetti in PCLinuxOS [qualsivoglia versione]).

negativo sia l'uno ("Il problema ormai è completamente risolto") che l'altro ("si può riottenere senza difficoltà alcuna anche XFCE (da interfaccia GRAFICA [ossia, da Synaptic]")
in quanto 1. La cosa è successa non più di 3-4 giorni fa
2. *ovviamente* ho usato soltanto Synaptic: ho il sacro terrore della riga di comando Smiling e vi ricorro (rarissimamente) solo quando non vedo altre vie d'uscita (ma non era stato questo il caso)

Ritratto di SandroTT
Offline
Joined: 28/03/2012
zafran ha scritto:

@ sandro TT
Avevi abilitato la sezione xfce4 nel repository?

Si.
Ecco pari-pari quello che ho fatto: ho cercato in Synaptic-Attività un "task-xfce*" sperando che facesse tutto da solo il "task".
Non trovandolo ho sgugolato e da qualche parte ho trovato un suggerimento (non mi vorrei sbagliare, ma forse era monsee) di settare come repository heanet.ie (mi pare). Cambiato il rep, ricaricato, continuavo a non trovare un "task-xfce*" e allora sono andato a guardare (*sempre in Synaptic!!!*) Impostazioni-repo-sezione, e c'era il solito "main updates nonfree games kde4" --> ho semplicemente cancellato "kde4" e sostituito con "xfce4", ricaricato (il repo rimaneva heanet.ie), ed è finalmente comparso l'agognato "task-xfce4", marcato per l'installazione e si è portato dietro una serie di pacchetti, *escluso* il famigerato texlive.

Il resto è come avevo già scritto: logout, login con DE Xfce, x quel poco che ho visto tutto era funzionante, la lingua era diventata "inglese" ma non me ne sono curato perchè intanto era solo una prima "presa di contatto" con Xfce, logout, nuovo login con DE Lxde --> lingua inglese (non tutto: forse saremo stati ad un 40% inglese e 60% italiano, anche nell'ambito dello stesso programma [es. menu in ing e voci del sottomenu in italiano, o viceversa]
--> riporto il repo a Garr pensando che potesse dipendere da quello (x monsee: anche il repo lo cerco da Gui, con menu-software center- Update Package Sources List) --> niente --> lancio addlocale ma mi dice che il sistema non è aggiornato --> x aggiornarlo occorreva scaricare quei 750 Mb di texlive ecc --> chiedo aiuto sul forum di Pclos.it Smiling

Ritratto di monsee
Offline
Joined: 16/09/2009
SandroTT ha scritto:
monsee ha scritto:

PS: la questione riportata e relativa ai pacchetti texlive, etc (a proposito: meglio installarli, i pacchetti suggeriti: non son stati suggeriti affatto a caso)... è ben nota (così come la conseguente "disinstallazione completa -e praticamente "forzata"- di XFCE ad essa collegata). Il problema ormai è completamente risolto, comunque, e si può riottenere senza difficoltà alcuna anche XFCE (da interfaccia GRAFICA [ossia, da Synaptic] ed evitando sempre -questa la mia raccomandazione, qui e ora e sempre anche per l'avvenire,- di usare il Terminale oppure la "riga di comando" per la gestione dei pacchetti in PCLinuxOS [qualsivoglia versione]).

negativo sia l'uno ("Il problema ormai è completamente risolto") che l'altro ("si può riottenere senza difficoltà alcuna anche XFCE (da interfaccia GRAFICA [ossia, da Synaptic]")
in quanto 1. La cosa è successa non più di 3-4 giorni fa
2. *ovviamente* ho usato soltanto Synaptic: ho il sacro terrore della riga di comando Smiling e vi ricorro (rarissimamente) solo quando non vedo altre vie d'uscita (ma non era stato questo il caso)

No, no, te lo ribadisco: la cosa è pienamente risolta e -io, personalmente... esattamente come tanti altri- so bene come uscire dai problemi (sempre e solamente utilizzando Synaptic [ovvero, l'interfacca grafica]). Questo, anche laddove si abbia come desktop-environment soltanto XFCE (che, nel processo di soluzione vien prima disinstalalto e poi, dopo l'avvenuta italianizzazione del sistema, reinstallato). O qualora si abbia LXDE... o anche qualora si abbia ZEN-mini.
Penso che la medesima strategia risolva anche negli altri casi, ma questi sono i soli che ho verificato di persona (e -lo ripeto- sempre con successo).
E avendolo fatto più volte di persona, qualora tu ne abbia voglia, ti posso indicare come si deve agire (non ci vuole la Laurea e non c'è da usare la "riga di comando", né da dettare mantra chini sul Terminale).
Alla fine dei giochi, avrai il Sistema perfettamente funzionante (ho affrontato questa specifica situazione sia in XFCE-Phoenix che in XFCE-Phinx che in LXDE che in LXDE-mini che in ZEN-mini [a 32 bit, in tutto i casi], risolvendo sempre la cosa), sia esso XFCE, sia esso LXDE... E in caso tu avessi già "personalizzato" XFCE, ritroverai anche le tue personalizzazioni.

Ritratto di leo82
Offline
Joined: 16/07/2011

salve a tutti ragazzi ho provato la vostra soluzione per cambiare lingua in italiano ma niente sono sempre in inglese...
sembra che non mi scarichi i pacchetti di lingua italiana....

Ritratto di monsee
Offline
Joined: 16/09/2009

La ragione è che c'è da effettuare l'aggiornamento di due pacchetti (e, per effettuarlo, c'è da eseguire un procedimento un po' particolare).
Alternativamente, puoi scegliere di tenerti tutto in inglese e di aspettare.
Se vuoi aggiornare subito, dunque, scrivilo... e ti darò le necessarie istruzioni (facilissime, ma da seguore assolutamente alla lettera).

Ritratto di leo82
Offline
Joined: 16/07/2011

ciao monsee sono riuscito ad avere la lingua italiana disinstallando vlc e tutte le sue dipendenze... ora mi manca solo firefox che è rimasto in inglese e non riesco a cambiarlo.... qualche idea?

Ritratto di Benzocaino
Offline
Joined: 11/12/2011

Per firefox io installo direttamente dal sito la lingua italiana, lo trovo il metodo più veloce ...
http://www.mozillaitalia.org/home/download/

Ritratto di leo82
Offline
Joined: 16/07/2011
Benzocaino ha scritto:

Per firefox io installo direttamente dal sito la lingua italiana, lo trovo il metodo più veloce ...
http://www.mozillaitalia.org/home/download/

grazie mille benzocaino ora è a posto...

Ritratto di zafran
Offline
Joined: 16/06/2008

Bon.
Metto risolto.