[RISOLTO] TDE: Riavvio e spegnimento solo da root dopo aggiornamento

3 contenuti / 0 new
Ultimo contenuto
Ritratto di francesco bat
Offline
Iscritto: 20/11/2011 - 02:46
[RISOLTO] TDE: Riavvio e spegnimento solo da root dopo aggiornamento

Ciao a tutti.

Per qualcuno che usa la versione Trinity Desktop, avete notato che dopo gli aggiornamenti non è più possibile riavviare e spegnere il pc regolarmente come utente normale ?

Se faccio riavvio o spegni finisco in modalità shell dove devo rilogarmi e digitare reboot o poweroff per chiudere.

Il problema si risolve solo se da Trinity desktop riavvio da terminale con privilegi di superutente.

Da quello che ho capito è che è un problema del TDM, infatti quando il sistema esce e finisco in shell, il TDM è terminato e da utente da shell diventa possibile riavviare o chiudere.

Se il TDM è ancora attivo non è possibile farlo se non sei root o superutente.

La cosa strana è anche da root non è possibile riavviare graficamente ma solo se digito da terminale reboot.

Provando a cambiare display manager a GDM il problema si risolve e posso riavviare e chiudere normalmente.

Ciao

Francesco bat

Ritratto di francesco bat
Offline
Iscritto: 20/11/2011 - 02:46

Risolto in questo modo:

http://www.pclinuxos.com/forum/index.php/topic,143475.0.html

Ciao

Francesco bat

Ritratto di zafran
Offline
Moderatore
Iscritto: 16/06/2008 - 16:10
Oggetto:
TDE: Riavvio e spegnimento solo da root dopo aggiornamento
»
[RISOLTO] TDE: Riavvio e spegnimento solo da root dopo aggiornamento

Riporto la risposta che ti ha dato reelcat per non rischiare di perdere il suggerimento (i post di quel forum non sono mai molto al sicuro, dipendendo dall'interesse di texstar a mantenerli)

Quote:
Hi Francesco bat,

In Trinity, there is a very simple solution for TDM:

Run Trinity Control Center > System Administration > Login Manager. Go to the Shutdown tab and click the Administration Mode button below. As root, change the default commands for reboot and shutdown:

for shutdown: /usr/bin/poweroff > /sbin/poweroff
for reboot: /usr/bin/reboot > /sbin/reboot

Save the settings and give them a try. Should work (works for me)