[RISOLTO] Schermo nero in avvio

16 contenuti / 0 new
Ultimo contenuto
Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38
[RISOLTO] Schermo nero in avvio

Ieri ho aggiornato Pc Linux da Synaptic e tutto sembrava andare bene. Oggi Pc Linux mi da lo schermo nero in avvio e non succede nulla.

Cosa si puó fare? Grazie in anticipo.

Ritratto di footstep11
Offline
Iscritto: 31/01/2013 - 11:01

Se vai dal medico e gli dici "oggi non mi sento bene" cosa ti aspetti che ti risponda?

A parte gli scherzi, cosa intendi con "schermo nero"? Completamente nero o hai un prompt con scritto login: ? Quale scheda grafica hai? Che desktop environment? Hai aggiornato anche il kernel? E quale usi? Hai provato ad entrare, se possibile, in modalità failsafe?

Dacci qualche informazione in più e forse potremmo aiutarti.

Ciao, Mauro

Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38

Per schermo nero, intendo che Pc Linux non si avvia. Come desktop environment c'é Lxde. Ho effettuato l'aggiornamento consigliato da Pc Linux. Il Kernel é qualcosa come 4.4.16. Non sono entrato in modalitá failsafe. La scheda grafica é una AMD Radion Rx 560, con 2 Gbyte di Ram.

Al momento sto scrivendo da Linux Mint, sulla stessa macchina. Se servono altre informazioni, fammi sapere, grazie.

 

Ritratto di footstep11
Offline
Iscritto: 31/01/2013 - 11:01

Quando fai partire pclos, prova a premere il tasto <ESC> in modo da visualizzare il punto dove si blocca e posta il risultato.

 

Ciao, Mauro

Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38

Ho premuto Esc, subito dopo aver fatto avviare Pc Linux. L'avvio é stato regolare fino all'inserimento della password. Dopo, lo schermo é diventato nero e il desktop non si é caricato.

Ritratto di footstep11
Offline
Iscritto: 31/01/2013 - 11:01

Quindi arrivi alla schermata di login.  Invece di inserire il tuo nome utente, prova ad inserire root (con la sua password). Se funziona, significa che hai un qualche problema di configurazione nel tuo account. Prova a crearne un altro, uscire e rientrare con quell'utente e dicci che cosa succede.

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Facendo una ricerca su google il tuo problema sembrerebbe relativo alla tua scheda grafica, almeno viene imputa molte volte e gia' sappiamo che le radeon sono maldigerite da linux. Se hai installato un nuovo kernel potresti provare ad entrare con uno piu' vecchio scegliendolo dal grub. Se non  hai installato un nuovo kernel esci con ctl+alt+f1 e dal prompt installa un kernel piu' recente, una volta finito riavvia ed incrocia le dita.

Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38

Non ho installato un nuovo kernel, a meno che non lo abbia fatto Synaptic quando mi ha proposto l'aggiornamento.

ctrl+alt+f1 vanno dati prima di fare il login? Come installo un nuvo kernel dal prompt dei comandi?

Mi scuso per l'inesperienza. Grazie

"Se non  hai installato un nuovo kernel esci con ctl+alt+f1 e dal prompt installa un kernel piu' recente, una volta finito riavvia ed incrocia le dita."

 

adrianomorselli wrote:

Facendo una ricerca su google il tuo problema sembrerebbe relativo alla tua scheda grafica, almeno viene imputa molte volte e gia' sappiamo che le radeon sono maldigerite da linux. Se hai installato un nuovo kernel potresti provare ad entrare con uno piu' vecchio scegliendolo dal grub. Se non  hai installato un nuovo kernel esci con ctl+alt+f1 e dal prompt installa un kernel piu' recente, una volta finito riavvia ed incrocia le dita.

Ritratto di footstep11
Offline
Iscritto: 31/01/2013 - 11:01

No, il nuovo kernel non si installa da solo. Deve essere installato selezionandolo, e se tu non sai di cosa stiamo parlando, di sicuro non lo hai fatto.

Il fatto che arrivi alla schermata di login implica che il driver della scheda grafica funziona (altrimenti arriveresti ad uno schermo nero con sctitto 'login:' mentre tu hai detto riesci ad inserire login/pass e DOPO lo schermo diventa nero).

Hai provato ad entrare come root, come ti avevo suggerito?

Ciao, Mauro

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Che la scheda grafica funziona non c 'e' dubbio visto che warp ci parla da linux mint e questo funziona. Diverso discorso riguarda i driver che nel caso di pclos sono sempre proprietari, mentre mint di default usa i nouvaeu. L'unico modo per capire dov'e' l'errore sarebbe vedere nel file di log, ma warp difficilmente lo puo' fare visto che il sistema manco si avvia dopo il login e non credo che lo fara' neppure come root, anche se provare non nuoce. Cosa resta da fare? Alla schermata nera dopo il login ctrl+alt+f1 , al prompt su + password_amministratore , apt-get update , apt-get install kernel-4.15.16 

Terminata l'installazione riavviare con reboot ed incrociare le dita. La mia speranza e' che un upgrade del kernel piu' recente sia meglio  integrato con la tua scheda grafica

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Se non dovesse funzionare qui hanno eisolto cosi' https://www.pclinuxos.com/forum/index.php/topic,145479.msg1242365.html#m...

Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38

Entrando come root, la situazione non cambia. Ottengo lo schermo nero e il desktop non appare.

footstep11 wrote:

Quindi arrivi alla schermata di login.  Invece di inserire il tuo nome utente, prova ad inserire root (con la sua password). Se funziona, significa che hai un qualche problema di configurazione nel tuo account. Prova a crearne un altro, uscire e rientrare con quell'utente e dicci che cosa succede.

Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38

Ho pensato che potrei reinstallare Pc Linux. Con l'occasione, utilizzerei il disco ssd con l'interfaccia Sata III, invece della Sata II dell'altro computer.

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Cosa c'entra sata III con la tua scheda gragica? Shok

Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38

Ovvio che Sata III non c'entra con la scheda grafica. Però, con l'occasione, potrei collegare il disco SSD, reinstallare i 2 Linux e avere un sistema più performante.

Comunque faccio ancora un tentativo come spiegato sopra.

adrianomorselli wrote:

Cosa c'entra sata III con la tua scheda gragica? Shok

Ritratto di warp
Offline
Iscritto: 20/01/2013 - 14:38

Come faccio a chiudere la discussione? Non ricordo mai la procedura.

La prossima settimana forse riesco a fare la reinstallazione col disco SSD.

Grazie