regolare l'orologio

Ritratto di fortu
AllegatoDimensione
Image icon schermata1.png22.89 KB
Forum: 

Ciao ieri ho installato pclinuxos kde e nonostante abbia seguito alcuni consigli del forum datati anni addietro, non sono riuscito a regolare per bene l'ora. Adesso mi segna  07:22, invece sono le ore 09:22. Inoltre ho cercato di aggiornare il fuso orario scegliendo Roma, ma mi dà questo errore:

Ritratto di adrianomorselli
Ritratto di fortu

Ho riavviato il portatile trovando l'ora di windows sbagliata come questa di pclinux. Ho aggiornato l'ora attraverso l'ora di internet ed ha funzionato, ma al riavvio in pclinux l'ora non si è sistemata.

Orologi | PCLinuxOS.it

Ritratto di fortu

Ho messo il link al commento precedente, perché ho seguito quella guida.

Ho regolata l'ora del bios perchè era 2 ore indietro, ma pclinux è rimasto sempre due ore indietro.

Ritratto di adrianomorselli

Ma non ho capito, hai detto che hai seguito quel vecchio post, che riguarda una situazione di penso un serverino dove gli hd vengolo tolti e rimessi a secondo del bisogno. E' anche il tuo caso? Una volta settata l'ora ti dovrebbe rimanere a posto se non continui a togliere e rimettere gli hd Shok Il link che ti ho messo io è un caso normale.

Ritratto di fortu

Ho seguito questa guida che ti linko. Poi l'ho regolato manuale e sembra che funzioni.

Ritratto di adrianomorselli

Si l'ho letta anche prima, comunque basta che ti abbia funzionato e che hai risolto

Ritratto di fortu

L'ho sistemata regolanodola manualmente, vedi allegato, Invece da "imposta data e ora automaticamente" non ha funziona perché non si aggiorna il server dell'ora.

Ritratto di fortu

Non mi ero accorto che la data si è sregolata, come si vede dallo screenshot precedente.

Ritratto di fortu

Non riesco a sistemare l'ora, se la regolo manualmente rimane indietro 2 ore, se la regolo automaticamente il server non riesce a connettersi, vedi allegato.

 

Ritratto di fortu

Ho notato che nell'elenco del fuso orario locale di pclinux manca la voce GMT + 1 e + 2 che sono i fusi orari per l'Italia. Invece è' presente solo GMT +0 oppure solo GMT. Forse è questo il motivo che l'ora dell'orologio rimane due ore indietro?

Ritratto di adrianomorselli

Bug già vecchio e per fortuna facilmente risolvibile http://www.pclinuxos.it/forum/installazione/impossibile-contattare-il-se...

Ritratto di dxgiusti

da configura you computer, sistema, localizzazione, imposta data ed ora.

Ritratto di fortu

Tutte queste prove già fatte. Ho ricontrollato (abilita "Attiva network time protocol" e scegli Europa|Italia: it.pool.ntp.org), era già abilitato.

Ritratto di fortu

Ho controllato nel bios e in effetti l'orlogio è due ore indietro. Non è che si è cancellata qualche configurazione del bios? Ho pensato anche che fosse la batteria del bios, ma si prende solo e credo sempre due ore.

Ritratto di adrianomorselli

Se la batteria ha almeno 4 anni è possibile, però se hai impostato l'ora dal server pclinuxos se ne dovrebbe fregare, magari ci mette un pò ad aggiornare ma lo fà. Eventualmente cerca un altro server in Europa con il tuo stesso fuso orario

Ritratto di adrianomorselli

Ricordati però una cosa, le modifiche vanno fatte da "configure your pclinuxos" e non da "configure your desktop", cioè devi farlo dal tool specifico di pclinuxos, altrimenti al riavvio ti ritrovi daccapo

Ritratto di fortu

Grazie.

Come server ho messo la Spagna. Aspetto un pò vediamo se l'ora si aggiorna.

Ritratto di adrianomorselli

Ho fatto una prova di ping verso it.pool.ntp.org e non trovo problemi, vuoi fare una prova tu? Da terminale digiti ping it.pool.ntp.org -c 1 come risultato dovrebbe darti:

PING it.pool.ntp.org (212.45.144.3) 56(84) bytes of data.
64 bytes from acacia.bilink.net (212.45.144.3): icmp_seq=1 ttl=249 time=42.6 ms

--- it.pool.ntp.org ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 42.627/42.627/42.627/0.000 ms

 

 

Ritratto di fortu

Guarda:

PING it.pool.ntp.org (193.204.114.233) 56(84) bytes of data.
64 bytes from ntp2.inrim.it (193.204.114.233): icmp_req=1 ttl=53 time=60.2 ms

--- it.pool.ntp.org ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 60.280/60.280/60.280/0.000 ms

Ritratto di adrianomorselli

Bene, abbiamo appurato che il tuo pc non ha problemi a collegarsi a quel server. Io adesso non ho il file di configurazione ntp perchè uso l'orologio di sistema, ma tu dovresti avere un file /etc/ntp.conf puoi copiarlo qui?

Ritratto di fortu

#
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. The
# default stratum is usually 3, but in this case we elect to use stratum
# 0. Since the server line does not have the prefer keyword, this driver
# is never used for synchronization, unless no other other
# synchronization source is available. In case the local host is
# controlled by some external source, such as an external oscillator or
# another protocol, the prefer keyword would cause the local host to
# disregard all other synchronization sources, unless the kernel
# modifications are in use and declare an unsynchronized condition.
#
server    127.127.1.0    # local clock
fudge    127.127.1.0 stratum 10

server 0.es.pool.ntp.org
server 1.es.pool.ntp.org
server 2.es.pool.ntp.org

#
# Drift file.  Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
#
driftfile /var/lib/ntp/drift
#multicastclient    224.0.1.1        # listen on default 224.0.1.1
#broadcastdelay    0.008

#
# Keys file.  If you want to diddle your server at run time, make a
# keys file (mode 600 for sure) and define the key number to be
# used for making requests.
# PLEASE DO NOT USE THE DEFAULT VALUES HERE. Pick your own, or remote
# systems might be able to reset your clock at will.
#
#keys        /etc/ntp/keys
#trustedkey    65535
#requestkey    65535
#controlkey    65535

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict default nomodify notrap nopeer noquery

 

Ritratto di fortu

Adriano come fai ad usare l'orologio di sistema.

Ritratto di adrianomorselli

Ho delle difficoltà a capire a causa degli a capo, non capisco quali righe sono commentate ed ho dei dubbi su quel 127.127.1.0 (direi che dovrebbe essere invece 127.0.01 ma se è commentato (#) non ha importanza). L'orologio del sistema è quello opposto a quello ntp, se vuoi cambiare in orologio del sistema, cioè quello del bios vedi di aggiustarlo prima nel bios avendo cura di salvare la modifica (normalmente con f10) e poi di modificare seguendo la procedura configure your computer/ sistema/ localizzazione/ imposta data ed ora e qui scegliere UTC

Ritratto di adrianomorselli

127.0.0.1 ma come ho detto sopra se la riga è commentata non ha importanza. Piuttosto manca del tutto l'IP del server che dovrebbe essere 5.56.160.3, ma può darsi benissimo che il file ntp.conf su pclinuxos sia diverso dall'esempio che vedo io, mi occorrerebbe avere una conferma. Ok esco da questo SO e passo a pclos e faccio la prova.

Ritratto di adrianomorselli

Sì confermo che il tuo ntp.conf è esatto, per passare all'orologio del sistema segui la procedura che ti ho detto e togli la spunta su "Attiva Network Time Protocol" e vedi se così risolvi....anche se non vedo nessun errore di sorta in quello che hai fatto, sono perplesso

Ritratto di fortu

Ho tolto la spunta su "Attiva Network Time Protocol" e l'orologio è rimasto lo stesso.

Nel pulsante "Cambia fuso orario" devo cambiare qualcosa?

Ritratto di fortu

Grazie Adriano

Non funzionava prima perché quando cambiavo l'ora al bios non l'ha memorizzavo. Nel pulsante "Cambia fuso orario" devo cambiare qualcosa? Va bene se ho tolto la spunta anche in "imposta data e ora automaticamente"? Vedi immagine:

Ritratto di adrianomorselli

In cambia fuso orario lascia Roma/Europe mentre la spunta in "imposta data ed  ora automaticamente" credo che si riferisca al cambio ora legale/solare, quindi lascia la spunta, ma non essendo su kde non lo so di preciso

Ritratto di fortu

Spuntando imposta data ed  ora automaticamente" guarda che succede, prima la schermata 6 e poi la 7.

Ritratto di fortu

Per quanto riguarda il "pulsante Cambia fuso orario" mi riferisco al percorso "configure your comuter sistema localizzazione imposta data e ora"

Ritratto di adrianomorselli

Piccolo crash? Beh succede. Si, si al tuo #31

Ritratto di fortu

Scusa si al commento #31 che vuol dire?

Ritratto di adrianomorselli

Metti il tuo fuso orario, cioè Europe/Roma

Ritratto di fortu

Dicevo in questa finestra

Ritratto di fortu

Quella che dici l'ho già sistemata. Sai l'orologio è dinuovo 2 ore indietro. Adesso controllo il bios.

Ritratto di fortu

Non capisco perché è rimasto indietro di due ore l'orologio del bios, nonostante l'abbia regolato solo ieri sera?

Adesso che l'ho regolato funziona anche l'orologio del SO.

Ritratto di adrianomorselli

Tu hai due sistemi installati, quindi dopo aver controllato nel bios ed aver salvato, entri in windows 7 e controlli che l'ora sia a posto, poi reboot ed entri anche in pclinuxos.

Ritratto di fortu

In effetti dopo aver controllato il bios (ora esatta), ho riavviato su windows e l'ora era due ore avanti. L'ho sistemata attraverso impostazione ora internet, flag su "sincronizza con un server di riferimento orario internet", ho aggiornato sul server "time.windows.com". Che dici va bene questa procedura, oppure uso l'orologio di sistema come ho fatto su pclinux e quindi tolgo la spunta su "sincronizza con un server di riferimento orario internet"?

Poi usando una guida presa da internet, che la posto di seguito, ho aggiunto questo comando nel registro di windows.Che dici lo lascio oppure lo elimino?

Per regolare l'ora si è aggiunto un comando sul registro.
regedit.exe >HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>TimeZoneInformation sulla destra>nuovo>DWORD (32-BIT)>con il nome RealTimeIsUniversital>doppioclick>codice 1

 

 

Ritratto di fortu

Ho riavviato su pclinux, indovina, due ore indietro. Mi prende in giro!

Ritratto di adrianomorselli

Ma perchè non fai semplicemente la stessa cosa su tutte due i SO? O usi utc o usi ntp

Ritratto di fortu

Riepilogando, ho usato ntp su tutte e due e l'orologio di pclinux non era corretto. Adesso proverò a usare utc su tutte e due. Ti informerò. A proposito mi puoi spiegare il significato di utc e ntp?

Grazie

Ritratto di adrianomorselli

Network Time Protocol = NTP ; con questo si usano server che ti mantengono l'ora aggiornata

Universal Time Coordinated = UTC ; questo è basato sul tempo medio di Greenwich, e chiaramente devi anche impostare il tuo fuso orario GMT+1, GMT+2 etcc.. ed è l'orologio interno dell'hardware, impostato dalla casa costruttrice

Ritratto di fortu

Ho aggiornato l'orologio del bios, tolto la spunta su "sincronizza con un server di riferimento orario internet" su windows e così penso che sia passato a utc, ma al riavvio in pclinux l'ora è di due ore indietro. Adesso provo ad elimanare quel file aggiunto nel registro di windows, vediamo se si sistema.

Ritratto di adrianomorselli

Ma per curiosità, hai controllato il calendario? Ora siamo in orario legale...segui il mio ragionamento, l'ora del bios se è impostato su Greenwich è ora 12,39, il tuo fuso orario è gtm+1 e quindi 13.39 ma se per caso la data è sballata e 1) sei in orario solare 2) non hai messo il tuo fuso orario per forza pclinuxos è due ore indietro!

Ritratto di fortu

Daccordo al tuo ragionamneto, ma non riesco a mettere il fuso orario in pclinuxos, perchè c'è solo la voce GMT, mancano le voce GMT +1 oppure GMT +2. Come faccio?

Ritratto di adrianomorselli

Europe/Rome E' da molto che si preferisce mettere tutte le città perchè non tutti sanno in quale fuso si è XD

Ritratto di fortu

Ho regolato da impostazione di sistema data e ora, guarda il risultato. Invece regolando il fuso orario dal percorso configura computer sistema ora e data, in cambia fuso orario non si trova la voce GMT +1

Ritratto di zafran

Non ho letto tutta la discussione ma di settare a off la voce UTC in /etc/default/rcS o analogo file di configurazione è già stato detto?

Ritratto di monsee

Mi sembra di no. Ma è, a mio parere, una valida idea.

Ritratto di fortu

Non è presente il file rcS nel percorso /etc/default

Pagine