[RISOLTO] Librecad crash e solo in inglese.

23 contenuti / 0 new
Ultimo contenuto
Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16
[RISOLTO] Librecad crash e solo in inglese.

Buondì come dal titolo ho installato su pclinuxos (Mate e Kde) librecad, ma a differenza di linux mint o ubuntu non ho la possibilità di renderlo in italiano e cosa peggiore quando inizio ad usarlo si chiude.

Qualcuno ha gli stessi problemi? E quali potrebbero essere le soluzioni?

Ps.: i SO sono aggiornati e  ho già provato a reinstallarli eliminando la cartella di configurazione in .config.

Grazie anticipatamente per le eventuali risposte e/o suggerimenti.

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Prova ad avviarlo da terminale e postare l'errore

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Installato su pclinuxos kde5 e librecad si avvia senza problemi, ho installato anche librecad-doc. La lingua e' solo in inglese, faro' un controllo. Se posti i tuoi errori possiamo vedere come risolvere

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Buondì, eccomi qua, scusa il ritardo nel risponderti, ti allego il file con il risultato del terminale.

Comunque non è che a me il programma non si avvia, crasha come inizio a disegnare. E questo è successo dopo qualche ultimo aggiornamento, anche se non saprei dire quale.

Inoltre quando l'ho installato, inizialmente, il programma era anche in italiano (oltre altre lingue) che si son perse con l'aggiornamento e questo già da tempo ma speravo che con i nuovi aggiornamenti la cosa venisse risolta...invece adesso neache funziona.

 

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Theme mate faenza dark, e' il tema che tu usi? Prova a cambiare theme, adwaita per esempio. Per la lingua ho visto che e' possibile richiedere direttamente sul sito di librecad, lo sbiluppo della traduzione dell'italiano e' molto indietro, circa il 50%. Forse per questo i developers di pclinuxos hanno preferito di upgradarla solo con lingua inglese. Puoi fare una richiesta sul forum internazionale, ma secondo me basterebbe che ti funzionasse. 

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Ciao ho provato a cambiare tema e a riavviare ma si comporta sempre nello stesso modo. Comunque non credo sia un problema legato al tema perchè lo fa anche sull'altra partizione con pclinuxos - mate.

 

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Ok, quindi lo stesso errore te lo da' sia pclos kde5 sia mate. Vedendo il tuo  link ti ho consigliato di mettere adwaita su mate, mentre su kde5 il tema di default e' breeze.  Se ti crasha ugualmente occorrerebbe vedere il tuo log...puo' dipendere sia da xorg sia da librecad buggato. Cosa ti posso consigliare per il momento? Utilizza la versione di librecad su linuxmint, oppure installa qcad su pclinuxos, che fra l'altro supporta i dwg. Oppure se riesci a dare gli errori attraverso il log (da copiare non appena ti crasha il programma) direttamente ai developers di pclinuxos

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Grazie Adriano userò come mi hai suggerito Qcad che ho già installato (e che funziona anche meglio a dire il vero), però volevo anche Librecad perchè Qcad non è più gratuito e non vorrei che sparisse dai repo di pclinuxos. 

Per quanto riguarda il tema ho già provato con quello di default ma non cambia niente, vedremo se magari con i prossimi aggiornamenti cambia qualcosa.

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Pero' non sarebbe male se tu potessi postare l'errore, sia da pclos mate sia da kde, se non hai la possibilita' di postarlo sul forum internazionale posso farlo io. E' sempre una cosa gradita ai developers segnalare gli errori cosi' possono risolvere.

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Ok grazie per l'interessamento, ti posto il log di xorg, quello di librecad non lo vedo, forse si trova in una posizione differente da var/log?

Allegati: 
Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Librecad lo puoi vedere solo se lo avvii da terminale, sullo stesso terminale dovresti vedere gli errori. Comunque non vedo errori evidenti nel tuo xorg, direi che e' proprio un problema del programma. Prova a fare un tentativo, installa la versione portable e vedi se questa funzia https://portableapps.com/apps/graphics_pictures/librecad-portable

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Ops questa richiede wine, scusa

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Ho fatto una richiesta di aiuto sul forum internazionale, normalmente sono abbastanza veloci a risolvere

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Ti allego il nuovo output dopo aver eseguito le modifiche al sistema grafico, magari aiuta...e di nuovo grazie per il tuo interessamento.

 

 

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Sembra che gia' hanno avvisato dello stesso errore https://www.pclinuxos.com/forum/index.php?topic=144707.0

Sul forum di librecad invece consigliano di installarlo da source, ma non mi sembra il caso. Controlla se hai installato il seguente pacchetto libdxfrw e se si prova a rimuoverlo. Di contro e' che la tua lista di errori si e' accorciata notevolmente.

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Buondì. no il pacchetto non è installato. Visto che hai detto che il problema è stato segnalato attendo i nuovi aggiornamenti, sperando che risolvano.

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Textar ha aggounto una patch e le lingue con il prossimo update 

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Grazie Adriano, allora aspetto i prossimi aggiornamenti. Di nuovo grazie per il tuo interessamento e buona domenica.

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Buondì, oggi sono arrivati gli aggiornamenti per librecad con anche i pacchetti per le lingue...eccellente il programma è tornato a funzionare come prima.

Di nuovo grazie ad Adriano per il suo interessamento.

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Buondì, oggi sono arrivati gli aggiornamenti per librecad con anche i pacchetti per le lingue...eccellente il programma è tornato a funzionare come prima.

Di nuovo grazie ad Adriano per il suo interessamento.

Ps.. per i moderatori per me la discussione è risolta.

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

I ragazzi di pclinuxos, textar in testa, sono bravi. Sono contento che il programma sia ritornato a funzionare, il mio interessamento e' dovuto, da sempre fan di pclinuxos tanto che sto curando la sua continuazione a 32bit. Se loro lavorano bene anch'io posso aiutare chi e' meno fortunato ed utilizza hardware obsoleto o low-powered.

Per poter mettere risolto puoi farlo da solo modificando il titolo del tuo post aggiugendoci [risolto]

Ritratto di eugenio66
Offline
Iscritto: 30/03/2014 - 23:16

Ciao Adriano, non vedo come possa farlo io, manca un pulsante per la modifica...sempre che non sia orbo e non riesca a vedere l'evidente 

Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Come adesso basta che immetti un nuovo commento e prima di salvarlo va in alto sul tuo primo intervento,  li' c'e' il pulsante per modificare il titolo come ti ho detto, a memoria e' sulla sx. Mal che vada zafran puo' farlo per te