Info startup PcLinuxOs

10 posts / 0 new
Ultimo contenuto
Ritratto di Psyko
Offline
Iscritto: 02/05/2013 - 08:49
Info startup PcLinuxOs

Salve,

Posseggo un pc con doppio sistema operativo (Windows 7 e PcLinuxOs 2013.04 KDE 16bit).

Grub 2 e' il bootloader.

Dopo aver lasciato il mio pc fermo per sei mesi al riavvio ho aggiornato Windows e i pacchetti di PcLinuxOs (con Synaptics).

Quest ultima operazione non e riuscita perche' c erano alcuni pacchetti danneggiati.

Ho riavviato il pc.

Al riavvio del pc PcLinux non si apre piu', dandomi un prompt di comandi (se tento di entrare con un account personale) o riavviando di continuo la schermata ''Welcome to loacalhost'' (se tento di entrare nell account root).

 

Come posso risolvere, cosa devo editare?

Mi scuso se non sono stato molto chiaro, ma sono novello del sistema.

Grazie in anticipo.

Ritratto di footstep11
Offline
Iscritto: 31/01/2013 - 11:01

Immagino che sia PcLinuxOs 2013.04 KDE 32bit... Wink

Dall'inizio dell'anno la versione a 32bit non e' piu' supportata, quindi non ci sono piu' aggiornamenti dall'anno scorso.  A questo punto la cosa piu' semplice e' fare una nuova installazione... se il tuo PC non supporta l'architettura a 64bit puoi provare uplos, che e' pclos 32bit mantenuta da un gruppo di volontari: http://www.liberainformatica.it/Uplos32/

Ciao, Mauro

Ritratto di zafran
Offline
Moderatore
Iscritto: 16/06/2008 - 16:10

Direi che qualcosa è andato storto per quanto riguarda il driver della scheda video.
Non ho capito bene la differenza fra l'accesso da utente e quello da root.

Comunque una shell di root ce la dovresti avere e da lì potresti digitare
do-vesa
quindi riavviare.
Al riavvio, il sistema dovrebbe ripartire con i driver vesa e darti un sistema grafico meno sofisticato ma funzionante.
Poi cercare di capire cosa è successo.

Però, PRIMA di tutto, guarda se hai un xorg.conf.
Cioè da shell dai il comando
ls -l /etc/X11/xorg*
e vedi se c'è e se ce n'è una versione antecedente all'update.
Io mi farei un backup di tutti file di xorg
mkdir /var/xorg-bkp
cp -R /etc/X11/xorg* /var/xorg-bkp/

Così poi puoi provare a riutilizzarne uno che in passato funzionava.

----------------------

Il suggerimento di footstep è sacrosanto e da me ovviamente (chissà perché!!!) raccomandatissimo sempre che tu sia in un sistema a 32 bit ma se tu lo fossi, un aggiornamento non avrebbe dovuto apportare modifiche visto che la 32bit è ferma ormai da 9 mesi.
Oppure sì se era un po' che non lo aggiornavi.

Per sapere la versione del tuo sistema, dai il comando
uname -a
Se sei a 32 bit, devi cambiare il repository e migrare al più presto a Uplos32.
Puoi iscriverti anche a quel forum

Ritratto di Psyko
Offline
Iscritto: 02/05/2013 - 08:49

Salve ragazzi, e grazie mille delle risposte a tutti, molto gentili, grazie.

Io ho un sistema a 64 bit, ne ero quasi sicuro, e ho controllato oggi.

Ho eseguito il comando uname -a e me lo ha confermato (credo) con questo messaggio:

Linux localhost 3.2.18-pclos2.bfs #1 SMP PREEMPT Thu May 24 12:11:06 CEST 2012 x......................86_64 x86_64 x86_64 GNU/Linux

Volevo segnalarVi che riavviando il pc e scegliendo Linux con Grub 2 mi trovo (come dovrei) nell immagine 1:

Qui se scelgo di entrare come root inserendo la password ottengo una flashata di un secondo nera con due righe scritte (che non riesco a leggere perche troppo veloce) e poi torna l immagine 1.

Se invece scelgo di entrare come Psyko inserendo la password ottengo l immagine 2, che e' la command line.

Provo qui a seguire il gentile suggerimento di zafran e di editare do-vesa?

Grazie ancora in anticipo

Ritratto di zafran
Offline
Moderatore
Iscritto: 16/06/2008 - 16:10

Veramente dice che non hai spazio sufficiente.

Guarda come sei messo con il comando
<strong>du -h</strong>

Probabilmente vedrai che / è piena al 98% se non al 100 e bisognerà che tu cancelli qualcosa con la shell o in alternativa con una live avviata apposta per vederci più chiaro (se non sei pratico della shell)..

 

Ritratto di Psyko
Offline
Iscritto: 02/05/2013 - 08:49

Salve ragazzi, salve Zafran.

Non avendo dimestichezza con la shell ho usato una live, ed una volta avviato LinuxOs in modalita' Guest ho cancellato i file nelle cartelle Temp (che mi indicava come piena) in due partizioni (dovrebbero essere quelle di Grub e quella di Linux).

Non e' cambiato nulla, cos altro dovrei cancellare con Live?

Digitando il comando ls -l /etc/X11/xorg*  ho visto la schermata che vi allego come immagine.

Quale backup scegliere e, soprattutto, come??

Premetto che a quanto pare io posso solo digitare comandi nella shell (in localhost) o usare il cd per la live.

Cosa dovrei fare?

 

Grazie in anticipo

Allegati: 
Ritratto di adrianomorselli
Offline
Iscritto: 02/01/2015 - 12:20

Qualsiasi modifica fatta da live è inefficace, o non permanente se preferisci così, ed è anche giusto così altrimenti sarebbe possibile distruggere un sistema altrimenti funzionante. La live ti serve solo per capire quali sono le directory "piene" che ti bloccano il sistema. Una volta capito puoi usare la shell per cancellarle per davvero con il comando rm. Una volta che sei con la shell ti porti nella directory imputata, tu dici che è appunto temp e quindi darai cd /tmp --> invio --> rm file_da_rimuovere 

Ritratto di zafran
Offline
Moderatore
Iscritto: 16/06/2008 - 16:10

Credo che vi stiate intortando con i termini.

@psyco
La live parte come sistema autonomo, quindi se cancelli il contenuto di /tmp, agisci nel filesystem della live e non in quello del sistema installato la cui /tmp/ va raggiunta in /media/sda1/tmp/.
Le modifiche fatte sul sistema installato sono permanenti. Non lo sono quelle apportate nel filesystem della live a meno che il boot non sia stato fatto ad hoc (modalità persistente).
Prima di avviare la live, da shell, da' il comando du -h e vedi cosa ti dice.

Ritratto di dxgiusti
Offline
Iscritto: 22/01/2013 - 17:30

il sistema installato quello della immagine 2 ti dice che non hai spazio. prova a pulire. nel terminale che ti appare, dai la tua pswd per diventare amministratore, quindi > apt-get autoclean , è ovviamente una prova. però è strano, mi risulta che i file presenti in /tmp vengano cancellati ad ogni riavvio. 

Ritratto di Psyko
Offline
Iscritto: 02/05/2013 - 08:49

Salve, problema risolto, o, meglio, ovviato.
Oltre a problemi di spazio e di un pacchetto broken, non c era piu possibilità di aggiornare la mia versione di OS (credo troppo vecchia) e Synaptics nn trovava più nulla nel Repository.

Ho ovviato formattando e installando l ultima versione (2017.04).

Non mi da Grub2, uso il numero 1, ma per ora va benissimo cosi.

Grazie a tutti della collaborazione.
P.