Installare phyton

Ritratto di max_tre2000

Ciao ragazzi,

vorrei cimentarmi un pò con phyton, cominciare ad impararlo ed usarlo, ma andando in synaptic trovo una marea di voci relative.

Quali sono i pacchetti da installare? Non vorrei metterne più del necessario o non strettamente utili al suo funzionamento, visto il poco spazio che ho sul disco, e non vorrei occuparne più del necessario.

Ritratto di adrianomorselli

Anch'io volevo cimentarmi in python tempo fà e la soluzione migliore che ho trovato è stata quella di installare una distro su usb e installare ìi i pacchetti relativi alle mie prove. Se invece vuoi solo cimentarti in giochi ed avere i pacchetti relativi ad avviarli non occupano granchè di spazio. Python minimale ce l'hai già installato, aggiungi pygame

Ritratto di pabform

Non ho mai fatto nulla in python, i linguaggi che ho un po' praticato, anni orsono quando lavoravo in una azienda informatica, sono java, html e visual basic, un po' di c++ ma poca roba, python e php mi solleticano, mi garberebbe provare ma non ne so niente. Su pclos è preinstallato python, non lo sapevo proverò a dargli un'occhiata.

Ritratto di max_tre2000

sicuri che sia preinstallato? (io ho lxde)

se do il comando

[marco@localhost ftp]$ pyhton ./test.py

mi risponde

bash: pyhton: comando non trovato

Ritratto di zafran

Dai solo pyhton e poi (vado a naso) exec ./test.py

Ritratto di adrianomorselli

La sintassi! python

Ritratto di footstep11

max_tre2000 wrote:

sicuri che sia preinstallato? (io ho lxde)

se do il comando

[marco@localhost ftp]$ pyhton ./test.py

mi risponde

bash: pyhton: comando non trovato

Se non sei sicuro del comando, usa l'autocompletamento della shell.  Premi l'inizio del comando seguito da un <TAB> (si trova normalmente in alto a sinistra, di fianco alla tasto della Q). Nel mio caso ottengo:

pyt<TAB>
python            python2.7-config  python3-2to3      python-config
python2           python2-config    python3.4         
python2.7         python3           python3.4m

Quindi python (e NON pyhton, come ha scrito tu) e' installato... sia la versione 2 che la versione 3.  Quella di default e' la versione 2.

Ciao, Mauro

Ritratto di pabform

si, è perfettamente funzionante

Ritratto di max_tre2000

grazie ragazzi, era un errore di sintassi del comando che davo...