[RISOLTO] Come condividere cartelle tra due portatili con Ubuntu, Pclinux e Windows.

116 contenuti / 0 new
Ultimo contenuto
Ritratto di fortu

La porta che devo aprire sul router è 21,oppure poss usare un range da 20 a 22 . Su windows firewall devo aggiungere la porta 21 sia in entrata che in uscita.

Ritratto di adrianomorselli

Se hai problemi con ssh su windows usa il protocollo ftp (porta 21). In questo caso però devi aggiungere sia su ubuntu sia su pclos ftp, per sicurezza anche il pacchetto openssh-sftp-server

Ritratto di adrianomorselli

fortu wrote:

La porta che devo aprire sul router è 21,oppure poss usare un range da 20 a 22 . Su windows firewall devo aggiungere la porta 21 sia in entrata che in uscita.

ftp porta 21 /ssh porta 22. E' indicata anche la porta 20 quindi è meglio se apri le porte da 20 a 22 comprese

Ritratto di fortu

Non ho capito quali sono i problemi con ssh su windows.

Per aggiungere su ubuntu e su pclinux ftp, basta installare openssh-sftp-server.

Ritratto di fortu

Ho aperto le porte di Windows firewall sia in entrata che in uscita con il protocollo tcp, occorre anche configurarle con il protocollo udp?

Ritratto di adrianomorselli

No come protocollo è inaffidabile per il trasferimento dati, non ritrasmette quelli persi. E' utilizzato dove occorre una latenza bassa, come trasmissione di video+voce in tempo reale come ad es. Void

Ritratto di fortu

Al server di filezilla mi da questo errore quando mi connetto.

(000004)25/06/2016 11:08:41 - (not logged in) (192.168.0.10)> 530 Login or password incorrect!
(000004)25/06/2016 11:08:41 - (not logged in) (192.168.0.10)> disconnected.

Ma se non ho la password su windows, come mai mi dà questo errore?

Ritratto di adrianomorselli

Và messa una password oltre che l'utente, non devi utlizzare quella di default, che fra l'altro non hai impostato, ma messa nelle configurazioni di filezilla server. Strano che quando hai avviato filezilla server non ti abbia chiesto di mettere un user e una password, ma rimedia cercando nelle configurazioni. E' una protezione per te, ecco perchè il server si rifiuta di connettersi.

Ritratto di adrianomorselli
Ritratto di fortu

Nella casella server address ho scritto 127.0.01 e in quella password ho lasciato vuoto, poi ho creato il certificato sbagliando il codice a due cifri invece di inserire IT ho messo 80, però il certifcato ha funzionato; poi nella scheda "passive mode settings" ho attivato "Use custom port range" inserendo quesi valori 50000-50040 e così il server si è loggato. Perciò quale utente e password devo inserie?

Ritratto di fortu

Finalmente ho capito come collegarmi. Dovevo scegliere il nome utente  e la password dell'account che creavo nel server di filezilla. Però da ubuntu mi avvisa che non è stato possibile leggere il contenuto della cartella. Perchè.

Ritratto di adrianomorselli

Ci sono diversi metodi di autenticazione, in pratica tu hai messo lo stesso metodo di autenticazione che si utilizza per i server web, un certificato. L'autenticazione con user e password serviva per una tua sicurezza, ma se sei contento così va bene. Io però se fossi in te metterei fra le regole l'accesso solo a certi user (tu) rifiutando l'accesso a tutti gli altri, nel link che ti ho messo c'è tutto scritto. Così eviti che il ragazzino che passa sotto la tua finestra con il portatile si colleghi al tuo server e curiosi fra i tuoi file Wink

Ritratto di adrianomorselli

fortu wrote:

Finalmente ho capito come collegarmi. Dovevo scegliere il nome utente  e la password dell'account che creavo nel server di filezilla. Però da ubuntu mi avvisa che non è stato possibile leggere il contenuto della cartella. Perchè.

Eheheh vai come un treno senza quasi leggere quello che ti scrivo. Risolviamo anche questo: cambia il tipo di connessione nelle opzioni di Filezilla Server (su windows) da Usa se disponibile FTP esplicito su TLS a Usa solo FTP non sicuro. Questo ti fà capire perchè proteggere con user + password

Ritratto di fortu

Non riescoa trovare questa impostazione che mi dici

Ritratto di adrianomorselli

Dovrebbe essere in "connessioni", però non è che l'errore segnato sia un timeout? Perchè se non setti la connessione in ubuntu e pclos dal lato client a 0 ti rifiuterà sempre la connessione.

Ritratto di fortu

Il timeout su ubuntu è 0, l'avevo impostato prima.

Ritratto di adrianomorselli

Facciamo una prova alternativa, così almeno puoi vedere dai log l'eventuale errore. Apri un browser su ubuntu o pclos e digita ftp://tuoip:21 (la porta ftp), eventualmente prova a sostituire se non dà responso con la porta 20. Ti dovrebbe chiedere sia l'user che la password

Ritratto di fortu

Allora con la porta 21 il browser restituisce impossibile contattare il server, invece con il 20 questo indirizzo è bloccato.

Ritratto di fortu

Quando connetto al server filezilla guarda l'errore:

Errore:    La connessione dati non può essere stabilita. ECONNREFUSED - Connection refused by server
Risposta:    425 Can't open data connection for transfer of "/"
Errore:    Non è stato possibile leggere il contenuto della cartella

Ritratto di fortu

Scusa non mettevo il imio ip.

Questo è il log con la porta 21"Can't open data connection for transfer of "/"

con la porta 20 invece questo indirizzo è bloccato.

Ritratto di fortu

Con la porta 20 non mi chiede nè indirizzo nè password.

Ritratto di adrianomorselli

Sto guardando qui https://forum.filezilla-project.org/viewtopic.php?f=6&t=24925&sid=073cb7... e sembra relativo a due problemi, il tipo di router e tutta un range di porte da aprire per il trasferimento dei dati. In pratica windows come server fà schifo, anche se come client funziona. Non posso neppure replicare la tua situazione, windows mi è precluso, l'unico in casa è quello di mio figlio e guai a toccarlo, senza poi dire che non ho probabilmente il tuo router. Non ti resta che dare una scorsa al link che ti ho messo e vedere se puoi risolvere aprendo anche un range di porte.

Ritratto di fortu

Niente da fare ho aperto anche il range delle porte della modalità passiva sia nel firewall di windows che nel router, ma la cartella risulta sempre vuota.

Ritratto di adrianomorselli

Come ti ho detto, windows server fà schifo, accontentati del client, tanto se sei in dualboot puoi benissimo prendere i dati da linux.

Ritratto di fortu

Quindi tutte queste porte aperte mi consigli di eliminarli sia sul firewall che sul router?

Ritratto di adrianomorselli

Windows mi fà incazzare, fai un'ultima prova, togli per il momento il firewall e riprova. Se non funziona ancora cerca nei prossimi giorni nei forum per windows, la speranza è l'ultima a morire. Ho visto che c'è anche un programma per windows per un server ssh, io però non posso provarlo, ho solo windows virtualizzato. http://mobassh.mobatek.net/

Ritratto di fortu

Nemmeno con firewall disattivato.

Ritratto di footstep11

Vedo ora questa discussione... perchè non utilizza samba, che è stato proprio creato per condividere files e cartelle tra linux e windows?  Il server samba credo che sia installato di default in pclinux (altrimenti è presente in synaptic).

In rete puoi trovare gazillioni di guide su come configurarlo: prova a cercare, ad esempio, "guida samba condivisione" (senza virgolette). Non posso dire altro perchè non l'ho mai usato...

Un'altra alternativa sarebbe di montare le partizioni sull'altro PC via NFS (anche questo disponibile via synaptic).  Puoi fare una ricerca di "guida nfs condivisione" per trovare informazioni...

Ciao, Mauro

Ritratto di adrianomorselli

Però @footstep ciò non toglie che Filezilla dovrebbe essere un server efficiente, in fin dei conti fra linux e linux funziona bene, i trasferimenti tra pc sono sicuri, senza perdita di dati e a me evitano tante scale, ho un paio di piani fra i vari pc. Che poi windows abbia dei problemi di per sè stesso, ho letto appena adesso che un problema potrebbe essere anche l'antivirus che potrebbe bloccare certe porte, e quindi poco importa inserirle fra quelle aperte nel firewall. Per il momento abbiamo un dato certo, come client filezilla funziona, da windows si può connettere al server linux. Utilizzare samba per fare l'inverso è un'ottima idea, anch'io non l'ho mai utilizzato, ma da windows a windows vedo che funziona.

Ritratto di adrianomorselli

Ah p.s. @fortu, se pensi di disattivare momentaneamente l'antivirus per fare i trasferimenti, non è detto che funzioni cito: If that does not help, you might want to try to uninstall your firewall to see what happens. Simply disabling your firewall might not work, as some firewalls cannot be fully disabled. In particular, most firewalls install virtual device drivers which cannot be disabled other than by uninstalling them. Also check for hidden firewalls. Programs such as virus scanners often have firewall functionality as well. "  Capito perchè il mercato mondiale dei server non è in mano a Windows?

Ritratto di fortu

Non riesco a collegarmi da ubuntu a windows nemmeno con il server samba.

Poi il firewall windows è integrato nel sistema, non è semplice disinstallare.

Ritratto di adrianomorselli

Disinstalla windows no? 'o'

Ritratto di fortu

Grazie, ancora non ci credo ma funziona. Non so come è successo ma non avevo spuntato la casella in modalità passiva "don't use external ip local connections", quando l'ho spuntato ha funzionato.

Ritratto di fortu

Siccome dopo un paio di secondi che non l'ho uso FZS si disconnette, come posso aumentare il tempo. Ho già impostato a 0 il timeout, come si vede dallo screenshot.

Ritratto di fortu

Sono veloce come un treno manco leggo, ho portato il timeout a 20 secondi, per risolvere il problema sopra specificato.

Ritratto di adrianomorselli

Non leggi neppure quello che scrivi? Lol! 0 serve per disabilitare il ritardo, ma se hai risolto con 20 tanto di guadagnato.

Ritratto di fortu

Infatti non ho risolto il problema. Come si può fare?

Quell'impostazione la posso riportare a 0, perchè se ho capito bene serve solo alla connessione con il filezilla server. e non a mantenere la connessione aperta per tot tempo,

Ritratto di adrianomorselli

No in realtà disabilitando il ritardo con "0" eviti che il server rifiuti la connessione causa timeout. Una volta connesso non c'è un limite di tempo. Ma alla fine cosa succede, ti connetti ma poi perdi la connessione? Prova con un bel ping, hai una connessione ballerina? Da terminale ping + IP del server, con ctrl+c fermi il tutto e vedi il risultato, più è bassa la latenza e meglio è la connessione, viene espressa ms, cioè in millesecondi, più è alto e peggio è

Ritratto di fortu

Quando posso faccio la prova è ti faccio sapere.

Ritratto di fortu

Come ti sembra:

64 bytes from 192.168.0.7: icmp_seq=1 ttl=128 time=1.45 ms
64 bytes from 192.168.0.7: icmp_seq=2 ttl=128 time=1.77 ms
64 bytes from 192.168.0.7: icmp_seq=3 ttl=128 time=1.79 ms
64 bytes from 192.168.0.7: icmp_seq=4 ttl=128 time=1.85 ms
64 bytes from 192.168.0.7: icmp_seq=5 ttl=128 time=1.72 ms
64 bytes from 192.168.0.7: icmp_seq=6 ttl=128 time=1.79 ms
64 bytes from 192.168.0.7: icmp_seq=7 ttl=128 time=1.53 ms
64 bytes from 192.168.0.7: icmp_seq=8 ttl=128 time=1.80 ms
64 bytes from 192.168.0.7: icmp_seq=9 ttl=128 time=1.78 ms
64 bytes from 192.168.0.7: icmp_seq=10 ttl=128 time=1.75 ms
64 bytes from 192.168.0.7: icmp_seq=11 ttl=128 time=2.88 ms
64 bytes from 192.168.0.7: icmp_seq=12 ttl=128 time=3.97 ms
64 bytes from 192.168.0.7: icmp_seq=13 ttl=128 time=1.85 ms
64 bytes from 192.168.0.7: icmp_seq=14 ttl=128 time=1.84 ms
64 bytes from 192.168.0.7: icmp_seq=15 ttl=128 time=1.95 ms
64 bytes from 192.168.0.7: icmp_seq=16 ttl=128 time=4.16 ms
64 bytes from 192.168.0.7: icmp_seq=17 ttl=128 time=1.82 ms
64 bytes from 192.168.0.7: icmp_seq=18 ttl=128 time=1.76 ms
64 bytes from 192.168.0.7: icmp_seq=19 ttl=128 time=43.8 ms
64 bytes from 192.168.0.7: icmp_seq=20 ttl=128 time=2.29 ms
64 bytes from 192.168.0.7: icmp_seq=21 ttl=128 time=1.78 ms
64 bytes from 192.168.0.7: icmp_seq=22 ttl=128 time=1.80 ms
64 bytes from 192.168.0.7: icmp_seq=23 ttl=128 time=1.84 ms
64 bytes from 192.168.0.7: icmp_seq=24 ttl=128 time=13.7 ms
64 bytes from 192.168.0.7: icmp_seq=25 ttl=128 time=1.91 ms
64 bytes from 192.168.0.7: icmp_seq=26 ttl=128 time=1.80 ms
64 bytes from 192.168.0.7: icmp_seq=27 ttl=128 time=1.84 ms
64 bytes from 192.168.0.7: icmp_seq=28 ttl=128 time=1.81 ms
64 bytes from 192.168.0.7: icmp_seq=29 ttl=128 time=1.77 ms
64 bytes from 192.168.0.7: icmp_seq=30 ttl=128 time=1.79 ms
64 bytes from 192.168.0.7: icmp_seq=31 ttl=128 time=1.78 ms
64 bytes from 192.168.0.7: icmp_seq=32 ttl=128 time=17.7 ms
64 bytes from 192.168.0.7: icmp_seq=33 ttl=128 time=6.90 ms
64 bytes from 192.168.0.7: icmp_seq=34 ttl=128 time=1.69 ms
64 bytes from 192.168.0.7: icmp_seq=35 ttl=128 time=1.88 ms

 

Ritratto di adrianomorselli

Non sono un esperto ma al seq=19 ti sbalza all'inpovviso a 43,8ms, a seq=24 a 13,7ms e a seq=32 a 17,7ms, sembrerebbe un pò ballerina, non riesci a stabilizzarla con un ripetitore? Non vorrei che il problema fosse appunto il router, non sembra avere però problemi se il server è linux Shok

Ritratto di fortu

Nemmeno io sono un esperto.
Però lo lascio così, vediamo come va.
Comunicando il mio ip sul forum non potrebbe essere un rischio per la sicurezza dei dati.
Quando avvio Windows si apre il programma filezilla server in automatico. Non si potrebbe evitare di farlo vedere sullo schermoa, magari rimarebbe aperto in background?

Ritratto di adrianomorselli

Non è l'IP esterno, è l'IP che ti viene assegnato dal router per il web casalingo, nessun problema se viene visto anche sul forum, e poi noi siamo discreti. Se vuoi eliminare l'applicazione in avvio vai su task-manager (click destro mouse) ed eliminalo fra le applicazioni d'avvio, presumendo che hai da windows8 in su. Se hai il 7 vale il vecchio comando msconfig

Ritratto di fortu

Disabiltando filezilla server in avvio su task-manager, il programma non si è avviato perfetto. Ma se volessi che si avviasse però in backgroun senza che il programma si aprirebbe sullo schermo; è possibile? 

Ritratto di fortu

Con filezilla client e server linux non riesco a vedere le partizioni dati. C'è un modo per poterli vedere, soprattutto quelle sui server linux dove mi serve prenderi i dati. Invece sul client di windows la partizione dati la vedo tranquillamente.

Ritratto di adrianomorselli

Le partizioni dati (se ben mi ricordo ne hai tantissime) sono montate?

Filezilla in background? Prova a vedere se è quello che fà per te http://www.acsu.buffalo.edu/~zdestes/UniServerZ/docs/manual/fz_basic_con...

Ritratto di fortu

Partizione dati ne ho una su un pc e un'altra sull'altro pc. Le partizioni sono montati, io intendo che li ho aperti con un click, in questo modo non riesco a vederli.

Ritratto di adrianomorselli

Non ti seguo più. chi vede e chi non vede, da dove e come, se fossi una cantante sarei Patty Bravo con "come fosse una bambola"

Ritratto di adrianomorselli

Andare sull'easy paga, comprendimi. Io attualmente ho due pc, ognuno dei quali ha due distro diverse, ma sempre linux. Windows lo uso solo in virtuale ma solo perchè ho 2 programmi, uno a pagamento per la trasformazione dei vhs in mp4 attraverso uno strano aggeggio, l'altro è relativo al navigatore satellitare, ma solo per gli aggiornamenti. Beh non solo riesco a vedere e a scaricare dati da uno all'altro, visto che ho ben 2 piani di distanza fra di loro, ma riesco persino a controllarli in remoto attraverso Remmina. Il mio consiglio iniziale era teso ad avere una situazione simile alla mia, completo controllo del pc remoto. Ma ad un certo punto mi sono veramente perso, non capisco più cosa ti funziona, se da o verso, vedi ma non scarichi, davvero mi sono perso completamente. Sarà la mia senilità perdonami Sad Quasi quasi ti volevo consigliare di installare TeamViewer per sistemare personalmente la cosa, ma poi mi sono reso conto che ognuno ha le sue cose personali. Ti chiedo di nuovo scusa ma non so più cosa fare per aiutarti

Ritratto di fortu

Spero di farmi capire. Non riesco a scaricare i dati che ho in una partizione dedicata dell'altro pc. Questa partizione non è visibile attraverso Filezilla server linux.

Pagine