installazione uefi

Ritratto di dxgiusti

eccomi quà. oggi ho effettuato la mia prima installazione ( pclos-mate ) su un disco gpt contenente win10 in dualboot. tutto bene senza problemi particolari. installato, aggiornato ecc. ho subito installato il kernel nuovo, ed ho aggiornato con update-grub.  il responso mi ha lasciato perplesso:

[palla@localhost ~]$ su
Password: 
[root@localhost palla]# update-grub
Generating grub configuration file ...
Tema trovato: /boot/grub2/themes/pclinuxos/theme.txt
Trovata immagine linux: /boot/vmlinuz-4.1.13-pclos1
Trovata immagine initrd: /boot/initrd-4.1.13-pclos1.img
Trovata immagine linux: /boot/vmlinuz-4.1.10-pclos1
Trovata immagine initrd: /boot/initrd-4.1.10-pclos1.img
Trovato Windows Boot Manager su /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Trovato PCLinuxOS su /dev/sda5
grep: Windows: File o directory non esistente
grep: Boot: File o directory non esistente
grep: Manager: File o directory non esistente
grep: HD(2,GPT,8216468e-6128-429c-959e-a84c7ef2fb1a,0xe1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...5................: File o directory non esistente
/etc/grub.d/42_efi: riga 21: grub2-efi-probe: comando non trovato
errore: syntax error.
errore: Incorrect command.
errore: syntax error.
errore: Incorrect command.
errore: syntax error.
Syntax error at line 187
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub2/grub.cfg.new file attached.
fatto

 

ho comunque riavviato e lui è ripartito normalmente con il vecchio. del nuovo nessuna traccia. poi ho un altro problema, se riavvio, mi appare la schermata di grub2 dove posso selezionare pclos oppure win, se invece arresto, al sucessvo riavvio parte subito 10 senza possibilità di scelta. sicuramente ho sbagliato qualche passaggio ma vorrei capire se c'è una possibilità per risolvere. a dimenticaco, ma non credo sia importante se riparto con supergrubdisk avvio tranquillamente pclos. per completre le info questo dualboot è sulla mia virtualbox.

Ritratto di zafran

dxgiusti!
È la prima volta che sento di un dualboot con pclos e win10.
Dunque è possibile?
Ottima notizia, grazie davvero.

Forse il problema sarebbe risolvibile disabilitando il os-prober e creando il file di avvio per windows a mano.

Ritratto di zafran

novità?

Ritratto di dxgiusti

nulla. ho abbandonato, sigh! se installo pclos su disco gpt gestito da uefi, nessun problema, se invece cerco di installare in dualboot non riesco o meglio non so dove installare il grub. al riavvio parte sempre solo win. comunque erano tutte prove che facevo in virtuale su VB avvio con EFI. se qualcuno ha voglia e tempo può provare. per info con ubuntu 15.10 nessun problema....

Ritratto di monsee

Non ho esperienza di sorta riguardo a gpt (semplicemente perché son uso "trasformare" i miei Hard Disks in HD "standard" [non gpt, dunque, ma con MBR] prima ancora di iniziare ad utilizzarli), però, riguardo all'installazione di GRUB cui accenni mi par potrebbe ritornarci utile sapere se stai parlando di GRUB (il "legacy-grub, che giudico prezioso e sempre utilizzo) oppure di GRUB2 (che, per conto mio, non vale l'inchiostro speso per incensarlo).
Dico questo perché mi consta che sia possibile (usando PCLinuxOS, a 32-bit o a 64-bit indifferentemente) installare GRUB (grub-legacy sicuramente, non son certissimo se ciò valga anche per GRUB2) in un luogo di propria libera scelta (io, ad esempio, trovo assai comodo installare GRUB [all'atto dell'installazione del Sistema] su floppy-disk e poi avviare PCLinuxOS in questo modo: l'ho fatto per anni, evitando, in tal modo il "dual-boot" fra Windows e PCLinuxOS [accendendo il PC con il floppy-disk inserito, mi si avvia PCLinuxOS automaticamente; estraendo il floppy-disk e poi accendendo il PC, si avvia automaticamente Windows]).
Per cui mi sorge spontanea la domanda se non sia possibile avviare PCLinuxOS senza ricorrere ad un "canonico" dual-boot con Windows, ma lasciando a Windows, intonso, il proprio avvio e dando a PCLinuxOS la possibilità di avviarsi in modo totalmente indipendente.
Di certo, ciò è possibile se si dispone di un HD basato su MBR (ovvero, è possibile se prima si trasforma l'HD da "gpt" a MBR) e si installa il GRUB ("legacy", ma forse va bene anche Grub2 [non l'ho mai provato, onestamente]) e si installa il GRUB di PCLinuxOS in un luogo del tutto "indipendente" da Windows (ad esempio, dentro ad un floppy-disk [io utilizzo allo scopo un Lettore-Floppy "esterno" USB] oppure dentro ad una piccola pen-drive o a qualcosa di consimile che ora non mi viene in mente).

Ritratto di dxgiusti

https://youtu.be/hWrNJLrewdY

dai e dai......  ricordarsi sempre prima di eseguire il lavoro una immagine del vostro 10. io uso clonezilla per semplicità del programma. la nuova versione supporta partizioni su tabelle gpt e si avvia in live con avvio EFI. ho usato una iso della comunity, nello specifico xfce-mini.

http://communityiso.pclosusers.com

tutte predisposte con grub-efi.

Ritratto di tuxino

nei repo cè, purtroppo non ho windows 8 o successivi per provare, chissà se installando grub2-efi funziona anche su pc con tabella msdos?

$ apt-cache policy grub2-efi
grub2-efi:
  Installed: (none)
  Candidate: 2.02-6pclos2015
  Version Table:
     2.02-6pclos2015 0
        500 http://ftp.nluug.nl pclinuxos/32bit/updates pkglist

quando ho tempo provo a installare quello e rimuovo grub2 e faccio una mylivcd con questo e vedo se funge anche con msdos, in caso si può uploadare così, in modo da poterla utilizzare anche su pc con uefi

Ritratto di tuxino

l'ho installato, ma non so com'è la situazione, è installato assieme a grub e grub2 , non so se è solo un pacchetto che fornisce il supporto a uefi o se in qualche modo si deve sostituire a grub2, ho provato con

# grub2-efi-install /dev/sda ma mi dice comando non trovato...boh può essere che basta grub2 con l'aggiunta del pacchetto grub2-efi.....e se quindi basta il classico # grub2-install /dev/sda...boh

Ritratto di dxgiusti

devi installare il pacchetto e basta. solo se il computer ha un avvio EFI lui verrà usato. se un computer ha l'avvio da mbr, verrà ignorato. nel caso venga avviato su computer con EFI la prima schermata sarà questa:

Ritratto di tuxino

Ah, ok, io come dicevo, non ho pc con uefi, comunque, allora, le prossime iso le provo anche aggiungendo tale pacchetto, anche se sono 32 bit, hanno kernel pae e non hanno problemi di rilevamento della ram oltre i 3 GB, quindi volendo possono essere installate anche su hardware 64 bit , se uno vuole.

Poi , se qualcuno ( tu per esempio Wink ) le vuole provare su pc con uefi vediamo come si comportano....Ciao

Ritratto di fortu

Non so se posso entrare adesso in questo argomento, ma ho provato a installare pc linux xfce e mate scaricandoli dal link che ha postato dixgusti, però in entrambi nel montare la partizione di 100mb Fat32 non ho trovato il boot/efi. Come si spiega?

Ritratto di dxgiusti

hai visto il video come faccio a montare bios/efi.

mi sorge un dubbio, tu stai installando in dualboot con la partizione efi già esistente oppure devi installare da nuovo senza avere quella partizione? nel caso la devi creare tu.

Ritratto di fortu

Si ho visto il video.
Sto installando in dualboot con le tre partizione che ha creato Windows 7, di cui una appunto fat 32 elfi nella quale dovrei montare pc linux e poi il resto del disco è non allocato.

Ritratto di fortu

Non so se può aiutare, volevo avvisare che nel bios da default ho disabilitato il secure boot e abilitato il Legadue support.
A proposito dopo aver provato la live pclinux, Windows non si è più avviato, comunque avevo creato un immagine con clonezilla, speriamo che posso ripristinata.

Ritratto di adrianomorselli

Cos'è il "Legadue support"? Shok

Ritratto di fortu

Scusa il legacy support

Ritratto di adrianomorselli

Prima di pasticciare con clonezilla ristabilisci il bios che forse windows  si riavvia. Wink

Ritratto di fortu

È come?

Ritratto di fortu

Comunque già ho pasticciato, perché nonostante il ripristino dell'immagine con clonezilla Windows non parte lo stesso

Ritratto di fortu

Secondo me si è corrotta la partizione efi di boot. Ma come ripristinarla.

Ritratto di dxgiusti

ricapitoliamo un attimo. se modifichi dal bios ed imposti "legacy", è ovvio che windows installato con bios/efi non si avvii più. rimetti il bios/efi e vedrai che win si riavvierà. ora con quelle impostazioni installa pclinux, come vedi nel video. in quel modo ti indicherà nel montaggio della partizione quella che gestisce l'avvio,la bios/efi. se invece come hai fatto tu imposti legacy, pclinux non ti segnalerà nessuna partizione da montare ed ovviamente win non si riavvierà più.

Ritratto di fortu

Scusami ma ho formattato il disco ed ho deciso di installare ubuntu e pclinux aprendo un altro post. In effetti mi confondo con il bios, perché nell'ordine di avvio permanente ce poco da fare, in quanto di predefinito ha il legacy supporto abilitato e il secure boot disabilitato, invece nell'avvio temporaneo si vede forse che a volte facevo avviare il dvd con eufi e a volte il dvd legacy e quindi ho fatto confusione. Comunque faccio fatica a capire questo tipo di noia.

Ritratto di fortu

Alla fine volevo dire bios.