driver webcam integrata (asus z9200)

Ritratto di nico1976
Forum: 

Buongiorno ragazzi, premesso che sono un neofita di pclinuxos (incredibile come s.o.),
volevo chiedervi un aiuto riguardo il funzionamento della mia webcam inegrata.
Ne ho provate di soluzioni.... ma non sono riuscito ha risolvere (cheese...) il centro di informazione la riconosce come ALI M5603C.

vi posto ciò che il terminale mi dice..

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 15d9:0a4c Trust International B.V. USB+PS/2 Optical Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 0402:5603 ALi Corp. M5603 Video Camera Controller

ALI M5603C

Classe 0 ((Defined at Interface level))
Sottoclasse 0
Protocollo 0
Versione USB 2.00
Identificativo fornitore 0x402 (ALi Corp.)
Identificativo prodotto 0x5603 (USB 2.0 Q-tec Webcam 300)
Revisione 1.02
Velocità 480 Mbit/s
Canali 0
Dimensione massima pacchetto 0

ringrazio anticipatamente quelli che mi risponderanno.
ciao.

Ritratto di francofait

nico1976 wrote:
Buongiorno ragazzi, premesso che sono un neofita di pclinuxos (incredibile come s.o.),
volevo chiedervi un aiuto riguardo il funzionamento della mia webcam inegrata.
Ne ho provate di soluzioni.... ma non sono riuscito ha risolvere (cheese...) il centro di informazione la riconosce come ALI M5603C.

vi posto ciò che il terminale mi dice..

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 15d9:0a4c Trust International B.V. USB+PS/2 Optical Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 0402:5603 ALi Corp. M5603 Video Camera Controller

ALI M5603C

Classe 0 ((Defined at Interface level))
Sottoclasse 0
Protocollo 0
Versione USB 2.00
Identificativo fornitore 0x402 (ALi Corp.)
Identificativo prodotto 0x5603 (USB 2.0 Q-tec Webcam 300)
Revisione 1.02
Velocità 480 Mbit/s
Canali 0
Dimensione massima pacchetto 0

ringrazio anticipatamente quelli che mi risponderanno.
ciao.


per prima cosa assicurati di avere installato l' ambiente per la compilazione ed installazione di driver , cioè , il compilatore e l' haeder del kernel in uso .
poi devi scaricare ed installara da synaptic i pacchetti :
ctags
Perl-Parse-ExuberantCtags
poi scarichi , compili ed installi questi : senza preoccuparti se il modello della webcam non è menzionato nel readmy incluso nei sorgenti .
mxhaard.free.fr/spca50x/Download/spca5xx-v4l1goodbye.tar.gz -
Se da ancora problemi . attendi , il tempo di farmi ripescare il comando da dare in console root per far si che exuberandctags esegua la sua funzione correttamente, alla faccia di Ali e dei driver per linux che non ha mai voluto fornire.

Ritratto di monsee

... Sei un grande, Franco!

Ritratto di francofait

se l' spca50x di mxaard.free , non risponde , scarica compila ed installa questo :
m560x-driver.svn.sourceforge.net/svnroot/m560x-driver/m560x/branches/m5602-gspca/

Ritratto di zafran

Certe volte mi spaventa.
Se solo non citasse tanto...

Ritratto di nico1976

Gentilissimo Francofait, (mi permetto di darti del tu)
ho seguito tuttoquello che mi hai chiesto ma non son riuscito a far funzionare sta maled... webcam integrata.
Ho installato da synaptics ctags e ....
Ho scaricato i pacchetti dai siti (anche quella m5603c) che mi hai detto, poi da root tramite il terminale ho installato i pacchetti con apt-get....
ho avviato cheese... skype ma non riconosce la webcam
Se vado in pclinuxos control center alla voce scanner mi evidenzia ali m5603c.... la identifica... mah!
grazie.

Ritratto di nico1976

Gentilissimo Francofait, (mi permetto di darti del tu)
ho seguito tutto quello che mi hai chiesto ma non son riuscito a far funzionare sta maled... webcam integrata.
Ho installato da synaptics ctags e ....
Ho scaricato i pacchetti dai siti (anche quella m5603c) che mi hai detto, poi da root tramite il terminale ho installato i pacchetti con apt-get....
ho avviato cheese... skype ma non riconosce la webcam
Se vado in pclinuxos control center alla voce scanner mi evidenzia ali m5603c.... la identifica... mah!
grazie.

Ritratto di nico1976

Gentilissimo Francofait, (mi permetto di darti del tu)
ho seguito tutto quello che mi hai chiesto ma non son riuscito a far funzionare sta maled... webcam integrata.
Ho installato da synaptics ctags e ....
Ho scaricato i pacchetti dai siti (anche quella m5603c) che mi hai detto, poi da root tramite il terminale ho installato i pacchetti con apt-get....
ho avviato cheese... skype ma non riconosce la webcam
Se vado in pclinuxos control center alla voce scanner mi evidenzia ali m5603c.... la identifica... mah!
grazie.

Ritratto di nico1976

scusate ho inviato 2 volte lo stesso commento, come posso cancellarlo?

Ritratto di francofait

Apri una console root e dai il comando :
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so mplayer tv:// -tv driver=v4l2:width=640:height=480:fps=25:device=/dev/video0 -vo x11″

Ritratto di francofait

Zafran , come puoi vedere , non sono un mostro e neppur son nato linuximparato , in questo caso si ha che fare con un produttore che da quell' orecchio non ci ha mai voluto sentire , tutte le possibiltà di risolvere sono legate alla pssibilità di riuscire ad imbrogliare il SO e costringerlo ad usare correttamente i driver di microdia , che fin dall' inizio si sono dimostrati i più idonei , le possibiltà di arrivare a risolvere dal momento che 2 configurazioni hardware perfettamente identiche non esistono , sono sul filo del rasoio.

Ritratto di nico1976

mi da questo risultato!

Creating config file: /root/.mplayer/config
MPlayer UNKNOWN-4.5.2 (C) 2000-2011 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski
comment: first try, more to come Wink
v4l2: unable to open '/dev/video0': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.

Exiting... (End of file)

Ritratto di francofait

se mplayer non è installato , non sarà facile che lo possa trovare , vediamo se procedendo con calma si riesce a spuntarla .
Chi la dura la vince . Per umberto bossi anche l' ha duro - hihi

Ritratto di nico1976

appena installato!

Ritratto di nico1976

ho ridato quel comando....
risultato

Playing tv://.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski
comment: first try, more to come Wink
v4l2: unable to open '/dev/video0': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.

Ritratto di francofait

famme zazzicare poi se riprova ad andare avanti , da quel risultato sembra che non viene creato il linksym /dev/vido0 con v412 .
Va creato a manina da console e reso permanente , altrimenti ad ogni riavvio qui si blocca e non può andare avanti.